4.1.6_release_blocker requested: [Issue 127876] unbreak ODK build with Java 8

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

4.1.6_release_blocker requested: [Issue 127876] unbreak ODK build with Java 8

bugzilla
Don Lewis <[hidden email]> has asked  for 4.1.6_release_blocker:
Issue 127876: unbreak ODK build with Java 8
https://bz.apache.org/ooo/show_bug.cgi?id=127876



--- Description ---
When building OpenOffice with the --enable-odk option, the build fails if Java
8 in installed.  Since earlier versions of Java are difficult to obtain, this
could be problematical for anyone who attempts to build OpenOffice 4.1.6 if
they don't already have an older version of Java installed.

To fix, these commits should be merged from trunk:
  https://svn.apache.org/viewvc?view=revision&revision=1591062 (partial)
  https://svn.apache.org/viewvc?view=revision&revision=1697228
  https://svn.apache.org/viewvc?view=revision&revision=1697237
  https://svn.apache.org/viewvc?view=revision&revision=1697247
  https://svn.apache.org/viewvc?view=revision&revision=1697306
  https://svn.apache.org/viewvc?view=revision&revision=1697312

The merge of 1591062 is only needed to prevent a merge conflict in one of the
later merges.  It is only a partial merge because a full merge of 1591062 fails
with a merge conflict.

In the top level directory of AOO416:
  svn merge -c 1591062 '^/openoffice/trunk/main/xmerge' main/xmerge
  svn merge -c 1697228 '^/openoffice/trunk' .
  svn merge -c 1697237 '^/openoffice/trunk' .
  svn merge -c 1697247 '^/openoffice/trunk' .
  svn merge -c 1697306 '^/openoffice/trunk' .
  svn merge -c 1697312 '^/openoffice/trunk' .

Fix tested in 4.1.6 on 32-bit Windows 7 with java 8 and CentOS 6 x86_64 with
java 1.7.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]