AOO418 cherry picks

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
43 messages Options
123
Reply | Threaded
Open this post in threaded view
|

AOO418 cherry picks

Don Lewis-2
I've got a bunch of cherry picks that I'm planning to merge into AOO418.
There are two categories:
  * Fixes from the FreeBSD port that have been upstreamed to the trunk
    and AOO42X branches, but I'm still carrying around in the FreeBSD
    port of 4.1.7.

  * Updates of a bunch of the bundled dependencies.  These have been
    updated in AOO42X and trunk for a while, but haven't been merged to
    AOO418.  The FreeBSD port mostly usees the system versions of these.

I'd like to revisit:

  commit 7a3beb322b74df1b6c96e03605837df34781c68f
  Author: Matthias Seidel <[hidden email]>
  Date:   Thu Oct 11 16:53:51 2018 +0000
 
      Rollback to Rev. 1843088 due to build errors.
     
      git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68

I'm still using the patch for the FreeBSD port.  Without it, a build
with --enable-odk will fail with Java 8 or newer.  I don't see how it
would break the build since the changes are just to structured comments
that are parsed to generate the documentation in the ODK.  When this was
backed out, I thought the reason was that building with a newer version
of the JDK would prevent runtime detection of older versions of the JDK.
So far asa I know, that's not a problem with AOO42X and trunk, which
have the changes.



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Pedro Lino-3
Hi Don, all

I'm still trying to compile 418 on Ubuntu 18.04 x64
I updated the 418 code but I get stuck at module graphite with the following error (log file at https://etherpad.wikimedia.org/p/config.log)

Any ideas?

Thanks!

configure: error: C compiler cannot create executables
See `config.log' for more details.
dmake:  Error code 77, while making './unxlngx6.pro/misc/build/so_configured_so_graphite'

1 module(s):
        graphite
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making /source/openoffice/main/graphite

When you have fixed the errors in that module you can resume the build by running:

        build --from graphite

> On 08/24/2020 3:04 AM Don Lewis <[hidden email]> wrote:
>
>  
> I've got a bunch of cherry picks that I'm planning to merge into AOO418.
> There are two categories:
>   * Fixes from the FreeBSD port that have been upstreamed to the trunk
>     and AOO42X branches, but I'm still carrying around in the FreeBSD
>     port of 4.1.7.
>
>   * Updates of a bunch of the bundled dependencies.  These have been
>     updated in AOO42X and trunk for a while, but haven't been merged to
>     AOO418.  The FreeBSD port mostly usees the system versions of these.
>
> I'd like to revisit:
>
>   commit 7a3beb322b74df1b6c96e03605837df34781c68f
>   Author: Matthias Seidel <[hidden email]>
>   Date:   Thu Oct 11 16:53:51 2018 +0000
>  
>       Rollback to Rev. 1843088 due to build errors.
>      
>       git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68
>
> I'm still using the patch for the FreeBSD port.  Without it, a build
> with --enable-odk will fail with Java 8 or newer.  I don't see how it
> would break the build since the changes are just to structured comments
> that are parsed to generate the documentation in the ODK.  When this was
> backed out, I thought the reason was that building with a newer version
> of the JDK would prevent runtime detection of older versions of the JDK.
> So far asa I know, that's not a problem with AOO42X and trunk, which
> have the changes.
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Don Lewis-2
On 24 Aug, Pedro Lino wrote:
> Hi Don, all
>
> I'm still trying to compile 418 on Ubuntu 18.04 x64
> I updated the 418 code but I get stuck at module graphite with the following error (log file at https://etherpad.wikimedia.org/p/config.log)
>
> Any ideas?

The error is happening during the configure step for graphite.  The
config.log mentioned is this one:

main/graphite/unxlngx6.pro/misc/build/silgraphite-2.3.1/engine/config.log

I don't believe I've run across any problems here.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Matthias Seidel
In reply to this post by Don Lewis-2
Hi Don,

Am 24.08.20 um 04:04 schrieb Don Lewis:

> I've got a bunch of cherry picks that I'm planning to merge into AOO418.
> There are two categories:
>   * Fixes from the FreeBSD port that have been upstreamed to the trunk
>     and AOO42X branches, but I'm still carrying around in the FreeBSD
>     port of 4.1.7.
>
>   * Updates of a bunch of the bundled dependencies.  These have been
>     updated in AOO42X and trunk for a while, but haven't been merged to
>     AOO418.  The FreeBSD port mostly usees the system versions of these.
>
> I'd like to revisit:
>
>   commit 7a3beb322b74df1b6c96e03605837df34781c68f
>   Author: Matthias Seidel <[hidden email]>
>   Date:   Thu Oct 11 16:53:51 2018 +0000
>  
>       Rollback to Rev. 1843088 due to build errors.
>      
>       git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68
>
> I'm still using the patch for the FreeBSD port.  Without it, a build
> with --enable-odk will fail with Java 8 or newer.  I don't see how it
> would break the build since the changes are just to structured comments
> that are parsed to generate the documentation in the ODK.  When this was
> backed out, I thought the reason was that building with a newer version
> of the JDK would prevent runtime detection of older versions of the JDK.
> So far asa I know, that's not a problem with AOO42X and trunk, which
> have the changes.
No, it was backed out because it broke the build.
But I am not sure if it was the patch itself or the way it was
committed. I think there were several fixes committed at once...

However, at that time a build that was compiled with Java 8 could not
see an installed Java 7 (at least on Windows).
Meanwhile Damjan has changed the Java detection (for AdpoptOpenJDK) so
we might try it again.

Regards,

   Matthias

>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Matthias Seidel
In reply to this post by Don Lewis-2

Hi Don,

Am 24.08.20 um 04:04 schrieb Don Lewis:
I've got a bunch of cherry picks that I'm planning to merge into AOO418.
There are two categories:
  * Fixes from the FreeBSD port that have been upstreamed to the trunk
    and AOO42X branches, but I'm still carrying around in the FreeBSD
    port of 4.1.7.

  * Updates of a bunch of the bundled dependencies.  These have been
    updated in AOO42X and trunk for a while, but haven't been merged to
    AOO418.  The FreeBSD port mostly usees the system versions of these.

I'd like to revisit:

  commit 7a3beb322b74df1b6c96e03605837df34781c68f
  Author: Matthias Seidel [hidden email]
  Date:   Thu Oct 11 16:53:51 2018 +0000
  
      Rollback to Rev. 1843088 due to build errors.
      
      git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68

I'm still using the patch for the FreeBSD port.  Without it, a build
with --enable-odk will fail with Java 8 or newer.  I don't see how it
would break the build since the changes are just to structured comments
that are parsed to generate the documentation in the ODK.  When this was
backed out, I thought the reason was that building with a newer version
of the JDK would prevent runtime detection of older versions of the JDK.
So far asa I know, that's not a problem with AOO42X and trunk, which
have the changes.

If I remember it right the Rollback included:

 - Issue 127887 - update bundled redland/raptor/rasqal
 - Issue 127875 - fix a loop that visits all objects on a page so that all objects get visited
 - Issue 127874 - fix bad potential invalid subscript bug when using Microsoft Uniscribe text layout API

We should commit all of the above again, one after the other.

"Issue 127876 - unbreak ODK build with Java 8" should be double checked because of the known issue with Java 7 JRE.

Regards,

   Matthias




---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Matthias Seidel
Am 27.08.20 um 19:32 schrieb Matthias Seidel:

Hi Don,

Am 24.08.20 um 04:04 schrieb Don Lewis:
I've got a bunch of cherry picks that I'm planning to merge into AOO418.
There are two categories:
  * Fixes from the FreeBSD port that have been upstreamed to the trunk
    and AOO42X branches, but I'm still carrying around in the FreeBSD
    port of 4.1.7.

  * Updates of a bunch of the bundled dependencies.  These have been
    updated in AOO42X and trunk for a while, but haven't been merged to
    AOO418.  The FreeBSD port mostly usees the system versions of these.

I'd like to revisit:

  commit 7a3beb322b74df1b6c96e03605837df34781c68f
  Author: Matthias Seidel [hidden email]
  Date:   Thu Oct 11 16:53:51 2018 +0000
  
      Rollback to Rev. 1843088 due to build errors.
      
      git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68

I'm still using the patch for the FreeBSD port.  Without it, a build
with --enable-odk will fail with Java 8 or newer.  I don't see how it
would break the build since the changes are just to structured comments
that are parsed to generate the documentation in the ODK.  When this was
backed out, I thought the reason was that building with a newer version
of the JDK would prevent runtime detection of older versions of the JDK.
So far asa I know, that's not a problem with AOO42X and trunk, which
have the changes.

If I remember it right the Rollback included:

 - Issue 127887 - update bundled redland/raptor/rasqal
 - Issue 127875 - fix a loop that visits all objects on a page so that all objects get visited
 - Issue 127874 - fix bad potential invalid subscript bug when using Microsoft Uniscribe text layout API

We should commit all of the above again, one after the other.

Correcting myself: I had re-committed Issue 127874 and Issue 127875 to 4.1.6 after the Rollback.

So Issue 127887 could now be committed to 4.1.8.
We should discuss the change in configure.in regarding MacOS with Jim.

Regards,

   Matthias

"Issue 127876 - unbreak ODK build with Java 8" should be double checked because of the known issue with Java 7 JRE.

Regards,

   Matthias


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Don Lewis-2
On 27 Aug, Matthias Seidel wrote:

> Am 27.08.20 um 19:32 schrieb Matthias Seidel:
>>
>> Hi Don,
>>
>> Am 24.08.20 um 04:04 schrieb Don Lewis:
>>> I've got a bunch of cherry picks that I'm planning to merge into AOO418.
>>> There are two categories:
>>>   * Fixes from the FreeBSD port that have been upstreamed to the trunk
>>>     and AOO42X branches, but I'm still carrying around in the FreeBSD
>>>     port of 4.1.7.
>>>
>>>   * Updates of a bunch of the bundled dependencies.  These have been
>>>     updated in AOO42X and trunk for a while, but haven't been merged to
>>>     AOO418.  The FreeBSD port mostly usees the system versions of these.
>>>
>>> I'd like to revisit:
>>>
>>>   commit 7a3beb322b74df1b6c96e03605837df34781c68f
>>>   Author: Matthias Seidel <[hidden email]>
>>>   Date:   Thu Oct 11 16:53:51 2018 +0000
>>>  
>>>       Rollback to Rev. 1843088 due to build errors.
>>>      
>>>       git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68
>>>
>>> I'm still using the patch for the FreeBSD port.  Without it, a build
>>> with --enable-odk will fail with Java 8 or newer.  I don't see how it
>>> would break the build since the changes are just to structured comments
>>> that are parsed to generate the documentation in the ODK.  When this was
>>> backed out, I thought the reason was that building with a newer version
>>> of the JDK would prevent runtime detection of older versions of the JDK.
>>> So far asa I know, that's not a problem with AOO42X and trunk, which
>>> have the changes.
>>
>> If I remember it right the Rollback included:
>>
>>  - Issue 127887 - update bundled redland/raptor/rasqal
>>  - Issue 127875 - fix a loop that visits all objects on a page so that
>> all objects get visited
>>  - Issue 127874 - fix bad potential invalid subscript bug when using
>> Microsoft Uniscribe text layout API
>>
>> We should commit all of the above again, one after the other.
>>
> Correcting myself: I had re-committed Issue 127874 and Issue 127875 to
> 4.1.6 after the Rollback.
>
> So Issue 127887 could now be committed to 4.1.8.
> We should discuss the change in configure.in regarding MacOS with Jim.

I'm working on a fairly large update to the bundled software.  I should
be able to create a pull request in a day or so.  127887 will be
included.  I'll test it on Linux and Windows.  I'll take a stab at the
MacOS bits, but won't be able to test it.

> Regards,
>
>    Matthias
>
>> "Issue 127876 - unbreak ODK build with Java 8" should be double
>> checked because of the known issue with Java 7 JRE.

Since 127876 only changes comments in our Java code, it should not
affect detection.  Without this change, is the Java 7 JRE detected if we
build with Java 8?


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Matthias Seidel
Hi Don,

Am 27.08.20 um 20:02 schrieb Don Lewis:

> On 27 Aug, Matthias Seidel wrote:
>> Am 27.08.20 um 19:32 schrieb Matthias Seidel:
>>> Hi Don,
>>>
>>> Am 24.08.20 um 04:04 schrieb Don Lewis:
>>>> I've got a bunch of cherry picks that I'm planning to merge into AOO418.
>>>> There are two categories:
>>>>   * Fixes from the FreeBSD port that have been upstreamed to the trunk
>>>>     and AOO42X branches, but I'm still carrying around in the FreeBSD
>>>>     port of 4.1.7.
>>>>
>>>>   * Updates of a bunch of the bundled dependencies.  These have been
>>>>     updated in AOO42X and trunk for a while, but haven't been merged to
>>>>     AOO418.  The FreeBSD port mostly usees the system versions of these.
>>>>
>>>> I'd like to revisit:
>>>>
>>>>   commit 7a3beb322b74df1b6c96e03605837df34781c68f
>>>>   Author: Matthias Seidel <[hidden email]>
>>>>   Date:   Thu Oct 11 16:53:51 2018 +0000
>>>>  
>>>>       Rollback to Rev. 1843088 due to build errors.
>>>>      
>>>>       git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68
>>>>
>>>> I'm still using the patch for the FreeBSD port.  Without it, a build
>>>> with --enable-odk will fail with Java 8 or newer.  I don't see how it
>>>> would break the build since the changes are just to structured comments
>>>> that are parsed to generate the documentation in the ODK.  When this was
>>>> backed out, I thought the reason was that building with a newer version
>>>> of the JDK would prevent runtime detection of older versions of the JDK.
>>>> So far asa I know, that's not a problem with AOO42X and trunk, which
>>>> have the changes.
>>> If I remember it right the Rollback included:
>>>
>>>  - Issue 127887 - update bundled redland/raptor/rasqal
>>>  - Issue 127875 - fix a loop that visits all objects on a page so that
>>> all objects get visited
>>>  - Issue 127874 - fix bad potential invalid subscript bug when using
>>> Microsoft Uniscribe text layout API
>>>
>>> We should commit all of the above again, one after the other.
>>>
>> Correcting myself: I had re-committed Issue 127874 and Issue 127875 to
>> 4.1.6 after the Rollback.
>>
>> So Issue 127887 could now be committed to 4.1.8.
>> We should discuss the change in configure.in regarding MacOS with Jim.
> I'm working on a fairly large update to the bundled software.  I should
> be able to create a pull request in a day or so.  127887 will be
> included.  I'll test it on Linux and Windows.  I'll take a stab at the
> MacOS bits, but won't be able to test it.
>
>> Regards,
>>
>>    Matthias
>>
>>> "Issue 127876 - unbreak ODK build with Java 8" should be double
>>> checked because of the known issue with Java 7 JRE.
> Since 127876 only changes comments in our Java code, it should not
> affect detection.  Without this change, is the Java 7 JRE detected if we
> build with Java 8?
The last time I built 4.1.x with Java 8 the installed Java 7 JDK wasn't
detected (on Windows).
That was without the patch.

I can test it again with a current revision but not before next week.

Regards,

   Matthias

>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Jim Jagielski
In reply to this post by Don Lewis-2
Let's commit and work after pushed.

> On Aug 27, 2020, at 2:02 PM, Don Lewis <[hidden email]> wrote:
>
> On 27 Aug, Matthias Seidel wrote:
>> Am 27.08.20 um 19:32 schrieb Matthias Seidel:
>>>
>>> Hi Don,
>>>
>>> Am 24.08.20 um 04:04 schrieb Don Lewis:
>>>> I've got a bunch of cherry picks that I'm planning to merge into AOO418.
>>>> There are two categories:
>>>>  * Fixes from the FreeBSD port that have been upstreamed to the trunk
>>>>    and AOO42X branches, but I'm still carrying around in the FreeBSD
>>>>    port of 4.1.7.
>>>>
>>>>  * Updates of a bunch of the bundled dependencies.  These have been
>>>>    updated in AOO42X and trunk for a while, but haven't been merged to
>>>>    AOO418.  The FreeBSD port mostly usees the system versions of these.
>>>>
>>>> I'd like to revisit:
>>>>
>>>>  commit 7a3beb322b74df1b6c96e03605837df34781c68f
>>>>  Author: Matthias Seidel <[hidden email]>
>>>>  Date:   Thu Oct 11 16:53:51 2018 +0000
>>>>
>>>>      Rollback to Rev. 1843088 due to build errors.
>>>>
>>>>      git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68
>>>>
>>>> I'm still using the patch for the FreeBSD port.  Without it, a build
>>>> with --enable-odk will fail with Java 8 or newer.  I don't see how it
>>>> would break the build since the changes are just to structured comments
>>>> that are parsed to generate the documentation in the ODK.  When this was
>>>> backed out, I thought the reason was that building with a newer version
>>>> of the JDK would prevent runtime detection of older versions of the JDK.
>>>> So far asa I know, that's not a problem with AOO42X and trunk, which
>>>> have the changes.
>>>
>>> If I remember it right the Rollback included:
>>>
>>>  - Issue 127887 - update bundled redland/raptor/rasqal
>>>  - Issue 127875 - fix a loop that visits all objects on a page so that
>>> all objects get visited
>>>  - Issue 127874 - fix bad potential invalid subscript bug when using
>>> Microsoft Uniscribe text layout API
>>>
>>> We should commit all of the above again, one after the other.
>>>
>> Correcting myself: I had re-committed Issue 127874 and Issue 127875 to
>> 4.1.6 after the Rollback.
>>
>> So Issue 127887 could now be committed to 4.1.8.
>> We should discuss the change in configure.in regarding MacOS with Jim.
>
> I'm working on a fairly large update to the bundled software.  I should
> be able to create a pull request in a day or so.  127887 will be
> included.  I'll test it on Linux and Windows.  I'll take a stab at the
> MacOS bits, but won't be able to test it.
>
>> Regards,
>>
>>    Matthias
>>
>>> "Issue 127876 - unbreak ODK build with Java 8" should be double
>>> checked because of the known issue with Java 7 JRE.
>
> Since 127876 only changes comments in our Java code, it should not
> affect detection.  Without this change, is the Java 7 JRE detected if we
> build with Java 8?
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Matthias Seidel
Hi Jim, Don,

Am 28.08.20 um 15:17 schrieb Jim Jagielski:
> Let's commit and work after pushed.

We should try

https://bz.apache.org/ooo/show_bug.cgi?id=127887

again for 4.1.8.

Regards,

   Matthias

>
>> On Aug 27, 2020, at 2:02 PM, Don Lewis <[hidden email]> wrote:
>>
>> On 27 Aug, Matthias Seidel wrote:
>>> Am 27.08.20 um 19:32 schrieb Matthias Seidel:
>>>> Hi Don,
>>>>
>>>> Am 24.08.20 um 04:04 schrieb Don Lewis:
>>>>> I've got a bunch of cherry picks that I'm planning to merge into AOO418.
>>>>> There are two categories:
>>>>>  * Fixes from the FreeBSD port that have been upstreamed to the trunk
>>>>>    and AOO42X branches, but I'm still carrying around in the FreeBSD
>>>>>    port of 4.1.7.
>>>>>
>>>>>  * Updates of a bunch of the bundled dependencies.  These have been
>>>>>    updated in AOO42X and trunk for a while, but haven't been merged to
>>>>>    AOO418.  The FreeBSD port mostly usees the system versions of these.
>>>>>
>>>>> I'd like to revisit:
>>>>>
>>>>>  commit 7a3beb322b74df1b6c96e03605837df34781c68f
>>>>>  Author: Matthias Seidel <[hidden email]>
>>>>>  Date:   Thu Oct 11 16:53:51 2018 +0000
>>>>>
>>>>>      Rollback to Rev. 1843088 due to build errors.
>>>>>
>>>>>      git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68
>>>>>
>>>>> I'm still using the patch for the FreeBSD port.  Without it, a build
>>>>> with --enable-odk will fail with Java 8 or newer.  I don't see how it
>>>>> would break the build since the changes are just to structured comments
>>>>> that are parsed to generate the documentation in the ODK.  When this was
>>>>> backed out, I thought the reason was that building with a newer version
>>>>> of the JDK would prevent runtime detection of older versions of the JDK.
>>>>> So far asa I know, that's not a problem with AOO42X and trunk, which
>>>>> have the changes.
>>>> If I remember it right the Rollback included:
>>>>
>>>>  - Issue 127887 - update bundled redland/raptor/rasqal
>>>>  - Issue 127875 - fix a loop that visits all objects on a page so that
>>>> all objects get visited
>>>>  - Issue 127874 - fix bad potential invalid subscript bug when using
>>>> Microsoft Uniscribe text layout API
>>>>
>>>> We should commit all of the above again, one after the other.
>>>>
>>> Correcting myself: I had re-committed Issue 127874 and Issue 127875 to
>>> 4.1.6 after the Rollback.
>>>
>>> So Issue 127887 could now be committed to 4.1.8.
>>> We should discuss the change in configure.in regarding MacOS with Jim.
>> I'm working on a fairly large update to the bundled software.  I should
>> be able to create a pull request in a day or so.  127887 will be
>> included.  I'll test it on Linux and Windows.  I'll take a stab at the
>> MacOS bits, but won't be able to test it.
>>
>>> Regards,
>>>
>>>    Matthias
>>>
>>>> "Issue 127876 - unbreak ODK build with Java 8" should be double
>>>> checked because of the known issue with Java 7 JRE.
>> Since 127876 only changes comments in our Java code, it should not
>> affect detection.  Without this change, is the Java 7 JRE detected if we
>> build with Java 8?
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Don Lewis-2
On  4 Sep, Matthias Seidel wrote:

> Hi Jim, Don,
>
> Am 28.08.20 um 15:17 schrieb Jim Jagielski:
>> Let's commit and work after pushed.
>
> We should try
>
> https://bz.apache.org/ooo/show_bug.cgi?id=127887
>
> again for 4.1.8.

I've included it in a large bundle of cherry-picks that I've been
testing.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Matthias Seidel
Am 04.09.20 um 18:45 schrieb Don Lewis:

> On  4 Sep, Matthias Seidel wrote:
>> Hi Jim, Don,
>>
>> Am 28.08.20 um 15:17 schrieb Jim Jagielski:
>>> Let's commit and work after pushed.
>> We should try
>>
>> https://bz.apache.org/ooo/show_bug.cgi?id=127887
>>
>> again for 4.1.8.
> I've included it in a large bundle of cherry-picks that I've been
> testing.
Thanks!
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Jim Jagielski
In reply to this post by Matthias Seidel
For 4.1.x we have always supported 10.7 as the min macOS version. Changing supported versions via a patch release does not seem right. IMO, we pull the rug out from under people when bumping patch revs.

> On Sep 4, 2020, at 9:18 AM, Matthias Seidel <[hidden email]> wrote:
>
> Hi Jim, Don,
>
> Am 28.08.20 um 15:17 schrieb Jim Jagielski:
>> Let's commit and work after pushed.
>
> We should try
>
> https://bz.apache.org/ooo/show_bug.cgi?id=127887
>
> again for 4.1.8.
>
> Regards,
>
>    Matthias
>
>>
>>> On Aug 27, 2020, at 2:02 PM, Don Lewis <[hidden email]> wrote:
>>>
>>> On 27 Aug, Matthias Seidel wrote:
>>>> Am 27.08.20 um 19:32 schrieb Matthias Seidel:
>>>>> Hi Don,
>>>>>
>>>>> Am 24.08.20 um 04:04 schrieb Don Lewis:
>>>>>> I've got a bunch of cherry picks that I'm planning to merge into AOO418.
>>>>>> There are two categories:
>>>>>> * Fixes from the FreeBSD port that have been upstreamed to the trunk
>>>>>>   and AOO42X branches, but I'm still carrying around in the FreeBSD
>>>>>>   port of 4.1.7.
>>>>>>
>>>>>> * Updates of a bunch of the bundled dependencies.  These have been
>>>>>>   updated in AOO42X and trunk for a while, but haven't been merged to
>>>>>>   AOO418.  The FreeBSD port mostly usees the system versions of these.
>>>>>>
>>>>>> I'd like to revisit:
>>>>>>
>>>>>> commit 7a3beb322b74df1b6c96e03605837df34781c68f
>>>>>> Author: Matthias Seidel <[hidden email]>
>>>>>> Date:   Thu Oct 11 16:53:51 2018 +0000
>>>>>>
>>>>>>     Rollback to Rev. 1843088 due to build errors.
>>>>>>
>>>>>>     git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68
>>>>>>
>>>>>> I'm still using the patch for the FreeBSD port.  Without it, a build
>>>>>> with --enable-odk will fail with Java 8 or newer.  I don't see how it
>>>>>> would break the build since the changes are just to structured comments
>>>>>> that are parsed to generate the documentation in the ODK.  When this was
>>>>>> backed out, I thought the reason was that building with a newer version
>>>>>> of the JDK would prevent runtime detection of older versions of the JDK.
>>>>>> So far asa I know, that's not a problem with AOO42X and trunk, which
>>>>>> have the changes.
>>>>> If I remember it right the Rollback included:
>>>>>
>>>>> - Issue 127887 - update bundled redland/raptor/rasqal
>>>>> - Issue 127875 - fix a loop that visits all objects on a page so that
>>>>> all objects get visited
>>>>> - Issue 127874 - fix bad potential invalid subscript bug when using
>>>>> Microsoft Uniscribe text layout API
>>>>>
>>>>> We should commit all of the above again, one after the other.
>>>>>
>>>> Correcting myself: I had re-committed Issue 127874 and Issue 127875 to
>>>> 4.1.6 after the Rollback.
>>>>
>>>> So Issue 127887 could now be committed to 4.1.8.
>>>> We should discuss the change in configure.in regarding MacOS with Jim.
>>> I'm working on a fairly large update to the bundled software.  I should
>>> be able to create a pull request in a day or so.  127887 will be
>>> included.  I'll test it on Linux and Windows.  I'll take a stab at the
>>> MacOS bits, but won't be able to test it.
>>>
>>>> Regards,
>>>>
>>>>   Matthias
>>>>
>>>>> "Issue 127876 - unbreak ODK build with Java 8" should be double
>>>>> checked because of the known issue with Java 7 JRE.
>>> Since 127876 only changes comments in our Java code, it should not
>>> affect detection.  Without this change, is the Java 7 JRE detected if we
>>> build with Java 8?
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Matthias Seidel
Hi Jim,

Am 07.09.20 um 15:14 schrieb Jim Jagielski:
> For 4.1.x we have always supported 10.7 as the min macOS version. Changing supported versions via a patch release does not seem right. IMO, we pull the rug out from under people when bumping patch revs.

That's one of the reasons why it was backed out of 4.1.6 and why I
wanted you to have a look.

Maybe the patch works also with 10.7?

Regards,

   Matthias

>
>> On Sep 4, 2020, at 9:18 AM, Matthias Seidel <[hidden email]> wrote:
>>
>> Hi Jim, Don,
>>
>> Am 28.08.20 um 15:17 schrieb Jim Jagielski:
>>> Let's commit and work after pushed.
>> We should try
>>
>> https://bz.apache.org/ooo/show_bug.cgi?id=127887
>>
>> again for 4.1.8.
>>
>> Regards,
>>
>>    Matthias
>>
>>>> On Aug 27, 2020, at 2:02 PM, Don Lewis <[hidden email]> wrote:
>>>>
>>>> On 27 Aug, Matthias Seidel wrote:
>>>>> Am 27.08.20 um 19:32 schrieb Matthias Seidel:
>>>>>> Hi Don,
>>>>>>
>>>>>> Am 24.08.20 um 04:04 schrieb Don Lewis:
>>>>>>> I've got a bunch of cherry picks that I'm planning to merge into AOO418.
>>>>>>> There are two categories:
>>>>>>> * Fixes from the FreeBSD port that have been upstreamed to the trunk
>>>>>>>   and AOO42X branches, but I'm still carrying around in the FreeBSD
>>>>>>>   port of 4.1.7.
>>>>>>>
>>>>>>> * Updates of a bunch of the bundled dependencies.  These have been
>>>>>>>   updated in AOO42X and trunk for a while, but haven't been merged to
>>>>>>>   AOO418.  The FreeBSD port mostly usees the system versions of these.
>>>>>>>
>>>>>>> I'd like to revisit:
>>>>>>>
>>>>>>> commit 7a3beb322b74df1b6c96e03605837df34781c68f
>>>>>>> Author: Matthias Seidel <[hidden email]>
>>>>>>> Date:   Thu Oct 11 16:53:51 2018 +0000
>>>>>>>
>>>>>>>     Rollback to Rev. 1843088 due to build errors.
>>>>>>>
>>>>>>>     git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68
>>>>>>>
>>>>>>> I'm still using the patch for the FreeBSD port.  Without it, a build
>>>>>>> with --enable-odk will fail with Java 8 or newer.  I don't see how it
>>>>>>> would break the build since the changes are just to structured comments
>>>>>>> that are parsed to generate the documentation in the ODK.  When this was
>>>>>>> backed out, I thought the reason was that building with a newer version
>>>>>>> of the JDK would prevent runtime detection of older versions of the JDK.
>>>>>>> So far asa I know, that's not a problem with AOO42X and trunk, which
>>>>>>> have the changes.
>>>>>> If I remember it right the Rollback included:
>>>>>>
>>>>>> - Issue 127887 - update bundled redland/raptor/rasqal
>>>>>> - Issue 127875 - fix a loop that visits all objects on a page so that
>>>>>> all objects get visited
>>>>>> - Issue 127874 - fix bad potential invalid subscript bug when using
>>>>>> Microsoft Uniscribe text layout API
>>>>>>
>>>>>> We should commit all of the above again, one after the other.
>>>>>>
>>>>> Correcting myself: I had re-committed Issue 127874 and Issue 127875 to
>>>>> 4.1.6 after the Rollback.
>>>>>
>>>>> So Issue 127887 could now be committed to 4.1.8.
>>>>> We should discuss the change in configure.in regarding MacOS with Jim.
>>>> I'm working on a fairly large update to the bundled software.  I should
>>>> be able to create a pull request in a day or so.  127887 will be
>>>> included.  I'll test it on Linux and Windows.  I'll take a stab at the
>>>> MacOS bits, but won't be able to test it.
>>>>
>>>>> Regards,
>>>>>
>>>>>   Matthias
>>>>>
>>>>>> "Issue 127876 - unbreak ODK build with Java 8" should be double
>>>>>> checked because of the known issue with Java 7 JRE.
>>>> Since 127876 only changes comments in our Java code, it should not
>>>> affect detection.  Without this change, is the Java 7 JRE detected if we
>>>> build with Java 8?
>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>>>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Jim Jagielski
Are these in trunk, or 4.2.x?

> On Sep 7, 2020, at 10:31 AM, Matthias Seidel <[hidden email]> wrote:
>
> Hi Jim,
>
> Am 07.09.20 um 15:14 schrieb Jim Jagielski:
>> For 4.1.x we have always supported 10.7 as the min macOS version. Changing supported versions via a patch release does not seem right. IMO, we pull the rug out from under people when bumping patch revs.
>
> That's one of the reasons why it was backed out of 4.1.6 and why I
> wanted you to have a look.
>
> Maybe the patch works also with 10.7?
>
> Regards,
>
>    Matthias
>
>>
>>> On Sep 4, 2020, at 9:18 AM, Matthias Seidel <[hidden email]> wrote:
>>>
>>> Hi Jim, Don,
>>>
>>> Am 28.08.20 um 15:17 schrieb Jim Jagielski:
>>>> Let's commit and work after pushed.
>>> We should try
>>>
>>> https://bz.apache.org/ooo/show_bug.cgi?id=127887
>>>
>>> again for 4.1.8.
>>>
>>> Regards,
>>>
>>>   Matthias
>>>
>>>>> On Aug 27, 2020, at 2:02 PM, Don Lewis <[hidden email]> wrote:
>>>>>
>>>>> On 27 Aug, Matthias Seidel wrote:
>>>>>> Am 27.08.20 um 19:32 schrieb Matthias Seidel:
>>>>>>> Hi Don,
>>>>>>>
>>>>>>> Am 24.08.20 um 04:04 schrieb Don Lewis:
>>>>>>>> I've got a bunch of cherry picks that I'm planning to merge into AOO418.
>>>>>>>> There are two categories:
>>>>>>>> * Fixes from the FreeBSD port that have been upstreamed to the trunk
>>>>>>>>  and AOO42X branches, but I'm still carrying around in the FreeBSD
>>>>>>>>  port of 4.1.7.
>>>>>>>>
>>>>>>>> * Updates of a bunch of the bundled dependencies.  These have been
>>>>>>>>  updated in AOO42X and trunk for a while, but haven't been merged to
>>>>>>>>  AOO418.  The FreeBSD port mostly usees the system versions of these.
>>>>>>>>
>>>>>>>> I'd like to revisit:
>>>>>>>>
>>>>>>>> commit 7a3beb322b74df1b6c96e03605837df34781c68f
>>>>>>>> Author: Matthias Seidel <[hidden email]>
>>>>>>>> Date:   Thu Oct 11 16:53:51 2018 +0000
>>>>>>>>
>>>>>>>>    Rollback to Rev. 1843088 due to build errors.
>>>>>>>>
>>>>>>>>    git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68
>>>>>>>>
>>>>>>>> I'm still using the patch for the FreeBSD port.  Without it, a build
>>>>>>>> with --enable-odk will fail with Java 8 or newer.  I don't see how it
>>>>>>>> would break the build since the changes are just to structured comments
>>>>>>>> that are parsed to generate the documentation in the ODK.  When this was
>>>>>>>> backed out, I thought the reason was that building with a newer version
>>>>>>>> of the JDK would prevent runtime detection of older versions of the JDK.
>>>>>>>> So far asa I know, that's not a problem with AOO42X and trunk, which
>>>>>>>> have the changes.
>>>>>>> If I remember it right the Rollback included:
>>>>>>>
>>>>>>> - Issue 127887 - update bundled redland/raptor/rasqal
>>>>>>> - Issue 127875 - fix a loop that visits all objects on a page so that
>>>>>>> all objects get visited
>>>>>>> - Issue 127874 - fix bad potential invalid subscript bug when using
>>>>>>> Microsoft Uniscribe text layout API
>>>>>>>
>>>>>>> We should commit all of the above again, one after the other.
>>>>>>>
>>>>>> Correcting myself: I had re-committed Issue 127874 and Issue 127875 to
>>>>>> 4.1.6 after the Rollback.
>>>>>>
>>>>>> So Issue 127887 could now be committed to 4.1.8.
>>>>>> We should discuss the change in configure.in regarding MacOS with Jim.
>>>>> I'm working on a fairly large update to the bundled software.  I should
>>>>> be able to create a pull request in a day or so.  127887 will be
>>>>> included.  I'll test it on Linux and Windows.  I'll take a stab at the
>>>>> MacOS bits, but won't be able to test it.
>>>>>
>>>>>> Regards,
>>>>>>
>>>>>>  Matthias
>>>>>>
>>>>>>> "Issue 127876 - unbreak ODK build with Java 8" should be double
>>>>>>> checked because of the known issue with Java 7 JRE.
>>>>> Since 127876 only changes comments in our Java code, it should not
>>>>> affect detection.  Without this change, is the Java 7 JRE detected if we
>>>>> build with Java 8?
>>>>>
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>>>>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Matthias Seidel
Hi Jim,

Am 08.09.20 um 19:53 schrieb Jim Jagielski:
> Are these in trunk, or 4.2.x?

I think so:

https://bz.apache.org/ooo/show_bug.cgi?id=127887#c0

Especially this one from you ;-)

https://svn.apache.org/viewvc?view=revision&revision=1805089

Regards,

   Matthias

>
>> On Sep 7, 2020, at 10:31 AM, Matthias Seidel <[hidden email]> wrote:
>>
>> Hi Jim,
>>
>> Am 07.09.20 um 15:14 schrieb Jim Jagielski:
>>> For 4.1.x we have always supported 10.7 as the min macOS version. Changing supported versions via a patch release does not seem right. IMO, we pull the rug out from under people when bumping patch revs.
>> That's one of the reasons why it was backed out of 4.1.6 and why I
>> wanted you to have a look.
>>
>> Maybe the patch works also with 10.7?
>>
>> Regards,
>>
>>    Matthias
>>
>>>> On Sep 4, 2020, at 9:18 AM, Matthias Seidel <[hidden email]> wrote:
>>>>
>>>> Hi Jim, Don,
>>>>
>>>> Am 28.08.20 um 15:17 schrieb Jim Jagielski:
>>>>> Let's commit and work after pushed.
>>>> We should try
>>>>
>>>> https://bz.apache.org/ooo/show_bug.cgi?id=127887
>>>>
>>>> again for 4.1.8.
>>>>
>>>> Regards,
>>>>
>>>>   Matthias
>>>>
>>>>>> On Aug 27, 2020, at 2:02 PM, Don Lewis <[hidden email]> wrote:
>>>>>>
>>>>>> On 27 Aug, Matthias Seidel wrote:
>>>>>>> Am 27.08.20 um 19:32 schrieb Matthias Seidel:
>>>>>>>> Hi Don,
>>>>>>>>
>>>>>>>> Am 24.08.20 um 04:04 schrieb Don Lewis:
>>>>>>>>> I've got a bunch of cherry picks that I'm planning to merge into AOO418.
>>>>>>>>> There are two categories:
>>>>>>>>> * Fixes from the FreeBSD port that have been upstreamed to the trunk
>>>>>>>>>  and AOO42X branches, but I'm still carrying around in the FreeBSD
>>>>>>>>>  port of 4.1.7.
>>>>>>>>>
>>>>>>>>> * Updates of a bunch of the bundled dependencies.  These have been
>>>>>>>>>  updated in AOO42X and trunk for a while, but haven't been merged to
>>>>>>>>>  AOO418.  The FreeBSD port mostly usees the system versions of these.
>>>>>>>>>
>>>>>>>>> I'd like to revisit:
>>>>>>>>>
>>>>>>>>> commit 7a3beb322b74df1b6c96e03605837df34781c68f
>>>>>>>>> Author: Matthias Seidel <[hidden email]>
>>>>>>>>> Date:   Thu Oct 11 16:53:51 2018 +0000
>>>>>>>>>
>>>>>>>>>    Rollback to Rev. 1843088 due to build errors.
>>>>>>>>>
>>>>>>>>>    git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68
>>>>>>>>>
>>>>>>>>> I'm still using the patch for the FreeBSD port.  Without it, a build
>>>>>>>>> with --enable-odk will fail with Java 8 or newer.  I don't see how it
>>>>>>>>> would break the build since the changes are just to structured comments
>>>>>>>>> that are parsed to generate the documentation in the ODK.  When this was
>>>>>>>>> backed out, I thought the reason was that building with a newer version
>>>>>>>>> of the JDK would prevent runtime detection of older versions of the JDK.
>>>>>>>>> So far asa I know, that's not a problem with AOO42X and trunk, which
>>>>>>>>> have the changes.
>>>>>>>> If I remember it right the Rollback included:
>>>>>>>>
>>>>>>>> - Issue 127887 - update bundled redland/raptor/rasqal
>>>>>>>> - Issue 127875 - fix a loop that visits all objects on a page so that
>>>>>>>> all objects get visited
>>>>>>>> - Issue 127874 - fix bad potential invalid subscript bug when using
>>>>>>>> Microsoft Uniscribe text layout API
>>>>>>>>
>>>>>>>> We should commit all of the above again, one after the other.
>>>>>>>>
>>>>>>> Correcting myself: I had re-committed Issue 127874 and Issue 127875 to
>>>>>>> 4.1.6 after the Rollback.
>>>>>>>
>>>>>>> So Issue 127887 could now be committed to 4.1.8.
>>>>>>> We should discuss the change in configure.in regarding MacOS with Jim.
>>>>>> I'm working on a fairly large update to the bundled software.  I should
>>>>>> be able to create a pull request in a day or so.  127887 will be
>>>>>> included.  I'll test it on Linux and Windows.  I'll take a stab at the
>>>>>> MacOS bits, but won't be able to test it.
>>>>>>
>>>>>>> Regards,
>>>>>>>
>>>>>>>  Matthias
>>>>>>>
>>>>>>>> "Issue 127876 - unbreak ODK build with Java 8" should be double
>>>>>>>> checked because of the known issue with Java 7 JRE.
>>>>>> Since 127876 only changes comments in our Java code, it should not
>>>>>> affect detection.  Without this change, is the Java 7 JRE detected if we
>>>>>> build with Java 8?
>>>>>>
>>>>>>
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>>>>>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Jim Jagielski
Hmmm... we still support 10.7 as the lowest macOS version on both truck and AOO420 so somewhere, somehow, that got reverted. So let's go ahead and pull those Issues into AOO418.

> On Sep 8, 2020, at 2:30 PM, Matthias Seidel <[hidden email]> wrote:
>
> Hi Jim,
>
> Am 08.09.20 um 19:53 schrieb Jim Jagielski:
>> Are these in trunk, or 4.2.x?
>
> I think so:
>
> https://bz.apache.org/ooo/show_bug.cgi?id=127887#c0
>
> Especially this one from you ;-)
>
> https://svn.apache.org/viewvc?view=revision&revision=1805089
>
> Regards,
>
>    Matthias
>
>>
>>> On Sep 7, 2020, at 10:31 AM, Matthias Seidel <[hidden email]> wrote:
>>>
>>> Hi Jim,
>>>
>>> Am 07.09.20 um 15:14 schrieb Jim Jagielski:
>>>> For 4.1.x we have always supported 10.7 as the min macOS version. Changing supported versions via a patch release does not seem right. IMO, we pull the rug out from under people when bumping patch revs.
>>> That's one of the reasons why it was backed out of 4.1.6 and why I
>>> wanted you to have a look.
>>>
>>> Maybe the patch works also with 10.7?
>>>
>>> Regards,
>>>
>>>   Matthias
>>>
>>>>> On Sep 4, 2020, at 9:18 AM, Matthias Seidel <[hidden email]> wrote:
>>>>>
>>>>> Hi Jim, Don,
>>>>>
>>>>> Am 28.08.20 um 15:17 schrieb Jim Jagielski:
>>>>>> Let's commit and work after pushed.
>>>>> We should try
>>>>>
>>>>> https://bz.apache.org/ooo/show_bug.cgi?id=127887
>>>>>
>>>>> again for 4.1.8.
>>>>>
>>>>> Regards,
>>>>>
>>>>>  Matthias
>>>>>
>>>>>>> On Aug 27, 2020, at 2:02 PM, Don Lewis <[hidden email]> wrote:
>>>>>>>
>>>>>>> On 27 Aug, Matthias Seidel wrote:
>>>>>>>> Am 27.08.20 um 19:32 schrieb Matthias Seidel:
>>>>>>>>> Hi Don,
>>>>>>>>>
>>>>>>>>> Am 24.08.20 um 04:04 schrieb Don Lewis:
>>>>>>>>>> I've got a bunch of cherry picks that I'm planning to merge into AOO418.
>>>>>>>>>> There are two categories:
>>>>>>>>>> * Fixes from the FreeBSD port that have been upstreamed to the trunk
>>>>>>>>>> and AOO42X branches, but I'm still carrying around in the FreeBSD
>>>>>>>>>> port of 4.1.7.
>>>>>>>>>>
>>>>>>>>>> * Updates of a bunch of the bundled dependencies.  These have been
>>>>>>>>>> updated in AOO42X and trunk for a while, but haven't been merged to
>>>>>>>>>> AOO418.  The FreeBSD port mostly usees the system versions of these.
>>>>>>>>>>
>>>>>>>>>> I'd like to revisit:
>>>>>>>>>>
>>>>>>>>>> commit 7a3beb322b74df1b6c96e03605837df34781c68f
>>>>>>>>>> Author: Matthias Seidel <[hidden email]>
>>>>>>>>>> Date:   Thu Oct 11 16:53:51 2018 +0000
>>>>>>>>>>
>>>>>>>>>>   Rollback to Rev. 1843088 due to build errors.
>>>>>>>>>>
>>>>>>>>>>   git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68
>>>>>>>>>>
>>>>>>>>>> I'm still using the patch for the FreeBSD port.  Without it, a build
>>>>>>>>>> with --enable-odk will fail with Java 8 or newer.  I don't see how it
>>>>>>>>>> would break the build since the changes are just to structured comments
>>>>>>>>>> that are parsed to generate the documentation in the ODK.  When this was
>>>>>>>>>> backed out, I thought the reason was that building with a newer version
>>>>>>>>>> of the JDK would prevent runtime detection of older versions of the JDK.
>>>>>>>>>> So far asa I know, that's not a problem with AOO42X and trunk, which
>>>>>>>>>> have the changes.
>>>>>>>>> If I remember it right the Rollback included:
>>>>>>>>>
>>>>>>>>> - Issue 127887 - update bundled redland/raptor/rasqal
>>>>>>>>> - Issue 127875 - fix a loop that visits all objects on a page so that
>>>>>>>>> all objects get visited
>>>>>>>>> - Issue 127874 - fix bad potential invalid subscript bug when using
>>>>>>>>> Microsoft Uniscribe text layout API
>>>>>>>>>
>>>>>>>>> We should commit all of the above again, one after the other.
>>>>>>>>>
>>>>>>>> Correcting myself: I had re-committed Issue 127874 and Issue 127875 to
>>>>>>>> 4.1.6 after the Rollback.
>>>>>>>>
>>>>>>>> So Issue 127887 could now be committed to 4.1.8.
>>>>>>>> We should discuss the change in configure.in regarding MacOS with Jim.
>>>>>>> I'm working on a fairly large update to the bundled software.  I should
>>>>>>> be able to create a pull request in a day or so.  127887 will be
>>>>>>> included.  I'll test it on Linux and Windows.  I'll take a stab at the
>>>>>>> MacOS bits, but won't be able to test it.
>>>>>>>
>>>>>>>> Regards,
>>>>>>>>
>>>>>>>> Matthias
>>>>>>>>
>>>>>>>>> "Issue 127876 - unbreak ODK build with Java 8" should be double
>>>>>>>>> checked because of the known issue with Java 7 JRE.
>>>>>>> Since 127876 only changes comments in our Java code, it should not
>>>>>>> affect detection.  Without this change, is the Java 7 JRE detected if we
>>>>>>> build with Java 8?
>>>>>>>
>>>>>>>
>>>>>>> ---------------------------------------------------------------------
>>>>>>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>>>>>>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>>>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Matthias Seidel
Hi Jim,

Am 15.09.20 um 13:00 schrieb Jim Jagielski:
> Hmmm... we still support 10.7 as the lowest macOS version on both truck and AOO420 so somewhere, somehow, that got reverted. So let's go ahead and pull those Issues into AOO418.
It got reverted here (and in some other commits):

https://github.com/apache/openoffice/commit/63fbc773865edd81abc91dd88f871bf29ce0a1f1

This may also be needed for Don's Pull Request:

https://github.com/apache/openoffice/pull/94

Regards,

   Matthias

>
>> On Sep 8, 2020, at 2:30 PM, Matthias Seidel <[hidden email]> wrote:
>>
>> Hi Jim,
>>
>> Am 08.09.20 um 19:53 schrieb Jim Jagielski:
>>> Are these in trunk, or 4.2.x?
>> I think so:
>>
>> https://bz.apache.org/ooo/show_bug.cgi?id=127887#c0
>>
>> Especially this one from you ;-)
>>
>> https://svn.apache.org/viewvc?view=revision&revision=1805089
>>
>> Regards,
>>
>>    Matthias
>>
>>>> On Sep 7, 2020, at 10:31 AM, Matthias Seidel <[hidden email]> wrote:
>>>>
>>>> Hi Jim,
>>>>
>>>> Am 07.09.20 um 15:14 schrieb Jim Jagielski:
>>>>> For 4.1.x we have always supported 10.7 as the min macOS version. Changing supported versions via a patch release does not seem right. IMO, we pull the rug out from under people when bumping patch revs.
>>>> That's one of the reasons why it was backed out of 4.1.6 and why I
>>>> wanted you to have a look.
>>>>
>>>> Maybe the patch works also with 10.7?
>>>>
>>>> Regards,
>>>>
>>>>   Matthias
>>>>
>>>>>> On Sep 4, 2020, at 9:18 AM, Matthias Seidel <[hidden email]> wrote:
>>>>>>
>>>>>> Hi Jim, Don,
>>>>>>
>>>>>> Am 28.08.20 um 15:17 schrieb Jim Jagielski:
>>>>>>> Let's commit and work after pushed.
>>>>>> We should try
>>>>>>
>>>>>> https://bz.apache.org/ooo/show_bug.cgi?id=127887
>>>>>>
>>>>>> again for 4.1.8.
>>>>>>
>>>>>> Regards,
>>>>>>
>>>>>>  Matthias
>>>>>>
>>>>>>>> On Aug 27, 2020, at 2:02 PM, Don Lewis <[hidden email]> wrote:
>>>>>>>>
>>>>>>>> On 27 Aug, Matthias Seidel wrote:
>>>>>>>>> Am 27.08.20 um 19:32 schrieb Matthias Seidel:
>>>>>>>>>> Hi Don,
>>>>>>>>>>
>>>>>>>>>> Am 24.08.20 um 04:04 schrieb Don Lewis:
>>>>>>>>>>> I've got a bunch of cherry picks that I'm planning to merge into AOO418.
>>>>>>>>>>> There are two categories:
>>>>>>>>>>> * Fixes from the FreeBSD port that have been upstreamed to the trunk
>>>>>>>>>>> and AOO42X branches, but I'm still carrying around in the FreeBSD
>>>>>>>>>>> port of 4.1.7.
>>>>>>>>>>>
>>>>>>>>>>> * Updates of a bunch of the bundled dependencies.  These have been
>>>>>>>>>>> updated in AOO42X and trunk for a while, but haven't been merged to
>>>>>>>>>>> AOO418.  The FreeBSD port mostly usees the system versions of these.
>>>>>>>>>>>
>>>>>>>>>>> I'd like to revisit:
>>>>>>>>>>>
>>>>>>>>>>> commit 7a3beb322b74df1b6c96e03605837df34781c68f
>>>>>>>>>>> Author: Matthias Seidel <[hidden email]>
>>>>>>>>>>> Date:   Thu Oct 11 16:53:51 2018 +0000
>>>>>>>>>>>
>>>>>>>>>>>   Rollback to Rev. 1843088 due to build errors.
>>>>>>>>>>>
>>>>>>>>>>>   git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68
>>>>>>>>>>>
>>>>>>>>>>> I'm still using the patch for the FreeBSD port.  Without it, a build
>>>>>>>>>>> with --enable-odk will fail with Java 8 or newer.  I don't see how it
>>>>>>>>>>> would break the build since the changes are just to structured comments
>>>>>>>>>>> that are parsed to generate the documentation in the ODK.  When this was
>>>>>>>>>>> backed out, I thought the reason was that building with a newer version
>>>>>>>>>>> of the JDK would prevent runtime detection of older versions of the JDK.
>>>>>>>>>>> So far asa I know, that's not a problem with AOO42X and trunk, which
>>>>>>>>>>> have the changes.
>>>>>>>>>> If I remember it right the Rollback included:
>>>>>>>>>>
>>>>>>>>>> - Issue 127887 - update bundled redland/raptor/rasqal
>>>>>>>>>> - Issue 127875 - fix a loop that visits all objects on a page so that
>>>>>>>>>> all objects get visited
>>>>>>>>>> - Issue 127874 - fix bad potential invalid subscript bug when using
>>>>>>>>>> Microsoft Uniscribe text layout API
>>>>>>>>>>
>>>>>>>>>> We should commit all of the above again, one after the other.
>>>>>>>>>>
>>>>>>>>> Correcting myself: I had re-committed Issue 127874 and Issue 127875 to
>>>>>>>>> 4.1.6 after the Rollback.
>>>>>>>>>
>>>>>>>>> So Issue 127887 could now be committed to 4.1.8.
>>>>>>>>> We should discuss the change in configure.in regarding MacOS with Jim.
>>>>>>>> I'm working on a fairly large update to the bundled software.  I should
>>>>>>>> be able to create a pull request in a day or so.  127887 will be
>>>>>>>> included.  I'll test it on Linux and Windows.  I'll take a stab at the
>>>>>>>> MacOS bits, but won't be able to test it.
>>>>>>>>
>>>>>>>>> Regards,
>>>>>>>>>
>>>>>>>>> Matthias
>>>>>>>>>
>>>>>>>>>> "Issue 127876 - unbreak ODK build with Java 8" should be double
>>>>>>>>>> checked because of the known issue with Java 7 JRE.
>>>>>>>> Since 127876 only changes comments in our Java code, it should not
>>>>>>>> affect detection.  Without this change, is the Java 7 JRE detected if we
>>>>>>>> build with Java 8?
>>>>>>>>
>>>>>>>>
>>>>>>>> ---------------------------------------------------------------------
>>>>>>>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>>>>>>>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>>>>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Jim Jagielski
Just a FYI that HEAD of AOO418 builds on macOS with no issues so far...

> On Sep 19, 2020, at 5:43 AM, Matthias Seidel <[hidden email]> wrote:
>
> Hi Jim,
>
> Am 15.09.20 um 13:00 schrieb Jim Jagielski:
>> Hmmm... we still support 10.7 as the lowest macOS version on both truck and AOO420 so somewhere, somehow, that got reverted. So let's go ahead and pull those Issues into AOO418.
> It got reverted here (and in some other commits):
>
> https://github.com/apache/openoffice/commit/63fbc773865edd81abc91dd88f871bf29ce0a1f1 <https://github.com/apache/openoffice/commit/63fbc773865edd81abc91dd88f871bf29ce0a1f1>
>
> This may also be needed for Don's Pull Request:
>
> https://github.com/apache/openoffice/pull/94 <https://github.com/apache/openoffice/pull/94>
>
> Regards,
>
>    Matthias
>
>>
>>> On Sep 8, 2020, at 2:30 PM, Matthias Seidel <[hidden email]> wrote:
>>>
>>> Hi Jim,
>>>
>>> Am 08.09.20 um 19:53 schrieb Jim Jagielski:
>>>> Are these in trunk, or 4.2.x?
>>> I think so:
>>>
>>> https://bz.apache.org/ooo/show_bug.cgi?id=127887#c0
>>>
>>> Especially this one from you ;-)
>>>
>>> https://svn.apache.org/viewvc?view=revision&revision=1805089
>>>
>>> Regards,
>>>
>>>   Matthias
>>>
>>>>> On Sep 7, 2020, at 10:31 AM, Matthias Seidel <[hidden email]> wrote:
>>>>>
>>>>> Hi Jim,
>>>>>
>>>>> Am 07.09.20 um 15:14 schrieb Jim Jagielski:
>>>>>> For 4.1.x we have always supported 10.7 as the min macOS version. Changing supported versions via a patch release does not seem right. IMO, we pull the rug out from under people when bumping patch revs.
>>>>> That's one of the reasons why it was backed out of 4.1.6 and why I
>>>>> wanted you to have a look.
>>>>>
>>>>> Maybe the patch works also with 10.7?
>>>>>
>>>>> Regards,
>>>>>
>>>>>  Matthias
>>>>>
>>>>>>> On Sep 4, 2020, at 9:18 AM, Matthias Seidel <[hidden email]> wrote:
>>>>>>>
>>>>>>> Hi Jim, Don,
>>>>>>>
>>>>>>> Am 28.08.20 um 15:17 schrieb Jim Jagielski:
>>>>>>>> Let's commit and work after pushed.
>>>>>>> We should try
>>>>>>>
>>>>>>> https://bz.apache.org/ooo/show_bug.cgi?id=127887
>>>>>>>
>>>>>>> again for 4.1.8.
>>>>>>>
>>>>>>> Regards,
>>>>>>>
>>>>>>> Matthias
>>>>>>>
>>>>>>>>> On Aug 27, 2020, at 2:02 PM, Don Lewis <[hidden email]> wrote:
>>>>>>>>>
>>>>>>>>> On 27 Aug, Matthias Seidel wrote:
>>>>>>>>>> Am 27.08.20 um 19:32 schrieb Matthias Seidel:
>>>>>>>>>>> Hi Don,
>>>>>>>>>>>
>>>>>>>>>>> Am 24.08.20 um 04:04 schrieb Don Lewis:
>>>>>>>>>>>> I've got a bunch of cherry picks that I'm planning to merge into AOO418.
>>>>>>>>>>>> There are two categories:
>>>>>>>>>>>> * Fixes from the FreeBSD port that have been upstreamed to the trunk
>>>>>>>>>>>> and AOO42X branches, but I'm still carrying around in the FreeBSD
>>>>>>>>>>>> port of 4.1.7.
>>>>>>>>>>>>
>>>>>>>>>>>> * Updates of a bunch of the bundled dependencies.  These have been
>>>>>>>>>>>> updated in AOO42X and trunk for a while, but haven't been merged to
>>>>>>>>>>>> AOO418.  The FreeBSD port mostly usees the system versions of these.
>>>>>>>>>>>>
>>>>>>>>>>>> I'd like to revisit:
>>>>>>>>>>>>
>>>>>>>>>>>> commit 7a3beb322b74df1b6c96e03605837df34781c68f
>>>>>>>>>>>> Author: Matthias Seidel <[hidden email]>
>>>>>>>>>>>> Date:   Thu Oct 11 16:53:51 2018 +0000
>>>>>>>>>>>>
>>>>>>>>>>>>  Rollback to Rev. 1843088 due to build errors.
>>>>>>>>>>>>
>>>>>>>>>>>>  git-svn-id: https://svn.apache.org/repos/asf/openoffice/branches/AOO416@18438571 13f79535-47bb-0310-9956-ffa450edef68
>>>>>>>>>>>>
>>>>>>>>>>>> I'm still using the patch for the FreeBSD port.  Without it, a build
>>>>>>>>>>>> with --enable-odk will fail with Java 8 or newer.  I don't see how it
>>>>>>>>>>>> would break the build since the changes are just to structured comments
>>>>>>>>>>>> that are parsed to generate the documentation in the ODK.  When this was
>>>>>>>>>>>> backed out, I thought the reason was that building with a newer version
>>>>>>>>>>>> of the JDK would prevent runtime detection of older versions of the JDK.
>>>>>>>>>>>> So far asa I know, that's not a problem with AOO42X and trunk, which
>>>>>>>>>>>> have the changes.
>>>>>>>>>>> If I remember it right the Rollback included:
>>>>>>>>>>>
>>>>>>>>>>> - Issue 127887 - update bundled redland/raptor/rasqal
>>>>>>>>>>> - Issue 127875 - fix a loop that visits all objects on a page so that
>>>>>>>>>>> all objects get visited
>>>>>>>>>>> - Issue 127874 - fix bad potential invalid subscript bug when using
>>>>>>>>>>> Microsoft Uniscribe text layout API
>>>>>>>>>>>
>>>>>>>>>>> We should commit all of the above again, one after the other.
>>>>>>>>>>>
>>>>>>>>>> Correcting myself: I had re-committed Issue 127874 and Issue 127875 to
>>>>>>>>>> 4.1.6 after the Rollback.
>>>>>>>>>>
>>>>>>>>>> So Issue 127887 could now be committed to 4.1.8.
>>>>>>>>>> We should discuss the change in configure.in regarding MacOS with Jim.
>>>>>>>>> I'm working on a fairly large update to the bundled software.  I should
>>>>>>>>> be able to create a pull request in a day or so.  127887 will be
>>>>>>>>> included.  I'll test it on Linux and Windows.  I'll take a stab at the
>>>>>>>>> MacOS bits, but won't be able to test it.
>>>>>>>>>
>>>>>>>>>> Regards,
>>>>>>>>>>
>>>>>>>>>> Matthias
>>>>>>>>>>
>>>>>>>>>>> "Issue 127876 - unbreak ODK build with Java 8" should be double
>>>>>>>>>>> checked because of the known issue with Java 7 JRE.
>>>>>>>>> Since 127876 only changes comments in our Java code, it should not
>>>>>>>>> affect detection.  Without this change, is the Java 7 JRE detected if we
>>>>>>>>> build with Java 8?
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> ---------------------------------------------------------------------
>>>>>>>>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>>>>>>>>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>>>>>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: AOO418 cherry picks

Don Lewis-2
On 22 Sep, Jim Jagielski wrote:
> Just a FYI that HEAD of AOO418 builds on macOS with no issues so far...

https://github.com/apache/openoffice/pull/94 has some macOS-specific
changes from AOO42X.




---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

123