Boring issue: Opening ODF document from LibreOffice 7 displays error

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Boring issue: Opening ODF document from LibreOffice 7 displays error

Bidouille
Hello dev team,


https://bz.apache.org/ooo/show_bug.cgi?id=128412

LibreOffice 7 use ODF 1.3 (experimental) for its documents.
Unable to open it without an error.
This is a painful for end-users.


:-/

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Boring issue: Opening ODF document from LibreOffice 7 displays error

Matthias Seidel
Hi Bidouille,

Am 08.11.20 um 17:25 schrieb Bidouille:
> Hello dev team,
>
>
> https://bz.apache.org/ooo/show_bug.cgi?id=128412
>
> LibreOffice 7 use ODF 1.3 (experimental) for its documents.
> Unable to open it without an error.
> This is a painful for end-users.

Yes, that is something we must address somehow.

What is your proposal?

Regards,

   Matthias

>
>
> :-/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Boring issue: Opening ODF document from LibreOffice 7 displays error

Bidouille
Hello Matthias,

I don't know if this ODF 1.3 will be available soon.
I don't find any release plan on OASIS.

----- Mail original -----

> De: "Matthias Seidel" <[hidden email]>
> À: [hidden email]
> Envoyé: Dimanche 15 Novembre 2020 12:49:27
> Objet: Re: Boring issue: Opening ODF document from LibreOffice 7 displays error
>
> Hi Bidouille,
>
> Am 08.11.20 um 17:25 schrieb Bidouille:
> > Hello dev team,
> >
> >
> > https://bz.apache.org/ooo/show_bug.cgi?id=128412
> >
> > LibreOffice 7 use ODF 1.3 (experimental) for its documents.
> > Unable to open it without an error.
> > This is a painful for end-users.
>
> Yes, that is something we must address somehow.
>
> What is your proposal?
>
> Regards,
>
>    Matthias
>
> >
> >
> > :-/
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Boring issue: Opening ODF document from LibreOffice 7 displays error

Rory O'Farrell
On Sun, 15 Nov 2020 13:09:57 +0100 (CET)
Bidouille <[hidden email]> wrote:

> Hello Matthias,
>
> I don't know if this ODF 1.3 will be available soon.
> I don't find any release plan on OASIS.


For information: the listings for v1.3 are at
https://docs.oasis-open.org/office/OpenDocument/v1.3/


RoryOF

>
> ----- Mail original -----
> > De: "Matthias Seidel" <[hidden email]>
> > À: [hidden email]
> > Envoyé: Dimanche 15 Novembre 2020 12:49:27
> > Objet: Re: Boring issue: Opening ODF document from LibreOffice 7 displays error
> >
> > Hi Bidouille,
> >
> > Am 08.11.20 um 17:25 schrieb Bidouille:
> > > Hello dev team,
> > >
> > >
> > > https://bz.apache.org/ooo/show_bug.cgi?id=128412
> > >
> > > LibreOffice 7 use ODF 1.3 (experimental) for its documents.
> > > Unable to open it without an error.
> > > This is a painful for end-users.
> >
> > Yes, that is something we must address somehow.
> >
> > What is your proposal?
> >
> > Regards,
> >
> >    Matthias
> >
> > >
> > >
> > > :-/
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email]
> > > For additional commands, e-mail: [hidden email]
> > >
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


--
Rory O'Farrell <[hidden email]>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Boring issue: Opening ODF document from LibreOffice 7 displays error

Matthias Seidel
In reply to this post by Bidouille
Hi,

Am 15.11.20 um 13:09 schrieb Bidouille:
> Hello Matthias,
>
> I don't know if this ODF 1.3 will be available soon.
> I don't find any release plan on OASIS.

It is an OASIS standard since December 2019(?) but not an ISO standard.

Implementing it in AOO takes time, so we should concentrate on making
the "error" message more logical.
That said, this will only be possible for 4.2.0 due to the needed
translation of new strings.

Regards,

   Matthias

>
> ----- Mail original -----
>> De: "Matthias Seidel" <[hidden email]>
>> À: [hidden email]
>> Envoyé: Dimanche 15 Novembre 2020 12:49:27
>> Objet: Re: Boring issue: Opening ODF document from LibreOffice 7 displays error
>>
>> Hi Bidouille,
>>
>> Am 08.11.20 um 17:25 schrieb Bidouille:
>>> Hello dev team,
>>>
>>>
>>> https://bz.apache.org/ooo/show_bug.cgi?id=128412
>>>
>>> LibreOffice 7 use ODF 1.3 (experimental) for its documents.
>>> Unable to open it without an error.
>>> This is a painful for end-users.
>> Yes, that is something we must address somehow.
>>
>> What is your proposal?
>>
>> Regards,
>>
>>    Matthias
>>
>>>
>>> :-/
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

RE: Boring issue: Opening ODF document from LibreOffice 7 displays error

Jörg Schmidt-2
In reply to this post by Matthias Seidel
 

> -----Original Message-----
> From: Matthias Seidel [mailto:[hidden email]]
> Sent: Sunday, November 15, 2020 12:49 PM
> To: [hidden email]
> Subject: Re: Boring issue: Opening ODF document from
> LibreOffice 7 displays error
>
> Hi Bidouille,
>
> Am 08.11.20 um 17:25 schrieb Bidouille:
> > Hello dev team,
> >
> >
> > https://bz.apache.org/ooo/show_bug.cgi?id=128412
> >
> > LibreOffice 7 use ODF 1.3 (experimental) for its documents.
> > Unable to open it without an error.

@Bidouille:
Strictly speaking, there is only a reference to a new program version, no error.

Do you have concrete test documents, which show problems and which you can make publicly available for testing?

> > This is a painful for end-users.

@Bidouille:
Would it be better to open the document without any comment and risk that the document is not displayed correctly?
This is a very real question, because this corresponds to the program behavior with e.g. doc or docx.

> What is your proposal?

at short term:
If the predominant opinion is that the, years of practice with OOXML or the MS binary formats is less "painful", then you should simply turn off the program update warning.

medium term:
we would first have to clarify how big the problems are in practice and therefore the predictable effort for their elimination. This clarification could be done by people involved with OASIS (i _believe_ there are also people from us there) or by creating test files and evaluating them.

long-term:
it does not help us (AOO) directly, but in the interest of the users, all parties involved should get together to implement ODF in free software and agree to implement ISO standards permanently, at least as a default.
Already in the dispute with Microsoft, the users were the ones who suffered, and now the same situation exists within the FOSS community - this is not good.


I have now only once test converted about 20 existing odt files (typical business letters) in LO 7.0.1 to the 1.3 (extended) ODF and could not find any concrete problems when opening them in AOO 4.1.7.
This does not mean that there are none, but it is assumed that they will not be massive.


In general, these format problems are as difficult to solve as the problems regarding OOXML, because we lack manpower.



Jörg





---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Boring issue: Opening ODF document from LibreOffice 7 displays error

Andrea Pescetti-2
In reply to this post by Matthias Seidel
Matthias Seidel wrote:
> Implementing it in AOO takes time, so we should concentrate on making
> the "error" message more logical.

Now:
This document was created by a newer version of OpenOffice. It may
contain features not supported by your current version.

Suggested:
This document uses an unsupported version of the Open Document Format.
Some features may not be displayed correctly.

Samples are available at
https://bz.apache.org/ooo/show_bug.cgi?id=128412 for those who need
them. Of course, we will need two different issues, one for the error
message (relatively quick fix) and one for the ODF 1.3 support (much
larger work).

Regards,
   Andrea.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Boring issue: Opening ODF document from LibreOffice 7 displays error

Matthias Seidel
Hi Andrea,

Am 15.11.20 um 14:37 schrieb Andrea Pescetti:

> Matthias Seidel wrote:
>> Implementing it in AOO takes time, so we should concentrate on making
>> the "error" message more logical.
>
> Now:
> This document was created by a newer version of OpenOffice. It may
> contain features not supported by your current version.
>
> Suggested:
> This document uses an unsupported version of the Open Document Format.
> Some features may not be displayed correctly.
Sounds good!

After we change that in source, Mechtilde can create a new template and
we can import it in Pootle.
Then the string is open for translation.

>
> Samples are available at
> https://bz.apache.org/ooo/show_bug.cgi?id=128412 for those who need
> them. Of course, we will need two different issues, one for the error
> message (relatively quick fix) and one for the ODF 1.3 support (much
> larger work).

I think Peter already created one:

https://bz.apache.org/ooo/show_bug.cgi?id=128282

Regards,

   Matthias

>
> Regards,
>   Andrea.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Boring issue: Opening ODF document from LibreOffice 7 displays error

Rory O'Farrell
In reply to this post by Andrea Pescetti-2
On Sun, 15 Nov 2020 14:37:49 +0100
Andrea Pescetti <[hidden email]> wrote:

> Matthias Seidel wrote:
> > Implementing it in AOO takes time, so we should concentrate on making
> > the "error" message more logical.
>
> Now:
> This document was created by a newer version of OpenOffice. It may
> contain features not supported by your current version.
>
> Suggested:
> This document uses an unsupported version of the Open Document Format.
> Some features may not be displayed correctly.
>
> Samples are available at
> https://bz.apache.org/ooo/show_bug.cgi?id=128412 for those who need
> them. Of course, we will need two different issues, one for the error
> message (relatively quick fix) and one for the ODF 1.3 support (much
> larger work).
>
> Regards,
>    Andrea.

I have been looking, and cannot find a document summarising the changes between ODF v1.2 and v1.3; does such a document exist? I have the full v1.3 specification, but would like a summary of the changes.

--
Rory O'Farrell <[hidden email]>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Boring issue: Opening ODF document from LibreOffice 7 displays error

Matthias Seidel
Hi Rory,

Am 15.11.20 um 14:47 schrieb Rory O'Farrell:

> On Sun, 15 Nov 2020 14:37:49 +0100
> Andrea Pescetti <[hidden email]> wrote:
>
>> Matthias Seidel wrote:
>>> Implementing it in AOO takes time, so we should concentrate on making
>>> the "error" message more logical.
>> Now:
>> This document was created by a newer version of OpenOffice. It may
>> contain features not supported by your current version.
>>
>> Suggested:
>> This document uses an unsupported version of the Open Document Format.
>> Some features may not be displayed correctly.
>>
>> Samples are available at
>> https://bz.apache.org/ooo/show_bug.cgi?id=128412 for those who need
>> them. Of course, we will need two different issues, one for the error
>> message (relatively quick fix) and one for the ODF 1.3 support (much
>> larger work).
>>
>> Regards,
>>    Andrea.
> I have been looking, and cannot find a document summarising the changes between ODF v1.2 and v1.3; does such a document exist? I have the full v1.3 specification, but would like a summary of the changes.
I will try to find something.

But as I remember, we use ODF 1.2 (extended) in AOO. I assume the
"extended" functions made it into ODF 1.3.

Regards,

   Matthias

>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Boring issue: Opening ODF document from LibreOffice 7 displays error

Bidouille
In reply to this post by Jörg Schmidt-2
> @Bidouille:
> Do you have concrete test documents, which show problems and which
> you can make publicly available for testing?
Read the dedicated issue: https://bz.apache.org/ooo/show_bug.cgi?id=128412

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: Boring issue: Opening ODF document from LibreOffice 7 displays error

Jörg Schmidt-2
Hello,

> -----Original Message-----
> From: Bidouille [mailto:[hidden email]]
> Sent: Sunday, November 15, 2020 3:50 PM
> To: [hidden email]
> Subject: Re: Boring issue: Opening ODF document from
> LibreOffice 7 displays error
>
> > @Bidouille:
> > Do you have concrete test documents, which show problems and which
> > you can make publicly available for testing?
> Read the dedicated issue:
> https://bz.apache.org/ooo/show_bug.cgi?id=128412

The example file in this issue generates a message, but the errors in the document are not caused by ODF 1.3, but by a lack of formula support, i.e. even if you save the document in ODF 1.2, the formulas would not work in AOO 4.x.

This lack of support for Calc table functions has been a major problem for AOO for years. The problem in practice is not so much that essential functions are missing, but that MS Office and LO have integrated more and more special table functions, which users then also use, although they could do the same calculations without these functions, only with the functions it is easier for average users.


Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]