Building AOO 4.2.0 woes on macOS

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Building AOO 4.2.0 woes on macOS

Jim Jagielski
I'm trying to build AOO 4.2.0 on macOS 10.12.6 and
I'm getting this error:

  ld: library not found for -ltl
  R=/Users/jim/src/asf/code/follow/aoo && S=$R/main && O=$S/solver/420/unxmaccx.pro && W=$O/workdir &&  mkdir -p $W/SrsPartMergeTarget/vcl/source/src/ && DYLD_LIBRARY_PATH=$O/lib $O/bin/transex3 -p vcl -i $S/vcl/source/src/units.src -o $W/SrsPartMergeTarget/vcl/source/src/units.src -m $R/extras/l10n/unxmaccx.pro/misc/sdf/vcl/source/src/localize.sdf -l all
  clang: error: linker command failed with exit code 1 (use -v to see invocation)
  make: *** [/Users/jim/src/asf/code/follow/aoo/main/solver/420/unxmaccx.pro/workdir/LinkTarget/Library/libvcl.dylib] Error 1
  make: *** Waiting for unfinished jobs....
  dmake:  Error code 2, while making 'all'

Anyone have any idea what -ltl is?

Obviously, no issues building 4.1.4....
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Building AOO 4.2.0 woes on macOS

Jim Jagielski
Hmmm. For some reason, either the build system isn't specifying
-L./solver/420/unxmaccx.pro/lib or else it's wanting to
link when it doesn't need to.

> On Oct 9, 2017, at 10:48 AM, Jim Jagielski <[hidden email]> wrote:
>
> I'm trying to build AOO 4.2.0 on macOS 10.12.6 and
> I'm getting this error:
>
>  ld: library not found for -ltl
>  R=/Users/jim/src/asf/code/follow/aoo && S=$R/main && O=$S/solver/420/unxmaccx.pro && W=$O/workdir &&  mkdir -p $W/SrsPartMergeTarget/vcl/source/src/ && DYLD_LIBRARY_PATH=$O/lib $O/bin/transex3 -p vcl -i $S/vcl/source/src/units.src -o $W/SrsPartMergeTarget/vcl/source/src/units.src -m $R/extras/l10n/unxmaccx.pro/misc/sdf/vcl/source/src/localize.sdf -l all
>  clang: error: linker command failed with exit code 1 (use -v to see invocation)
>  make: *** [/Users/jim/src/asf/code/follow/aoo/main/solver/420/unxmaccx.pro/workdir/LinkTarget/Library/libvcl.dylib] Error 1
>  make: *** Waiting for unfinished jobs....
>  dmake:  Error code 2, while making 'all'
>
> Anyone have any idea what -ltl is?
>
> Obviously, no issues building 4.1.4....
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]