Building on Ubuntu 18.04

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Building on Ubuntu 18.04

Pedro Lino-3
Hi all

I'm following the Step by Step guide https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
to build AOO 4.1.8 under Ubuntu 18.04.4 64-bit

At step

./configure \
--with-dmake-url=https://sourceforge.net/projects/oooextras.mirror/files/dmake-4.12.tar.bz2 \
--with-epm-url=https://sourceforge.net/projects/oooextras.mirror/files/epm-3.7.tar.gz \
--disable-odk \
--disable-binfilter \
--with-jdk-home

I get error
configure: error: yes/bin/java not found, please use --with-jdk-home

Java is
openjdk version "1.8.0_252"
OpenJDK Runtime Environment (build 1.8.0_252-8u252-b09-1~18.04-b09)
OpenJDK 64-Bit Server VM (build 25.252-b09, mixed mode)

Help?
Reply | Threaded
Open this post in threaded view
|

Re: Building on Ubuntu 18.04

Matthias Seidel
Hi Pedro,

Am 20.06.20 um 18:32 schrieb Pedro Lino:

> Hi all
>
> I'm following the Step by Step guide https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
> to build AOO 4.1.8 under Ubuntu 18.04.4 64-bit
>
> At step
>
> ./configure \
> --with-dmake-url=https://sourceforge.net/projects/oooextras.mirror/files/dmake-4.12.tar.bz2 \
> --with-epm-url=https://sourceforge.net/projects/oooextras.mirror/files/epm-3.7.tar.gz \
> --disable-odk \
> --disable-binfilter \
> --with-jdk-home
>
> I get error
> configure: error: yes/bin/java not found, please use --with-jdk-home
You did not specify the path to your JDK...

e.g.

        --with-jdk-home=/usr/lib/jvm/java-8-openjdk-amd64 \

Regards,

   Matthias

>
> Java is
> openjdk version "1.8.0_252"
> OpenJDK Runtime Environment (build 1.8.0_252-8u252-b09-1~18.04-b09)
> OpenJDK 64-Bit Server VM (build 25.252-b09, mixed mode)
>
> Help?
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Building on Ubuntu 18.04

Pedro Lino-3
Hi Matthias

(FWIW I tried https://webchat.freenode.net/?channels=dev.openoffice.org first, but people was have been AFK ;) )

> On 06/20/2020 5:43 PM Matthias Seidel <[hidden email]> wrote:

> You did not specify the path to your JDK...
>
> e.g.
>
>         --with-jdk-home=/usr/lib/jvm/java-8-openjdk-amd64 \

Thanks!
That allowed me to move a bit further :)

Now stuck at

configure: error: Package requirements (gconf-2.0 ) were not met:
No package 'gconf-2.0' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

But if I do
sudo apt-get install gconf-2.0

Note, selecting 'gir1.2-gconf-2.0' for regex 'gconf-2.0'
gir1.2-gconf-2.0 is already the newest version (3.2.6-4ubuntu1)

What now?

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Building on Ubuntu 18.04

Mechtilde Stehmann-2
Hello Pedro,

Am 20.06.20 um 19:46 schrieb Pedro Lino:
> Hi Matthias
>
> (FWIW I tried https://webchat.freenode.net/?channels=dev.openoffice.org first, but people was have been AFK ;) )

You was to fast. Now I'm there.


>
>> On 06/20/2020 5:43 PM Matthias Seidel <[hidden email]> wrote:
>
>> You did not specify the path to your JDK...
>>
>> e.g.
>>
>>         --with-jdk-home=/usr/lib/jvm/java-8-openjdk-amd64 \
>
> Thanks!
> That allowed me to move a bit further :)
>
> Now stuck at
>
> configure: error: Package requirements (gconf-2.0 ) were not met:
> No package 'gconf-2.0' found
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
>
> But if I do
> sudo apt-get install gconf-2.0
>
> Note, selecting 'gir1.2-gconf-2.0' for regex 'gconf-2.0'
> gir1.2-gconf-2.0 is already the newest version (3.2.6-4ubuntu1)
>
> What now?
>
For the next question I have to look deeper in my build environment.

Regards
--
Mechtilde Stehmann
## Apache OpenOffice
## Freie Office Suite für Linux, MacOSX, Windows und OS/2
## Debian Developer
## PGP encryption welcome
## F0E3 7F3D C87A 4998 2899  39E7 F287 7BBA 141A AD7F


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Building on Ubuntu 18.04

Mechtilde Stehmann-2
In reply to this post by Pedro Lino-3
Hello Pedro,

I sum up:

I have a Ubuntu 18.04 and you want to build the branch 4.1.8. I guess to
build 4.1.8 you need Ubuntu  16.04 or an older one

I use Debian 9 which was released at the beginning of 2017 and building
4.2.x for improving the translation process.

I tried now to start a build for the 4.1.8 branch and it fails. so I
guess to start building it is easier to use the 4.2.x branch.

Kind regards

Am 20.06.20 um 19:46 schrieb Pedro Lino:

> Hi Matthias
>
> (FWIW I tried https://webchat.freenode.net/?channels=dev.openoffice.org first, but people was have been AFK ;) )
>
>> On 06/20/2020 5:43 PM Matthias Seidel <[hidden email]> wrote:
>
>> You did not specify the path to your JDK...
>>
>> e.g.
>>
>>         --with-jdk-home=/usr/lib/jvm/java-8-openjdk-amd64 \
>
> Thanks!
> That allowed me to move a bit further :)
>
> Now stuck at
>
> configure: error: Package requirements (gconf-2.0 ) were not met:
> No package 'gconf-2.0' found
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
>
> But if I do
> sudo apt-get install gconf-2.0
>
> Note, selecting 'gir1.2-gconf-2.0' for regex 'gconf-2.0'
> gir1.2-gconf-2.0 is already the newest version (3.2.6-4ubuntu1)
>
> What now?
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
--
Mechtilde Stehmann
## Apache OpenOffice
## Freie Office Suite für Linux, MacOSX, Windows und OS/2
## Debian Developer
## PGP encryption welcome
## F0E3 7F3D C87A 4998 2899  39E7 F287 7BBA 141A AD7F


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Building on Ubuntu 18.04

Pedro Lino-3
In reply to this post by Mechtilde Stehmann-2
Hi Mechtilde

> On 06/20/2020 6:55 PM Mechtilde <[hidden email]> wrote:

> > (FWIW I tried https://webchat.freenode.net/?channels=dev.openoffice.org first, but people was have been AFK ;) )
>
> You was to fast. Now I'm there.

That is what I figured. That is why I mentioned AFK ;)
Thanks!
 
> For the next question I have to look deeper in my build environment.

Thank you! I will leave IRC open :)

Kind regards,
Pedro

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]