Building on Windows 7

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Building on Windows 7

jonasalfredsson@gmail.com
Hi,

I'm trying to build Open Office from trunk on Windows 7. Had some trouble getting through the configure and bootstrap but finally now building step is starting. A few modules into the build the following error occurs in module jpeg:

jonasalfredsson@TOMMY-TUMULT /cygdrive/c/source/aoo-trunk/main/instsetoo_native

$ build --all:jpeg
build -- version: 275224

=============
Building module jpeg
=============

Entering /cygdrive/c/source/aoo-trunk/main/jpeg

mkdir: cannot create directory `./wntmsci12.pro/misc/build/jpeg-8d/': File exists
/usr/bin/bash: line 1:  3612 Segmentation fault      (core dumped) dmake
dmake:  Error code 139, while making './wntmsci12.pro/misc/build/so_built_jpeg'

1 module(s): jpeg need(s) to be rebuilt

Reason(s): ERROR: error 65280 occurred while making /cygdrive/c/source/aoo-trunk/main/jpeg


I have no clue to where to begin looking for the source to this error message. Any hints would be very helpful.

Thanks

/Jonas
Reply | Threaded
Open this post in threaded view
|

Re: Building on Windows 7

Andre Fischer
On 16.01.2014 14:12, [hidden email] wrote:

> Hi,
>
> I'm trying to build Open Office from trunk on Windows 7. Had some trouble
> getting through the configure and bootstrap but finally now building step is
> starting. A few modules into the build the following error occurs in module
> jpeg:
>
> jonasalfredsson@TOMMY-TUMULT
> /cygdrive/c/source/aoo-trunk/main/instsetoo_native
>
> $ build --all:jpeg
> build -- version: 275224
>
> =============
> Building module jpeg
> =============
>
> Entering /cygdrive/c/source/aoo-trunk/main/jpeg
>
> mkdir: cannot create directory `./wntmsci12.pro/misc/build/jpeg-8d/': File
> exists
> /usr/bin/bash: line 1:  3612 Segmentation fault      (core dumped) dmake
> dmake:  Error code 139, while making
> './wntmsci12.pro/misc/build/so_built_jpeg'
>
> 1 module(s): jpeg need(s) to be rebuilt
>
> Reason(s): ERROR: error 65280 occurred while making
> /cygdrive/c/source/aoo-trunk/main/jpeg
>
>
> I have no clue to where to begin looking for the source to this error
> message. Any hints would be very helpful.

I don't know either but it would be interesting to know if a second try
crashes at the exact same place.
Can you run the build --all:jpeg command a second time?

-Andre

>
> Thanks
>
> /Jonas
>
>
>
> --
> View this message in context: http://openoffice.2283327.n4.nabble.com/Building-on-Windows-7-tp4657909.html
> Sent from the Development mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Building on Windows 7

jonasalfredsson@gmail.com
Running build a second time produce the following:

jonasalfredsson@TOMMY-TUMULT /cygdrive/c/source/aoo-trunk/main/instsetoo_native
$ build --all:jpeg
build -- version: 275224

=============
Building module jpeg
=============

Entering /cygdrive/c/source/aoo-trunk/main/jpeg

mkdir: cannot create directory `./wntmsci12.pro/misc/build/jpeg-8d/': File exists
/usr/bin/bash: line 1:  9236 Segmentation fault      (core dumped) dmake
dmake:  Error code 139, while making './wntmsci12.pro/misc/build/so_built_jpeg'

1 module(s): jpeg need(s) to be rebuilt

Reason(s): ERROR: error 65280 occurred while making /cygdrive/c/source/aoo-trunk/main/jpeg

/Jonas
Reply | Threaded
Open this post in threaded view
|

Re: Building on Windows 7

Steve Yin
Hi Jonas,

It seems like a privilege issue. Maybe it was caused by cygwin. I think you
can run cygwin as administrator again and try.


On Fri, Jan 17, 2014 at 12:05 AM, [hidden email] <
[hidden email]> wrote:

> Running build a second time produce the following:
>
> jonasalfredsson@TOMMY-TUMULT
> /cygdrive/c/source/aoo-trunk/main/instsetoo_native
> $ build --all:jpeg
> build -- version: 275224
>
> =============
> Building module jpeg
> =============
>
> Entering /cygdrive/c/source/aoo-trunk/main/jpeg
>
> mkdir: cannot create directory `./wntmsci12.pro/misc/build/jpeg-8d/': File
> exists
> /usr/bin/bash: line 1:  9236 Segmentation fault      (core dumped) dmake
> dmake:  Error code 139, while making
> './wntmsci12.pro/misc/build/so_built_jpeg'
>
> 1 module(s): jpeg need(s) to be rebuilt
>
> Reason(s): ERROR: error 65280 occurred while making
> /cygdrive/c/source/aoo-trunk/main/jpeg
>
> /Jonas
>
>
>
>
> --
> View this message in context:
> http://openoffice.2283327.n4.nabble.com/Building-on-Windows-7-tp4657909p4657925.html
> Sent from the Development mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Best Regards,

Steve Yin
Reply | Threaded
Open this post in threaded view
|

Re: Building on Windows 7

jonasalfredsson@gmail.com
Same result when running cygwin as administrator.