CppUnit version

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

CppUnit version

Stephan Bergmann-2
<http://andreasmaooo.blogger.de/stories/1685775/>: "But after source
LinuxX86-64Env.Set.sh and ./bootstrap the make command stoped in the
directory cppunit with an error:
`/local/ooovanilla/ooodev_hg/newworkingDEV300/cppunit/unxlngx6.pro/misc/build/cppunit-1.12.1'
dmake: Error code 2, while making
'./unxlngx6.pro/misc/build/so_built_cppunit'

"I can't find a solution for this issue but I get help from Thorsten
Behrens in the go-oo channel. He pointed me to a patch in the go-oo
repro: build-allow-system-cppunit-1.12.0.diff. This patch changes the
line in the configure.in from
PKG_CHECK_MODULES( CPPUNIT, cppunit >= 1.12.1 )
to
PKG_CHECK_MODULES( CPPUNIT, cppunit >= 1.12.0 )"

Andreas, please file an issue to lower CppUnit requirement to 1.12.0
then.  (And whoever wrote that apparently trivial go-oo patch -- why did
you not bother upstreaming it?)

(<http://wiki.services.openoffice.org/wiki/Test_Cleanup#CppUnit_1.12.1>
"minimal required version for now arbitrarily 1.12.1" -- I just grabbed
the then-newest version and did not bother to check with anything else,
so chose it as the minimal requirement. If it turns out that certain
environments would benefit from a lower requirement, and the lower
versions actually work fine in OOo, we should adapt that accordingly.)

-Stephan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: CppUnit version

Thorsten Behrens-3
Stephan Bergmann wrote:
> Andreas, please file an issue to lower CppUnit requirement to 1.12.0
> then.  (And whoever wrote that apparently trivial go-oo patch -- why
> did you not bother upstreaming it?)
>
Hi Stephan,

sorry - but such things can happen in the middle of a frenzy "get
the freaking build working again" night or two.

> (<http://wiki.services.openoffice.org/wiki/Test_Cleanup#CppUnit_1.12.1>
> "minimal required version for now arbitrarily 1.12.1" -- I just
> grabbed the then-newest version and did not bother to check with
> anything else, so chose it as the minimal requirement.
>
Well, that's also kind of a lazy attitude to impose on others, no? ;)

Anyway, glad this is on the right way now!

Cheers,

-- Thorsten

attachment0 (205 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: CppUnit version

Rene Engelhard-7
In reply to this post by Stephan Bergmann-2
Hi,

On Fri, Aug 27, 2010 at 11:24:26AM +0200, Stephan Bergmann wrote:

> `/local/ooovanilla/ooodev_hg/newworkingDEV300/cppunit/unxlngx6.pro/misc/build/cppunit-1.12.1'
> dmake: Error code 2, while making  
> './unxlngx6.pro/misc/build/so_built_cppunit'
>
> "I can't find a solution for this issue but I get help from Thorsten  
> Behrens in the go-oo channel. He pointed me to a patch in the go-oo  
> repro: build-allow-system-cppunit-1.12.0.diff. This patch changes the  
> line in the configure.in from
> PKG_CHECK_MODULES( CPPUNIT, cppunit >= 1.12.1 )
> to
> PKG_CHECK_MODULES( CPPUNIT, cppunit >= 1.12.0 )"

That makes no sense. (Except when he subsqeuently also got told to
use --with-system-cppunit).

> Andreas, please file an issue to lower CppUnit requirement to 1.12.0  
> then.  (And whoever wrote that apparently trivial go-oo patch -- why did  
> you not bother upstreaming it?)

I didn't do the patch (pmladek did) but I didn't bother either to point
you to it (and I know the statement you cite below). Why?

libcppunit-dev |   1.12.1-1 |        stable | alpha, amd64, arm, armel, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc

Debian lenny was released almost 1.5 years ago. Not counting the freeze before
that. So anything shipping 1.12.0 didn't get updated in 1.5 years.

(Which wonders me: Andreas has gcc 4.5(!) but that ancient cppunit. Sounds like
a broken distro to me. Most uptodate gcc but ancient other stuff...)

Grüße/Regards,

René

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: CppUnit version

andreasma
In reply to this post by Stephan Bergmann-2
Hi Stephan,

Am Freitag, 27. August 2010, 11:24:26 schrieb Stephan Bergmann:

> <http://andreasmaooo.blogger.de/stories/1685775/>: "But after source
> LinuxX86-64Env.Set.sh and ./bootstrap the make command stoped in the
> directory cppunit with an error:
> `/local/ooovanilla/ooodev_hg/newworkingDEV300/cppunit/unxlngx6.pro/misc/bui
> ld/cppunit-1.12.1' dmake: Error code 2, while making
> './unxlngx6.pro/misc/build/so_built_cppunit'
>
> "I can't find a solution for this issue but I get help from Thorsten
> Behrens in the go-oo channel. He pointed me to a patch in the go-oo
> repro: build-allow-system-cppunit-1.12.0.diff. This patch changes the
> line in the configure.in from
> PKG_CHECK_MODULES( CPPUNIT, cppunit >= 1.12.1 )
> to
> PKG_CHECK_MODULES( CPPUNIT, cppunit >= 1.12.0 )"
>
> Andreas, please file an issue to lower CppUnit requirement to 1.12.0
> then.  (And whoever wrote that apparently trivial go-oo patch -- why did
> you not bother upstreaming it?)
>

I filed for this problem an issue:
http://www.openoffice.org/issues/show_bug.cgi?id=114068.
Should I write more specific information to that issue?

Regards,
Andreas
--
## Content Developer OpenOffice.org: lang/DE
## Freie Office-Suite für Linux, Mac, Windows, Solaris
## http://de.openoffice.org
## OpenOffice.org Portable: http://oooportable.org
## Meine Seite: http://www.amantke.de 

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]