DEV300m84 hangs when saving from Calc

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

DEV300m84 hangs when saving from Calc

Regina Henschel
Hi all,

I have build DEV300m84 on WinXP. That works so far, but saving a
spreadsheet document from Calc gives always the Debug Output:

Error: wrong NameAccess
 From File C:/DEV300m84my/xmloff/source/core/SettingsExportHelper.cxx at
Line 406

If I ignore it, the file is saved, but OOo does not react on mouse or
key. I have to kill it with task manager.

Is this a special problem of my build? Is there something to avoid the
problem? It is very annoying when testing my changes.

Kind regards
Regina



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: DEV300m84 hangs when saving from Calc

Daniel Rentz-3
Hi Regina,

Am 08.08.2010 19:12, schrieb Regina Henschel:

> I have build DEV300m84 on WinXP. That works so far, but saving a
> spreadsheet document from Calc gives always the Debug Output:
>
> Error: wrong NameAccess
>  From File C:/DEV300m84my/xmloff/source/core/SettingsExportHelper.cxx at
> Line 406
>
> If I ignore it, the file is saved, but OOo does not react on mouse or
> key. I have to kill it with task manager.
>
> Is this a special problem of my build? Is there something to avoid the
> problem? It is very annoying when testing my changes.

I'll have a look.

Daniel

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: DEV300m84 hangs when saving from Calc

David Tardon
On Mon, Aug 09, 2010 at 10:20:11AM +0200, Daniel Rentz wrote:

> Hi Regina,
>
> Am 08.08.2010 19:12, schrieb Regina Henschel:
>
> >I have build DEV300m84 on WinXP. That works so far, but saving a
> >spreadsheet document from Calc gives always the Debug Output:
> >
> >Error: wrong NameAccess
> > From File C:/DEV300m84my/xmloff/source/core/SettingsExportHelper.cxx at
> >Line 406
> >
> >If I ignore it, the file is saved, but OOo does not react on mouse or
> >key. I have to kill it with task manager.
> >
> >Is this a special problem of my build? Is there something to avoid the
> >problem? It is very annoying when testing my changes.
>
> I'll have a look.
>

Hi,

see http://qa.openoffice.org/issues/show_bug.cgi?id=113737 for the
assertion.

D.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: DEV300m84 hangs when saving from Calc

Regina Henschel
Hi David,

David Tardon schrieb:

> On Mon, Aug 09, 2010 at 10:20:11AM +0200, Daniel Rentz wrote:
>> Hi Regina,
>>
>> Am 08.08.2010 19:12, schrieb Regina Henschel:
>>
>>> I have build DEV300m84 on WinXP. That works so far, but saving a
>>> spreadsheet document from Calc gives always the Debug Output:
>>>
>>> Error: wrong NameAccess
>>>  From File C:/DEV300m84my/xmloff/source/core/SettingsExportHelper.cxx at
>>> Line 406
>>>
>>> If I ignore it, the file is saved, but OOo does not react on mouse or
>>> key. I have to kill it with task manager.
>>>
>>> Is this a special problem of my build? Is there something to avoid the
>>> problem? It is very annoying when testing my changes.
>>
>> I'll have a look.
>>
>
> Hi,
>
> see http://qa.openoffice.org/issues/show_bug.cgi?id=113737 for the
> assertion.
>

I have applied the patch. Now I get no longer a Debug Output, but OOo
still hangs after saving.

Kind regards
Regina

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: DEV300m84 hangs when saving from Calc

Daniel Rentz-3
Am 09.08.2010 11:26, schrieb Regina Henschel:
> Hi David,
>
>> see http://qa.openoffice.org/issues/show_bug.cgi?id=113737 for the
>> assertion.
>>
>
> I have applied the patch. Now I get no longer a Debug Output, but OOo
> still hangs after saving.

No problem in DEV300m86. Did you try it in a debugger?

Regards
Daniel

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: DEV300m84 hangs when saving from Calc

Regina Henschel
Hi Daniel,

Daniel Rentz schrieb:

> Am 09.08.2010 11:26, schrieb Regina Henschel:
>> Hi David,
>>
>>> see http://qa.openoffice.org/issues/show_bug.cgi?id=113737 for the
>>> assertion.
>>>
>>
>> I have applied the patch. Now I get no longer a Debug Output, but OOo
>> still hangs after saving.
>
> No problem in DEV300m86.

Building DEV300m86 and testing there will take some time.

  Did you try it in a debugger?

No, I do not know how to do it :(

Kind regards
Regina

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: DEV300m84 hangs when saving from Calc

Regina Henschel
Hi Daniel,

Regina Henschel schrieb:

> Hi Daniel,
>
> Daniel Rentz schrieb:
>> Am 09.08.2010 11:26, schrieb Regina Henschel:
>>> Hi David,
>>>
>>>> see http://qa.openoffice.org/issues/show_bug.cgi?id=113737 for the
>>>> assertion.
>>>>
>>>
>>> I have applied the patch. Now I get no longer a Debug Output, but OOo
>>> still hangs after saving.
>>
>> No problem in DEV300m86.
>
> Building DEV300m86 and testing there will take some time.
>

So back again. I have build DEV300m86 (without binfilter, because build
breaks there) and can confirm, that saving works in DEV300m86.

Kind regards
Regina

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]