Error While Building Module Scripting

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Error While Building Module Scripting

Rajith Ravi
  
Hi volker,

               While Building the OO2.0 the build stops in the module scripting. I logged the error shown below.

(windows XP, VisualStudio.Net2003,Java1.4.2_09,TCSH)

build -- version: 1.144

=============
Building project scripting
=============
/cygdrive/e/oo2.0/src/scripting/source/basprov
-------------
/cygdrive/e/oo2.0/src/scripting/source/dlgprov
-------------
/cygdrive/e/oo2.0/src/scripting/source/provider
-------------
/cygdrive/e/oo2.0/src/scripting/source/protocolhandler
-------------
/cygdrive/e/oo2.0/src/scripting/java
-------------
guw.pl /cygdrive/c/apache-ant-1.6.5/bin/ant -Dprj=.. -Dprjname=scripting -Ddebug=off -Doptimize=on  -Dtarget=scriptruntimeforjava -Dsolar.update=on -Dout=../wntmsci10.pro -Dinpath=wntmsci10.pro -Dproext=".pro"  -Dsolar.bin=/cygdrive/e/oo2.0/src/solver/680/wntmsci10.pro/bin -Dsolar.jar=/cygdrive/e/oo2.0/src/solver/680/wntmsci10.pro/bin -Dsolar.doc=/cygdrive/e/oo2.0/src/solver/680/wntmsci10.pro/doc  -Dcommon.jar=/cygdrive/e/oo2.0/src/solver/680/common.pro/bin -Dcommon.doc=/cygdrive/e/oo2.0/src/solver/680/common.pro/doc  -f build.xml  -emacs
Buildfile: build.xml

prepare:

compile:
Compiling 31 source files to E:\oo2.0\src\scripting\wntmsci10.pro\class
This version of java does not support the classic compiler; upgrading to modern
E:\oo2.0\src\scripting\java\com\sun\star\script\framework\provider\ClassLoaderFactory.java:60: cannot resolve symbol
symbol  : class NoSuitableClassLoaderException
location: class com.sun.star.script.framework.provider.ClassLoaderFactory
        throws NoSuitableClassLoaderException, MalformedURLException
               ^
E:\oo2.0\src\scripting\java\com\sun\star\script\framework\provider\ClassLoaderFactory.java:72: cannot resolve symbol
symbol  : class NoSuitableClassLoaderException
location: class com.sun.star.script.framework.provider.ClassLoaderFactory
        throws NoSuitableClassLoaderException
               ^
E:\oo2.0\src\scripting\java\com\sun\star\script\framework\provider\ClassLoaderFactory.java:83: cannot resolve symbol
symbol  : class NoSuitableClassLoaderException
location: class com.sun.star.script.framework.provider.ClassLoaderFactory
            throw new NoSuitableClassLoaderException(
                      ^
Note: Some input files use or override a deprecated API.
Note: Recompile with -deprecation for details.
3 errors
---* tg_merge.mk *---



Regards,


Rajith
Reply | Threaded
Open this post in threaded view
|

Re: Error While Building Module Scripting

Joesny Fagner de Oliveira
Hi i have the same error but in other module... but not have the
solution too.

:(

Joesny.

Rajith Ravi wrote:

>  
>Hi volker,
>
>               While Building the OO2.0 the build stops in the module scripting. I logged the error shown below.
>
>(windows XP, VisualStudio.Net2003,Java1.4.2_09,TCSH)
>
>build -- version: 1.144
>
>=============
>Building project scripting
>=============
>/cygdrive/e/oo2.0/src/scripting/source/basprov
>-------------
>/cygdrive/e/oo2.0/src/scripting/source/dlgprov
>-------------
>/cygdrive/e/oo2.0/src/scripting/source/provider
>-------------
>/cygdrive/e/oo2.0/src/scripting/source/protocolhandler
>-------------
>/cygdrive/e/oo2.0/src/scripting/java
>-------------
>guw.pl /cygdrive/c/apache-ant-1.6.5/bin/ant -Dprj=.. -Dprjname=scripting -Ddebug=off -Doptimize=on  -Dtarget=scriptruntimeforjava -Dsolar.update=on -Dout=../wntmsci10.pro -Dinpath=wntmsci10.pro -Dproext=".pro"  -Dsolar.bin=/cygdrive/e/oo2.0/src/solver/680/wntmsci10.pro/bin -Dsolar.jar=/cygdrive/e/oo2.0/src/solver/680/wntmsci10.pro/bin -Dsolar.doc=/cygdrive/e/oo2.0/src/solver/680/wntmsci10.pro/doc  -Dcommon.jar=/cygdrive/e/oo2.0/src/solver/680/common.pro/bin -Dcommon.doc=/cygdrive/e/oo2.0/src/solver/680/common.pro/doc  -f build.xml  -emacs
>Buildfile: build.xml
>
>prepare:
>
>compile:
>Compiling 31 source files to E:\oo2.0\src\scripting\wntmsci10.pro\class
>This version of java does not support the classic compiler; upgrading to modern
>E:\oo2.0\src\scripting\java\com\sun\star\script\framework\provider\ClassLoaderFactory.java:60: cannot resolve symbol
>symbol  : class NoSuitableClassLoaderException
>location: class com.sun.star.script.framework.provider.ClassLoaderFactory
>        throws NoSuitableClassLoaderException, MalformedURLException
>               ^
>E:\oo2.0\src\scripting\java\com\sun\star\script\framework\provider\ClassLoaderFactory.java:72: cannot resolve symbol
>symbol  : class NoSuitableClassLoaderException
>location: class com.sun.star.script.framework.provider.ClassLoaderFactory
>        throws NoSuitableClassLoaderException
>               ^
>E:\oo2.0\src\scripting\java\com\sun\star\script\framework\provider\ClassLoaderFactory.java:83: cannot resolve symbol
>symbol  : class NoSuitableClassLoaderException
>location: class com.sun.star.script.framework.provider.ClassLoaderFactory
>            throw new NoSuitableClassLoaderException(
>                      ^
>Note: Some input files use or override a deprecated API.
>Note: Recompile with -deprecation for details.
>3 errors
>---* tg_merge.mk *---
>
>
>
>Regards,
>
>
>Rajith
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]