Error instsetoo_native: codes.txt not found

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Error instsetoo_native: codes.txt not found

Davide Dozza
I'm still trzing to compile DEV300_m82 on WinXP and now I've found this
problem:

Entering /cygdrive/c/DEV300_82/instsetoo_native/util

dmake:  makefile.mk:  line 211:  Warning: -- Prior to dmake 4.5 only one
%-target per target-definition worked reliably. Check your makefiles.

C:/cygwin/bin/perl -w C:/DEV300_82/solenv/bin/make_installer.pl -f
../util/openo
ffice.lst -l en-US -p OpenOffice -u ../wntmsci12.pro -buildid 9510
-msitemplate
../wntmsci12.pro/misc/openoffice/msi_templates -msilanguage
../wntmsci12.pro/mis
c/win_ulffiles -format archive
Subroutine installer::epmfile::getcwd redefined at
C:/DEV300_82/solenv/bin/modul
es/installer/epmfile.pm line 43
... checking environment variables ...
... cleaning the output tree ...
... removing directory C:/cygwin/tmp/ooopackaging/i_25721276937464 ...

**************************************************
ERROR: ERROR: Cannot find file
C:/DEV300_82/instsetoo_native/wntmsci12.pro/misc/
openoffice/msi_templates/codes.txt
in function: check_file
**************************************************

**************************************************
ERROR: Saved logfile: logfile.log
**************************************************
Sat Jun 19 10:51:06 2010 (00:04 min.)
dmake:  Error code 255, while making 'openoffice_en-US.archive'

Davide


signature.asc (267 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Error instsetoo_native: codes.txt not found

Davide Dozza
I copied by hand such file from inc_openoffice directory and the build
process seems to preceed correctly.

But now I'have this problem:

------------------------------------
... languages en-US ...
... analyzing update database ...
... analyzing files ...
ERROR: The following files could not be found:
ERROR: File not found: msvcr71.dll
ERROR: File not found: msvcp80.dll
ERROR: File not found: msvcr80.dll
... cleaning the output tree ...
... removing directory C:/cygwin/tmp/ooopackaging/i_39201276956150 ...

**************************************************
ERROR: ERROR: Missing files
in function: remove_Files_Without_Sourcedirectory
**************************************************

**************************************************
ERROR: Saved logfile:
C:/DEV300_82/instsetoo_native/wntmsci12.pro/OpenOffice/arc
hive/logging/en-US/log_DEV300_en-US.log
**************************************************
Sat Jun 19 16:03:17 2010 (00:47 min.)
dmake:  Error code 255, while making 'openoffice_en-US.archive'


Davide


Davide Dozza ha scritto:

> I'm still trzing to compile DEV300_m82 on WinXP and now I've found this
> problem:
>
> Entering /cygdrive/c/DEV300_82/instsetoo_native/util
>
> dmake:  makefile.mk:  line 211:  Warning: -- Prior to dmake 4.5 only one
> %-target per target-definition worked reliably. Check your makefiles.
>
> C:/cygwin/bin/perl -w C:/DEV300_82/solenv/bin/make_installer.pl -f
> ../util/openo
> ffice.lst -l en-US -p OpenOffice -u ../wntmsci12.pro -buildid 9510
> -msitemplate
> ../wntmsci12.pro/misc/openoffice/msi_templates -msilanguage
> ../wntmsci12.pro/mis
> c/win_ulffiles -format archive
> Subroutine installer::epmfile::getcwd redefined at
> C:/DEV300_82/solenv/bin/modul
> es/installer/epmfile.pm line 43
> ... checking environment variables ...
> ... cleaning the output tree ...
> ... removing directory C:/cygwin/tmp/ooopackaging/i_25721276937464 ...
>
> **************************************************
> ERROR: ERROR: Cannot find file
> C:/DEV300_82/instsetoo_native/wntmsci12.pro/misc/
> openoffice/msi_templates/codes.txt
> in function: check_file
> **************************************************
>
> **************************************************
> ERROR: Saved logfile: logfile.log
> **************************************************
> Sat Jun 19 10:51:06 2010 (00:04 min.)
> dmake:  Error code 255, while making 'openoffice_en-US.archive'
>
> Davide
>


signature.asc (267 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Error instsetoo_native: codes.txt not found

Mathias Bauer-6
In reply to this post by Davide Dozza
Hi Davide,

On 19.06.2010 13:43, Davide Dozza wrote:

> I'm still trzing to compile DEV300_m82 on WinXP and now I've found this
> problem:
>
> Entering /cygdrive/c/DEV300_82/instsetoo_native/util
>
> dmake:  makefile.mk:  line 211:  Warning: -- Prior to dmake 4.5 only one
> %-target per target-definition worked reliably. Check your makefiles.
>
> C:/cygwin/bin/perl -w C:/DEV300_82/solenv/bin/make_installer.pl -f
> ../util/openo
> ffice.lst -l en-US -p OpenOffice -u ../wntmsci12.pro -buildid 9510
> -msitemplate
> ../wntmsci12.pro/misc/openoffice/msi_templates -msilanguage
> ../wntmsci12.pro/mis
> c/win_ulffiles -format archive
> Subroutine installer::epmfile::getcwd redefined at
> C:/DEV300_82/solenv/bin/modul
> es/installer/epmfile.pm line 43
> ... checking environment variables ...
> ... cleaning the output tree ...
> ... removing directory C:/cygwin/tmp/ooopackaging/i_25721276937464 ...
>
> **************************************************
> ERROR: ERROR: Cannot find file
> C:/DEV300_82/instsetoo_native/wntmsci12.pro/misc/
> openoffice/msi_templates/codes.txt
> in function: check_file
> **************************************************
>
> **************************************************
> ERROR: Saved logfile: logfile.log
> **************************************************
> Sat Jun 19 10:51:06 2010 (00:04 min.)
> dmake:  Error code 255, while making 'openoffice_en-US.archive'
>
> Davide
>

this is a known problem and I asked the developer to fix it, but
unfortunately he didn't do that until now. It seems that I should ask again.

You can workaround the problem by setting "BUILD_SPECIAL" to TRUE before
calling "build" in instsetoo_native.

Regards,
Mathias

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Error instsetoo_native: codes.txt not found

Davide Dozza
Hi Mathias,

Mathias Bauer ha scritto:

> Hi Davide,
>
> On 19.06.2010 13:43, Davide Dozza wrote:
>> I'm still trzing to compile DEV300_m82 on WinXP and now I've found this
>> problem:
>>
>> Entering /cygdrive/c/DEV300_82/instsetoo_native/util
>>
>> dmake:  makefile.mk:  line 211:  Warning: -- Prior to dmake 4.5 only one
>> %-target per target-definition worked reliably. Check your makefiles.
>>
>> C:/cygwin/bin/perl -w C:/DEV300_82/solenv/bin/make_installer.pl -f
>> ../util/openo
>> ffice.lst -l en-US -p OpenOffice -u ../wntmsci12.pro -buildid 9510
>> -msitemplate
>> ../wntmsci12.pro/misc/openoffice/msi_templates -msilanguage
>> ../wntmsci12.pro/mis
>> c/win_ulffiles -format archive
>> Subroutine installer::epmfile::getcwd redefined at
>> C:/DEV300_82/solenv/bin/modul
>> es/installer/epmfile.pm line 43
>> ... checking environment variables ...
>> ... cleaning the output tree ...
>> ... removing directory C:/cygwin/tmp/ooopackaging/i_25721276937464 ...
>>
>> **************************************************
>> ERROR: ERROR: Cannot find file
>> C:/DEV300_82/instsetoo_native/wntmsci12.pro/misc/
>> openoffice/msi_templates/codes.txt
>> in function: check_file
>> **************************************************
>>
>> **************************************************
>> ERROR: Saved logfile: logfile.log
>> **************************************************
>> Sat Jun 19 10:51:06 2010 (00:04 min.)
>> dmake:  Error code 255, while making 'openoffice_en-US.archive'
>>
>> Davide
>>
>
> this is a known problem and I asked the developer to fix it, but
> unfortunately he didn't do that until now. It seems that I should ask
> again.
>
> You can workaround the problem by setting "BUILD_SPECIAL" to TRUE before
> calling "build" in instsetoo_native.
I returned back to the m81 branch and I did what you suggested.
Before I also removed the directory wntmsci12.pro, but I receive such error:

... removing directory C:/cygwin/tmp/ooopackaging/i_4401277366115 ...

**************************************************
ERROR: ERROR: Could not register all components for file services.rdb
(gid_Starregistry_Services_Rdb)!
in function: create_services_rdb
**************************************************

**************************************************
ERROR: Saved logfile:
C:/DEV300_m81/instsetoo_native/wntmsci12.pro/OpenOffice/ar
chive/logging/en-US/log_DEV300_en-US.log
**************************************************
Thu Jun 24 09:58:20 2010 (03:06 min.)
dmake:  Error code 255, while making 'openoffice_en-US.archive'

In the log file I've found:

register component
'file:///C:/DEV300_m81/solver/300/wntmsci12.pro/bin/frmmi.dll
' in registry
'C:/cygwin/tmp/ooopackaging/i_4401277366115/wntmsci12.pro/OpenOffi
ce/archive/gid_Starregistry_Services_Rdb_servicesrdb/en-US_inprogress_1/services
.rdb' failed!
error (CannotRegisterImplementationException): loading component library
failed:
 file:///C:/DEV300_m81/solver/300/wntmsci12.pro/bin/frmmi.dll

Here you can find the complete log file.

http://wikisend.com/download/528490/log_DEV300_en-US.log

Davide


>
> Regards,
> Mathias
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>



signature.asc (267 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Error instsetoo_native: codes.txt not found

Davide Dozza
Davide Dozza ha scritto:
> Hi Mathias,
>

[...]

>>>
>> this is a known problem and I asked the developer to fix it, but
>> unfortunately he didn't do that until now. It seems that I should ask
>> again.
>>
>> You can workaround the problem by setting "BUILD_SPECIAL" to TRUE before
>> calling "build" in instsetoo_native.
>
> I returned back to the m81 branch and I did what you suggested.
> Before I also removed the directory wntmsci12.pro, but I receive such error:
>
> ... removing directory C:/cygwin/tmp/ooopackaging/i_4401277366115 ...
>
> **************************************************
> ERROR: ERROR: Could not register all components for file services.rdb
> (gid_Starregistry_Services_Rdb)!
> in function: create_services_rdb
> **************************************************
>
> **************************************************
> ERROR: Saved logfile:
> C:/DEV300_m81/instsetoo_native/wntmsci12.pro/OpenOffice/ar
> chive/logging/en-US/log_DEV300_en-US.log
> **************************************************
> Thu Jun 24 09:58:20 2010 (03:06 min.)
> dmake:  Error code 255, while making 'openoffice_en-US.archive'
>
This error happens also without setting the variable SPECIAL_BUILD to
TRUE. Therefore is related to something else.

Any suggestion?


signature.asc (267 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Error instsetoo_native: codes.txt not found

Mathias Bauer
In reply to this post by Davide Dozza
Hi Davide,

On 24.06.2010 10:09, Davide Dozza wrote:

> In the log file I've found:
>
> register component
> 'file:///C:/DEV300_m81/solver/300/wntmsci12.pro/bin/frmmi.dll
> ' in registry
> 'C:/cygwin/tmp/ooopackaging/i_4401277366115/wntmsci12.pro/OpenOffi
> ce/archive/gid_Starregistry_Services_Rdb_servicesrdb/en-US_inprogress_1/services
> .rdb' failed!
> error (CannotRegisterImplementationException): loading component library
> failed:
>   file:///C:/DEV300_m81/solver/300/wntmsci12.pro/bin/frmmi.dll
>
> Here you can find the complete log file.
>
> http://wikisend.com/download/528490/log_DEV300_en-US.log

That indicates that your frmmi.dll is either not there or misses some
prerequisites. You can find out more using the dependency walker tool
that you can download from the Internet (http://www.dependencywalker.com).

Please go do the solver/bin folder and call "$(depends) frmmi.dll".
"$(depends)" is the path to your depends.exe. You should see which dll
is missing or where symbols in a dll are missing.

Regards,
Mathias

--
Mathias Bauer (mba) - Project Lead OpenOffice.org Writer
OpenOffice.org Engineering at Sun: http://blogs.sun.com/GullFOSS
Please don't reply to "[hidden email]".
I use it for the OOo lists and only rarely read other mails sent to it.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Error instsetoo_native: codes.txt not found

Davide Dozza
Mathias Bauer ha scritto:

[...]

>
> That indicates that your frmmi.dll is either not there or misses some
> prerequisites. You can find out more using the dependency walker tool
> that you can download from the Internet (http://www.dependencywalker.com).
>
> Please go do the solver/bin folder and call "$(depends) frmmi.dll".
> "$(depends)" is the path to your depends.exe. You should see which dll
> is missing or where symbols in a dll are missing.

Depends reports that frmmi.dll was corrupted.

I suppose I've to rebuild the solver.

Is it possible to do it without rebuild OOo?

Davide


>
> Regards,
> Mathias
>



signature.asc (267 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Error instsetoo_native: codes.txt not found

Michael Stahl-3
On 24/06/2010 13:51, Davide Dozza wrote:

> Mathias Bauer ha scritto:
>
> [...]
>
>> That indicates that your frmmi.dll is either not there or misses some
>> prerequisites. You can find out more using the dependency walker tool
>> that you can download from the Internet (http://www.dependencywalker.com).
>>
>> Please go do the solver/bin folder and call "$(depends) frmmi.dll".
>> "$(depends)" is the path to your depends.exe. You should see which dll
>> is missing or where symbols in a dll are missing.
>
> Depends reports that frmmi.dll was corrupted.
>
> I suppose I've to rebuild the solver.
>
> Is it possible to do it without rebuild OOo?
>
> Davide

well, the solver contains OOo :)

but you can partially rebuild it:

first find out the module where the broken library is built:

grep frmmi.dll solver/inc/*/deliver.log

the module will be the directory name e.g. solver/inc/sw/deliver.log => sw

then cd into instsetoo_native and do:

build --prepare --from MODULE

that will remove all output trees from the module and all dependencies,
and also the delivered files from the solver.

then build --from MODULE  in instsetoo_native should rebuild the deleted
stuff.

--
"The use of four-letter words like goto can occasionally be justified
 even in the best of company." -- Donald E. Knuth


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Error instsetoo_native: codes.txt not found

Davide Dozza
In reply to this post by Davide Dozza
Davide Dozza ha scritto:

> Mathias Bauer ha scritto:
>
> [...]
>
>> That indicates that your frmmi.dll is either not there or misses some
>> prerequisites. You can find out more using the dependency walker tool
>> that you can download from the Internet (http://www.dependencywalker.com).
>>
>> Please go do the solver/bin folder and call "$(depends) frmmi.dll".
>> "$(depends)" is the path to your depends.exe. You should see which dll
>> is missing or where symbols in a dll are missing.
>
> Depends reports that frmmi.dll was corrupted.
>
> I suppose I've to rebuild the solver.
Uhm... I reply myself.

I've rebuilded forms module  which is the oring of frmmi.dll

After the command deliver inside forms module, should I rebuild something?


Davide


signature.asc (267 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Error instsetoo_native: codes.txt not found

Mathias Bauer
On 06/24/2010 02:27 PM, Davide Dozza wrote:

> Davide Dozza ha scritto:
>> Mathias Bauer ha scritto:
>>
>> [...]
>>
>>> That indicates that your frmmi.dll is either not there or misses some
>>> prerequisites. You can find out more using the dependency walker tool
>>> that you can download from the Internet (http://www.dependencywalker.com).
>>>
>>> Please go do the solver/bin folder and call "$(depends) frmmi.dll".
>>> "$(depends)" is the path to your depends.exe. You should see which dll
>>> is missing or where symbols in a dll are missing.
>>
>> Depends reports that frmmi.dll was corrupted.
>>
>> I suppose I've to rebuild the solver.
>
> Uhm... I reply myself.
>
> I've rebuilded forms module  which is the oring of frmmi.dll
>
> After the command deliver inside forms module, should I rebuild something?

AFAIK there is no other library that depends on the forms library, so I
think that you don't need to rebuild something else.

Regards,
Mathias

--
Mathias Bauer (mba) - Project Lead OpenOffice.org Writer
OpenOffice.org Engineering at Sun: http://blogs.sun.com/GullFOSS
Please don't reply to "[hidden email]".
I use it for the OOo lists and only rarely read other mails sent to it.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]