Errors in bootstrap while building dmake

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Errors in bootstrap while building dmake

Matthias Seidel
Hi all,

After updating a lot of packages (incl. gcc) in Cygwin64 yesterday I can
no longer build AOO for Windows.

I get errors in bootstrap while building dmake:

make[2]: Verzeichnis
„/cygdrive/c/Source/openoffice/main/solenv/wntmsci12.pro/misc/build/dmake-4.12“
wird betreten
depbase=`echo infer.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; \
if gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -I./unix/cygwin -I./unix
-I./unix/cygwin/gnu -I./unix/cygwin -I./unix      -g -O2 -MT infer.o -MD
-MP -MF "$depbase.Tpo" -c -o infer.o infer.c; \
then mv -f "$depbase.Tpo" "$depbase.Po"; else rm -f "$depbase.Tpo"; exit
1; fi
In Datei, eingebunden von extern.h:38,
                 von infer.c:33:
config.h:188:16: Fehler: doppeltes »unsigned«
  188 | #define size_t unsigned int
      |                ^~~~~~~~
config.h:188:25: Fehler: zwei oder mehr Datentypen in Deklaration
  188 | #define size_t unsigned int
      |                         ^~~
config.h:185:15: Fehler: zwei oder mehr Datentypen in Deklaration
  185 | #define off_t long int
      |               ^~~~
config.h:185:20: Fehler: zwei oder mehr Datentypen in Deklaration
  185 | #define off_t long int
      |                    ^~~
In Datei, eingebunden von extern.h:86,
                 von infer.c:33:
itypes.h:58:5: Fehler: #error "No 2 byte type, you lose."
   58 | #   error "No 2 byte type, you lose."
      |     ^~~~~
itypes.h:77:5: Fehler: #error "No 4 byte type, you lose."
   77 | #   error "No 4 byte type, you lose."
      |     ^~~~~
...


Is there anything we can do to ensure that AOO can be built with an
updated Cygwin?
Would Jim's updated dmake help?

Regards,
   Matthias

smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Errors in bootstrap while building dmake

Peter Kovacs-3
can you post what g++ -v prints on bash?

Am 24.02.20 um 17:40 schrieb Matthias Seidel:

> Hi all,
>
> After updating a lot of packages (incl. gcc) in Cygwin64 yesterday I can
> no longer build AOO for Windows.
>
> I get errors in bootstrap while building dmake:
>
> make[2]: Verzeichnis
> „/cygdrive/c/Source/openoffice/main/solenv/wntmsci12.pro/misc/build/dmake-4.12“
> wird betreten
> depbase=`echo infer.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; \
> if gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -I./unix/cygwin -I./unix
> -I./unix/cygwin/gnu -I./unix/cygwin -I./unix      -g -O2 -MT infer.o -MD
> -MP -MF "$depbase.Tpo" -c -o infer.o infer.c; \
> then mv -f "$depbase.Tpo" "$depbase.Po"; else rm -f "$depbase.Tpo"; exit
> 1; fi
> In Datei, eingebunden von extern.h:38,
>                   von infer.c:33:
> config.h:188:16: Fehler: doppeltes »unsigned«
>    188 | #define size_t unsigned int
>        |                ^~~~~~~~
> config.h:188:25: Fehler: zwei oder mehr Datentypen in Deklaration
>    188 | #define size_t unsigned int
>        |                         ^~~
> config.h:185:15: Fehler: zwei oder mehr Datentypen in Deklaration
>    185 | #define off_t long int
>        |               ^~~~
> config.h:185:20: Fehler: zwei oder mehr Datentypen in Deklaration
>    185 | #define off_t long int
>        |                    ^~~
> In Datei, eingebunden von extern.h:86,
>                   von infer.c:33:
> itypes.h:58:5: Fehler: #error "No 2 byte type, you lose."
>     58 | #   error "No 2 byte type, you lose."
>        |     ^~~~~
> itypes.h:77:5: Fehler: #error "No 4 byte type, you lose."
>     77 | #   error "No 4 byte type, you lose."
>        |     ^~~~~
> ...
>
>
> Is there anything we can do to ensure that AOO can be built with an
> updated Cygwin?
> Would Jim's updated dmake help?
>
> Regards,
>     Matthias

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Errors in bootstrap while building dmake

Matthias Seidel
Hi,

Am 24.02.20 um 18:18 schrieb Peter Kovacs:
> can you post what g++ -v prints on bash?
---
$ g++ -v
Es werden eingebaute Spezifikationen verwendet.
COLLECT_GCC=g++
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-cygwin/9.2.0/lto-wrapper.exe
Ziel: x86_64-pc-cygwin
Konfiguriert mit:
/cygdrive/i/szsz/tmpp/gcc/gcc-9.2.0-2.x86_64/src/gcc-9.2.0/configure
--srcdir=/cygdrive/i/szsz/tmpp/gcc/gcc-9.2.0-2.x86_64/src/gcc-9.2.0
--prefix=/usr --exec-prefix=/usr --localstatedir=/var --sysconfdir=/etc
--docdir=/usr/share/doc/gcc --htmldir=/usr/share/doc/gcc/html -C
--build=x86_64-pc-cygwin --host=x86_64-pc-cygwin
--target=x86_64-pc-cygwin --without-libiconv-prefix
--without-libintl-prefix --libexecdir=/usr/lib --enable-shared
--enable-shared-libgcc --enable-static
--enable-version-specific-runtime-libs --enable-bootstrap
--enable-__cxa_atexit --with-dwarf2 --with-tune=generic
--enable-languages=c,c++,fortran,lto,objc,obj-c++ --enable-graphite
--enable-threads=posix --enable-libatomic --enable-libgomp
--enable-libquadmath --enable-libquadmath-support --disable-libssp
--enable-libada --disable-symvers --with-gnu-ld --with-gnu-as
--with-cloog-include=/usr/include/cloog-isl --without-libiconv-prefix
--without-libintl-prefix --with-system-zlib --enable-linker-build-id
--with-default-libstdcxx-abi=gcc4-compatible
--enable-libstdcxx-filesystem-ts
Thread-Modell: posix
gcc-Version 9.2.0 (GCC)

---

(This is Cygwin64)
gcc was updated yesterday. I even downgraded to 7.3.0-3 with no effect.

Regards,

   Matthias

>
> Am 24.02.20 um 17:40 schrieb Matthias Seidel:
>> Hi all,
>>
>> After updating a lot of packages (incl. gcc) in Cygwin64 yesterday I can
>> no longer build AOO for Windows.
>>
>> I get errors in bootstrap while building dmake:
>>
>> make[2]: Verzeichnis
>> „/cygdrive/c/Source/openoffice/main/solenv/wntmsci12.pro/misc/build/dmake-4.12“
>>
>> wird betreten
>> depbase=`echo infer.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; \
>> if gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -I./unix/cygwin -I./unix
>> -I./unix/cygwin/gnu -I./unix/cygwin -I./unix      -g -O2 -MT infer.o -MD
>> -MP -MF "$depbase.Tpo" -c -o infer.o infer.c; \
>> then mv -f "$depbase.Tpo" "$depbase.Po"; else rm -f "$depbase.Tpo"; exit
>> 1; fi
>> In Datei, eingebunden von extern.h:38,
>>                   von infer.c:33:
>> config.h:188:16: Fehler: doppeltes »unsigned«
>>    188 | #define size_t unsigned int
>>        |                ^~~~~~~~
>> config.h:188:25: Fehler: zwei oder mehr Datentypen in Deklaration
>>    188 | #define size_t unsigned int
>>        |                         ^~~
>> config.h:185:15: Fehler: zwei oder mehr Datentypen in Deklaration
>>    185 | #define off_t long int
>>        |               ^~~~
>> config.h:185:20: Fehler: zwei oder mehr Datentypen in Deklaration
>>    185 | #define off_t long int
>>        |                    ^~~
>> In Datei, eingebunden von extern.h:86,
>>                   von infer.c:33:
>> itypes.h:58:5: Fehler: #error "No 2 byte type, you lose."
>>     58 | #   error "No 2 byte type, you lose."
>>        |     ^~~~~
>> itypes.h:77:5: Fehler: #error "No 4 byte type, you lose."
>>     77 | #   error "No 4 byte type, you lose."
>>        |     ^~~~~
>> ...
>>
>>
>> Is there anything we can do to ensure that AOO can be built with an
>> updated Cygwin?
>> Would Jim's updated dmake help?
>>
>> Regards,
>>     Matthias
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Errors in bootstrap while building dmake

Peter Kovacs-3
The error suggest a coder error.

But that is strange. So I would try to set following environment Variable:

export |CXXFLAGS = $||CXXFLAGS |||-std=gnu98||

||and then try configure again. Maybe it is something that newer
definitions are more rigid then the super old we use.||

||But it is a shot in the blue.
||

||


Am 24.02.20 um 18:23 schrieb Matthias Seidel:

> Hi,
>
> Am 24.02.20 um 18:18 schrieb Peter Kovacs:
>> can you post what g++ -v prints on bash?
> ---
> $ g++ -v
> Es werden eingebaute Spezifikationen verwendet.
> COLLECT_GCC=g++
> COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-cygwin/9.2.0/lto-wrapper.exe
> Ziel: x86_64-pc-cygwin
> Konfiguriert mit:
> /cygdrive/i/szsz/tmpp/gcc/gcc-9.2.0-2.x86_64/src/gcc-9.2.0/configure
> --srcdir=/cygdrive/i/szsz/tmpp/gcc/gcc-9.2.0-2.x86_64/src/gcc-9.2.0
> --prefix=/usr --exec-prefix=/usr --localstatedir=/var --sysconfdir=/etc
> --docdir=/usr/share/doc/gcc --htmldir=/usr/share/doc/gcc/html -C
> --build=x86_64-pc-cygwin --host=x86_64-pc-cygwin
> --target=x86_64-pc-cygwin --without-libiconv-prefix
> --without-libintl-prefix --libexecdir=/usr/lib --enable-shared
> --enable-shared-libgcc --enable-static
> --enable-version-specific-runtime-libs --enable-bootstrap
> --enable-__cxa_atexit --with-dwarf2 --with-tune=generic
> --enable-languages=c,c++,fortran,lto,objc,obj-c++ --enable-graphite
> --enable-threads=posix --enable-libatomic --enable-libgomp
> --enable-libquadmath --enable-libquadmath-support --disable-libssp
> --enable-libada --disable-symvers --with-gnu-ld --with-gnu-as
> --with-cloog-include=/usr/include/cloog-isl --without-libiconv-prefix
> --without-libintl-prefix --with-system-zlib --enable-linker-build-id
> --with-default-libstdcxx-abi=gcc4-compatible
> --enable-libstdcxx-filesystem-ts
> Thread-Modell: posix
> gcc-Version 9.2.0 (GCC)
>
> ---
>
> (This is Cygwin64)
> gcc was updated yesterday. I even downgraded to 7.3.0-3 with no effect.
>
> Regards,
>
>     Matthias
>
>> Am 24.02.20 um 17:40 schrieb Matthias Seidel:
>>> Hi all,
>>>
>>> After updating a lot of packages (incl. gcc) in Cygwin64 yesterday I can
>>> no longer build AOO for Windows.
>>>
>>> I get errors in bootstrap while building dmake:
>>>
>>> make[2]: Verzeichnis
>>> „/cygdrive/c/Source/openoffice/main/solenv/wntmsci12.pro/misc/build/dmake-4.12“
>>>
>>> wird betreten
>>> depbase=`echo infer.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; \
>>> if gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -I./unix/cygwin -I./unix
>>> -I./unix/cygwin/gnu -I./unix/cygwin -I./unix      -g -O2 -MT infer.o -MD
>>> -MP -MF "$depbase.Tpo" -c -o infer.o infer.c; \
>>> then mv -f "$depbase.Tpo" "$depbase.Po"; else rm -f "$depbase.Tpo"; exit
>>> 1; fi
>>> In Datei, eingebunden von extern.h:38,
>>>                    von infer.c:33:
>>> config.h:188:16: Fehler: doppeltes »unsigned«
>>>     188 | #define size_t unsigned int
>>>         |                ^~~~~~~~
>>> config.h:188:25: Fehler: zwei oder mehr Datentypen in Deklaration
>>>     188 | #define size_t unsigned int
>>>         |                         ^~~
>>> config.h:185:15: Fehler: zwei oder mehr Datentypen in Deklaration
>>>     185 | #define off_t long int
>>>         |               ^~~~
>>> config.h:185:20: Fehler: zwei oder mehr Datentypen in Deklaration
>>>     185 | #define off_t long int
>>>         |                    ^~~
>>> In Datei, eingebunden von extern.h:86,
>>>                    von infer.c:33:
>>> itypes.h:58:5: Fehler: #error "No 2 byte type, you lose."
>>>      58 | #   error "No 2 byte type, you lose."
>>>         |     ^~~~~
>>> itypes.h:77:5: Fehler: #error "No 4 byte type, you lose."
>>>      77 | #   error "No 4 byte type, you lose."
>>>         |     ^~~~~
>>> ...
>>>
>>>
>>> Is there anything we can do to ensure that AOO can be built with an
>>> updated Cygwin?
>>> Would Jim's updated dmake help?
>>>
>>> Regards,
>>>      Matthias
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
Reply | Threaded
Open this post in threaded view
|

Re: Errors in bootstrap while building dmake

Matthias Seidel
Hi,

Am 24.02.20 um 18:49 schrieb Peter Kovacs:

> The error suggest a coder error.
>
> But that is strange. So I would try to set following environment
> Variable:
>
> export |CXXFLAGS = $||CXXFLAGS |||-std=gnu98||
>
> ||and then try configure again. Maybe it is something that newer
> definitions are more rigid then the super old we use.||
>
> ||But it is a shot in the blue.
I will try to do that!

But until this is fixed I am out. No builds for 418 or 42X.

> ||
>
> ||
>
>
> Am 24.02.20 um 18:23 schrieb Matthias Seidel:
>> Hi,
>>
>> Am 24.02.20 um 18:18 schrieb Peter Kovacs:
>>> can you post what g++ -v prints on bash?
>> ---
>> $ g++ -v
>> Es werden eingebaute Spezifikationen verwendet.
>> COLLECT_GCC=g++
>> COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-cygwin/9.2.0/lto-wrapper.exe
>> Ziel: x86_64-pc-cygwin
>> Konfiguriert mit:
>> /cygdrive/i/szsz/tmpp/gcc/gcc-9.2.0-2.x86_64/src/gcc-9.2.0/configure
>> --srcdir=/cygdrive/i/szsz/tmpp/gcc/gcc-9.2.0-2.x86_64/src/gcc-9.2.0
>> --prefix=/usr --exec-prefix=/usr --localstatedir=/var --sysconfdir=/etc
>> --docdir=/usr/share/doc/gcc --htmldir=/usr/share/doc/gcc/html -C
>> --build=x86_64-pc-cygwin --host=x86_64-pc-cygwin
>> --target=x86_64-pc-cygwin --without-libiconv-prefix
>> --without-libintl-prefix --libexecdir=/usr/lib --enable-shared
>> --enable-shared-libgcc --enable-static
>> --enable-version-specific-runtime-libs --enable-bootstrap
>> --enable-__cxa_atexit --with-dwarf2 --with-tune=generic
>> --enable-languages=c,c++,fortran,lto,objc,obj-c++ --enable-graphite
>> --enable-threads=posix --enable-libatomic --enable-libgomp
>> --enable-libquadmath --enable-libquadmath-support --disable-libssp
>> --enable-libada --disable-symvers --with-gnu-ld --with-gnu-as
>> --with-cloog-include=/usr/include/cloog-isl --without-libiconv-prefix
>> --without-libintl-prefix --with-system-zlib --enable-linker-build-id
>> --with-default-libstdcxx-abi=gcc4-compatible
>> --enable-libstdcxx-filesystem-ts
>> Thread-Modell: posix
>> gcc-Version 9.2.0 (GCC)
>>
>> ---
>>
>> (This is Cygwin64)
>> gcc was updated yesterday. I even downgraded to 7.3.0-3 with no effect.
>>
>> Regards,
>>
>>     Matthias
>>
>>> Am 24.02.20 um 17:40 schrieb Matthias Seidel:
>>>> Hi all,
>>>>
>>>> After updating a lot of packages (incl. gcc) in Cygwin64 yesterday
>>>> I can
>>>> no longer build AOO for Windows.
>>>>
>>>> I get errors in bootstrap while building dmake:
>>>>
>>>> make[2]: Verzeichnis
>>>> „/cygdrive/c/Source/openoffice/main/solenv/wntmsci12.pro/misc/build/dmake-4.12“
>>>>
>>>>
>>>> wird betreten
>>>> depbase=`echo infer.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; \
>>>> if gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -I./unix/cygwin -I./unix
>>>> -I./unix/cygwin/gnu -I./unix/cygwin -I./unix      -g -O2 -MT
>>>> infer.o -MD
>>>> -MP -MF "$depbase.Tpo" -c -o infer.o infer.c; \
>>>> then mv -f "$depbase.Tpo" "$depbase.Po"; else rm -f "$depbase.Tpo";
>>>> exit
>>>> 1; fi
>>>> In Datei, eingebunden von extern.h:38,
>>>>                    von infer.c:33:
>>>> config.h:188:16: Fehler: doppeltes »unsigned«
>>>>     188 | #define size_t unsigned int
>>>>         |                ^~~~~~~~
>>>> config.h:188:25: Fehler: zwei oder mehr Datentypen in Deklaration
>>>>     188 | #define size_t unsigned int
>>>>         |                         ^~~
>>>> config.h:185:15: Fehler: zwei oder mehr Datentypen in Deklaration
>>>>     185 | #define off_t long int
>>>>         |               ^~~~
>>>> config.h:185:20: Fehler: zwei oder mehr Datentypen in Deklaration
>>>>     185 | #define off_t long int
>>>>         |                    ^~~
>>>> In Datei, eingebunden von extern.h:86,
>>>>                    von infer.c:33:
>>>> itypes.h:58:5: Fehler: #error "No 2 byte type, you lose."
>>>>      58 | #   error "No 2 byte type, you lose."
>>>>         |     ^~~~~
>>>> itypes.h:77:5: Fehler: #error "No 4 byte type, you lose."
>>>>      77 | #   error "No 4 byte type, you lose."
>>>>         |     ^~~~~
>>>> ...
>>>>
>>>>
>>>> Is there anything we can do to ensure that AOO can be built with an
>>>> updated Cygwin?
>>>> Would Jim's updated dmake help?
>>>>
>>>> Regards,
>>>>      Matthias
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Errors in bootstrap while building dmake

Matthias Seidel
In reply to this post by Matthias Seidel
Hi all,

Just today, there was an update of "binutils" for Cygwin and now the
errors are gone... ;-)

Sorry for the trouble, I am just doing a new build now!

Regards,

   Matthias

Am 24.02.20 um 18:23 schrieb Matthias Seidel:

> Hi,
>
> Am 24.02.20 um 18:18 schrieb Peter Kovacs:
>> can you post what g++ -v prints on bash?
> ---
> $ g++ -v
> Es werden eingebaute Spezifikationen verwendet.
> COLLECT_GCC=g++
> COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-cygwin/9.2.0/lto-wrapper.exe
> Ziel: x86_64-pc-cygwin
> Konfiguriert mit:
> /cygdrive/i/szsz/tmpp/gcc/gcc-9.2.0-2.x86_64/src/gcc-9.2.0/configure
> --srcdir=/cygdrive/i/szsz/tmpp/gcc/gcc-9.2.0-2.x86_64/src/gcc-9.2.0
> --prefix=/usr --exec-prefix=/usr --localstatedir=/var --sysconfdir=/etc
> --docdir=/usr/share/doc/gcc --htmldir=/usr/share/doc/gcc/html -C
> --build=x86_64-pc-cygwin --host=x86_64-pc-cygwin
> --target=x86_64-pc-cygwin --without-libiconv-prefix
> --without-libintl-prefix --libexecdir=/usr/lib --enable-shared
> --enable-shared-libgcc --enable-static
> --enable-version-specific-runtime-libs --enable-bootstrap
> --enable-__cxa_atexit --with-dwarf2 --with-tune=generic
> --enable-languages=c,c++,fortran,lto,objc,obj-c++ --enable-graphite
> --enable-threads=posix --enable-libatomic --enable-libgomp
> --enable-libquadmath --enable-libquadmath-support --disable-libssp
> --enable-libada --disable-symvers --with-gnu-ld --with-gnu-as
> --with-cloog-include=/usr/include/cloog-isl --without-libiconv-prefix
> --without-libintl-prefix --with-system-zlib --enable-linker-build-id
> --with-default-libstdcxx-abi=gcc4-compatible
> --enable-libstdcxx-filesystem-ts
> Thread-Modell: posix
> gcc-Version 9.2.0 (GCC)
>
> ---
>
> (This is Cygwin64)
> gcc was updated yesterday. I even downgraded to 7.3.0-3 with no effect.
>
> Regards,
>
>    Matthias
>
>> Am 24.02.20 um 17:40 schrieb Matthias Seidel:
>>> Hi all,
>>>
>>> After updating a lot of packages (incl. gcc) in Cygwin64 yesterday I can
>>> no longer build AOO for Windows.
>>>
>>> I get errors in bootstrap while building dmake:
>>>
>>> make[2]: Verzeichnis
>>> „/cygdrive/c/Source/openoffice/main/solenv/wntmsci12.pro/misc/build/dmake-4.12“
>>>
>>> wird betreten
>>> depbase=`echo infer.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; \
>>> if gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -I./unix/cygwin -I./unix
>>> -I./unix/cygwin/gnu -I./unix/cygwin -I./unix      -g -O2 -MT infer.o -MD
>>> -MP -MF "$depbase.Tpo" -c -o infer.o infer.c; \
>>> then mv -f "$depbase.Tpo" "$depbase.Po"; else rm -f "$depbase.Tpo"; exit
>>> 1; fi
>>> In Datei, eingebunden von extern.h:38,
>>>                   von infer.c:33:
>>> config.h:188:16: Fehler: doppeltes »unsigned«
>>>    188 | #define size_t unsigned int
>>>        |                ^~~~~~~~
>>> config.h:188:25: Fehler: zwei oder mehr Datentypen in Deklaration
>>>    188 | #define size_t unsigned int
>>>        |                         ^~~
>>> config.h:185:15: Fehler: zwei oder mehr Datentypen in Deklaration
>>>    185 | #define off_t long int
>>>        |               ^~~~
>>> config.h:185:20: Fehler: zwei oder mehr Datentypen in Deklaration
>>>    185 | #define off_t long int
>>>        |                    ^~~
>>> In Datei, eingebunden von extern.h:86,
>>>                   von infer.c:33:
>>> itypes.h:58:5: Fehler: #error "No 2 byte type, you lose."
>>>     58 | #   error "No 2 byte type, you lose."
>>>        |     ^~~~~
>>> itypes.h:77:5: Fehler: #error "No 4 byte type, you lose."
>>>     77 | #   error "No 4 byte type, you lose."
>>>        |     ^~~~~
>>> ...
>>>
>>>
>>> Is there anything we can do to ensure that AOO can be built with an
>>> updated Cygwin?
>>> Would Jim's updated dmake help?
>>>
>>> Regards,
>>>     Matthias
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Errors in bootstrap while building dmake

Peter Kovacs-3
wohoo!

Not our issue are the best issues!

Am 25.02.20 um 12:03 schrieb Matthias Seidel:

> Hi all,
>
> Just today, there was an update of "binutils" for Cygwin and now the
> errors are gone... ;-)
>
> Sorry for the trouble, I am just doing a new build now!
>
> Regards,
>
>     Matthias
>
> Am 24.02.20 um 18:23 schrieb Matthias Seidel:
>> Hi,
>>
>> Am 24.02.20 um 18:18 schrieb Peter Kovacs:
>>> can you post what g++ -v prints on bash?
>> ---
>> $ g++ -v
>> Es werden eingebaute Spezifikationen verwendet.
>> COLLECT_GCC=g++
>> COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-cygwin/9.2.0/lto-wrapper.exe
>> Ziel: x86_64-pc-cygwin
>> Konfiguriert mit:
>> /cygdrive/i/szsz/tmpp/gcc/gcc-9.2.0-2.x86_64/src/gcc-9.2.0/configure
>> --srcdir=/cygdrive/i/szsz/tmpp/gcc/gcc-9.2.0-2.x86_64/src/gcc-9.2.0
>> --prefix=/usr --exec-prefix=/usr --localstatedir=/var --sysconfdir=/etc
>> --docdir=/usr/share/doc/gcc --htmldir=/usr/share/doc/gcc/html -C
>> --build=x86_64-pc-cygwin --host=x86_64-pc-cygwin
>> --target=x86_64-pc-cygwin --without-libiconv-prefix
>> --without-libintl-prefix --libexecdir=/usr/lib --enable-shared
>> --enable-shared-libgcc --enable-static
>> --enable-version-specific-runtime-libs --enable-bootstrap
>> --enable-__cxa_atexit --with-dwarf2 --with-tune=generic
>> --enable-languages=c,c++,fortran,lto,objc,obj-c++ --enable-graphite
>> --enable-threads=posix --enable-libatomic --enable-libgomp
>> --enable-libquadmath --enable-libquadmath-support --disable-libssp
>> --enable-libada --disable-symvers --with-gnu-ld --with-gnu-as
>> --with-cloog-include=/usr/include/cloog-isl --without-libiconv-prefix
>> --without-libintl-prefix --with-system-zlib --enable-linker-build-id
>> --with-default-libstdcxx-abi=gcc4-compatible
>> --enable-libstdcxx-filesystem-ts
>> Thread-Modell: posix
>> gcc-Version 9.2.0 (GCC)
>>
>> ---
>>
>> (This is Cygwin64)
>> gcc was updated yesterday. I even downgraded to 7.3.0-3 with no effect.
>>
>> Regards,
>>
>>     Matthias
>>
>>> Am 24.02.20 um 17:40 schrieb Matthias Seidel:
>>>> Hi all,
>>>>
>>>> After updating a lot of packages (incl. gcc) in Cygwin64 yesterday I can
>>>> no longer build AOO for Windows.
>>>>
>>>> I get errors in bootstrap while building dmake:
>>>>
>>>> make[2]: Verzeichnis
>>>> „/cygdrive/c/Source/openoffice/main/solenv/wntmsci12.pro/misc/build/dmake-4.12“
>>>>
>>>> wird betreten
>>>> depbase=`echo infer.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; \
>>>> if gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -I./unix/cygwin -I./unix
>>>> -I./unix/cygwin/gnu -I./unix/cygwin -I./unix      -g -O2 -MT infer.o -MD
>>>> -MP -MF "$depbase.Tpo" -c -o infer.o infer.c; \
>>>> then mv -f "$depbase.Tpo" "$depbase.Po"; else rm -f "$depbase.Tpo"; exit
>>>> 1; fi
>>>> In Datei, eingebunden von extern.h:38,
>>>>                    von infer.c:33:
>>>> config.h:188:16: Fehler: doppeltes »unsigned«
>>>>     188 | #define size_t unsigned int
>>>>         |                ^~~~~~~~
>>>> config.h:188:25: Fehler: zwei oder mehr Datentypen in Deklaration
>>>>     188 | #define size_t unsigned int
>>>>         |                         ^~~
>>>> config.h:185:15: Fehler: zwei oder mehr Datentypen in Deklaration
>>>>     185 | #define off_t long int
>>>>         |               ^~~~
>>>> config.h:185:20: Fehler: zwei oder mehr Datentypen in Deklaration
>>>>     185 | #define off_t long int
>>>>         |                    ^~~
>>>> In Datei, eingebunden von extern.h:86,
>>>>                    von infer.c:33:
>>>> itypes.h:58:5: Fehler: #error "No 2 byte type, you lose."
>>>>      58 | #   error "No 2 byte type, you lose."
>>>>         |     ^~~~~
>>>> itypes.h:77:5: Fehler: #error "No 4 byte type, you lose."
>>>>      77 | #   error "No 4 byte type, you lose."
>>>>         |     ^~~~~
>>>> ...
>>>>
>>>>
>>>> Is there anything we can do to ensure that AOO can be built with an
>>>> updated Cygwin?
>>>> Would Jim's updated dmake help?
>>>>
>>>> Regards,
>>>>      Matthias
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Errors in bootstrap while building dmake

Matthias Seidel

Am 25.02.20 um 12:04 schrieb Peter Kovacs:
> wohoo!
>
> Not our issue are the best issues!

Definitely!

See:

https://cygwin.com/ml/cygwin/2020-02/msg00228.html

Regards,

   Matthias

>
> Am 25.02.20 um 12:03 schrieb Matthias Seidel:
>> Hi all,
>>
>> Just today, there was an update of "binutils" for Cygwin and now the
>> errors are gone... ;-)
>>
>> Sorry for the trouble, I am just doing a new build now!
>>
>> Regards,
>>
>>     Matthias
>>
>> Am 24.02.20 um 18:23 schrieb Matthias Seidel:
>>> Hi,
>>>
>>> Am 24.02.20 um 18:18 schrieb Peter Kovacs:
>>>> can you post what g++ -v prints on bash?
>>> ---
>>> $ g++ -v
>>> Es werden eingebaute Spezifikationen verwendet.
>>> COLLECT_GCC=g++
>>> COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-cygwin/9.2.0/lto-wrapper.exe
>>> Ziel: x86_64-pc-cygwin
>>> Konfiguriert mit:
>>> /cygdrive/i/szsz/tmpp/gcc/gcc-9.2.0-2.x86_64/src/gcc-9.2.0/configure
>>> --srcdir=/cygdrive/i/szsz/tmpp/gcc/gcc-9.2.0-2.x86_64/src/gcc-9.2.0
>>> --prefix=/usr --exec-prefix=/usr --localstatedir=/var --sysconfdir=/etc
>>> --docdir=/usr/share/doc/gcc --htmldir=/usr/share/doc/gcc/html -C
>>> --build=x86_64-pc-cygwin --host=x86_64-pc-cygwin
>>> --target=x86_64-pc-cygwin --without-libiconv-prefix
>>> --without-libintl-prefix --libexecdir=/usr/lib --enable-shared
>>> --enable-shared-libgcc --enable-static
>>> --enable-version-specific-runtime-libs --enable-bootstrap
>>> --enable-__cxa_atexit --with-dwarf2 --with-tune=generic
>>> --enable-languages=c,c++,fortran,lto,objc,obj-c++ --enable-graphite
>>> --enable-threads=posix --enable-libatomic --enable-libgomp
>>> --enable-libquadmath --enable-libquadmath-support --disable-libssp
>>> --enable-libada --disable-symvers --with-gnu-ld --with-gnu-as
>>> --with-cloog-include=/usr/include/cloog-isl --without-libiconv-prefix
>>> --without-libintl-prefix --with-system-zlib --enable-linker-build-id
>>> --with-default-libstdcxx-abi=gcc4-compatible
>>> --enable-libstdcxx-filesystem-ts
>>> Thread-Modell: posix
>>> gcc-Version 9.2.0 (GCC)
>>>
>>> ---
>>>
>>> (This is Cygwin64)
>>> gcc was updated yesterday. I even downgraded to 7.3.0-3 with no effect.
>>>
>>> Regards,
>>>
>>>     Matthias
>>>
>>>> Am 24.02.20 um 17:40 schrieb Matthias Seidel:
>>>>> Hi all,
>>>>>
>>>>> After updating a lot of packages (incl. gcc) in Cygwin64 yesterday
>>>>> I can
>>>>> no longer build AOO for Windows.
>>>>>
>>>>> I get errors in bootstrap while building dmake:
>>>>>
>>>>> make[2]: Verzeichnis
>>>>> „/cygdrive/c/Source/openoffice/main/solenv/wntmsci12.pro/misc/build/dmake-4.12“
>>>>>
>>>>>
>>>>> wird betreten
>>>>> depbase=`echo infer.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; \
>>>>> if gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -I./unix/cygwin -I./unix
>>>>> -I./unix/cygwin/gnu -I./unix/cygwin -I./unix      -g -O2 -MT
>>>>> infer.o -MD
>>>>> -MP -MF "$depbase.Tpo" -c -o infer.o infer.c; \
>>>>> then mv -f "$depbase.Tpo" "$depbase.Po"; else rm -f
>>>>> "$depbase.Tpo"; exit
>>>>> 1; fi
>>>>> In Datei, eingebunden von extern.h:38,
>>>>>                    von infer.c:33:
>>>>> config.h:188:16: Fehler: doppeltes »unsigned«
>>>>>     188 | #define size_t unsigned int
>>>>>         |                ^~~~~~~~
>>>>> config.h:188:25: Fehler: zwei oder mehr Datentypen in Deklaration
>>>>>     188 | #define size_t unsigned int
>>>>>         |                         ^~~
>>>>> config.h:185:15: Fehler: zwei oder mehr Datentypen in Deklaration
>>>>>     185 | #define off_t long int
>>>>>         |               ^~~~
>>>>> config.h:185:20: Fehler: zwei oder mehr Datentypen in Deklaration
>>>>>     185 | #define off_t long int
>>>>>         |                    ^~~
>>>>> In Datei, eingebunden von extern.h:86,
>>>>>                    von infer.c:33:
>>>>> itypes.h:58:5: Fehler: #error "No 2 byte type, you lose."
>>>>>      58 | #   error "No 2 byte type, you lose."
>>>>>         |     ^~~~~
>>>>> itypes.h:77:5: Fehler: #error "No 4 byte type, you lose."
>>>>>      77 | #   error "No 4 byte type, you lose."
>>>>>         |     ^~~~~
>>>>> ...
>>>>>
>>>>>
>>>>> Is there anything we can do to ensure that AOO can be built with an
>>>>> updated Cygwin?
>>>>> Would Jim's updated dmake help?
>>>>>
>>>>> Regards,
>>>>>      Matthias
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment