Expat 2.2.3 and Windows woes

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
19 messages Options
Reply | Threaded
Open this post in threaded view
|

Expat 2.2.3 and Windows woes

Jim Jagielski
Hrm. Matthias is reporting that with expat 2.2.3, that Windows is
no longer building....

Some ideas:

  o expat 2.2.3 requires c99
  o expat 2.2.3 requires loadlibrary.obj be built
    and it doesn't look like our expat-2.2.3.patch
    file, which creates makefile.mk does that.

Can anyone check and correct?

tia

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Matthias Seidel
Hi Jim,

I applied your patch but now it stops at:

---

1 module(s):
        expat
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making
/cygdrive/c/Source/aoo-414/main/expat

When you have fixed the errors in that module you can resume the build
by running:

        build --from expat

---


Am 03.08.2017 um 22:34 schrieb Jim Jagielski:

> Hrm. Matthias is reporting that with expat 2.2.3, that Windows is
> no longer building....
>
> Some ideas:
>
>   o expat 2.2.3 requires c99
>   o expat 2.2.3 requires loadlibrary.obj be built
>     and it doesn't look like our expat-2.2.3.patch
>     file, which creates makefile.mk does that.
>
> Can anyone check and correct?
>
> tia
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Jim Jagielski
Is there any way to get a more verbose build output?

I am totally in-the-dark re: Windows build environs, so I'm
just spit balling on possible fixes ;)

> On Aug 3, 2017, at 5:44 PM, Matthias Seidel <[hidden email]> wrote:
>
> Hi Jim,
>
> I applied your patch but now it stops at:
>
> ---
>
> 1 module(s):
>        expat
> need(s) to be rebuilt
>
> Reason(s):
>
> ERROR: error 65280 occurred while making
> /cygdrive/c/Source/aoo-414/main/expat
>
> When you have fixed the errors in that module you can resume the build
> by running:
>
>        build --from expat
>
> ---
>
>
> Am 03.08.2017 um 22:34 schrieb Jim Jagielski:
>> Hrm. Matthias is reporting that with expat 2.2.3, that Windows is
>> no longer building....
>>
>> Some ideas:
>>
>>  o expat 2.2.3 requires c99
>>  o expat 2.2.3 requires loadlibrary.obj be built
>>    and it doesn't look like our expat-2.2.3.patch
>>    file, which creates makefile.mk does that.
>>
>> Can anyone check and correct?
>>
>> tia
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Matthias Seidel
I forced a build from our buildbot:
https://ci.apache.org/builders/aoo-w741x/builds/155

Maybe those logs are telling something...

Additionally I reverted my SVN back to expat2.2.1 and will let it
(hopefully) build over night.
For me it is time to go to bed... ;-)


Am 03.08.2017 um 23:50 schrieb Jim Jagielski:

> Is there any way to get a more verbose build output?
>
> I am totally in-the-dark re: Windows build environs, so I'm
> just spit balling on possible fixes ;)
>
>> On Aug 3, 2017, at 5:44 PM, Matthias Seidel <[hidden email]> wrote:
>>
>> Hi Jim,
>>
>> I applied your patch but now it stops at:
>>
>> ---
>>
>> 1 module(s):
>>        expat
>> need(s) to be rebuilt
>>
>> Reason(s):
>>
>> ERROR: error 65280 occurred while making
>> /cygdrive/c/Source/aoo-414/main/expat
>>
>> When you have fixed the errors in that module you can resume the build
>> by running:
>>
>>        build --from expat
>>
>> ---
>>
>>
>> Am 03.08.2017 um 22:34 schrieb Jim Jagielski:
>>> Hrm. Matthias is reporting that with expat 2.2.3, that Windows is
>>> no longer building....
>>>
>>> Some ideas:
>>>
>>>  o expat 2.2.3 requires c99
>>>  o expat 2.2.3 requires loadlibrary.obj be built
>>>    and it doesn't look like our expat-2.2.3.patch
>>>    file, which creates makefile.mk does that.
>>>
>>> Can anyone check and correct?
>>>
>>> tia
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Matthias Seidel
Am 04.08.2017 um 00:10 schrieb Matthias Seidel:
> I forced a build from our buildbot:
> https://ci.apache.org/builders/aoo-w741x/builds/155
>
> Maybe those logs are telling something...

https://ci.apache.org/projects/openoffice/buildlogs/win41x/log/wntmsci12.pro.build.html

"error LNK2019: unresolved external symbol __Expat_LoadLibrary
referenced in function _writeRandomBytes_RtlGenRandom
../../wntmsci12.pro/bin/sax.uno.dll : fatal error LNK1120: 1 unresolved
externals"

>
> Additionally I reverted my SVN back to expat2.2.1 and will let it
> (hopefully) build over night.
> For me it is time to go to bed... ;-)

My "personal" build is still running, so I got past that point by
reverting to expat2.2.1.

>
>
> Am 03.08.2017 um 23:50 schrieb Jim Jagielski:
>> Is there any way to get a more verbose build output?
>>
>> I am totally in-the-dark re: Windows build environs, so I'm
>> just spit balling on possible fixes ;)
>>
>>> On Aug 3, 2017, at 5:44 PM, Matthias Seidel <[hidden email]> wrote:
>>>
>>> Hi Jim,
>>>
>>> I applied your patch but now it stops at:
>>>
>>> ---
>>>
>>> 1 module(s):
>>>        expat
>>> need(s) to be rebuilt
>>>
>>> Reason(s):
>>>
>>> ERROR: error 65280 occurred while making
>>> /cygdrive/c/Source/aoo-414/main/expat
>>>
>>> When you have fixed the errors in that module you can resume the build
>>> by running:
>>>
>>>        build --from expat
>>>
>>> ---
>>>
>>>
>>> Am 03.08.2017 um 22:34 schrieb Jim Jagielski:
>>>> Hrm. Matthias is reporting that with expat 2.2.3, that Windows is
>>>> no longer building....
>>>>
>>>> Some ideas:
>>>>
>>>>  o expat 2.2.3 requires c99
>>>>  o expat 2.2.3 requires loadlibrary.obj be built
>>>>    and it doesn't look like our expat-2.2.3.patch
>>>>    file, which creates makefile.mk does that.
>>>>
>>>> Can anyone check and correct?
>>>>
>>>> tia
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Jim Jagielski-2
Ahh.. so yeah, either the obj file for loadlibrary is not being built or else its not being linked in. At this point we need someone who knows the Windows dev environment to help out on what needs to be done... I am guessing it is our makefile.mk file that needs to be updated??

On 2017-08-04 01:17, Matthias Seidel <[hidden email]> wrote:

> Am 04.08.2017 um 00:10 schrieb Matthias Seidel:
> > I forced a build from our buildbot:
> > https://ci.apache.org/builders/aoo-w741x/builds/155
> >
> > Maybe those logs are telling something...
>
> https://ci.apache.org/projects/openoffice/buildlogs/win41x/log/wntmsci12.pro.build.html
>
> "error LNK2019: unresolved external symbol __Expat_LoadLibrary
> referenced in function _writeRandomBytes_RtlGenRandom
> ../../wntmsci12.pro/bin/sax.uno.dll : fatal error LNK1120: 1 unresolved
> externals"
>
> >
> > Additionally I reverted my SVN back to expat2.2.1 and will let it
> > (hopefully) build over night.
> > For me it is time to go to bed... ;-)
>
> My "personal" build is still running, so I got past that point by
> reverting to expat2.2.1.
>
> >
> >
> > Am 03.08.2017 um 23:50 schrieb Jim Jagielski:
> >> Is there any way to get a more verbose build output?
> >>
> >> I am totally in-the-dark re: Windows build environs, so I'm
> >> just spit balling on possible fixes ;)
> >>
> >>> On Aug 3, 2017, at 5:44 PM, Matthias Seidel <[hidden email]> wrote:
> >>>
> >>> Hi Jim,
> >>>
> >>> I applied your patch but now it stops at:
> >>>
> >>> ---
> >>>
> >>> 1 module(s):
> >>>        expat
> >>> need(s) to be rebuilt
> >>>
> >>> Reason(s):
> >>>
> >>> ERROR: error 65280 occurred while making
> >>> /cygdrive/c/Source/aoo-414/main/expat
> >>>
> >>> When you have fixed the errors in that module you can resume the build
> >>> by running:
> >>>
> >>>        build --from expat
> >>>
> >>> ---
> >>>
> >>>
> >>> Am 03.08.2017 um 22:34 schrieb Jim Jagielski:
> >>>> Hrm. Matthias is reporting that with expat 2.2.3, that Windows is
> >>>> no longer building....
> >>>>
> >>>> Some ideas:
> >>>>
> >>>>  o expat 2.2.3 requires c99
> >>>>  o expat 2.2.3 requires loadlibrary.obj be built
> >>>>    and it doesn't look like our expat-2.2.3.patch
> >>>>    file, which creates makefile.mk does that.
> >>>>
> >>>> Can anyone check and correct?
> >>>>
> >>>> tia
> >>>>
> >>>> ---------------------------------------------------------------------
> >>>> To unsubscribe, e-mail: [hidden email]
> >>>> For additional commands, e-mail: [hidden email]
> >>>>
> >>>>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: [hidden email]
> >> For additional commands, e-mail: [hidden email]
> >>
> >
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Matthias Seidel
Am 04.08.2017 um 13:30 schrieb Jim Jagielski:
> Ahh.. so yeah, either the obj file for loadlibrary is not being built or else its not being linked in. At this point we need someone who knows the Windows dev environment to help out on what needs to be done... I am guessing it is our makefile.mk file that needs to be updated??

I hope someone can jump in here...

Meanwhile my build (based on Rev. 1803945 with reverted expat2.2.1)
finished successful.

>
> On 2017-08-04 01:17, Matthias Seidel <[hidden email]> wrote:
>> Am 04.08.2017 um 00:10 schrieb Matthias Seidel:
>>> I forced a build from our buildbot:
>>> https://ci.apache.org/builders/aoo-w741x/builds/155
>>>
>>> Maybe those logs are telling something...
>> https://ci.apache.org/projects/openoffice/buildlogs/win41x/log/wntmsci12.pro.build.html
>>
>> "error LNK2019: unresolved external symbol __Expat_LoadLibrary
>> referenced in function _writeRandomBytes_RtlGenRandom
>> ../../wntmsci12.pro/bin/sax.uno.dll : fatal error LNK1120: 1 unresolved
>> externals"
>>
>>> Additionally I reverted my SVN back to expat2.2.1 and will let it
>>> (hopefully) build over night.
>>> For me it is time to go to bed... ;-)
>> My "personal" build is still running, so I got past that point by
>> reverting to expat2.2.1.
>>
>>>
>>> Am 03.08.2017 um 23:50 schrieb Jim Jagielski:
>>>> Is there any way to get a more verbose build output?
>>>>
>>>> I am totally in-the-dark re: Windows build environs, so I'm
>>>> just spit balling on possible fixes ;)
>>>>
>>>>> On Aug 3, 2017, at 5:44 PM, Matthias Seidel <[hidden email]> wrote:
>>>>>
>>>>> Hi Jim,
>>>>>
>>>>> I applied your patch but now it stops at:
>>>>>
>>>>> ---
>>>>>
>>>>> 1 module(s):
>>>>>        expat
>>>>> need(s) to be rebuilt
>>>>>
>>>>> Reason(s):
>>>>>
>>>>> ERROR: error 65280 occurred while making
>>>>> /cygdrive/c/Source/aoo-414/main/expat
>>>>>
>>>>> When you have fixed the errors in that module you can resume the build
>>>>> by running:
>>>>>
>>>>>        build --from expat
>>>>>
>>>>> ---
>>>>>
>>>>>
>>>>> Am 03.08.2017 um 22:34 schrieb Jim Jagielski:
>>>>>> Hrm. Matthias is reporting that with expat 2.2.3, that Windows is
>>>>>> no longer building....
>>>>>>
>>>>>> Some ideas:
>>>>>>
>>>>>>  o expat 2.2.3 requires c99
>>>>>>  o expat 2.2.3 requires loadlibrary.obj be built
>>>>>>    and it doesn't look like our expat-2.2.3.patch
>>>>>>    file, which creates makefile.mk does that.
>>>>>>
>>>>>> Can anyone check and correct?
>>>>>>
>>>>>> tia
>>>>>>
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: [hidden email]
>>>>>> For additional commands, e-mail: [hidden email]
>>>>>>
>>>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>
>>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Jim Jagielski-2
Worse case scenario I have an ugly, nasty hack: simply append loadlibrary to the end of the xmlparse.c file... Unless someone has other ideas, we may be forced to try that.

On 2017-08-04 08:57, Matthias Seidel <[hidden email]> wrote:

> Am 04.08.2017 um 13:30 schrieb Jim Jagielski:
> > Ahh.. so yeah, either the obj file for loadlibrary is not being built or else its not being linked in. At this point we need someone who knows the Windows dev environment to help out on what needs to be done... I am guessing it is our makefile.mk file that needs to be updated??
>
> I hope someone can jump in here...
>
> Meanwhile my build (based on Rev. 1803945 with reverted expat2.2.1)
> finished successful.
>
> >
> > On 2017-08-04 01:17, Matthias Seidel <[hidden email]> wrote:
> >> Am 04.08.2017 um 00:10 schrieb Matthias Seidel:
> >>> I forced a build from our buildbot:
> >>> https://ci.apache.org/builders/aoo-w741x/builds/155
> >>>
> >>> Maybe those logs are telling something...
> >> https://ci.apache.org/projects/openoffice/buildlogs/win41x/log/wntmsci12.pro.build.html
> >>
> >> "error LNK2019: unresolved external symbol __Expat_LoadLibrary
> >> referenced in function _writeRandomBytes_RtlGenRandom
> >> ../../wntmsci12.pro/bin/sax.uno.dll : fatal error LNK1120: 1 unresolved
> >> externals"
> >>
> >>> Additionally I reverted my SVN back to expat2.2.1 and will let it
> >>> (hopefully) build over night.
> >>> For me it is time to go to bed... ;-)
> >> My "personal" build is still running, so I got past that point by
> >> reverting to expat2.2.1.
> >>
> >>>
> >>> Am 03.08.2017 um 23:50 schrieb Jim Jagielski:
> >>>> Is there any way to get a more verbose build output?
> >>>>
> >>>> I am totally in-the-dark re: Windows build environs, so I'm
> >>>> just spit balling on possible fixes ;)
> >>>>
> >>>>> On Aug 3, 2017, at 5:44 PM, Matthias Seidel <[hidden email]> wrote:
> >>>>>
> >>>>> Hi Jim,
> >>>>>
> >>>>> I applied your patch but now it stops at:
> >>>>>
> >>>>> ---
> >>>>>
> >>>>> 1 module(s):
> >>>>>        expat
> >>>>> need(s) to be rebuilt
> >>>>>
> >>>>> Reason(s):
> >>>>>
> >>>>> ERROR: error 65280 occurred while making
> >>>>> /cygdrive/c/Source/aoo-414/main/expat
> >>>>>
> >>>>> When you have fixed the errors in that module you can resume the build
> >>>>> by running:
> >>>>>
> >>>>>        build --from expat
> >>>>>
> >>>>> ---
> >>>>>
> >>>>>
> >>>>> Am 03.08.2017 um 22:34 schrieb Jim Jagielski:
> >>>>>> Hrm. Matthias is reporting that with expat 2.2.3, that Windows is
> >>>>>> no longer building....
> >>>>>>
> >>>>>> Some ideas:
> >>>>>>
> >>>>>>  o expat 2.2.3 requires c99
> >>>>>>  o expat 2.2.3 requires loadlibrary.obj be built
> >>>>>>    and it doesn't look like our expat-2.2.3.patch
> >>>>>>    file, which creates makefile.mk does that.
> >>>>>>
> >>>>>> Can anyone check and correct?
> >>>>>>
> >>>>>> tia
> >>>>>>
> >>>>>> ---------------------------------------------------------------------
> >>>>>> To unsubscribe, e-mail: [hidden email]
> >>>>>> For additional commands, e-mail: [hidden email]
> >>>>>>
> >>>>>>
> >>>> ---------------------------------------------------------------------
> >>>> To unsubscribe, e-mail: [hidden email]
> >>>> For additional commands, e-mail: [hidden email]
> >>>>
> >>
> >>
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Jim Jagielski
In reply to this post by Matthias Seidel
can you kick off another win buildbot run on r1804151 ??

thx!

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Matthias Seidel
Done!


Am 04.08.2017 um 21:07 schrieb Jim Jagielski:
> can you kick off another win buildbot run on r1804151 ??
>
> thx!
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>



smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Jim Jagielski
Grr...

1 module(s):
        expat
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making /cygdrive/e/slave14/aoo-w741x/build/main/expat

When you have fixed the errors in that module you can resume the build by running:

        build --from expat


I really wish I had more direct access to a Win build environ. Or
at least that the buildbot was more vocal. :/
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Matthias Seidel
https://ci.apache.org/projects/openoffice/buildlogs/win41x/main/expat/wntmsci12.pro/misc/logs/expat.txt


Am 05.08.2017 um 00:14 schrieb Jim Jagielski:

> Grr...
>
> 1 module(s):
> expat
> need(s) to be rebuilt
>
> Reason(s):
>
> ERROR: error 65280 occurred while making /cygdrive/e/slave14/aoo-w741x/build/main/expat
>
> When you have fixed the errors in that module you can resume the build by running:
>
> build --from expat
>
>
> I really wish I had more direct access to a Win build environ. Or
> at least that the buildbot was more vocal. :/
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Jim Jagielski
r1804159

Just when you thought this work-around couldn't get uglier :)

Let's kick off another, please.

> On Aug 4, 2017, at 6:17 PM, Matthias Seidel <[hidden email]> wrote:
>
> https://ci.apache.org/projects/openoffice/buildlogs/win41x/main/expat/wntmsci12.pro/misc/logs/expat.txt
>
>
> Am 05.08.2017 um 00:14 schrieb Jim Jagielski:
>> Grr...
>>
>> 1 module(s):
>> expat
>> need(s) to be rebuilt
>>
>> Reason(s):
>>
>> ERROR: error 65280 occurred while making /cygdrive/e/slave14/aoo-w741x/build/main/expat
>>
>> When you have fixed the errors in that module you can resume the build by running:
>>
>> build --from expat
>>
>>
>> I really wish I had more direct access to a Win build environ. Or
>> at least that the buildbot was more vocal. :/
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Don Lewis-2
In reply to this post by Jim Jagielski-2
On  4 Aug, Jim Jagielski wrote:
> Ahh.. so yeah, either the obj file for loadlibrary is not being built
> or else its not being linked in. At this point we need someone who
> knows the Windows dev environment to help out on what needs to be
> done... I am guessing it is our makefile.mk file that needs to be
> updated??

I can't test this for a while, but in the part of expat-2.2.3.patch that
creates the makefile.mk to actually build expat, I think that the
loadlibrary.obj file needs to be conditionally added to SLOFILES when
the OS is Windows.  Dunno if other changes are needed.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Matthias Seidel
In reply to this post by Jim Jagielski
Done!

You can see the results here:
https://ci.apache.org/projects/openoffice/buildlogs/win41x/log/wntmsci12.pro.build.html

Bedtime for me... ;-)


Am 05.08.2017 um 00:38 schrieb Jim Jagielski:

> r1804159
>
> Just when you thought this work-around couldn't get uglier :)
>
> Let's kick off another, please.
>> On Aug 4, 2017, at 6:17 PM, Matthias Seidel <[hidden email]> wrote:
>>
>> https://ci.apache.org/projects/openoffice/buildlogs/win41x/main/expat/wntmsci12.pro/misc/logs/expat.txt
>>
>>
>> Am 05.08.2017 um 00:14 schrieb Jim Jagielski:
>>> Grr...
>>>
>>> 1 module(s):
>>> expat
>>> need(s) to be rebuilt
>>>
>>> Reason(s):
>>>
>>> ERROR: error 65280 occurred while making /cygdrive/e/slave14/aoo-w741x/build/main/expat
>>>
>>> When you have fixed the errors in that module you can resume the build by running:
>>>
>>> build --from expat
>>>
>>>
>>> I really wish I had more direct access to a Win build environ. Or
>>> at least that the buildbot was more vocal. :/
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Jim Jagielski
In reply to this post by Don Lewis-2

> On Aug 4, 2017, at 6:52 PM, Don Lewis <[hidden email]> wrote:
>
> On  4 Aug, Jim Jagielski wrote:
>> Ahh.. so yeah, either the obj file for loadlibrary is not being built
>> or else its not being linked in. At this point we need someone who
>> knows the Windows dev environment to help out on what needs to be
>> done... I am guessing it is our makefile.mk file that needs to be
>> updated??
>
> I can't test this for a while, but in the part of expat-2.2.3.patch that
> creates the makefile.mk to actually build expat, I think that the
> loadlibrary.obj file needs to be conditionally added to SLOFILES when
> the OS is Windows.  Dunno if other changes are needed.
>

We tried that... :/

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Matthias Seidel
In reply to this post by Matthias Seidel
That looks like a successful build to me!

I will start a build on my machine based on Rev. 1804159...


Am 05.08.2017 um 00:57 schrieb Matthias Seidel:

> Done!
>
> You can see the results here:
> https://ci.apache.org/projects/openoffice/buildlogs/win41x/log/wntmsci12.pro.build.html
>
> Bedtime for me... ;-)
>
>
> Am 05.08.2017 um 00:38 schrieb Jim Jagielski:
>> r1804159
>>
>> Just when you thought this work-around couldn't get uglier :)
>>
>> Let's kick off another, please.
>>> On Aug 4, 2017, at 6:17 PM, Matthias Seidel <[hidden email]> wrote:
>>>
>>> https://ci.apache.org/projects/openoffice/buildlogs/win41x/main/expat/wntmsci12.pro/misc/logs/expat.txt
>>>
>>>
>>> Am 05.08.2017 um 00:14 schrieb Jim Jagielski:
>>>> Grr...
>>>>
>>>> 1 module(s):
>>>> expat
>>>> need(s) to be rebuilt
>>>>
>>>> Reason(s):
>>>>
>>>> ERROR: error 65280 occurred while making /cygdrive/e/slave14/aoo-w741x/build/main/expat
>>>>
>>>> When you have fixed the errors in that module you can resume the build by running:
>>>>
>>>> build --from expat
>>>>
>>>>
>>>> I really wish I had more direct access to a Win build environ. Or
>>>> at least that the buildbot was more vocal. :/
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Matthias Seidel
Am 05.08.2017 um 09:52 schrieb Matthias Seidel:
> That looks like a successful build to me!
>
> I will start a build on my machine based on Rev. 1804159...

Meanwhile I installed the build from our buildbot. Quick and easy.

Note: The environment of the Windows buildbot is slightly different and
the build is for testing only!

>
>
> Am 05.08.2017 um 00:57 schrieb Matthias Seidel:
>> Done!
>>
>> You can see the results here:
>> https://ci.apache.org/projects/openoffice/buildlogs/win41x/log/wntmsci12.pro.build.html
>>
>> Bedtime for me... ;-)
>>
>>
>> Am 05.08.2017 um 00:38 schrieb Jim Jagielski:
>>> r1804159
>>>
>>> Just when you thought this work-around couldn't get uglier :)
>>>
>>> Let's kick off another, please.
>>>> On Aug 4, 2017, at 6:17 PM, Matthias Seidel <[hidden email]> wrote:
>>>>
>>>> https://ci.apache.org/projects/openoffice/buildlogs/win41x/main/expat/wntmsci12.pro/misc/logs/expat.txt
>>>>
>>>>
>>>> Am 05.08.2017 um 00:14 schrieb Jim Jagielski:
>>>>> Grr...
>>>>>
>>>>> 1 module(s):
>>>>> expat
>>>>> need(s) to be rebuilt
>>>>>
>>>>> Reason(s):
>>>>>
>>>>> ERROR: error 65280 occurred while making /cygdrive/e/slave14/aoo-w741x/build/main/expat
>>>>>
>>>>> When you have fixed the errors in that module you can resume the build by running:
>>>>>
>>>>> build --from expat
>>>>>
>>>>>
>>>>> I really wish I had more direct access to a Win build environ. Or
>>>>> at least that the buildbot was more vocal. :/
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: [hidden email]
>>>>> For additional commands, e-mail: [hidden email]
>>>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Expat 2.2.3 and Windows woes

Jim Jagielski
In reply to this post by Matthias Seidel
W00t!!

I am starting on the Linux 32, 64 and macOS builds as we speak.

> On Aug 5, 2017, at 3:52 AM, Matthias Seidel <[hidden email]> wrote:
>
> That looks like a successful build to me!
>
> I will start a build on my machine based on Rev. 1804159...
>
>
> Am 05.08.2017 um 00:57 schrieb Matthias Seidel:
>> Done!
>>
>> You can see the results here:
>> https://ci.apache.org/projects/openoffice/buildlogs/win41x/log/wntmsci12.pro.build.html
>>
>> Bedtime for me... ;-)
>>
>>
>> Am 05.08.2017 um 00:38 schrieb Jim Jagielski:
>>> r1804159
>>>
>>> Just when you thought this work-around couldn't get uglier :)
>>>
>>> Let's kick off another, please.
>>>> On Aug 4, 2017, at 6:17 PM, Matthias Seidel <[hidden email]> wrote:
>>>>
>>>> https://ci.apache.org/projects/openoffice/buildlogs/win41x/main/expat/wntmsci12.pro/misc/logs/expat.txt
>>>>
>>>>
>>>> Am 05.08.2017 um 00:14 schrieb Jim Jagielski:
>>>>> Grr...
>>>>>
>>>>> 1 module(s):
>>>>> expat
>>>>> need(s) to be rebuilt
>>>>>
>>>>> Reason(s):
>>>>>
>>>>> ERROR: error 65280 occurred while making /cygdrive/e/slave14/aoo-w741x/build/main/expat
>>>>>
>>>>> When you have fixed the errors in that module you can resume the build by running:
>>>>>
>>>>> build --from expat
>>>>>
>>>>>
>>>>> I really wish I had more direct access to a Win build environ. Or
>>>>> at least that the buildbot was more vocal. :/
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: [hidden email]
>>>>> For additional commands, e-mail: [hidden email]
>>>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]