[FORUMS] Please test forums

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
22 messages Options
12
Reply | Threaded
Open this post in threaded view
|

[FORUMS] Please test forums

Dave Fisher
Hi -

The new Forum VM is ready for testing at https://forum-test.openoffice.org/

The data on this update to date to roughly Noon EDT. 17:00 UTC.

Please make sure that you can do all the usual activity.

If all goes well this phase of testing will end on Tuesday at Noon EDT.

Regards,
Dave

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Алексей Евгеньевич Харламенков
Hello colleagues!
 
I'm glad to open forums.
 
My name is Alexey Harlamenkov.
 
My account on the Wiki: https://wiki.openoffice.org/wiki/User:Sancho
I created more than 1000 pages in the Russian section of the Wiki.
 
Please open the Russian section of the forum forum-test.openoffice.org/RU/forum/
I'm ready to administer this forum.
 
 
Yours faithfully,
Alexey Harlamenkov
 
Email: [hidden email]
Web: http://harlamenkov.ru
Mob .: 7 (926) 233-46-64

> -------- Перенаправленное сообщение --------
>
> Тема: [FORUMS] Please test forums
> Дата: Fri, 22 Jun 2018 12:18:39 -0700
> От: Dave Fisher <[hidden email]>
> Отвечать: [hidden email]
> Кому: [hidden email]
>
> Hi -
>
> The new Forum VM is ready for testing at https://forum-test.openoffice.org/
>
> The data on this update to date to roughly Noon EDT. 17:00 UTC.
>
> Please make sure that you can do all the usual activity.
>
> If all goes well this phase of testing will end on Tuesday at Noon EDT.
>
> Regards,
> Dave

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Hagar Delest-2
In reply to this post by Dave Fisher
Hi Dave,

First, the responsiveness is back with this configuration, that's great!

I've tried several admin and moderator tasks and it seems OK on the English forum (post moderation approval, post edition, user profile edit, topic move).

However I saw is that some posts are shown empty. If I edit the post I see the text in the message area but when I try to submit, it becomes blank and empty (but I managed to edit one as stated above).
For example, compare these 2 identical threads:
- https://forum-test.openoffice.org/en/forum/viewtopic.php?f=49&t=61238
- https://forum.openoffice.org/en/forum/viewtopic.php?f=49&t=61238

I can't submit posts, perhaps it's linked, I get the blank message area with the error message: "Your message contains too few characters." Maybe the test database is read only.

Hagar


Le 22/06/2018 à 21:18, Dave Fisher a écrit :

> Hi -
>
> The new Forum VM is ready for testing at https://forum-test.openoffice.org/
>
> The data on this update to date to roughly Noon EDT. 17:00 UTC.
>
> Please make sure that you can do all the usual activity.
>
> If all goes well this phase of testing will end on Tuesday at Noon EDT.
>
> Regards,
> Dave

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Dave Fisher
Hi Hagar,

Thanks.

On Jun 22, 2018, at 2:29 PM, Hagar Delest <[hidden email]> wrote:

Hi Dave,

First, the responsiveness is back with this configuration, that's great!

I've tried several admin and moderator tasks and it seems OK on the English forum (post moderation approval, post edition, user profile edit, topic move).

However I saw is that some posts are shown empty. If I edit the post I see the text in the message area but when I try to submit, it becomes blank and empty (but I managed to edit one as stated above).
For example, compare these 2 identical threads:
- https://forum-test.openoffice.org/en/forum/viewtopic.php?f=49&t=61238
- https://forum.openoffice.org/en/forum/viewtopic.php?f=49&t=61238

It looks like the posts with missing content have quote callouts. I’ll have to dig into these.


I can't submit posts, perhaps it's linked, I get the blank message area with the error message: "Your message contains too few characters." Maybe the test database is read only.

I did an mysqldump and then ran the sql on the new sql server. I’ll need to dig. It could be a version issue PHP and MySQL are upgraded. I may have to jump on the upgrade to phpBB as this could be related.

If you cn try to see if the other forums work that would be great.

Regards,
Dave



Hagar


Le 22/06/2018 à 21:18, Dave Fisher a écrit :
Hi -

The new Forum VM is ready for testing at https://forum-test.openoffice.org/

The data on this update to date to roughly Noon EDT. 17:00 UTC.

Please make sure that you can do all the usual activity.

If all goes well this phase of testing will end on Tuesday at Noon EDT.

Regards,
Dave



signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Dave Fisher
In reply to this post by Алексей Евгеньевич Харламенков
Hi -

> On Jun 22, 2018, at 1:50 PM, Алексей Евгеньевич Харламенков <[hidden email]> wrote:
>
> Hello colleagues!
>
> I'm glad to open forums.
>
> My name is Alexey Harlamenkov.
>
> My account on the Wiki: https://wiki.openoffice.org/wiki/UsHi er:Sancho
> I created more than 1000 pages in the Russian section of the Wiki.
Upgrades to the Wiki are coming and those will need to be tested. Please standby it will be soonish.

>
> Please open the Russian section of the forum forum-test.openoffice.org/RU/forum/
> I'm ready to administer this forum.

I’m not going to do this anytime soon. I’m an unpaid volunteer and the upgrades being done are required or we have to take the Forums down.

In a month or two we might decide to open new forums until then I would suggest that you engage with the Forum team about their rules for moderation, etc.

Regards,
Dave

>
>
> Yours faithfully,
> Alexey Harlamenkov
>
> Email: [hidden email]
> Web: http://harlamenkov.ru
> Mob .: 7 (926) 233-46-64
>
>> -------- Перенаправленное сообщение --------
>>
>> Тема: [FORUMS] Please test forums
>> Дата: Fri, 22 Jun 2018 12:18:39 -0700
>> От: Dave Fisher <[hidden email]>
>> Отвечать: [hidden email]
>> Кому: [hidden email]
>>
>> Hi -
>>
>> The new Forum VM is ready for testing at https://forum-test.openoffice.org/
>>
>> The data on this update to date to roughly Noon EDT. 17:00 UTC.
>>
>> Please make sure that you can do all the usual activity.
>>
>> If all goes well this phase of testing will end on Tuesday at Noon EDT.
>>
>> Regards,
>> Dave
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

FR web forum
In reply to this post by Dave Fisher
French forum has some rewriting rules.
Example:
https://forum.openoffice.org/fr/forum/ftopic35311.html
jump to
https://forum.openoffice.org/fr/forum/viewtopic.php?f=29&t=35311
These don't work anymmore.

----- Mail original -----

> De: "Dave Fisher" <[hidden email]>
> À: [hidden email]
> Envoyé: Vendredi 22 Juin 2018 21:18:39
> Objet: [FORUMS] Please test forums
>
> Hi -
>
>
> The new Forum VM is ready for testing at
> https://forum-test.openoffice.org/
>
>
> The data on this update to date to roughly Noon EDT. 17:00 UTC.
>
>
> Please make sure that you can do all the usual activity.
>
>
> If all goes well this phase of testing will end on Tuesday at Noon
> EDT.
>
>
> Regards,
> Dave

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Алексей Евгеньевич Харламенков
In reply to this post by Алексей Евгеньевич Харламенков
Dave! good afternoon.

Thank you for your reply.

I'm also a volunteer.
Earlier I actively participated in the project. I signed an agreement with SUN about the transfer of rights and my name was in OpenOffice.org 2.x-3.x About - CTRL + SDT: "Alexey Harlamenkov".

I created a wiki section: https://wiki.openoffice.org/wiki/RU
Wiki / RU rules are coordinated with wiki administrators: https://wiki.openoffice.org/wiki/RU/rules

I wrote "The philosophy of OpenOffice.org": https://wiki.openoffice.org/wiki/RU/kb/philosophy
Many years passed and I'm not ashamed of my work.

Now I again have time, which I can invest in the project.

My name is for some reason not on the list of volunteers: https://cwiki.apache.org/confluence/display/OOOUSERS/Directory+of+Volunteers

Can I recover as a full participant in the project? - What documents do I need to sign? What procedure?
How to register correctly on the forum? https://forum-test.openoffice.org OR https://forum.openoffice.org ?
Where can I read the rules?

My qualification: QA - Automated Testing, Manual Testing; Interoperability; User Support - forums, wiki, Tutorials, Training; Community Development; User; User Documentation - Author, Editor; Distribution; l10n (RU); Install.

Sincerely, Dr. h. c.,
Aleksey Evgenievich Harlamenkov

Email: [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Hagar Delest-2
Hi Aleksey,

The opening of a forum is not an easy thing. Basically we need to have a core team ready to perform the admin and moderation tasks required to prevent spam and sustain a good level of support to users.

I propose you register the English forum and open a discussion for that.

Regards
Hagar

Le 23/06/2018 à 16:08, Алексей Евгеньевич Харламенков a écrit :

> Dave! good afternoon.
>
> Thank you for your reply.
>
> I'm also a volunteer.
> Earlier I actively participated in the project. I signed an agreement with SUN about the transfer of rights and my name was in OpenOffice.org 2.x-3.x About - CTRL + SDT: "Alexey Harlamenkov".
>
> I created a wiki section: https://wiki.openoffice.org/wiki/RU
> Wiki / RU rules are coordinated with wiki administrators: https://wiki.openoffice.org/wiki/RU/rules
>
> I wrote "The philosophy of OpenOffice.org": https://wiki.openoffice.org/wiki/RU/kb/philosophy
> Many years passed and I'm not ashamed of my work.
>
> Now I again have time, which I can invest in the project.
>
> My name is for some reason not on the list of volunteers: https://cwiki.apache.org/confluence/display/OOOUSERS/Directory+of+Volunteers
>
> Can I recover as a full participant in the project? - What documents do I need to sign? What procedure?
> How to register correctly on the forum? https://forum-test.openoffice.org OR https://forum.openoffice.org ?
> Where can I read the rules?
>
> My qualification: QA - Automated Testing, Manual Testing; Interoperability; User Support - forums, wiki, Tutorials, Training; Community Development; User; User Documentation - Author, Editor; Distribution; l10n (RU); Install.
>
> Sincerely, Dr. h. c.,
> Aleksey Evgenievich Harlamenkov
>
> Email: [hidden email]
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Hagar Delest-2
In reply to this post by Dave Fisher
Hi,

Le 23/06/2018 à 00:06, Dave Fisher a écrit :
> It looks like the posts with missing content have quote callouts. I’ll have to dig into these.
Indeed, good catch.
The [quote] and [code] BBCode have the same effect.
The [edit] and [rel] BBCode do not show up but they do not blank the whole post.
BBCode for bold works fine.

>> I can't submit posts, perhaps it's linked, I get the blank message area with the error message: "Your message contains too few characters." Maybe the test database is read only.
>
> I did an mysqldump and then ran the sql on the new sql server. I’ll need to dig. It could be a version issue PHP and MySQL are upgraded. I may have to jump on the upgrade to phpBB as this could be related.
>
PHP version looks still quite old in the admin panel of the test forum.


> If you cn try to see if the other forums work that would be great.
I can't but I've sent a global message to all the Native Language admins, asking them to test their board and report any problem to the dev list.

Regards,
Hagar

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Алексей Евгеньевич Харламенков
In reply to this post by Алексей Евгеньевич Харламенков
I registered.

My nickname: a.harlamenkov

In which section of the forum is it correct to open a topic about the opening of the Russian forum?

Sincerely, Dr. h. c.,
Alexey Evgenievich Kharlamenkov

Email: [hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Алексей Евгеньевич Харламенков
Hi Hagar,

> Basically we need to have the core team ready to perform the admin and moderation tasks necessary to prevent spam and sustain a good level of support to users.

It was these duties that I carried out for 6 years in the Russian forum. At the same time I worked with the wiki.


Sincerely, Dr. h. c.,
Alexey Evgenievich Harlamenkov

Email: [hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Hagar Delest-2
In reply to this post by Алексей Евгеньевич Харламенков
Hi,

You can ask for that in this part of the forum: https://forum.openoffice.org/en/forum/viewforum.php?f=102
I've tweaked your account, you should be able to post directly.

Hagar

Le 23/06/2018 à 17:55, Алексей Евгеньевич Харламенков a écrit :

> I registered.
>
> My nickname: a.harlamenkov
>
> In which section of the forum is it correct to open a topic about the opening of the Russian forum?
>
> Sincerely, Dr. h. c.,
> Alexey Evgenievich Kharlamenkov
>
> Email: [hidden email]
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Алексей Евгеньевич Харламенков
In reply to this post by Алексей Евгеньевич Харламенков
Hi Hagar,

> You can ask for that in this part of the forum:
> https://forum.openoffice.org/en/forum/viewforum.php?f=102


On your advice I created a theme: https://forum.openoffice.org/en/forum/viewtopic.php?f=102&t=94050

I understand the difficulties of opening a new forum while updating the software. Therefore, I ask you to consider this issue after the update.


Sincerely, Dr. h. c.,
Aleksey Evgenievich Harlamenkov

Email: [hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Dave Fisher
In reply to this post by Hagar Delest-2
Hi -

Sent from my iPhone

> On Jun 23, 2018, at 7:48 AM, Hagar Delest <[hidden email]> wrote:
>
> Hi,
>
>> Le 23/06/2018 à 00:06, Dave Fisher a écrit :
>> It looks like the posts with missing content have quote callouts. I’ll have to dig into these.
> Indeed, good catch.
> The [quote] and [code] BBCode have the same effect.
> The [edit] and [rel] BBCode do not show up but they do not blank the whole post.
> BBCode for bold works fine.

I am inclined to consider these to be due to code deprecated in php 7. I’ll try to confirm.  I’m inclined to upgrade phpBB to the latest, apply our customizations and retest.

>
>>> I can't submit posts, perhaps it's linked, I get the blank message area with the error message: "Your message contains too few characters." Maybe the test database is read only.
>>
>> I did an mysqldump and then ran the sql on the new sql server. I’ll need to dig. It could be a version issue PHP and MySQL are upgraded. I may have to jump on the upgrade to phpBB as this could be related.
>>
> PHP version looks still quite old in the admin panel of the test forum.

Exactly.

>
>
>> If you cn try to see if the other forums work that would be great.
> I can't but I've sent a global message to all the Native Language admins, asking them to test their board and report any problem to the dev list.

Thanks,
Dave

>
> Regards,
> Hagar
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Dave Fisher
In reply to this post by FR web forum
Hi -

Thanks for the report. We did put these into the server configuration We will investigate.

Regards,
Dave

Sent from my iPhone

> On Jun 23, 2018, at 1:35 AM, FR web forum <[hidden email]> wrote:
>
> French forum has some rewriting rules.
> Example:
> https://forum.openoffice.org/fr/forum/ftopic35311.html
> jump to
> https://forum.openoffice.org/fr/forum/viewtopic.php?f=29&t=35311
> These don't work anymmore.
>
> ----- Mail original -----
>> De: "Dave Fisher" <[hidden email]>
>> À: [hidden email]
>> Envoyé: Vendredi 22 Juin 2018 21:18:39
>> Objet: [FORUMS] Please test forums
>>
>> Hi -
>>
>>
>> The new Forum VM is ready for testing at
>> https://forum-test.openoffice.org/
>>
>>
>> The data on this update to date to roughly Noon EDT. 17:00 UTC.
>>
>>
>> Please make sure that you can do all the usual activity.
>>
>>
>> If all goes well this phase of testing will end on Tuesday at Noon
>> EDT.
>>
>>
>> Regards,
>> Dave
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Reizinger Zoltán
In reply to this post by Dave Fisher
Hi Dave,

I run some test, on HU forum. I tried to create new post. I meet same
isse as Hagar, can not post.

Allways get the error, independently from post text lenght:

Your message contains too few characters.

My tests were on HU and EN forum, same errors.

Thanks,
Zoltan


2018.06.22. 21:18 keltezéssel, Dave Fisher írta:

> Hi -
>
> The new Forum VM is ready for testing at
> https://forum-test.openoffice.org/
>
> The data on this update to date to roughly Noon EDT. 17:00 UTC.
>
> Please make sure that you can do all the usual activity.
>
> If all goes well this phase of testing will end on Tuesday at Noon EDT.
>
> Regards,
> Dave


Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Reizinger Zoltán
Hi Dave,
Another problems:

The filters on forums not working:
Go to "View your posts" try to filter it. The filters not working in HU,
EN forum
Zoltan

2018.06.25. 13:33 keltezéssel, Reizinger Zoltán írta:

> Hi Dave,
>
> I run some test, on HU forum. I tried to create new post. I meet same
> isse as Hagar, can not post.
>
> Allways get the error, independently from post text lenght:
>
> Your message contains too few characters.
>
> My tests were on HU and EN forum, same errors.
>
> Thanks,
> Zoltan
>
>
> 2018.06.22. 21:18 keltezéssel, Dave Fisher írta:
>> Hi -
>>
>> The new Forum VM is ready for testing at
>> https://forum-test.openoffice.org/
>>
>> The data on this update to date to roughly Noon EDT. 17:00 UTC.
>>
>> Please make sure that you can do all the usual activity.
>>
>> If all goes well this phase of testing will end on Tuesday at Noon EDT.
>>
>> Regards,
>> Dave
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Hagar Delest-2
I tried a search with "spell*" keyword and got the following error when display results as topics (works fine as posts), no author specified:
General Error
SQL ERROR [ mysqli ]

Expression #1 of ORDER BY clause is not in SELECT list, references column 'forumaoo_en.u.username_clean' which is not in SELECT list; this is incompatible with DISTINCT [3065]

SQL

SELECT DISTINCT SQL_CALC_FOUND_ROWS t.topic_id FROM phpbb_en_topics t, phpbb_en_users u, phpbb_en_posts p WHERE MATCH (p.post_subject, p.post_text) AGAINST ('+spell ' IN BOOLEAN MODE) AND u.user_id = t.topic_poster AND t.topic_id = p.topic_id ORDER BY u.username_clean ASC LIMIT 250

BACKTRACE

FILE: x1/var_lib_phpBB/com309/includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: x1/var_lib_phpBB/com309/includes/db/mysqli.php
LINE: 205
CALL: dbal_mysqli->sql_query()

FILE: x1/var_lib_phpBB/com309/includes/db/dbal.php
LINE: 170
CALL: dbal_mysqli->_sql_query_limit()

FILE: x1/var_lib_phpBB/com309/includes/search/fulltext_mysql.php
LINE: 472
CALL: dbal->sql_query_limit()

FILE: x1/var_lib_phpBB/com309/search.php
LINE: 508
CALL: fulltext_mysql->keyword_search()


If I add an author, I get a slightly different one:
General Error
SQL ERROR [ mysqli ]

Expression #1 of ORDER BY clause is not in SELECT list, references column 'forumaoo_en.u.username_clean' which is not in SELECT list; this is incompatible with DISTINCT [3065]

SQL

SELECT DISTINCT SQL_CALC_FOUND_ROWS t.topic_id FROM phpbb_en_topics t, phpbb_en_users u, phpbb_en_posts p WHERE MATCH (p.post_subject, p.post_text) AGAINST ('+spell* ' IN BOOLEAN MODE) AND u.user_id = t.topic_poster AND t.topic_id = p.topic_id AND p.forum_id NOT IN (5, 7, 8, 9, 10, 11, 12, 13, 18, 19, 20, 21, 25, 29, 30, 39, 40, 42, 44, 45, 47, 48, 49, 50, 51, 52, 53, 54, 60, 61, 62, 64, 66, 67, 68, 69, 70, 71, 73, 74, 75, 76, 82, 83, 84, 85, 87, 88, 90, 91, 93, 94, 95, 96, 97, 98, 99, 100, 102, 103, 104, 105, 106, 107) AND p.poster_id IN (62, 54431) ORDER BY u.username_clean ASC LIMIT 250

BACKTRACE

FILE: x1/var_lib_phpBB/com309/includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: x1/var_lib_phpBB/com309/includes/db/mysqli.php
LINE: 205
CALL: dbal_mysqli->sql_query()

FILE: x1/var_lib_phpBB/com309/includes/db/dbal.php
LINE: 170
CALL: dbal_mysqli->_sql_query_limit()

FILE: x1/var_lib_phpBB/com309/includes/search/fulltext_mysql.php
LINE: 472
CALL: dbal->sql_query_limit()

FILE: x1/var_lib_phpBB/com309/search.php
LINE: 508
CALL: fulltext_mysql->keyword_search()

Note: in both cases, the wildcard * leads to the same result.

Hagar

Le 25/06/2018 à 17:15, Reizinger Zoltán a écrit :

> Hi Dave,
> Another problems:
>
> The filters on forums not working:
> Go to "View your posts" try to filter it. The filters not working in HU, EN forum
> Zoltan
>
> 2018.06.25. 13:33 keltezéssel, Reizinger Zoltán írta:
>> Hi Dave,
>>
>> I run some test, on HU forum. I tried to create new post. I meet same isse as Hagar, can not post.
>>
>> Allways get the error, independently from post text lenght:
>>
>> Your message contains too few characters.
>>
>> My tests were on HU and EN forum, same errors.
>>
>> Thanks,
>> Zoltan
>>
>>
>> 2018.06.22. 21:18 keltezéssel, Dave Fisher írta:
>>> Hi -
>>>
>>> The new Forum VM is ready for testing at https://forum-test.openoffice.org/
>>>
>>> The data on this update to date to roughly Noon EDT. 17:00 UTC.
>>>
>>> Please make sure that you can do all the usual activity.
>>>
>>> If all goes well this phase of testing will end on Tuesday at Noon EDT.
>>>
>>> Regards,
>>> Dave
>>
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Hagar Delest-2
For the record, the custom search on the landing page works on the test forum (it is broken since a while on the current page).

Some other comments here also: https://forum.openoffice.org/en/forum/viewtopic.php?f=102&t=94047
Problem with special characters in the password and sorting no applied (seems to affect several features requiring a sorting).

Hagar

Le 25/06/2018 à 21:56, Hagar Delest a écrit :

> I tried a search with "spell*" keyword and got the following error when display results as topics (works fine as posts), no author specified:
> General Error
> SQL ERROR [ mysqli ]
>
> Expression #1 of ORDER BY clause is not in SELECT list, references column 'forumaoo_en.u.username_clean' which is not in SELECT list; this is incompatible with DISTINCT [3065]
>
> SQL
>
> SELECT DISTINCT SQL_CALC_FOUND_ROWS t.topic_id FROM phpbb_en_topics t, phpbb_en_users u, phpbb_en_posts p WHERE MATCH (p.post_subject, p.post_text) AGAINST ('+spell ' IN BOOLEAN MODE) AND u.user_id = t.topic_poster AND t.topic_id = p.topic_id ORDER BY u.username_clean ASC LIMIT 250
>
> BACKTRACE
>
> FILE: x1/var_lib_phpBB/com309/includes/db/mysqli.php
> LINE: 163
> CALL: dbal->sql_error()
>
> FILE: x1/var_lib_phpBB/com309/includes/db/mysqli.php
> LINE: 205
> CALL: dbal_mysqli->sql_query()
>
> FILE: x1/var_lib_phpBB/com309/includes/db/dbal.php
> LINE: 170
> CALL: dbal_mysqli->_sql_query_limit()
>
> FILE: x1/var_lib_phpBB/com309/includes/search/fulltext_mysql.php
> LINE: 472
> CALL: dbal->sql_query_limit()
>
> FILE: x1/var_lib_phpBB/com309/search.php
> LINE: 508
> CALL: fulltext_mysql->keyword_search()
>
>
> If I add an author, I get a slightly different one:
> General Error
> SQL ERROR [ mysqli ]
>
> Expression #1 of ORDER BY clause is not in SELECT list, references column 'forumaoo_en.u.username_clean' which is not in SELECT list; this is incompatible with DISTINCT [3065]
>
> SQL
>
> SELECT DISTINCT SQL_CALC_FOUND_ROWS t.topic_id FROM phpbb_en_topics t, phpbb_en_users u, phpbb_en_posts p WHERE MATCH (p.post_subject, p.post_text) AGAINST ('+spell* ' IN BOOLEAN MODE) AND u.user_id = t.topic_poster AND t.topic_id = p.topic_id AND p.forum_id NOT IN (5, 7, 8, 9, 10, 11, 12, 13, 18, 19, 20, 21, 25, 29, 30, 39, 40, 42, 44, 45, 47, 48, 49, 50, 51, 52, 53, 54, 60, 61, 62, 64, 66, 67, 68, 69, 70, 71, 73, 74, 75, 76, 82, 83, 84, 85, 87, 88, 90, 91, 93, 94, 95, 96, 97, 98, 99, 100, 102, 103, 104, 105, 106, 107) AND p.poster_id IN (62, 54431) ORDER BY u.username_clean ASC LIMIT 250
>
> BACKTRACE
>
> FILE: x1/var_lib_phpBB/com309/includes/db/mysqli.php
> LINE: 163
> CALL: dbal->sql_error()
>
> FILE: x1/var_lib_phpBB/com309/includes/db/mysqli.php
> LINE: 205
> CALL: dbal_mysqli->sql_query()
>
> FILE: x1/var_lib_phpBB/com309/includes/db/dbal.php
> LINE: 170
> CALL: dbal_mysqli->_sql_query_limit()
>
> FILE: x1/var_lib_phpBB/com309/includes/search/fulltext_mysql.php
> LINE: 472
> CALL: dbal->sql_query_limit()
>
> FILE: x1/var_lib_phpBB/com309/search.php
> LINE: 508
> CALL: fulltext_mysql->keyword_search()
>
> Note: in both cases, the wildcard * leads to the same result.
>
> Hagar
>
> Le 25/06/2018 à 17:15, Reizinger Zoltán a écrit :
>> Hi Dave,
>> Another problems:
>>
>> The filters on forums not working:
>> Go to "View your posts" try to filter it. The filters not working in HU, EN forum
>> Zoltan
>>
>> 2018.06.25. 13:33 keltezéssel, Reizinger Zoltán írta:
>>> Hi Dave,
>>>
>>> I run some test, on HU forum. I tried to create new post. I meet same isse as Hagar, can not post.
>>>
>>> Allways get the error, independently from post text lenght:
>>>
>>> Your message contains too few characters.
>>>
>>> My tests were on HU and EN forum, same errors.
>>>
>>> Thanks,
>>> Zoltan
>>>
>>>
>>> 2018.06.22. 21:18 keltezéssel, Dave Fisher írta:
>>>> Hi -
>>>>
>>>> The new Forum VM is ready for testing at https://forum-test.openoffice.org/
>>>>
>>>> The data on this update to date to roughly Noon EDT. 17:00 UTC.
>>>>
>>>> Please make sure that you can do all the usual activity.
>>>>
>>>> If all goes well this phase of testing will end on Tuesday at Noon EDT.
>>>>
>>>> Regards,
>>>> Dave
>>>
>>>
>>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [FORUMS] Please test forums

Hagar Delest-2
Hi,

Any news? I thought it would have been migrated last week.

Hagar

Le 27/06/2018 à 23:23, Hagar Delest a écrit :

> For the record, the custom search on the landing page works on the test forum (it is broken since a while on the current page).
>
> Some other comments here also: https://forum.openoffice.org/en/forum/viewtopic.php?f=102&t=94047
> Problem with special characters in the password and sorting no applied (seems to affect several features requiring a sorting).
>
> Hagar
>
> Le 25/06/2018 à 21:56, Hagar Delest a écrit :
>> I tried a search with "spell*" keyword and got the following error when display results as topics (works fine as posts), no author specified:
>> General Error
>> SQL ERROR [ mysqli ]
>>
>> Expression #1 of ORDER BY clause is not in SELECT list, references column 'forumaoo_en.u.username_clean' which is not in SELECT list; this is incompatible with DISTINCT [3065]
>>
>> SQL
>>
>> SELECT DISTINCT SQL_CALC_FOUND_ROWS t.topic_id FROM phpbb_en_topics t, phpbb_en_users u, phpbb_en_posts p WHERE MATCH (p.post_subject, p.post_text) AGAINST ('+spell ' IN BOOLEAN MODE) AND u.user_id = t.topic_poster AND t.topic_id = p.topic_id ORDER BY u.username_clean ASC LIMIT 250
>>
>> BACKTRACE
>>
>> FILE: x1/var_lib_phpBB/com309/includes/db/mysqli.php
>> LINE: 163
>> CALL: dbal->sql_error()
>>
>> FILE: x1/var_lib_phpBB/com309/includes/db/mysqli.php
>> LINE: 205
>> CALL: dbal_mysqli->sql_query()
>>
>> FILE: x1/var_lib_phpBB/com309/includes/db/dbal.php
>> LINE: 170
>> CALL: dbal_mysqli->_sql_query_limit()
>>
>> FILE: x1/var_lib_phpBB/com309/includes/search/fulltext_mysql.php
>> LINE: 472
>> CALL: dbal->sql_query_limit()
>>
>> FILE: x1/var_lib_phpBB/com309/search.php
>> LINE: 508
>> CALL: fulltext_mysql->keyword_search()
>>
>>
>> If I add an author, I get a slightly different one:
>> General Error
>> SQL ERROR [ mysqli ]
>>
>> Expression #1 of ORDER BY clause is not in SELECT list, references column 'forumaoo_en.u.username_clean' which is not in SELECT list; this is incompatible with DISTINCT [3065]
>>
>> SQL
>>
>> SELECT DISTINCT SQL_CALC_FOUND_ROWS t.topic_id FROM phpbb_en_topics t, phpbb_en_users u, phpbb_en_posts p WHERE MATCH (p.post_subject, p.post_text) AGAINST ('+spell* ' IN BOOLEAN MODE) AND u.user_id = t.topic_poster AND t.topic_id = p.topic_id AND p.forum_id NOT IN (5, 7, 8, 9, 10, 11, 12, 13, 18, 19, 20, 21, 25, 29, 30, 39, 40, 42, 44, 45, 47, 48, 49, 50, 51, 52, 53, 54, 60, 61, 62, 64, 66, 67, 68, 69, 70, 71, 73, 74, 75, 76, 82, 83, 84, 85, 87, 88, 90, 91, 93, 94, 95, 96, 97, 98, 99, 100, 102, 103, 104, 105, 106, 107) AND p.poster_id IN (62, 54431) ORDER BY u.username_clean ASC LIMIT 250
>>
>> BACKTRACE
>>
>> FILE: x1/var_lib_phpBB/com309/includes/db/mysqli.php
>> LINE: 163
>> CALL: dbal->sql_error()
>>
>> FILE: x1/var_lib_phpBB/com309/includes/db/mysqli.php
>> LINE: 205
>> CALL: dbal_mysqli->sql_query()
>>
>> FILE: x1/var_lib_phpBB/com309/includes/db/dbal.php
>> LINE: 170
>> CALL: dbal_mysqli->_sql_query_limit()
>>
>> FILE: x1/var_lib_phpBB/com309/includes/search/fulltext_mysql.php
>> LINE: 472
>> CALL: dbal->sql_query_limit()
>>
>> FILE: x1/var_lib_phpBB/com309/search.php
>> LINE: 508
>> CALL: fulltext_mysql->keyword_search()
>>
>> Note: in both cases, the wildcard * leads to the same result.
>>
>> Hagar
>>
>> Le 25/06/2018 à 17:15, Reizinger Zoltán a écrit :
>>> Hi Dave,
>>> Another problems:
>>>
>>> The filters on forums not working:
>>> Go to "View your posts" try to filter it. The filters not working in HU, EN forum
>>> Zoltan
>>>
>>> 2018.06.25. 13:33 keltezéssel, Reizinger Zoltán írta:
>>>> Hi Dave,
>>>>
>>>> I run some test, on HU forum. I tried to create new post. I meet same isse as Hagar, can not post.
>>>>
>>>> Allways get the error, independently from post text lenght:
>>>>
>>>> Your message contains too few characters.
>>>>
>>>> My tests were on HU and EN forum, same errors.
>>>>
>>>> Thanks,
>>>> Zoltan
>>>>
>>>>
>>>> 2018.06.22. 21:18 keltezéssel, Dave Fisher írta:
>>>>> Hi -
>>>>>
>>>>> The new Forum VM is ready for testing at https://forum-test.openoffice.org/
>>>>>
>>>>> The data on this update to date to roughly Noon EDT. 17:00 UTC.
>>>>>
>>>>> Please make sure that you can do all the usual activity.
>>>>>
>>>>> If all goes well this phase of testing will end on Tuesday at Noon EDT.
>>>>>
>>>>> Regards,
>>>>> Dave
>>>>
>>>>
>>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

12