Failing to build 4.1.4

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
19 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Failing to build 4.1.4

Patricia Shanahan
I checked out 4.1.4, and tried to build it, Windows 8.1. The build fails
right at the end. I'm attaching my configure parameters. Any tips for
how to fix this?

... unopkg.exe sync --verbose -env:UNO_JAVA_JFW_ENV_JREHOME=true 2>&1 | ...
... creating archive file ...
... cleaning the output tree ...
... removing directory /tmp/ooopackaging/i_553641496418124 ...
Error: ERROR: Could not move directory from /tmp/80p1ud64RK to
/tmp/80p1ud64RK_temp.55364

**************************************************
ERROR: ERROR: Could not move directory from /tmp/80p1ud64RK to
/tmp/80p1ud64RK_temp.55364
in function: rename_directory
**************************************************
in function: rename_directorystopping log at Fri Jun  2 08:45:53 2017
dmake:  Error code 255, while making 'openoffice_en-US.archive'

1 module(s):
         instsetoo_native
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making
/cygdrive/c/OpenOfficeDev/AOO414/main/instsetoo_native/util

When you have fixed the errors in that module you can resume the build
by running:

         build --all:instsetoo_native


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

run_configure.sh (876 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Matthias Seidel

Hi Patricia,

Although I can not help with this specific error I wonder that you can build with:

--with-epm-url="http://www.msweet.org/files/project2/epm-3.7-source.tar.gz"

That source is not existent any more and I had to change to:

--with-epm-url=https://sourceforge.net/projects/oooextras.mirror/files/epm-3.7.tar.gz

(See: https://wiki.openoffice.org/w/index.php?title=Documentation/Building_Guide_AOO )

Regards, Matthias


Am 02.06.2017 um 18:51 schrieb Patricia Shanahan:
I checked out 4.1.4, and tried to build it, Windows 8.1. The build fails right at the end. I'm attaching my configure parameters. Any tips for how to fix this?

... unopkg.exe sync --verbose -env:UNO_JAVA_JFW_ENV_JREHOME=true 2>&1 | ...
... creating archive file ...
... cleaning the output tree ...
... removing directory /tmp/ooopackaging/i_553641496418124 ...
Error: ERROR: Could not move directory from /tmp/80p1ud64RK to /tmp/80p1ud64RK_temp.55364

**************************************************
ERROR: ERROR: Could not move directory from /tmp/80p1ud64RK to /tmp/80p1ud64RK_temp.55364
in function: rename_directory
**************************************************
in function: rename_directorystopping log at Fri Jun  2 08:45:53 2017
dmake:  Error code 255, while making 'openoffice_en-US.archive'

1 module(s):
        instsetoo_native
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making /cygdrive/c/OpenOfficeDev/AOO414/main/instsetoo_native/util

When you have fixed the errors in that module you can resume the build by running:

        build --all:instsetoo_native


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Patricia Shanahan
Thanks. I'll make that change and try again. Fixing any anomaly may help.

On 6/2/2017 10:22 AM, Matthias Seidel wrote:

> Hi Patricia,
>
> Although I can not help with this specific error I wonder that you can
> build with:
>
> --with-epm-url="http://www.msweet.org/files/project2/epm-3.7-source.tar.gz"
>
> That source is not existent any more and I had to change to:
>
> --with-epm-url=https://sourceforge.net/projects/oooextras.mirror/files/epm-3.7.tar.gz
>
> (See:
> https://wiki.openoffice.org/w/index.php?title=Documentation/Building_Guide_AOO
> )
>
> Regards, Matthias
>
>
> Am 02.06.2017 um 18:51 schrieb Patricia Shanahan:
>> I checked out 4.1.4, and tried to build it, Windows 8.1. The build
>> fails right at the end. I'm attaching my configure parameters. Any
>> tips for how to fix this?
>>
>> ... unopkg.exe sync --verbose -env:UNO_JAVA_JFW_ENV_JREHOME=true 2>&1
>> | ...
>> ... creating archive file ...
>> ... cleaning the output tree ...
>> ... removing directory /tmp/ooopackaging/i_553641496418124 ...
>> Error: ERROR: Could not move directory from /tmp/80p1ud64RK to
>> /tmp/80p1ud64RK_temp.55364
>>
>> **************************************************
>> ERROR: ERROR: Could not move directory from /tmp/80p1ud64RK to
>> /tmp/80p1ud64RK_temp.55364
>> in function: rename_directory
>> **************************************************
>> in function: rename_directorystopping log at Fri Jun  2 08:45:53 2017
>> dmake:  Error code 255, while making 'openoffice_en-US.archive'
>>
>> 1 module(s):
>>         instsetoo_native
>> need(s) to be rebuilt
>>
>> Reason(s):
>>
>> ERROR: error 65280 occurred while making
>> /cygdrive/c/OpenOfficeDev/AOO414/main/instsetoo_native/util
>>
>> When you have fixed the errors in that module you can resume the build
>> by running:
>>
>>         build --all:instsetoo_native
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Marcus (OOo)
In reply to this post by Patricia Shanahan
Am 02.06.2017 um 18:51 schrieb Patricia Shanahan:
> I checked out 4.1.4, and tried to build it, Windows 8.1. The build fails
> right at the end. I'm attaching my configure parameters. Any tips for
> how to fix this?

no real "hacker" solutions but some general questions:

- It's failing quit at the end (building the install files), so maybe
   the build options are no longer a problem.
- The same problem again after starting a complete new build?
- Also after you have cleaned-up everything?
- Enough disk space?

HTH

Marcus

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Patricia Shanahan
Thanks for the suggestions.

I am doing a clean build, but it takes a while on Windows 8.1. I have
441 GB of free space on the disk, so I don't think that is the problem.

On 6/2/2017 11:02 AM, Marcus wrote:

> Am 02.06.2017 um 18:51 schrieb Patricia Shanahan:
>> I checked out 4.1.4, and tried to build it, Windows 8.1. The build
>> fails right at the end. I'm attaching my configure parameters. Any
>> tips for how to fix this?
>
> no real "hacker" solutions but some general questions:
>
> - It's failing quit at the end (building the install files), so maybe
>   the build options are no longer a problem.
> - The same problem again after starting a complete new build?
> - Also after you have cleaned-up everything?
> - Enough disk space?
>
> HTH
>
> Marcus
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Patricia Shanahan
The new build, done clean and incorporating Matthias' suggested change,
completed successfully. Thanks again for the suggestions.

On 6/2/2017 11:20 AM, Patricia Shanahan wrote:

> Thanks for the suggestions.
>
> I am doing a clean build, but it takes a while on Windows 8.1. I have
> 441 GB of free space on the disk, so I don't think that is the problem.
>
> On 6/2/2017 11:02 AM, Marcus wrote:
>> Am 02.06.2017 um 18:51 schrieb Patricia Shanahan:
>>> I checked out 4.1.4, and tried to build it, Windows 8.1. The build
>>> fails right at the end. I'm attaching my configure parameters. Any
>>> tips for how to fix this?
>>
>> no real "hacker" solutions but some general questions:
>>
>> - It's failing quit at the end (building the install files), so maybe
>>   the build options are no longer a problem.
>> - The same problem again after starting a complete new build?
>> - Also after you have cleaned-up everything?
>> - Enough disk space?
>>
>> HTH
>>
>> Marcus
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Matthias Seidel
That sounds great!

I just finished a new build on Windows and was able to fix an (optical)
bug in the Japanese Installer... ;-)

Matthias


Am 03.06.2017 um 15:14 schrieb Patricia Shanahan:

> The new build, done clean and incorporating Matthias' suggested
> change, completed successfully. Thanks again for the suggestions.
>
> On 6/2/2017 11:20 AM, Patricia Shanahan wrote:
>> Thanks for the suggestions.
>>
>> I am doing a clean build, but it takes a while on Windows 8.1. I have
>> 441 GB of free space on the disk, so I don't think that is the problem.
>>
>> On 6/2/2017 11:02 AM, Marcus wrote:
>>> Am 02.06.2017 um 18:51 schrieb Patricia Shanahan:
>>>> I checked out 4.1.4, and tried to build it, Windows 8.1. The build
>>>> fails right at the end. I'm attaching my configure parameters. Any
>>>> tips for how to fix this?
>>>
>>> no real "hacker" solutions but some general questions:
>>>
>>> - It's failing quit at the end (building the install files), so maybe
>>>   the build options are no longer a problem.
>>> - The same problem again after starting a complete new build?
>>> - Also after you have cleaned-up everything?
>>> - Enough disk space?
>>>
>>> HTH
>>>
>>> Marcus
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Rory O'Farrell
On Sat, 3 Jun 2017 19:33:59 +0200
Matthias Seidel <[hidden email]> wrote:

> That sounds great!
>
> I just finished a new build on Windows and was able to fix an (optical)
> bug in the Japanese Installer... ;-)
>
> Matthias

For information, I have been using 4.1.4 for about a week, and at the level of my use (Text writing/editing/layout) of long book texts and simple Spreadsheet, it has behaved perfectly.
 
--
Rory O'Farrell <[hidden email]>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Raphael Bircher-3
Hi Rory

Am .06.2017, 19:43 Uhr, schrieb Rory O'Farrell <[hidden email]>:

> On Sat, 3 Jun 2017 19:33:59 +0200
> Matthias Seidel <[hidden email]> wrote:
>
>> That sounds great!
>>
>> I just finished a new build on Windows and was able to fix an (optical)
>> bug in the Japanese Installer... ;-)
>>
>> Matthias
>
> For information, I have been using 4.1.4 for about a week, and at the  
> level of my use (Text writing/editing/layout) of long book texts and  
> simple Spreadsheet, it has behaved perfectly.

Thanks a load for that feedback. On witch system you use Apache OpenOffice?

Regards, Raphael



--
My introduction https://youtu.be/Ln4vly5sxYU

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Rory O'Farrell
On Sat, 03 Jun 2017 20:45:10 +0200
"Raphael Bircher" <[hidden email]> wrote:

> Hi Rory
>
> Am .06.2017, 19:43 Uhr, schrieb Rory O'Farrell <[hidden email]>:
>
> > On Sat, 3 Jun 2017 19:33:59 +0200
> > Matthias Seidel <[hidden email]> wrote:
> >
> >> That sounds great!
> >>
> >> I just finished a new build on Windows and was able to fix an (optical)
> >> bug in the Japanese Installer... ;-)
> >>
> >> Matthias
> >
> > For information, I have been using 4.1.4 for about a week, and at the  
> > level of my use (Text writing/editing/layout) of long book texts and  
> > simple Spreadsheet, it has behaved perfectly.
>
> Thanks a load for that feedback. On witch system you use Apache OpenOffice?
>
> Regards, Raphael

I run on Xubuntu 16.04.02

--
Rory O'Farrell <[hidden email]>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Jim Jagielski
Cool! Is it a build you did yourself or one you downloaded from
somewhere?

tia

> On Jun 3, 2017, at 2:55 PM, Rory O'Farrell <[hidden email]> wrote:
>
> On Sat, 03 Jun 2017 20:45:10 +0200
> "Raphael Bircher" <[hidden email]> wrote:
>
>> Hi Rory
>>
>> Am .06.2017, 19:43 Uhr, schrieb Rory O'Farrell <[hidden email]>:
>>
>>> On Sat, 3 Jun 2017 19:33:59 +0200
>>> Matthias Seidel <[hidden email]> wrote:
>>>
>>>> That sounds great!
>>>>
>>>> I just finished a new build on Windows and was able to fix an (optical)
>>>> bug in the Japanese Installer... ;-)
>>>>
>>>> Matthias
>>>
>>> For information, I have been using 4.1.4 for about a week, and at the  
>>> level of my use (Text writing/editing/layout) of long book texts and  
>>> simple Spreadsheet, it has behaved perfectly.
>>
>> Thanks a load for that feedback. On witch system you use Apache OpenOffice?
>>
>> Regards, Raphael
>
> I run on Xubuntu 16.04.02
>
> --
> Rory O'Farrell <[hidden email]>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Rory O'Farrell
On Mon, 5 Jun 2017 07:44:32 -0400
Jim Jagielski <[hidden email]> wrote:

> Cool! Is it a build you did yourself or one you downloaded from
> somewhere?
>
> tia
> > On Jun 3, 2017, at 2:55 PM, Rory O'Farrell <[hidden email]> wrote:
> >
> > On Sat, 03 Jun 2017 20:45:10 +0200
> > "Raphael Bircher" <[hidden email]> wrote:
> >
> >> Hi Rory
> >>
> >> Am .06.2017, 19:43 Uhr, schrieb Rory O'Farrell <[hidden email]>:
> >>
> >>> On Sat, 3 Jun 2017 19:33:59 +0200
> >>> Matthias Seidel <[hidden email]> wrote:
> >>>
> >>>> That sounds great!
> >>>>
> >>>> I just finished a new build on Windows and was able to fix an (optical)
> >>>> bug in the Japanese Installer... ;-)
> >>>>
> >>>> Matthias
> >>>
> >>> For information, I have been using 4.1.4 for about a week, and at the  
> >>> level of my use (Text writing/editing/layout) of long book texts and  
> >>> simple Spreadsheet, it has behaved perfectly.
> >>
> >> Thanks a load for that feedback. On witch system you use Apache OpenOffice?
> >>
> >> Regards, Raphael
> >
> > I run on Xubuntu 16.04.02
> >
> > --
> > Rory O'Farrell <[hidden email]>

It was a download from the prebuilt en_US version for 64 bit linux (deb)

--
Rory O'Farrell <[hidden email]>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Andrea Pescetti-2
Rory O'Farrell wrote:
> It was a download from the prebuilt en_US version for 64 bit linux (deb)

Do you remember which one exactly? It's time to consolidate the QA effort.

I've removed my AOO414 branch builds (not 4.1.4, but "something on the
way to 4.1.4") from my home.apache.org space to avoid confusion, and
I'll be using Jim's builds as soon as they are available in Italian.

Let's make sure we are using Jim's build for testing. Of course, I
remain available for providing Linux builds at any time as a backup.

Regards,
   Andrea.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Rory O'Farrell
On Mon, 5 Jun 2017 18:03:25 +0200
Andrea Pescetti <[hidden email]> wrote:

> Rory O'Farrell wrote:
> > It was a download from the prebuilt en_US version for 64 bit linux (deb)
>
> Do you remember which one exactly? It's time to consolidate the QA effort.
>
> I've removed my AOO414 branch builds (not 4.1.4, but "something on the
> way to 4.1.4") from my home.apache.org space to avoid confusion, and
> I'll be using Jim's builds as soon as they are available in Italian.
>
> Let's make sure we are using Jim's build for testing. Of course, I
> remain available for providing Linux builds at any time as a backup.
>
> Regards,
>    Andrea.
>

The download URL was
https://ci.apache.org/projects/openoffice/install/41x/Apache_OpenOffice_4.1.4_Linux_x86-64_install-deb_en-US_2017-05-21_12%3A45%3A02_1795696.tar.gz

--
Rory O'Farrell <[hidden email]>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Matthias Seidel
Am 05.06.2017 um 18:21 schrieb Rory O'Farrell:

> On Mon, 5 Jun 2017 18:03:25 +0200
> Andrea Pescetti <[hidden email]> wrote:
>
>> Rory O'Farrell wrote:
>>> It was a download from the prebuilt en_US version for 64 bit linux (deb)
>> Do you remember which one exactly? It's time to consolidate the QA effort.
>>
>> I've removed my AOO414 branch builds (not 4.1.4, but "something on the
>> way to 4.1.4") from my home.apache.org space to avoid confusion, and
>> I'll be using Jim's builds as soon as they are available in Italian.
>>
>> Let's make sure we are using Jim's build for testing. Of course, I
>> remain available for providing Linux builds at any time as a backup.
>>
>> Regards,
>>    Andrea.
>>
> The download URL was
> https://ci.apache.org/projects/openoffice/install/41x/Apache_OpenOffice_4.1.4_Linux_x86-64_install-deb_en-US_2017-05-21_12%3A45%3A02_1795696.tar.gz
>
Hi Rory,

That is a (weekly) build from our builbot.
Although I found no problems while testing them, they are build on
Ubuntu 14.04 and might differ from Jim's builds.

I will switch to Jim's build as soon as there is a German version... ;-)

Regards, Matthias




smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Matthias Seidel
In reply to this post by Andrea Pescetti-2
Hi Andrea,

I was able to build AOO414 (branch) for Windows in several languages
together with the SDK.
But how to build language packs? Maybe I have missed a configure
switch... ;-)

BTW, I was able to fix a problem in the Chinese installer (in fact: ja,
ko, zh-CN, zh-TW) for Windows.

https://bz.apache.org/ooo/show_bug.cgi?id=92264

Kind regards, Matthias


Am 05.06.2017 um 18:03 schrieb Andrea Pescetti:

> Rory O'Farrell wrote:
>> It was a download from the prebuilt en_US version for 64 bit linux (deb)
>
> Do you remember which one exactly? It's time to consolidate the QA
> effort.
>
> I've removed my AOO414 branch builds (not 4.1.4, but "something on the
> way to 4.1.4") from my home.apache.org space to avoid confusion, and
> I'll be using Jim's builds as soon as they are available in Italian.
>
> Let's make sure we are using Jim's build for testing. Of course, I
> remain available for providing Linux builds at any time as a backup.
>
> Regards,
>   Andrea.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Marcus (OOo)
Am 06.06.2017 um 22:45 schrieb Matthias Seidel:
> But how to build language packs? Maybe I have missed a configure
> switch... ;-)

there is the "with-lang" switch in the build options that is used to
build the normal install sets *and* langpacks:

--with-lang="de en-US fr it"

To pack actually the langpacks use the following command:

dmake ooolanguagepack

See the official build script for a complete overview:
.../aoo/devtools/build-scripts/4.1.2/unxlngix6/build_aoo64bit_on_centos5.sh

IMHO for Windows it should be similar as the same build system is used.
But I'm not sure as I don't build on Windows. ;-)

HTH

Marcus



> Am 05.06.2017 um 18:03 schrieb Andrea Pescetti:
>> Rory O'Farrell wrote:
>>> It was a download from the prebuilt en_US version for 64 bit linux (deb)
>>
>> Do you remember which one exactly? It's time to consolidate the QA
>> effort.
>>
>> I've removed my AOO414 branch builds (not 4.1.4, but "something on the
>> way to 4.1.4") from my home.apache.org space to avoid confusion, and
>> I'll be using Jim's builds as soon as they are available in Italian.
>>
>> Let's make sure we are using Jim's build for testing. Of course, I
>> remain available for providing Linux builds at any time as a backup.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Matthias Seidel
Am 06.06.2017 um 23:41 schrieb Marcus:

> Am 06.06.2017 um 22:45 schrieb Matthias Seidel:
>> But how to build language packs? Maybe I have missed a configure
>> switch... ;-)
>
> there is the "with-lang" switch in the build options that is used to
> build the normal install sets *and* langpacks:
>
> --with-lang="de en-US fr it"
>
> To pack actually the langpacks use the following command:
>
> dmake ooolanguagepack
That may be the missing point...
As soon as my build is done I will try that! ;-)

Thanks a lot!

Matthias

>
> See the official build script for a complete overview:
> .../aoo/devtools/build-scripts/4.1.2/unxlngix6/build_aoo64bit_on_centos5.sh
>
>
> IMHO for Windows it should be similar as the same build system is
> used. But I'm not sure as I don't build on Windows. ;-)
>
> HTH
>
> Marcus
>
>
>
>> Am 05.06.2017 um 18:03 schrieb Andrea Pescetti:
>>> Rory O'Farrell wrote:
>>>> It was a download from the prebuilt en_US version for 64 bit linux
>>>> (deb)
>>>
>>> Do you remember which one exactly? It's time to consolidate the QA
>>> effort.
>>>
>>> I've removed my AOO414 branch builds (not 4.1.4, but "something on the
>>> way to 4.1.4") from my home.apache.org space to avoid confusion, and
>>> I'll be using Jim's builds as soon as they are available in Italian.
>>>
>>> Let's make sure we are using Jim's build for testing. Of course, I
>>> remain available for providing Linux builds at any time as a backup.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failing to build 4.1.4

Matthias Seidel
In reply to this post by Marcus (OOo)
Am 06.06.2017 um 23:41 schrieb Marcus:

> Am 06.06.2017 um 22:45 schrieb Matthias Seidel:
>> But how to build language packs? Maybe I have missed a configure
>> switch... ;-)
>
> there is the "with-lang" switch in the build options that is used to
> build the normal install sets *and* langpacks:
>
> --with-lang="de en-US fr it"
>
> To pack actually the langpacks use the following command:
>
> dmake ooolanguagepack
>
> See the official build script for a complete overview:
> .../aoo/devtools/build-scripts/4.1.2/unxlngix6/build_aoo64bit_on_centos5.sh
>
>
> IMHO for Windows it should be similar as the same build system is
> used. But I'm not sure as I don't build on Windows. ;-)
"dmake ooolanguagepack" does not seem to work, the language packs for
Windows are bundled with the NSIS installer.
Our Windows buildbots didn't create langpacks either, so it must be a
separate process...

Regards, Matthias

>
> HTH
>
> Marcus
>
>
>
>> Am 05.06.2017 um 18:03 schrieb Andrea Pescetti:
>>> Rory O'Farrell wrote:
>>>> It was a download from the prebuilt en_US version for 64 bit linux
>>>> (deb)
>>>
>>> Do you remember which one exactly? It's time to consolidate the QA
>>> effort.
>>>
>>> I've removed my AOO414 branch builds (not 4.1.4, but "something on the
>>> way to 4.1.4") from my home.apache.org space to avoid confusion, and
>>> I'll be using Jim's builds as soon as they are available in Italian.
>>>
>>> Let's make sure we are using Jim's build for testing. Of course, I
>>> remain available for providing Linux builds at any time as a backup.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


smime.p7s (4K) Download Attachment
Loading...