Font support

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Font support

Bill & Janet Washington
Hi Folks,

     I frequently print out some Persian (Farsi)
documents for some Persian friends, but Open
Office often does not play nice with the Farsi
font which is written right to left.

when I cut and paste the text into a Writer page
some text displays correctly, some displays as
blocks and some runs off the page.

Sometimes I can get the blocks to display
correctly by adding carriage returns or spaces,

For example try cutting and pasting a block of
text from this web page:

https://www.bible.com/bible/118/JHN.1.nmv

to a Writer Document.

This occurs with Open Office 4.1.5

When I cut and paste the same text into Word it
displays correctly - The only Font package
installed is "English"

Is it possible to correct this anomaly?

Best Regards

Bill Washington


Reply | Threaded
Open this post in threaded view
|

Re: Font support

Joost Andrae-2
Hi Bill,

if your system does support Persian input and if it supports Persian
fonts then you might want to configure Complex Text Layout in menu item
/Tools/Config/Language Support/Languages

If you activate the checkbox within this dialog for CTL then you can
select Persian language support. You probably have to restart OpenOffice
to activate the changes.

If you activate CTL then OpenOffice activates the support for RTL (right
to left) input schema, etc.

Kind regards, Joost

Am 07.01.2018 um 07:59 schrieb Bill & Janet Washington:

> Hi Folks,
>
>      I frequently print out some Persian (Farsi) documents for some
> Persian friends, but Open Office often does not play nice with the Farsi
> font which is written right to left.
>
> when I cut and paste the text into a Writer page some text displays
> correctly, some displays as blocks and some runs off the page.
>
> Sometimes I can get the blocks to display correctly by adding carriage
> returns or spaces,
>
> For example try cutting and pasting a block of text from this web page:
>
> https://www.bible.com/bible/118/JHN.1.nmv
>
> to a Writer Document.
>
> This occurs with Open Office 4.1.5
>
> When I cut and paste the same text into Word it displays correctly - The
> only Font package installed is "English"
>
> Is it possible to correct this anomaly?
>
> Best Regards
>
> Bill Washington
>
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]