Fwd: [Issue 121930] Tracking Issue for Spell Checking Not Working

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Fwd: [Issue 121930] Tracking Issue for Spell Checking Not Working

Peter Kovacs-2
This bug seems old.
Should we keep it around?

I don't know. What are the action point in this one?


-------- Ursprüngliche Nachricht --------
Von: [hidden email]
Gesendet: 13. Juni 2017 02:49:05 MESZ
An: [hidden email]
Betreff: [Issue 121930] Tracking Issue for Spell Checking Not Working

https://bz.apache.org/ooo/show_bug.cgi?id=121930

--- Comment #127 from Joe <[hidden email]> ---
This is one of the most useless “help” sites I have ever seen. And most of the
responses here are ridiculous. Aren't the developers here supposed to update
these programs when a bug is found?
I don't know about anybody else but my spellcheck just stops working. Twice. So
I just deleted the program and reinstalled it. Works fine. I didn't change any
directory names, didn't add any remotely related programs, have no detectable
virus, the spellcheck just stops working from what appears to be an internal
problem. So fix it. Jeez!

--
You are receiving this mail because:
You are the assignee for the issue.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Fwd: [Issue 121930] Tracking Issue for Spell Checking Not Working

Rory O'Farrell
On Tue, 13 Jun 2017 06:51:16 +0200
Peter Kovacs <[hidden email]> wrote:

> This bug seems old.
> Should we keep it around?
>
> I don't know. What are the action point in this one?
>

As far as I can tell, from advising on the Forum, most spellcheck problems arising from loss of spellcheck on a previously working system are due to over-hasty power off of the computer, without leaving time for the hardware write buffers (which are internal to the hard disk) to flush the User Profile to disk.  

On old (OOo) linux installations (circa Ubuntu 8.04) it was not unusual for a fresh OOo install to start with faulty spellcheck; the solution then, as now, was to delete the User Profile.  

We do not have detailed knowledge of how the users reporting faulty spellcheck on installation actually install their AOO; very frequently they try peculiar methods rather than simply double clicking the downloaded .exe file

Rory

>
> -------- Ursprüngliche Nachricht --------
> Von: [hidden email]
> Gesendet: 13. Juni 2017 02:49:05 MESZ
> An: [hidden email]
> Betreff: [Issue 121930] Tracking Issue for Spell Checking Not Working
>
> https://bz.apache.org/ooo/show_bug.cgi?id=121930
>
> --- Comment #127 from Joe <[hidden email]> ---
> This is one of the most useless “help” sites I have ever seen. And most of the
> responses here are ridiculous. Aren't the developers here supposed to update
> these programs when a bug is found?
> I don't know about anybody else but my spellcheck just stops working. Twice. So
> I just deleted the program and reinstalled it. Works fine. I didn't change any
> directory names, didn't add any remotely related programs, have no detectable
> virus, the spellcheck just stops working from what appears to be an internal
> problem. So fix it. Jeez!
>
> --
> You are receiving this mail because:
> You are the assignee for the issue.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Rory O'Farrell <[hidden email]>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Fwd: [Issue 121930] Tracking Issue for Spell Checking Not Working

Peter Kovacs-2
I see.
Do we say then we don't fix This?
Or should we look for an solution?

One idea could be, to see if we can manage the profile in a way if the profile got corrupted Open Office falls back to a default profile and tries to go from there.

Don't know how easy it is to implement, but it would be a action starting point

Am 13. Juni 2017 07:54:04 MESZ schrieb Rory O'Farrell <[hidden email]>:

>On Tue, 13 Jun 2017 06:51:16 +0200
>Peter Kovacs <[hidden email]> wrote:
>
>> This bug seems old.
>> Should we keep it around?
>>
>> I don't know. What are the action point in this one?
>>
>
>As far as I can tell, from advising on the Forum, most spellcheck
>problems arising from loss of spellcheck on a previously working system
>are due to over-hasty power off of the computer, without leaving time
>for the hardware write buffers (which are internal to the hard disk) to
>flush the User Profile to disk.  
>
>On old (OOo) linux installations (circa Ubuntu 8.04) it was not unusual
>for a fresh OOo install to start with faulty spellcheck; the solution
>then, as now, was to delete the User Profile.  
>
>We do not have detailed knowledge of how the users reporting faulty
>spellcheck on installation actually install their AOO; very frequently
>they try peculiar methods rather than simply double clicking the
>downloaded .exe file
>
>Rory
>
>>
>> -------- Ursprüngliche Nachricht --------
>> Von: [hidden email]
>> Gesendet: 13. Juni 2017 02:49:05 MESZ
>> An: [hidden email]
>> Betreff: [Issue 121930] Tracking Issue for Spell Checking Not Working
>>
>> https://bz.apache.org/ooo/show_bug.cgi?id=121930
>>
>> --- Comment #127 from Joe <[hidden email]> ---
>> This is one of the most useless “help” sites I have ever seen. And
>most of the
>> responses here are ridiculous. Aren't the developers here supposed to
>update
>> these programs when a bug is found?
>> I don't know about anybody else but my spellcheck just stops working.
>Twice. So
>> I just deleted the program and reinstalled it. Works fine. I didn't
>change any
>> directory names, didn't add any remotely related programs, have no
>detectable
>> virus, the spellcheck just stops working from what appears to be an
>internal
>> problem. So fix it. Jeez!
>>
>> --
>> You are receiving this mail because:
>> You are the assignee for the issue.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Fwd: [Issue 121930] Tracking Issue for Spell Checking Not Working

Andrea Pescetti-2
Peter Kovacs wrote:
> One idea could be, to see if we can manage the profile in a way if the profile got corrupted Open Office falls back to a default profile and tries to go from there.

The simplest way to approach the issue (since it is not reproducible in
general and, once fixed, does not come back even on the same system,
according to reports) is to provide an easy way to reset the user profile.

This can be done with a simple external tool that would simply
remove/rename the "user" folder within the ".openoffice" (or similar
name) folder. The tool would then be sent as a standard answer when the
issue is reported.

Next step might be to include a similar functionality in OpenOffice
itself through a menu item, like Tools - Reset Configuration or similar.

Someone might think that these are just workarounds, but we did have a
bug with profile migrations and that was fixed years ago - but still a
broken profile will remain broken. At the moment we don't have a common
way to reproduce the issue and I believe that the mitigation would be
more than enough.

Regards,
   Andrea.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Fwd: [Issue 121930] Tracking Issue for Spell Checking Not Working

Rory O'Farrell
On Tue, 13 Jun 2017 18:14:57 +0200
Andrea Pescetti <[hidden email]> wrote:

> Peter Kovacs wrote:
> > One idea could be, to see if we can manage the profile in a way if the profile got corrupted Open Office falls back to a default profile and tries to go from there.
>
> The simplest way to approach the issue (since it is not reproducible in
> general and, once fixed, does not come back even on the same system,
> according to reports) is to provide an easy way to reset the user profile.
>
> This can be done with a simple external tool that would simply
> remove/rename the "user" folder within the ".openoffice" (or similar
> name) folder. The tool would then be sent as a standard answer when the
> issue is reported.

"Rename" is best, as it allows customisation to be brought forward to the new User Profile (if User skills permit).

Rory

>
> Next step might be to include a similar functionality in OpenOffice
> itself through a menu item, like Tools - Reset Configuration or similar.
>
> Someone might think that these are just workarounds, but we did have a
> bug with profile migrations and that was fixed years ago - but still a
> broken profile will remain broken. At the moment we don't have a common
> way to reproduce the issue and I believe that the mitigation would be
> more than enough.
>
> Regards,
>    Andrea.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Rory O'Farrell <[hidden email]>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...