[GitHub] [openoffice] ardovm opened a new pull request #109: Allow boost::tr1 to build with Gcc version >= 7

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[GitHub] [openoffice] ardovm opened a new pull request #109: Allow boost::tr1 to build with Gcc version >= 7

GitBox

ardovm opened a new pull request #109:
URL: https://github.com/apache/openoffice/pull/109


   As already pointed out by [bug 127712](https://bz.apache.org/ooo/show_bug.cgi?id=127712), Gcc seems to have changed its behavior, with respect to filesystem paths, since Gcc 7.
   
   The Boost::tr1 libraries expect C++ standard library headers to be installed into paths that contain the full Gcc version (major.minor.patchlevel). This is may not happen since Gcc 7.
   
   This PR is aimed to allow compilation of current AOO sources on systems with Gcc version 7 or later, and C++ headers installed accordingly to the more recent standard. It was tested on openSUSE Leap 15.2 x86_64.


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
[hidden email]



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]