Help building AOO416 on Ubuntu 16.04

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Help building AOO416 on Ubuntu 16.04

Pedro Lino-3
Hi all


I have come across the first two problems:


1) E: Package 'openjdk-7-jdk' has no installation candidate

I installed openjdk-8 instead


2) The following packages have unmet dependencies:
libgstreamer-ocaml : Depends: ocaml-base-nox-4.02.3
Conflicts: libgstreamer-ocaml:i386 but 0.2.0-2build2 is to be installed
libgstreamer-ocaml:i386 : Conflicts: libgstreamer-ocaml but 0.2.0-2build2 is to be installed
libgstreamer-ocaml-dev : Depends: ocaml-nox-4.02.3
Depends: ocaml-findlib but it is not going to be installed
Conflicts: libgstreamer-ocaml-dev:i386 but 0.2.0-2build2 is to be installed
libgstreamer-ocaml-dev:i386 : Depends: ocaml-nox-4.02.3:i386
Depends: libgstreamer1.0-dev:i386 but it is not going to be installed
Depends: libgstreamer-plugins-base1.0-dev:i386 but it is not going to be installed
Conflicts: libgstreamer-ocaml-dev but 0.2.0-2build2 is to be installed
E: Unable to correct problems, you have held broken packages.


Help?

Is someone going to be online today on IRC or available for direct email? I think these newbie problems don't belong in the dev mailing list.


Regards,

Pedro
Reply | Threaded
Open this post in threaded view
|

Re: Help building AOO416 on Ubuntu 16.04

Gavin McDonald-3
Hi Pedro,


On Sun, Oct 14, 2018 at 8:25 PM Pedro Lino <[hidden email]> wrote:

> Hi all
>
>
> I have come across the first two problems:
>
>
> 1) E: Package 'openjdk-7-jdk' has no installation candidate
>
> I installed openjdk-8 instead
>
>
> 2) The following packages have unmet dependencies:
> libgstreamer-ocaml : Depends: ocaml-base-nox-4.02.3
> Conflicts: libgstreamer-ocaml:i386 but 0.2.0-2build2 is to be installed
> libgstreamer-ocaml:i386 : Conflicts: libgstreamer-ocaml but 0.2.0-2build2
> is to be installed
> libgstreamer-ocaml-dev : Depends: ocaml-nox-4.02.3
> Depends: ocaml-findlib but it is not going to be installed
> Conflicts: libgstreamer-ocaml-dev:i386 but 0.2.0-2build2 is to be installed
> libgstreamer-ocaml-dev:i386 : Depends: ocaml-nox-4.02.3:i386
> Depends: libgstreamer1.0-dev:i386 but it is not going to be installed
> Depends: libgstreamer-plugins-base1.0-dev:i386 but it is not going to be
> installed
> Conflicts: libgstreamer-ocaml-dev but 0.2.0-2build2 is to be installed
> E: Unable to correct problems, you have held broken packages.
>
>
> Help?
>

What build instructions have you been following so far?


> Is someone going to be online today on IRC or available for direct email?
> I think these newbie problems don't belong in the dev mailing list.
>

16.04 isnt in our build systems yet for openoffice, and so only a handful
of developers have been trying it so far.
With that said, I believe this list is the right place for such questions
so that those that follow can see the discussions in the
archives.

Gav...


>
> Regards,
>
> Pedro
>
Reply | Threaded
Open this post in threaded view
|

Re: Help building AOO416 on Ubuntu 16.04

Pedro Lino-3
Hi Gavin


> What build instructions have you been following so far?
>


https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step#Ubuntu_12.04

but checking the 14.04 changes if needed


>
>         > >         Is someone going to be online today on IRC or available for direct email? I think these newbie problems don't belong in the dev mailing list.
> >
> >     >
>     16.04 isnt in our build systems yet for openoffice, and so only a handful of developers have been trying it so far.
>     With that said, I believe this list is the right place for such questions so that those that follow can see the discussions in the
>     archives.
>

Yes, I am aware of that. But it was suggested in this mailing list that since 14.04 is EOL and 16.04 will be supported until 2021, this should be the next move.

Since I'm running 16.04 I volunteered to give it a run (my first time building binaries) and check what are the differences/obstacles compared to what is described for 12.04 and 14.04

If the people on the list are up to receiving newbie questions, I don't have any problem in showing publicly my ignorance :)


Best,

Pedro
Reply | Threaded
Open this post in threaded view
|

Re: Help building AOO416 on Ubuntu 16.04

Matthias Seidel
Hi Pedro,

Am 14.10.2018 um 12:21 schrieb Pedro Lino:
> Hi Gavin
>
>
>> What build instructions have you been following so far?
>>
>
> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step#Ubuntu_12.04
>
> but checking the 14.04 changes if needed

I think I managed it with these instructions. But ignored most of the
warnings, as they are fixed already (either in Ubuntu or in AOO branch).

>
>
>>         > >         Is someone going to be online today on IRC or available for direct email? I think these newbie problems don't belong in the dev mailing list.
>>>     >
>>     16.04 isnt in our build systems yet for openoffice, and so only a handful of developers have been trying it so far.
>>     With that said, I believe this list is the right place for such questions so that those that follow can see the discussions in the
>>     archives.
>>
> Yes, I am aware of that. But it was suggested in this mailing list that since 14.04 is EOL and 16.04 will be supported until 2021, this should be the next move.

14.04 is still supported until 2019 (5 years for an LTS).
But 16.04 would be the next step.

Regards,
   Matthias

>
> Since I'm running 16.04 I volunteered to give it a run (my first time building binaries) and check what are the differences/obstacles compared to what is described for 12.04 and 14.04
>
> If the people on the list are up to receiving newbie questions, I don't have any problem in showing publicly my ignorance :)
>
>
> Best,
>
> Pedro
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Help building AOO416 on Ubuntu 16.04

Matthias Seidel
In reply to this post by Pedro Lino-3
Hi Pedro,

Am 14.10.2018 um 11:25 schrieb Pedro Lino:
> Hi all
>
>
> I have come across the first two problems:
>
>
> 1) E: Package 'openjdk-7-jdk' has no installation candidate
>
> I installed openjdk-8 instead

JDK 8 is OK as long as you use --disable-odk in configure.
Hopefully we can get a patch into 4.1.6 that will allow us to build ODK
with Java 8.

Regards,
   Matthias

>
>
> 2) The following packages have unmet dependencies:
> libgstreamer-ocaml : Depends: ocaml-base-nox-4.02.3
> Conflicts: libgstreamer-ocaml:i386 but 0.2.0-2build2 is to be installed
> libgstreamer-ocaml:i386 : Conflicts: libgstreamer-ocaml but 0.2.0-2build2 is to be installed
> libgstreamer-ocaml-dev : Depends: ocaml-nox-4.02.3
> Depends: ocaml-findlib but it is not going to be installed
> Conflicts: libgstreamer-ocaml-dev:i386 but 0.2.0-2build2 is to be installed
> libgstreamer-ocaml-dev:i386 : Depends: ocaml-nox-4.02.3:i386
> Depends: libgstreamer1.0-dev:i386 but it is not going to be installed
> Depends: libgstreamer-plugins-base1.0-dev:i386 but it is not going to be installed
> Conflicts: libgstreamer-ocaml-dev but 0.2.0-2build2 is to be installed
> E: Unable to correct problems, you have held broken packages.
>
>
> Help?
>
> Is someone going to be online today on IRC or available for direct email? I think these newbie problems don't belong in the dev mailing list.
>
>
> Regards,
>
> Pedro
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Help building AOO416 on Ubuntu 16.04

Pedro Lino-3
In reply to this post by Matthias Seidel
Hi Matthias

> On October 14, 2018 at 11:34 AM Matthias Seidel <[hidden email] mailto:[hidden email] > wrote:
>
>     I think I managed it with these instructions. But ignored most of the
>     warnings, as they are fixed already (either in Ubuntu or in AOO branch).
>

Ok. So any instructions on how to solve the dependencies problems I run into?


>
>         > > Yes, I am aware of that. But it was suggested in this mailing list that since 14.04 is EOL and 16.04 will be supported until 2021, this should be the next move.
> >
> >     >     14.04 is still supported until 2019 (5 years for an LTS).
>     But 16.04 would be the next step.
>

Thank you for the correction.

I also manage a laptop running 18.04 so I can also try it at a later stage but I prefer to learn how to find/solve problems in my daily usage 16.04 machine.


Regards,

Pedro
Reply | Threaded
Open this post in threaded view
|

Re: Help building AOO416 on Ubuntu 16.04

Pedro Lino-3
In reply to this post by Matthias Seidel

> JDK 8 is OK as long as you use --disable-odk in configure.
>     Hopefully we can get a patch into 4.1.6 that will allow us to build ODK
>     with Java 8
>


Excellent! Thank you for confirming.

-disable-odk is included in the Step-by-step guide so that is what I will be using


Regards,

Pedro
Reply | Threaded
Open this post in threaded view
|

Re: Help building AOO416 on Ubuntu 16.04

Matthias Seidel
In reply to this post by Pedro Lino-3
Hi Pedro,

Am 14.10.2018 um 12:47 schrieb Pedro Lino:
> Hi Matthias
>
>> On October 14, 2018 at 11:34 AM Matthias Seidel <[hidden email] mailto:[hidden email] > wrote:
>>
>>     I think I managed it with these instructions. But ignored most of the
>>     warnings, as they are fixed already (either in Ubuntu or in AOO branch).
>>
> Ok. So any instructions on how to solve the dependencies problems I run into?

I still have a 16.04 VM, so I could try to set up an environment...
But I *think* I just never downgraded g++/gcc but took the provided one.

Regards,
   Matthias

>
>
>>         > > Yes, I am aware of that. But it was suggested in this mailing list that since 14.04 is EOL and 16.04 will be supported until 2021, this should be the next move.
>>>     >     14.04 is still supported until 2019 (5 years for an LTS).
>>     But 16.04 would be the next step.
>>
> Thank you for the correction.
>
> I also manage a laptop running 18.04 so I can also try it at a later stage but I prefer to learn how to find/solve problems in my daily usage 16.04 machine.
>
>
> Regards,
>
> Pedro
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Help building AOO416 on Ubuntu 16.04

Peter Kovacs-2
I have been able to build OpenOffice with latest gcc . That has been a while go before my Laptop migration.
You have to set the fix to the right standard and you might have to set some behaviour flags.
I check for my config and post it.

Am 14. Oktober 2018 14:49:26 MESZ schrieb Matthias Seidel <[hidden email]>:

>Hi Pedro,
>
>Am 14.10.2018 um 12:47 schrieb Pedro Lino:
>> Hi Matthias
>>
>>> On October 14, 2018 at 11:34 AM Matthias Seidel
><[hidden email] mailto:[hidden email] > wrote:
>>>
>>>     I think I managed it with these instructions. But ignored most
>of the
>>>     warnings, as they are fixed already (either in Ubuntu or in AOO
>branch).
>>>
>> Ok. So any instructions on how to solve the dependencies problems I
>run into?
>
>I still have a 16.04 VM, so I could try to set up an environment...
>But I *think* I just never downgraded g++/gcc but took the provided
>one.
>
>Regards,
>   Matthias
>
>>
>>
>>>         > > Yes, I am aware of that. But it was suggested in this
>mailing list that since 14.04 is EOL and 16.04 will be supported until
>2021, this should be the next move.
>>>>     >     14.04 is still supported until 2019 (5 years for an LTS).
>>>     But 16.04 would be the next step.
>>>
>> Thank you for the correction.
>>
>> I also manage a laptop running 18.04 so I can also try it at a later
>stage but I prefer to learn how to find/solve problems in my daily
>usage 16.04 machine.
>>
>>
>> Regards,
>>
>> Pedro
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]