Issue for 4.1.4 and MacOS

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
93 messages Options
12345
Reply | Threaded
Open this post in threaded view
|

Re: Issue for 4.1.4 and MacOS

Jim Jagielski
Copying here:

This is interesting...

When opening the Base file I get the following in /var/log/system.log:

596:Nov  3 10:29:19 Daves-MacBook-Pro soffice[70777]: assertion failed: 16G29: libxpc.dylib + 74307 [BF896DF0-D8E9-31A8-A4B3-01120BFEEE52]: 0x89
597:Nov  3 10:29:22 Daves-MacBook-Pro soffice[70777]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked

When I open the Base file with the original 4.1.4 from October 17 I only see:

598:Nov  3 10:31:40 Daves-MacBook-Pro soffice[70791]: assertion failed: 16G29: libxpc.dylib + 74307 [BF896DF0-D8E9-31A8-A4B3-01120BFEEE52]: 0x89



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Issue for 4.1.4 and MacOS

Jim Jagielski
I can't even imagine what in the build system would cause this situation
or how changes in the build system would do this.

Does someone know, off the top of their head, the process/code
flow which is being performed? I guess I could try to attach to
the soffice process and step through, but it would be nice to
have at least some prelim basic idea of where some useful
breakpoints should be set.

> On Nov 3, 2017, at 5:21 PM, Jim Jagielski <[hidden email]> wrote:
>
> Copying here:
>
> This is interesting...
>
> When opening the Base file I get the following in /var/log/system.log:
>
> 596:Nov  3 10:29:19 Daves-MacBook-Pro soffice[70777]: assertion failed: 16G29: libxpc.dylib + 74307 [BF896DF0-D8E9-31A8-A4B3-01120BFEEE52]: 0x89
> 597:Nov  3 10:29:22 Daves-MacBook-Pro soffice[70777]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked
>
> When I open the Base file with the original 4.1.4 from October 17 I only see:
>
> 598:Nov  3 10:31:40 Daves-MacBook-Pro soffice[70791]: assertion failed: 16G29: libxpc.dylib + 74307 [BF896DF0-D8E9-31A8-A4B3-01120BFEEE52]: 0x89
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Issue for 4.1.4 and MacOS

Dave Fisher
Hi Jim,

I did some googling of the error message. On this page may be a clue: https://discussions.apple.com/thread/7677685

I wonder if there is something with the internal SQL setup. I know we have developers who are working on variations and Base can handle alternatives.

I am going to try a few things like rebooting, etc, but I don’t have much time today. So I thought I’d share my suspicions…

Here is another link with an idea from a similar error in VMWare Fusion: https://www.reddit.com/r/vmware/comments/5n5723/internal_error_with_fusion_is_there_a_logfile_to/?st=j9n1owd1&sh=4eeb46f7

Regards,
Dave

> On Nov 4, 2017, at 2:02 PM, Jim Jagielski <[hidden email]> wrote:
>
> I can't even imagine what in the build system would cause this situation
> or how changes in the build system would do this.
>
> Does someone know, off the top of their head, the process/code
> flow which is being performed? I guess I could try to attach to
> the soffice process and step through, but it would be nice to
> have at least some prelim basic idea of where some useful
> breakpoints should be set.
>
>> On Nov 3, 2017, at 5:21 PM, Jim Jagielski <[hidden email]> wrote:
>>
>> Copying here:
>>
>> This is interesting...
>>
>> When opening the Base file I get the following in /var/log/system.log:
>>
>> 596:Nov  3 10:29:19 Daves-MacBook-Pro soffice[70777]: assertion failed: 16G29: libxpc.dylib + 74307 [BF896DF0-D8E9-31A8-A4B3-01120BFEEE52]: 0x89
>> 597:Nov  3 10:29:22 Daves-MacBook-Pro soffice[70777]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked
>>
>> When I open the Base file with the original 4.1.4 from October 17 I only see:
>>
>> 598:Nov  3 10:31:40 Daves-MacBook-Pro soffice[70791]: assertion failed: 16G29: libxpc.dylib + 74307 [BF896DF0-D8E9-31A8-A4B3-01120BFEEE52]: 0x89
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


signature.asc (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Issue for 4.1.4 and MacOS

Jim Jagielski
Reply | Threaded
Open this post in threaded view
|

Re: Issue for 4.1.4 and MacOS

Andrea Pescetti-2
Jim Jagielski wrote:
> I am wondering if this means/requires that the build machine
> MUST be running 10.12 (Sierra).

The original report https://bz.apache.org/ooo/show_bug.cgi?id=127580 
says that the Base bug happens with the new (20171101) builds but not
with the 4.1.4 builds released in October.

Both builds were done on the same system, right? Just with different
configuration options.

Regards,
   Andrea.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Issue for 4.1.4 and MacOS

Jim Jagielski
yep

> On Nov 5, 2017, at 5:49 PM, Andrea Pescetti <[hidden email]> wrote:
>
> Jim Jagielski wrote:
>> I am wondering if this means/requires that the build machine
>> MUST be running 10.12 (Sierra).
>
> The original report https://bz.apache.org/ooo/show_bug.cgi?id=127580 says that the Base bug happens with the new (20171101) builds but not with the 4.1.4 builds released in October.
>
> Both builds were done on the same system, right? Just with different configuration options.
>
> Regards,
>  Andrea.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Issue for 4.1.4 and MacOS

Jim Jagielski
In reply to this post by Jim Jagielski
Considering that it was the xml2/xslt libs that changed
between the version, I am focusing my attention on that.
The pervious version, that broke embedded charts but worked
with the table used/linked macOS's libs. This latest
version uses local libs; which looks to have fixed the
embedded chart but broke the table/sql.

I *think* that the macOS versions did not incorporate iconv,
whereas the local libs do. So I'm rebuilding xml2 with
'--without-iconv' to see if that resolve it.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Issue for 4.1.4 and MacOS

Jim Jagielski
A reminder of what I'm talking about:

    < LIBXML_CFLAGS='-I/usr/local/include/libxml2'
    ---
    > LIBXML_CFLAGS='-I/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/usr/include/libxml2'
    1289,1291c1326,1328
    < LIBXML_LIBS='-L/usr/local/lib -lxml2 -lz -lpthread -liconv -lm'
    < LIBXSLT_CFLAGS='-I/usr/local/include -I/usr/local/include/libxml2'
    < LIBXSLT_LIBS='-L/usr/local/lib -lxslt -lxml2'
    ---
    > LIBXML_LIBS='-L/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/usr/lib -lxml2 -lz -lpthread -licucore -lm'
    > LIBXSLT_CFLAGS='-I/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/usr/include -I/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/usr/include/libxml2'
    > LIBXSLT_LIBS='-L/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/usr/lib -lxslt -lxml2 -lz -lpthread -licucore -lm'


> On Nov 6, 2017, at 12:43 PM, Jim Jagielski <[hidden email]> wrote:
>
> Considering that it was the xml2/xslt libs that changed
> between the version, I am focusing my attention on that.
> The pervious version, that broke embedded charts but worked
> with the table used/linked macOS's libs. This latest
> version uses local libs; which looks to have fixed the
> embedded chart but broke the table/sql.
>
> I *think* that the macOS versions did not incorporate iconv,
> whereas the local libs do. So I'm rebuilding xml2 with
> '--without-iconv' to see if that resolve it.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Issue for 4.1.4 and MacOS

Jim Jagielski
Okey dokey... I *think* that having xml2 built w/ iconv was,
in fact, the issue. Double checking as we speak.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Issue for 4.1.4 and MacOS

Dave Fisher
Good news is that the Base issue is fixed.

Bad news is that the Charts saving issue has returned.

Sorry.

Regards,
Dave

> On Nov 6, 2017, at 12:27 PM, Jim Jagielski <[hidden email]> wrote:
>
> Okey dokey... I *think* that having xml2 built w/ iconv was,
> in fact, the issue. Double checking as we speak.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


signature.asc (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Issue for 4.1.4 and MacOS

Patricia Shanahan
There is something I've seen in the OpenOffice code that may be involved
in the silent failures to do something. For example,
main\xmloff\source\core\xmlexp.cxx, line 759:

                catch( com::sun::star::uno::Exception& )
                {
                }

This will hide any and all UNO exceptions thrown in anything called from
the corresponding try block, even with assertions enabled. I assume the
intent is that the problem has already been reported, but I don't think
it is really safe to relay on that.

Maybe scatter some breakpoints at places like that?

On 11/6/2017 2:12 PM, Dave Fisher wrote:

> Good news is that the Base issue is fixed.
>
> Bad news is that the Charts saving issue has returned.
>
> Sorry.
>
> Regards,
> Dave
>
>> On Nov 6, 2017, at 12:27 PM, Jim Jagielski <[hidden email]> wrote:
>>
>> Okey dokey... I *think* that having xml2 built w/ iconv was,
>> in fact, the issue. Double checking as we speak.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Issue for 4.1.4 and MacOS

Dave Fisher
Hi Jim,

I’m not seeing an improvement in the latest build you are now pushing to dist.

Base works. I still get the two system.log messages.

Charts are not saved even if I just do a save as.

I wonder if we also need the redland/raptor update that is in trunk. I can spare a few hours tomorrow to try building on my side if we can confirm a few things. Up to you. We can webex or something ..

Regards,
Dave

> On Nov 6, 2017, at 6:20 PM, Patricia Shanahan <[hidden email]> wrote:
>
> There is something I've seen in the OpenOffice code that may be involved in the silent failures to do something. For example, main\xmloff\source\core\xmlexp.cxx, line 759:
>
> catch( com::sun::star::uno::Exception& )
> {
> }
>
> This will hide any and all UNO exceptions thrown in anything called from the corresponding try block, even with assertions enabled. I assume the intent is that the problem has already been reported, but I don't think it is really safe to relay on that.
>
> Maybe scatter some breakpoints at places like that?
>
> On 11/6/2017 2:12 PM, Dave Fisher wrote:
>> Good news is that the Base issue is fixed.
>> Bad news is that the Charts saving issue has returned.
>> Sorry.
>> Regards,
>> Dave
>>> On Nov 6, 2017, at 12:27 PM, Jim Jagielski <[hidden email]> wrote:
>>>
>>> Okey dokey... I *think* that having xml2 built w/ iconv was,
>>> in fact, the issue. Double checking as we speak.
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


signature.asc (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Issue for 4.1.4 and MacOS

Larry Gusaas-4
In reply to this post by Dave Fisher
I got the same result as Dave.
Larry

On 2017-11-06, 4:12 PM Dave Fisher wrote:

> Good news is that the Base issue is fixed.
>
> Bad news is that the Charts saving issue has returned.
>
> Sorry.
>
> Regards,
> Dave
>
>> On Nov 6, 2017, at 12:27 PM, Jim Jagielski <[hidden email]> wrote:
>>
>> Okey dokey... I *think* that having xml2 built w/ iconv was,
>> in fact, the issue. Double checking as we speak.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
> __________
>


--
_________________________________

Larry I. Gusaas
Moose Jaw, Saskatchewan Canada
Website: http://larry-gusaas.com
"An artist is never ahead of his time but most people are far behind theirs." - Edgard Varese



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

12345