Issues w/ downloading ext sources from source forge on CentOS5 for 4.1.6

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Issues w/ downloading ext sources from source forge on CentOS5 for 4.1.6

Jim Jagielski
CentOS5 has a VERY old perl. The problem is that sometime between the release of AOO 4.1.5 and 4.1.6, Sourceforge has, from what I can see, moved to using LetsEncrypt and the download perl script now fails whenever it tries to download ext sources:

   downloading to /home/jim/src/asf/code/AOO416/ext_sources/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz.part
   download from http://sourceforge.net/projects/oooextras.mirror/files/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz failed (500 Can't connect to sourceforge.net:443)
    download failed

So currently, the 4.1.6 Linux builds, using our "official" community build platform, is broken.

My plan is to see if upgrading to a newer openssl and Perl solves this.



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Issues w/ downloading ext sources from source forge on CentOS5 for 4.1.6

Jim Jagielski
Confirmed that with a somewhat newer Perl (I'm using 5.14.3) and openssl 1.0.2p, the downloads go off w/o a hitch.

Build progressing as we speak.

> On Aug 31, 2018, at 11:55 AM, Jim Jagielski <[hidden email]> wrote:
>
> CentOS5 has a VERY old perl. The problem is that sometime between the release of AOO 4.1.5 and 4.1.6, Sourceforge has, from what I can see, moved to using LetsEncrypt and the download perl script now fails whenever it tries to download ext sources:
>
>   downloading to /home/jim/src/asf/code/AOO416/ext_sources/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz.part
>   download from http://sourceforge.net/projects/oooextras.mirror/files/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz failed (500 Can't connect to sourceforge.net:443)
>    download failed
>
> So currently, the 4.1.6 Linux builds, using our "official" community build platform, is broken.
>
> My plan is to see if upgrading to a newer openssl and Perl solves this.
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Issues w/ downloading ext sources from source forge on CentOS5 for 4.1.6

Matthias Seidel
FWIW,

the buildbots already produce 4.1.6 builds:
https://www.openoffice.org/download/devbuilds.html

Unfortunately the page is not updated because our CMS is broken (again).

Regards,

   Matthias


Am 31.08.2018 um 18:26 schrieb Jim Jagielski:

> Confirmed that with a somewhat newer Perl (I'm using 5.14.3) and openssl 1.0.2p, the downloads go off w/o a hitch.
>
> Build progressing as we speak.
>
>> On Aug 31, 2018, at 11:55 AM, Jim Jagielski <[hidden email]> wrote:
>>
>> CentOS5 has a VERY old perl. The problem is that sometime between the release of AOO 4.1.5 and 4.1.6, Sourceforge has, from what I can see, moved to using LetsEncrypt and the download perl script now fails whenever it tries to download ext sources:
>>
>>   downloading to /home/jim/src/asf/code/AOO416/ext_sources/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz.part
>>   download from http://sourceforge.net/projects/oooextras.mirror/files/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz failed (500 Can't connect to sourceforge.net:443)
>>    download failed
>>
>> So currently, the 4.1.6 Linux builds, using our "official" community build platform, is broken.
>>
>> My plan is to see if upgrading to a newer openssl and Perl solves this.
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Issues w/ downloading ext sources from source forge on CentOS5 for 4.1.6

Jim Jagielski
But the buildbots are not the platforms used to create the community builds...

> On Aug 31, 2018, at 12:31 PM, Matthias Seidel <[hidden email]> wrote:
>
> FWIW,
>
> the buildbots already produce 4.1.6 builds:
> https://www.openoffice.org/download/devbuilds.html
>
> Unfortunately the page is not updated because our CMS is broken (again).
>
> Regards,
>
>    Matthias
>
>
> Am 31.08.2018 um 18:26 schrieb Jim Jagielski:
>> Confirmed that with a somewhat newer Perl (I'm using 5.14.3) and openssl 1.0.2p, the downloads go off w/o a hitch.
>>
>> Build progressing as we speak.
>>
>>> On Aug 31, 2018, at 11:55 AM, Jim Jagielski <[hidden email]> wrote:
>>>
>>> CentOS5 has a VERY old perl. The problem is that sometime between the release of AOO 4.1.5 and 4.1.6, Sourceforge has, from what I can see, moved to using LetsEncrypt and the download perl script now fails whenever it tries to download ext sources:
>>>
>>>  downloading to /home/jim/src/asf/code/AOO416/ext_sources/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz.part
>>>  download from http://sourceforge.net/projects/oooextras.mirror/files/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz failed (500 Can't connect to sourceforge.net:443)
>>>   download failed
>>>
>>> So currently, the 4.1.6 Linux builds, using our "official" community build platform, is broken.
>>>
>>> My plan is to see if upgrading to a newer openssl and Perl solves this.
>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Issues w/ downloading ext sources from source forge on CentOS5 for 4.1.6

Matthias Seidel
Am 31.08.2018 um 19:35 schrieb Jim Jagielski:
> But the buildbots are not the platforms used to create the community builds...

I know.
But they are the first ones to discover a broken build.

>
>> On Aug 31, 2018, at 12:31 PM, Matthias Seidel <[hidden email]> wrote:
>>
>> FWIW,
>>
>> the buildbots already produce 4.1.6 builds:
>> https://www.openoffice.org/download/devbuilds.html
>>
>> Unfortunately the page is not updated because our CMS is broken (again).
>>
>> Regards,
>>
>>    Matthias
>>
>>
>> Am 31.08.2018 um 18:26 schrieb Jim Jagielski:
>>> Confirmed that with a somewhat newer Perl (I'm using 5.14.3) and openssl 1.0.2p, the downloads go off w/o a hitch.
>>>
>>> Build progressing as we speak.
>>>
>>>> On Aug 31, 2018, at 11:55 AM, Jim Jagielski <[hidden email]> wrote:
>>>>
>>>> CentOS5 has a VERY old perl. The problem is that sometime between the release of AOO 4.1.5 and 4.1.6, Sourceforge has, from what I can see, moved to using LetsEncrypt and the download perl script now fails whenever it tries to download ext sources:
>>>>
>>>>  downloading to /home/jim/src/asf/code/AOO416/ext_sources/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz.part
>>>>  download from http://sourceforge.net/projects/oooextras.mirror/files/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz failed (500 Can't connect to sourceforge.net:443)
>>>>   download failed
>>>>
>>>> So currently, the 4.1.6 Linux builds, using our "official" community build platform, is broken.
>>>>
>>>> My plan is to see if upgrading to a newer openssl and Perl solves this.
>>>>
>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Issues w/ downloading ext sources from source forge on CentOS5 for 4.1.6

Jim Jagielski
Not if they aren't using the exact same setup as the community builds :)

The buildbots are Ubuntu, iirc. The community build servers are CentOS5 (for 4.1.x)

> On Aug 31, 2018, at 1:37 PM, Matthias Seidel <[hidden email]> wrote:
>
> Am 31.08.2018 um 19:35 schrieb Jim Jagielski:
>> But the buildbots are not the platforms used to create the community builds...
>
> I know.
> But they are the first ones to discover a broken build.
>
>>
>>> On Aug 31, 2018, at 12:31 PM, Matthias Seidel <[hidden email]> wrote:
>>>
>>> FWIW,
>>>
>>> the buildbots already produce 4.1.6 builds:
>>> https://www.openoffice.org/download/devbuilds.html
>>>
>>> Unfortunately the page is not updated because our CMS is broken (again).
>>>
>>> Regards,
>>>
>>>   Matthias
>>>
>>>
>>> Am 31.08.2018 um 18:26 schrieb Jim Jagielski:
>>>> Confirmed that with a somewhat newer Perl (I'm using 5.14.3) and openssl 1.0.2p, the downloads go off w/o a hitch.
>>>>
>>>> Build progressing as we speak.
>>>>
>>>>> On Aug 31, 2018, at 11:55 AM, Jim Jagielski <[hidden email]> wrote:
>>>>>
>>>>> CentOS5 has a VERY old perl. The problem is that sometime between the release of AOO 4.1.5 and 4.1.6, Sourceforge has, from what I can see, moved to using LetsEncrypt and the download perl script now fails whenever it tries to download ext sources:
>>>>>
>>>>> downloading to /home/jim/src/asf/code/AOO416/ext_sources/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz.part
>>>>> download from http://sourceforge.net/projects/oooextras.mirror/files/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz failed (500 Can't connect to sourceforge.net:443)
>>>>>  download failed
>>>>>
>>>>> So currently, the 4.1.6 Linux builds, using our "official" community build platform, is broken.
>>>>>
>>>>> My plan is to see if upgrading to a newer openssl and Perl solves this.
>>>>>
>>>>>
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: [hidden email]
>>>>> For additional commands, e-mail: [hidden email]
>>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Issues w/ downloading ext sources from source forge on CentOS5 for 4.1.6

Matthias Seidel
Am 31.08.2018 um 19:40 schrieb Jim Jagielski:
> Not if they aren't using the exact same setup as the community builds :)
>
> The buildbots are Ubuntu, iirc. The community build servers are CentOS5 (for 4.1.x)

I know. Ubuntu 14.04 and Windows 10 to be exact.

Should we delete the buildbots now? ;-)

>
>> On Aug 31, 2018, at 1:37 PM, Matthias Seidel <[hidden email]> wrote:
>>
>> Am 31.08.2018 um 19:35 schrieb Jim Jagielski:
>>> But the buildbots are not the platforms used to create the community builds...
>> I know.
>> But they are the first ones to discover a broken build.
>>
>>>> On Aug 31, 2018, at 12:31 PM, Matthias Seidel <[hidden email]> wrote:
>>>>
>>>> FWIW,
>>>>
>>>> the buildbots already produce 4.1.6 builds:
>>>> https://www.openoffice.org/download/devbuilds.html
>>>>
>>>> Unfortunately the page is not updated because our CMS is broken (again).
>>>>
>>>> Regards,
>>>>
>>>>   Matthias
>>>>
>>>>
>>>> Am 31.08.2018 um 18:26 schrieb Jim Jagielski:
>>>>> Confirmed that with a somewhat newer Perl (I'm using 5.14.3) and openssl 1.0.2p, the downloads go off w/o a hitch.
>>>>>
>>>>> Build progressing as we speak.
>>>>>
>>>>>> On Aug 31, 2018, at 11:55 AM, Jim Jagielski <[hidden email]> wrote:
>>>>>>
>>>>>> CentOS5 has a VERY old perl. The problem is that sometime between the release of AOO 4.1.5 and 4.1.6, Sourceforge has, from what I can see, moved to using LetsEncrypt and the download perl script now fails whenever it tries to download ext sources:
>>>>>>
>>>>>> downloading to /home/jim/src/asf/code/AOO416/ext_sources/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz.part
>>>>>> download from http://sourceforge.net/projects/oooextras.mirror/files/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz failed (500 Can't connect to sourceforge.net:443)
>>>>>>  download failed
>>>>>>
>>>>>> So currently, the 4.1.6 Linux builds, using our "official" community build platform, is broken.
>>>>>>
>>>>>> My plan is to see if upgrading to a newer openssl and Perl solves this.
>>>>>>
>>>>>>
>>>>>>
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: [hidden email]
>>>>>> For additional commands, e-mail: [hidden email]
>>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: [hidden email]
>>>>> For additional commands, e-mail: [hidden email]
>>>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Issues w/ downloading ext sources from source forge on CentOS5 for 4.1.6

Jim Jagielski
LOL :)

> On Aug 31, 2018, at 1:42 PM, Matthias Seidel <[hidden email]> wrote:
>
> Am 31.08.2018 um 19:40 schrieb Jim Jagielski:
>> Not if they aren't using the exact same setup as the community builds :)
>>
>> The buildbots are Ubuntu, iirc. The community build servers are CentOS5 (for 4.1.x)
>
> I know. Ubuntu 14.04 and Windows 10 to be exact.
>
> Should we delete the buildbots now? ;-)
>
>>
>>> On Aug 31, 2018, at 1:37 PM, Matthias Seidel <[hidden email]> wrote:
>>>
>>> Am 31.08.2018 um 19:35 schrieb Jim Jagielski:
>>>> But the buildbots are not the platforms used to create the community builds...
>>> I know.
>>> But they are the first ones to discover a broken build.
>>>
>>>>> On Aug 31, 2018, at 12:31 PM, Matthias Seidel <[hidden email]> wrote:
>>>>>
>>>>> FWIW,
>>>>>
>>>>> the buildbots already produce 4.1.6 builds:
>>>>> https://www.openoffice.org/download/devbuilds.html
>>>>>
>>>>> Unfortunately the page is not updated because our CMS is broken (again).
>>>>>
>>>>> Regards,
>>>>>
>>>>>  Matthias
>>>>>
>>>>>
>>>>> Am 31.08.2018 um 18:26 schrieb Jim Jagielski:
>>>>>> Confirmed that with a somewhat newer Perl (I'm using 5.14.3) and openssl 1.0.2p, the downloads go off w/o a hitch.
>>>>>>
>>>>>> Build progressing as we speak.
>>>>>>
>>>>>>> On Aug 31, 2018, at 11:55 AM, Jim Jagielski <[hidden email]> wrote:
>>>>>>>
>>>>>>> CentOS5 has a VERY old perl. The problem is that sometime between the release of AOO 4.1.5 and 4.1.6, Sourceforge has, from what I can see, moved to using LetsEncrypt and the download perl script now fails whenever it tries to download ext sources:
>>>>>>>
>>>>>>> downloading to /home/jim/src/asf/code/AOO416/ext_sources/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz.part
>>>>>>> download from http://sourceforge.net/projects/oooextras.mirror/files/ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz failed (500 Can't connect to sourceforge.net:443)
>>>>>>> download failed
>>>>>>>
>>>>>>> So currently, the 4.1.6 Linux builds, using our "official" community build platform, is broken.
>>>>>>>
>>>>>>> My plan is to see if upgrading to a newer openssl and Perl solves this.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> ---------------------------------------------------------------------
>>>>>>> To unsubscribe, e-mail: [hidden email]
>>>>>>> For additional commands, e-mail: [hidden email]
>>>>>>>
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: [hidden email]
>>>>>> For additional commands, e-mail: [hidden email]
>>>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
>> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>