JRE'S installation

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

JRE'S installation

duyunfen-4
Hi,Joachim

Thanks for your answer!

I find that the question is jre hadn't been installed when I install openoffice. that
is when I install openoffice,jre was no installed.but it had been surely packaged.the
code I downloaded and built was oo2.4.

why it was no installed? Is there anywhere or some parameter need to modified?

Best Regards.

duyunfen
Reply | Threaded
Open this post in threaded view
|

Re: JRE'S installation

Joachim Lingner - Sun Germany Software Engineer - ham02 - Hamburg
duyunfen schrieb:
> Hi,Joachim
>
> Thanks for your answer!
>
> I find that the question is jre hadn't been installed when I install openoffice. that
> is when I install openoffice,jre was no installed.

Ok, I misunderstood.

but it had been surely packaged.the
> code I downloaded and built was oo2.4.
>
> why it was no installed? Is there anywhere or some parameter need to modified?

I cannot answer that :(


Joachim
>
> Best Regards.
>
> duyunfen

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: JRE'S installation

Rüdiger Timm
In reply to this post by duyunfen-4


duyunfen wrote:
> Hi,Joachim
>
> Thanks for your answer!
>
> I find that the question is jre hadn't been installed when I install openoffice. that
> is when I install openoffice,jre was no installed.but it had been surely packaged.the
> code I downloaded and built was oo2.4.

Hi!

What makes you sure that jre has been packed into your OOo install set?
AFAIK sources for jre are not included in OOo sources. What command have
you called to build? What did your install set got built to (directory
name), instsetoo_native\wntmsci12.pro\OpenOffice or
instsetoo_native\wntmsci12.pro\OpenOffice_wJRE

Ruediger

>
> why it was no installed? Is there anywhere or some parameter need to modified?
>
> Best Regards.
>
> duyunfen
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: JRE'S installation

duyunfen-4
In reply to this post by duyunfen-4
Hi,all

My compile step was as follows:

1."dmake "under instsetoo_native.
2."dmake openofficewithjre"under instsetoo_native\util.In this step compile
 error.It tell me jre-6u4-windows-i586-p.exe can not been found,for details
 see the attached bmp please.
 Then I copy a jre-6u4-windows-i586-p.exe to solver\680\wntmsci10.pro\bin
(Is this solution right?). Then dmake success.
3. Install instsetoo_native\wntmsci10.pro\OpenOffice_wJRE. At the beginning
of the installation,the JRE's installational progress bar  didn't show.After
the installation completed, I found jre-6u4-windows-i586-p.exe was just
copied to C:\Program Files\OpenOffice.org 2.4\program,but jre was not
installed.

I want to dmake a version with jre,and during the installation process jre
can be auto installed.Who can give me some advice?

Thanks & Regards.
duyunfen
Reply | Threaded
Open this post in threaded view
|

Re: JRE'S installation

Ingo Schmidt
In reply to this post by duyunfen-4
Hi duyunfen,

> 2."dmake openofficewithjre"under instsetoo_native\util.In this step compile
>  error.It tell me jre-6u4-windows-i586-p.exe can not been found,for details
>  see the attached bmp please.
>  Then I copy a jre-6u4-windows-i586-p.exe to solver\680\wntmsci10.pro\bin
> (Is this solution right?). Then dmake success.

yes, that path is okay. It is only necessary that one of the include
pathes is used, that are defined in instsetoo_native/util/openoffice.lst
for each product.

> 3. Install instsetoo_native\wntmsci10.pro\OpenOffice_wJRE. At the beginning
> of the installation,the JRE's installational progress bar  didn't show.After
> the installation completed, I found jre-6u4-windows-i586-p.exe was just
> copied to C:\Program Files\OpenOffice.org 2.4\program,but jre was not
> installed.

Hm, this shoud work, as you described it. Did you do a special kind of
installation? In silent installations the JRE is never installed,
because it is part of InstallUISequence in msi table and not of
InstallExecuteSequence. But as you described, you did not do a silent
installation.
Did you select the module JRE below the "Optional Components" ? This is
deselectable in the installation.
One more idea: If the JRE is already installed, it will not be installed
once more. Therefore the Windows Registry is checked. If there is an
entry below

HKLM/Software/Javasoft/Java Runtime Environment/1.6.0_04

named "Javahome", then the module is automatically deselected during
installation process.

Regards

 Ingo



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]