Links Do Not Work in Calc

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Links Do Not Work in Calc

Vince@Gmail
AOO 4.1.5 on DELL desktop; WIN10 Home x64

_________________________________________________________


I don't know or understand how update Links, or update Styles, is
supposed to work in Calc.

Each time a Calc file is opened, I am prompted for a Yes/No to up date
All Links, or sometimes Y/N to update New Styles.

In an opened Calc file I have selected a cell and pointed to a specific
cell that is located in a different Calc file.

( e.g., entered in the cell:

=('file:///C:/Users/Username/Documents/...../....filename.ods'#$'sheetname...'.J79
).

This is no longer working in several Calc files ( "0" value is returned
rather than the expected value contained within the external file &
Cell). But, this /pointing to an external file's cell/ does work in a
New Calc file, when pointing to the same external file sheet & cell.

I hope that somebody can point me in the direction of or give me a
description of how this is suppose to work, and perhaps enlighten me on
the possibilities of why it is no longer working for several of my
existing Calc files.

In addition, I would appreciate receiving hints about the Update/Use Old
Styles template prompts.

TNX.


Regards,

VinceB.



Reply | Threaded
Open this post in threaded view
|

Re: Links Do Not Work in Calc

Brian Barker-2
At 13:01 29/09/2019 -0400, Vince Bonly wrote:
>AOO 4.1.5 on DELL desktop; WIN10 Home x64
>I don't know or understand how update Links, or update Styles, is
>supposed to work in Calc.

Warning: I'm not sure I do, either. But I may be able to help.

>Each time a Calc file is opened, I am prompted for a Yes/No to up
>date All Links, or sometimes Y/N to update New Styles.

Good-oh! That's helpful.

>In an opened Calc file I have selected a cell and pointed to a
>specific cell that is located in a different Calc file. ( e.g. ...)
>This is no longer working in several Calc files ("0" value is
>returned rather than the expected value contained within the
>external file & Cell). But, this /pointing to an external file's
>cell/ does work in a New Calc file, when pointing to the same
>external file sheet & cell. I hope that somebody can point me in the
>direction of or give me a description of how this is suppose to
>work, and perhaps enlighten me on the possibilities of why it is no
>longer working for several of my existing Calc files.

One idea: the target document needs to have been saved after any
changes before any values from it can be harvested in this way.

>In addition, I would appreciate receiving hints about the Update/Use
>Old Styles template prompts.

Not sure about these.

At 13:11 29/09/2019 -0400, Vince Bonly wrote:
>With a Calc file already opened, is it possible to update all links?

o There is a facility at Tools | Cell Content > | Recalculate (or F9)
which I imagine should do this, but I don't see that it does. I don't know why.

o There is a an additional "Recalculate Hard" facility at
Ctrl+Shift+F9, but I don't see that this operates as you might expect
either. You might like to try it.

o Here's a workaround:
  + Save the harvesting document if necessary, so as to preserve any changes.
  + Go to File | Reload. This will stimulate the interaction you see
when opening such a document file and give you the chance to say "Yes".

I suppose other possibilities are that your harvesting document has
somehow become corrupt or - more likely - that your link is no longer
accurate. Have you perhaps moved the target file, renamed a folder,
or renamed the target file itself, perhaps to correct a misspelling?
What happens if you re-create the link in the harvesting file from
scratch? It's best to do this by clicking on the target cell instead
of attempting to type the entire link, of course.

I trust this helps.

Brian Barker


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Links Do Not Work in Calc

Vince@Gmail
In reply to this post by Vince@Gmail

On 9/29/2019 2:12 PM, Brian Barker wrote:
>
> One idea: the target document needs to have been saved after any
> changes before any values from it can be harvested in this way.
>
>

That one idea hit the mark Brian!

When I returned to work on my Calc spreadsheets today, the problem was
not experienced. Then, when I made a change to one of my
/_external_/ref/source/ Calc files, (i.e., what you have called " the
target document") today, the problem was experienced again. After saving
my /_external_///ref/source/ file, closing AOO and reopening Calc, I was
able to "harvest" once again.  So, I must remember to save those files
before attempting to harvest data values from them.

Many thanks for your insight and sharing of your ideas.

Regards,
VinceB.