Minimum Ant version is now 1.9.1

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Minimum Ant version is now 1.9.1

Damjan Jovanovic
Hi

In porting main/jurt to gbuild in commits 1828636 and 1828638, I've ended
up doing considerable development in Ant, adding the ability to call IDL
tools (idlc, regmerge, javamaker) from Ant, and with the features I've
used, the minimum Ant version is now 1.9.1.

Please let me know if you have any problems.

Regards
Damjan
Reply | Threaded
Open this post in threaded view
|

Re: Minimum Ant version is now 1.9.1

Matthias Seidel
Hi Damjan,

Am 08.04.2018 um 14:59 schrieb Damjan Jovanovic:
> Hi
>
> In porting main/jurt to gbuild in commits 1828636 and 1828638, I've ended
> up doing considerable development in Ant, adding the ability to call IDL
> tools (idlc, regmerge, javamaker) from Ant, and with the features I've
> used, the minimum Ant version is now 1.9.1.
>
> Please let me know if you have any problems.

Hi Damjan,

Thank you for your work!

My Windows builds for trunk are done with Ant 1.10.3, so I don't expect
problems here.
However I will start a new build and will let you know... ;-)

(BTW: Windows BB is on 1.9.7 and both Linux BBs are on 1.9.3)

Regards,
   Matthias

>
> Regards
> Damjan
>



smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Minimum Ant version is now 1.9.1

Andrea Pescetti-2
In reply to this post by Damjan Jovanovic
Damjan Jovanovic wrote:
> the minimum Ant version is now 1.9.1.
> Please let me know if you have any problems.

We've used Ant 1.9.x for Linux builds as of (I believe) 4.1.3, so no
problem at all for me.

Regards,
   Andrea.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Minimum Ant version is now 1.9.1

Matthias Seidel
In reply to this post by Damjan Jovanovic
Hi,

Maybe we should set:

  ant_minver=1.7.0

in main/configure.ac to the new minimum version?

Regards,

   Matthias


Am 08.04.2018 um 14:59 schrieb Damjan Jovanovic:

> Hi
>
> In porting main/jurt to gbuild in commits 1828636 and 1828638, I've ended
> up doing considerable development in Ant, adding the ability to call IDL
> tools (idlc, regmerge, javamaker) from Ant, and with the features I've
> used, the minimum Ant version is now 1.9.1.
>
> Please let me know if you have any problems.
>
> Regards
> Damjan
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Minimum Ant version is now 1.9.1

Jim Jagielski
+1

> On Apr 10, 2018, at 7:20 AM, Matthias Seidel <[hidden email]> wrote:
>
> Hi,
>
> Maybe we should set:
>
>   ant_minver=1.7.0
>
> in main/configure.ac to the new minimum version?
>
> Regards,
>
>    Matthias
>
>
> Am 08.04.2018 um 14:59 schrieb Damjan Jovanovic:
>> Hi
>>
>> In porting main/jurt to gbuild in commits 1828636 and 1828638, I've ended
>> up doing considerable development in Ant, adding the ability to call IDL
>> tools (idlc, regmerge, javamaker) from Ant, and with the features I've
>> used, the minimum Ant version is now 1.9.1.
>>
>> Please let me know if you have any problems.
>>
>> Regards
>> Damjan
>>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Minimum Ant version is now 1.9.1

Jim Jagielski
In reply to this post by Damjan Jovanovic
No prob... I've been using at least that version on the Linux and macOS
builds for 4.1.x

> On Apr 8, 2018, at 8:59 AM, Damjan Jovanovic <[hidden email]> wrote:
>
> Hi
>
> In porting main/jurt to gbuild in commits 1828636 and 1828638, I've ended
> up doing considerable development in Ant, adding the ability to call IDL
> tools (idlc, regmerge, javamaker) from Ant, and with the features I've
> used, the minimum Ant version is now 1.9.1.
>
> Please let me know if you have any problems.
>
> Regards
> Damjan


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Minimum Ant version is now 1.9.1

Matthias Seidel
Am 10.04.2018 um 13:26 schrieb Jim Jagielski:
> No prob... I've been using at least that version on the Linux and macOS
> builds for 4.1.x

The same for the Windows builds.

It seems that the minimum Ant version was indeed 1.6.0 and only 1.7.0 if
MedaiWiki was enabled.

---
ant_minver=1.6.0
# update for more extensions...
if test "$ENABLE_MEDIAWIKI" = "YES"; then
  ant_minver=1.7.0
fi
---

But MediaWiki is broken anyway [1] and hopefully we can get it working
with a newer Ant?
That said, should we set both to 1.9.1?

Regards,

  Matthias

[1] https://bz.apache.org/ooo/show_bug.cgi?id=92492


>> On Apr 8, 2018, at 8:59 AM, Damjan Jovanovic <[hidden email]> wrote:
>>
>> Hi
>>
>> In porting main/jurt to gbuild in commits 1828636 and 1828638, I've ended
>> up doing considerable development in Ant, adding the ability to call IDL
>> tools (idlc, regmerge, javamaker) from Ant, and with the features I've
>> used, the minimum Ant version is now 1.9.1.
>>
>> Please let me know if you have any problems.
>>
>> Regards
>> Damjan
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Minimum Ant version is now 1.9.1

Damjan Jovanovic
In reply to this post by Matthias Seidel
I've also updated our Java policy wiki page with the new requirements:
https://wiki.openoffice.org/wiki/Policies/Java_Usage

On Tue, Apr 10, 2018 at 1:20 PM, Matthias Seidel <[hidden email]
> wrote:

> Hi,
>
> Maybe we should set:
>
>   ant_minver=1.7.0
>
> in main/configure.ac to the new minimum version?
>
> Regards,
>
>    Matthias
>
>
> Am 08.04.2018 um 14:59 schrieb Damjan Jovanovic:
> > Hi
> >
> > In porting main/jurt to gbuild in commits 1828636 and 1828638, I've ended
> > up doing considerable development in Ant, adding the ability to call IDL
> > tools (idlc, regmerge, javamaker) from Ant, and with the features I've
> > used, the minimum Ant version is now 1.9.1.
> >
> > Please let me know if you have any problems.
> >
> > Regards
> > Damjan
> >
>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Minimum Ant version is now 1.9.1

Matthias Seidel
Hi Damjan,

Am 10.04.2018 um 13:46 schrieb Damjan Jovanovic:
> I've also updated our Java policy wiki page with the new requirements:
> https://wiki.openoffice.org/wiki/Policies/Java_Usage

Is Java 1.7. a requirement of Ant >=1.9.1?

I thought you mentioned Java 1.6 at some point as minimum.
(Just asking and thinking of the OS/2 port)

Regards,
   Matthias

>
> On Tue, Apr 10, 2018 at 1:20 PM, Matthias Seidel <[hidden email]
>> wrote:
>> Hi,
>>
>> Maybe we should set:
>>
>>   ant_minver=1.7.0
>>
>> in main/configure.ac to the new minimum version?
>>
>> Regards,
>>
>>    Matthias
>>
>>
>> Am 08.04.2018 um 14:59 schrieb Damjan Jovanovic:
>>> Hi
>>>
>>> In porting main/jurt to gbuild in commits 1828636 and 1828638, I've ended
>>> up doing considerable development in Ant, adding the ability to call IDL
>>> tools (idlc, regmerge, javamaker) from Ant, and with the features I've
>>> used, the minimum Ant version is now 1.9.1.
>>>
>>> Please let me know if you have any problems.
>>>
>>> Regards
>>> Damjan
>>>
>>
>>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Minimum Ant version is now 1.9.1

Damjan Jovanovic
Ant 1.9.x only needs Java 1.5, but the code I've written for the SDBC-JDBC
bridge and PostgreSQL database driver needs Java 1.7.

On Sat, Apr 14, 2018 at 1:13 PM, Matthias Seidel <[hidden email]
> wrote:

> Hi Damjan,
>
> Am 10.04.2018 um 13:46 schrieb Damjan Jovanovic:
> > I've also updated our Java policy wiki page with the new requirements:
> > https://wiki.openoffice.org/wiki/Policies/Java_Usage
>
> Is Java 1.7. a requirement of Ant >=1.9.1?
>
> I thought you mentioned Java 1.6 at some point as minimum.
> (Just asking and thinking of the OS/2 port)
>
> Regards,
>    Matthias
>
> >
> > On Tue, Apr 10, 2018 at 1:20 PM, Matthias Seidel <
> [hidden email]
> >> wrote:
> >> Hi,
> >>
> >> Maybe we should set:
> >>
> >>   ant_minver=1.7.0
> >>
> >> in main/configure.ac to the new minimum version?
> >>
> >> Regards,
> >>
> >>    Matthias
> >>
> >>
> >> Am 08.04.2018 um 14:59 schrieb Damjan Jovanovic:
> >>> Hi
> >>>
> >>> In porting main/jurt to gbuild in commits 1828636 and 1828638, I've
> ended
> >>> up doing considerable development in Ant, adding the ability to call
> IDL
> >>> tools (idlc, regmerge, javamaker) from Ant, and with the features I've
> >>> used, the minimum Ant version is now 1.9.1.
> >>>
> >>> Please let me know if you have any problems.
> >>>
> >>> Regards
> >>> Damjan
> >>>
> >>
> >>
>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Minimum Ant version is now 1.9.1

Matthias Seidel
Am 15.04.2018 um 05:48 schrieb Damjan Jovanovic:
> Ant 1.9.x only needs Java 1.5, but the code I've written for the SDBC-JDBC
> bridge and PostgreSQL database driver needs Java 1.7.

Thanks for the clarification! ;-)

Matthias

>
> On Sat, Apr 14, 2018 at 1:13 PM, Matthias Seidel <[hidden email]
>> wrote:
>> Hi Damjan,
>>
>> Am 10.04.2018 um 13:46 schrieb Damjan Jovanovic:
>>> I've also updated our Java policy wiki page with the new requirements:
>>> https://wiki.openoffice.org/wiki/Policies/Java_Usage
>> Is Java 1.7. a requirement of Ant >=1.9.1?
>>
>> I thought you mentioned Java 1.6 at some point as minimum.
>> (Just asking and thinking of the OS/2 port)
>>
>> Regards,
>>    Matthias
>>
>>> On Tue, Apr 10, 2018 at 1:20 PM, Matthias Seidel <
>> [hidden email]
>>>> wrote:
>>>> Hi,
>>>>
>>>> Maybe we should set:
>>>>
>>>>   ant_minver=1.7.0
>>>>
>>>> in main/configure.ac to the new minimum version?
>>>>
>>>> Regards,
>>>>
>>>>    Matthias
>>>>
>>>>
>>>> Am 08.04.2018 um 14:59 schrieb Damjan Jovanovic:
>>>>> Hi
>>>>>
>>>>> In porting main/jurt to gbuild in commits 1828636 and 1828638, I've
>> ended
>>>>> up doing considerable development in Ant, adding the ability to call
>> IDL
>>>>> tools (idlc, regmerge, javamaker) from Ant, and with the features I've
>>>>> used, the minimum Ant version is now 1.9.1.
>>>>>
>>>>> Please let me know if you have any problems.
>>>>>
>>>>> Regards
>>>>> Damjan
>>>>>
>>>>
>>
>>


smime.p7s (5K) Download Attachment