Mozilla build tools version 3.0 are currently not compatible with AOO

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Mozilla build tools version 3.0 are currently not compatible with AOO

Don Lewis-2
The 3.0 version of the Mozilla build tools are not compatible with the
AOO build.  The organization of the installed files is different, which
makes configure think that the installation is incomplete.  I don't know
how easy this would be to fix, but the 2.x versions are smaller, so we
should probably just document that 2.2.0 or lower should be used.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Mozilla build tools version 3.0 are currently not compatible with AOO

Matthias Seidel
Am 15.08.2017 um 14:37 schrieb Don Lewis:
> The 3.0 version of the Mozilla build tools are not compatible with the
> AOO build.  The organization of the installed files is different, which
> makes configure think that the installation is incomplete.  I don't know
> how easy this would be to fix, but the 2.x versions are smaller, so we
> should probably just document that 2.2.0 or lower should be used.

I did that already in our Wiki:
https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step#Windows_7.2C_Windows_8.1.2C_Windows_10

Additionally from the release notes:

"Important changes since version 2.2.0:
   MozillaBuild now requires Windows 7+ 64-bit to install."

So now is the perfect time to migrate to a 64bit build environment.

>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>



smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Mozilla build tools version 3.0 are currently not compatible with AOO

Marcus (OOo)
In reply to this post by Don Lewis-2
Am 15.08.2017 um 14:37 schrieb Don Lewis:
> The 3.0 version of the Mozilla build tools are not compatible with the
> AOO build.  The organization of the installed files is different, which
> makes configure think that the installation is incomplete.  I don't know
> how easy this would be to fix, but the 2.x versions are smaller, so we
> should probably just document that 2.2.0 or lower should be used.

thanks for the hint. I've updated the following Wiki pages:

https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step

https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO

Marcus

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]