New flterbehavior for forms in 3.3

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

New flterbehavior for forms in 3.3

Peter Eberlein-3
Hi,

if a listbox in a form is linked to another table (foreign key relation)
and the content of the listbox is loaded with a select statement (no
subform), then the behavior in OpenOffice.org 3.3 is another one then in
OpenOffice 3.2.0:

If I click on the filter button on the form, in OpenOffice 3.3 the
filter navigator pops up and the listbox keeps its last value.

In OpenOffice 3.2 the listbox is empty and the fiter navigator is not
visible, which I find better.

Bug or feature?

Regards

Peter

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New flterbehavior for forms in 3.3

Frank Schönheit
Hi Peter,

> if a listbox in a form is linked to another table (foreign key relation)
> and the content of the listbox is loaded with a select statement (no
> subform), then the behavior in OpenOffice.org 3.3 is another one then in
> OpenOffice 3.2.0:
>
> If I click on the filter button on the form, in OpenOffice 3.3 the
> filter navigator pops up and the listbox keeps its last value.
>
> In OpenOffice 3.2 the listbox is empty and the fiter navigator is not
> visible, which I find better.
>
> Bug or feature?

I remember we fixed two bugs with list boxes and the form based filter
(114540, 114403), fixed in CWS dba34a. In the course of fixing those, we
also found other strange behaviors in this context, though I don't find
the issues right now. Maybe what you describe is one of those quirks.

In any way, you might want to try a recent developer snapshot to see if
the problem is fixed there.

Without further details, the "bug or feature" question is difficult to
answer. But as always - feel free to submit an issue.

Ciao
Frank

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New flterbehavior for forms in 3.3

Peter Eberlein-3
Hi Frank
Am 22.12.2010 13:45, schrieb Frank Schönheit:

> Hi Peter,
>
>> if a listbox in a form is linked to another table (foreign key relation)
>> and the content of the listbox is loaded with a select statement (no
>> subform), then the behavior in OpenOffice.org 3.3 is another one then in
>> OpenOffice 3.2.0:
>>
>> If I click on the filter button on the form, in OpenOffice 3.3 the
>> filter navigator pops up and the listbox keeps its last value.
>>
>> In OpenOffice 3.2 the listbox is empty and the fiter navigator is not
>> visible, which I find better.
>>
>> Bug or feature?
>
> I remember we fixed two bugs with list boxes and the form based filter
> (114540, 114403), fixed in CWS dba34a. In the course of fixing those, we
> also found other strange behaviors in this context, though I don't find
> the issues right now. Maybe what you describe is one of those quirks.
>
> In any way, you might want to try a recent developer snapshot to see if
> the problem is fixed there.
>
> Without further details, the "bug or feature" question is difficult to
> answer. But as always - feel free to submit an issue.
>
just tested m95:

a somewhat different behavior to 3.3rc7:
The filter navigator pops up, but in the navigator the last value of the
list box is no criteria anymore. Nevertheless the last result of the
select statement is visible in the list box, which I consider an issue.
The listbox should become empty in the standard form filter view, as it
was in 3.2. I will file an issue for that.

Regards and Merry Christmas

Peter

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New flterbehavior for forms in 3.3

Peter Eberlein-3
Am 22.12.2010 16:43, schrieb Peter Eberlein:
> Hi Frank
> Am 22.12.2010 13:45, schrieb Frank Schönheit:

>> Without further details, the "bug or feature" question is difficult to
>> answer. But as always - feel free to submit an issue.
>>
> just tested m95:
>
> a somewhat different behavior to 3.3rc7:
> The filter navigator pops up, but in the navigator the last value of the
> list box is no criteria anymore. Nevertheless the last result of the
> select statement is visible in the list box, which I consider an issue.
> The listbox should become empty in the standard form filter view, as it
> was in 3.2. I will file an issue for that.
>
http://qa.openoffice.org/issues/show_bug.cgi?id=116215

Peter


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]