OpenOffice Build Error

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenOffice Build Error

Nikhil Gupta
Hi everyone,
i am Nikhil from India. I am novice to open source as of now but really
interested to learn and contribute for this organization.
I have been trying to set up OpenOffice environment on my Ubuntu(14.04)
system. I am following the steps given on the official site.
https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step

I have completed all the build requirements that has been stated in this
page:
https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO

I build and installed dmake and epm by following source.
But when I runs ./bootstrap in main directory it says No such File or
directory

Do i have to manually download it or what to do.

I would be really very grateful, if I could get help in this. I am
totally stuck. I have tried lot many ways but couldn't resolve the
errors.

Thank you Team in anticipation!

Regards,
Nikhil
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice Build Error

Mechtilde Stehmann-2
Hello,

did you install

cd main

wget -O external/unowinreg/unowinreg.dll
http://tools.openoffice.org/unowinreg_prebuild/680/unowinreg.dll

which is one line

Kind regards

Am 25.01.19 um 18:54 schrieb Nikhil Gupta:

> Hi everyone,
> i am Nikhil from India. I am novice to open source as of now but really
> interested to learn and contribute for this organization.
> I have been trying to set up OpenOffice environment on my Ubuntu(14.04)
> system. I am following the steps given on the official site.
> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
>
> I have completed all the build requirements that has been stated in this
> page:
> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
>
> I build and installed dmake and epm by following source.
> But when I runs ./bootstrap in main directory it says No such File or
> directory
>
> Do i have to manually download it or what to do.
>
> I would be really very grateful, if I could get help in this. I am
> totally stuck. I have tried lot many ways but couldn't resolve the
> errors.
>
> Thank you Team in anticipation!
>
> Regards,
> Nikhil
>
--
Mechtilde Stehmann
## Apache OpenOffice
## Freie Office Suite für Linux, MacOSX, Windows
## Debian Developer
## PGP encryption welcome
## F0E3 7F3D C87A 4998 2899  39E7 F287 7BBA 141A AD7F


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice Build Error

Nikhil Gupta
Hi,

 Yes,I had already installed unowinreg.dll from the above mentioned source.
But the problem still remains.
Are there any log files generated when we build the OpenOffice.
So that we can check out where the problem occured.

On Fri, Jan 25, 2019 at 11:36 PM Mechtilde <[hidden email]> wrote:

> Hello,
>
> did you install
>
> cd main
>
> wget -O external/unowinreg/unowinreg.dll
> http://tools.openoffice.org/unowinreg_prebuild/680/unowinreg.dll
>
> which is one line
>
> Kind regards
>
> Am 25.01.19 um 18:54 schrieb Nikhil Gupta:
> > Hi everyone,
> > i am Nikhil from India. I am novice to open source as of now but really
> > interested to learn and contribute for this organization.
> > I have been trying to set up OpenOffice environment on my Ubuntu(14.04)
> > system. I am following the steps given on the official site.
> >
> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
> >
> > I have completed all the build requirements that has been stated in this
> > page:
> > https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
> >
> > I build and installed dmake and epm by following source.
> > But when I runs ./bootstrap in main directory it says No such File or
> > directory
> >
> > Do i have to manually download it or what to do.
> >
> > I would be really very grateful, if I could get help in this. I am
> > totally stuck. I have tried lot many ways but couldn't resolve the
> > errors.
> >
> > Thank you Team in anticipation!
> >
> > Regards,
> > Nikhil
> >
>
> --
> Mechtilde Stehmann
> ## Apache OpenOffice
> ## Freie Office Suite für Linux, MacOSX, Windows
> ## Debian Developer
> ## PGP encryption welcome
> ## F0E3 7F3D C87A 4998 2899  39E7 F287 7BBA 141A AD7F
>
>
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice Build Error

Marcus (OOo)
Am 25.01.19 um 19:27 schrieb Nikhil Gupta:
>   Yes,I had already installed unowinreg.dll from the above mentioned source.
> But the problem still remains.
> Are there any log files generated when we build the OpenOffice.
> So that we can check out where the problem occured.

I wonder that you are asking. When you start the build your screen
should be full of it. ;-)

It would be helpful when you can give us this output.

Marcus



> On Fri, Jan 25, 2019 at 11:36 PM Mechtilde <[hidden email]> wrote:
>
>> Hello,
>>
>> did you install
>>
>> cd main
>>
>> wget -O external/unowinreg/unowinreg.dll
>> http://tools.openoffice.org/unowinreg_prebuild/680/unowinreg.dll
>>
>> which is one line
>>
>> Kind regards
>>
>> Am 25.01.19 um 18:54 schrieb Nikhil Gupta:
>>> Hi everyone,
>>> i am Nikhil from India. I am novice to open source as of now but really
>>> interested to learn and contribute for this organization.
>>> I have been trying to set up OpenOffice environment on my Ubuntu(14.04)
>>> system. I am following the steps given on the official site.
>>>
>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
>>>
>>> I have completed all the build requirements that has been stated in this
>>> page:
>>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
>>>
>>> I build and installed dmake and epm by following source.
>>> But when I runs ./bootstrap in main directory it says No such File or
>>> directory
>>>
>>> Do i have to manually download it or what to do.
>>>
>>> I would be really very grateful, if I could get help in this. I am
>>> totally stuck. I have tried lot many ways but couldn't resolve the
>>> errors.
>>>
>>> Thank you Team in anticipation!
>>>
>>> Regards,
>>> Nikhil


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice Build Error

Peter Kovacs-3
In reply to this post by Nikhil Gupta
What was the output of configure?

On 25.01.19 19:27, Nikhil Gupta wrote:

> Hi,
>
>  Yes,I had already installed unowinreg.dll from the above mentioned source.
> But the problem still remains.
> Are there any log files generated when we build the OpenOffice.
> So that we can check out where the problem occured.
>
> On Fri, Jan 25, 2019 at 11:36 PM Mechtilde <[hidden email]> wrote:
>
>> Hello,
>>
>> did you install
>>
>> cd main
>>
>> wget -O external/unowinreg/unowinreg.dll
>> http://tools.openoffice.org/unowinreg_prebuild/680/unowinreg.dll
>>
>> which is one line
>>
>> Kind regards
>>
>> Am 25.01.19 um 18:54 schrieb Nikhil Gupta:
>>> Hi everyone,
>>> i am Nikhil from India. I am novice to open source as of now but really
>>> interested to learn and contribute for this organization.
>>> I have been trying to set up OpenOffice environment on my Ubuntu(14.04)
>>> system. I am following the steps given on the official site.
>>>
>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
>>> I have completed all the build requirements that has been stated in this
>>> page:
>>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
>>>
>>> I build and installed dmake and epm by following source.
>>> But when I runs ./bootstrap in main directory it says No such File or
>>> directory
>>>
>>> Do i have to manually download it or what to do.
>>>
>>> I would be really very grateful, if I could get help in this. I am
>>> totally stuck. I have tried lot many ways but couldn't resolve the
>>> errors.
>>>
>>> Thank you Team in anticipation!
>>>
>>> Regards,
>>> Nikhil
>>>
>> --
>> Mechtilde Stehmann
>> ## Apache OpenOffice
>> ## Freie Office Suite für Linux, MacOSX, Windows
>> ## Debian Developer
>> ## PGP encryption welcome
>> ## F0E3 7F3D C87A 4998 2899  39E7 F287 7BBA 141A AD7F
>>
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice Build Error

Nikhil Gupta
In reply to this post by Marcus (OOo)
Yes you are right.
But Before start building we have to do the configuration and
bootstrapping.As in the mentioned resource:
https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
After I installed epm and Dmake, we have to run the ./bootstrap in main
directory. but the file is not present.
and if i directly goes into the Building portion,
I have to run the source<platform-id>, to add environment variables ,how to
find my platform id from main/soenv file
Thanks

On Sat, Jan 26, 2019 at 12:18 AM Marcus <[hidden email]> wrote:

> Am 25.01.19 um 19:27 schrieb Nikhil Gupta:
> >   Yes,I had already installed unowinreg.dll from the above mentioned
> source.
> > But the problem still remains.
> > Are there any log files generated when we build the OpenOffice.
> > So that we can check out where the problem occured.
>
> I wonder that you are asking. When you start the build your screen
> should be full of it. ;-)
>
> It would be helpful when you can give us this output.
>
> Marcus
>
>
>
> > On Fri, Jan 25, 2019 at 11:36 PM Mechtilde <[hidden email]> wrote:
> >
> >> Hello,
> >>
> >> did you install
> >>
> >> cd main
> >>
> >> wget -O external/unowinreg/unowinreg.dll
> >> http://tools.openoffice.org/unowinreg_prebuild/680/unowinreg.dll
> >>
> >> which is one line
> >>
> >> Kind regards
> >>
> >> Am 25.01.19 um 18:54 schrieb Nikhil Gupta:
> >>> Hi everyone,
> >>> i am Nikhil from India. I am novice to open source as of now but really
> >>> interested to learn and contribute for this organization.
> >>> I have been trying to set up OpenOffice environment on my Ubuntu(14.04)
> >>> system. I am following the steps given on the official site.
> >>>
> >>
> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
> >>>
> >>> I have completed all the build requirements that has been stated in
> this
> >>> page:
> >>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
> >>>
> >>> I build and installed dmake and epm by following source.
> >>> But when I runs ./bootstrap in main directory it says No such File or
> >>> directory
> >>>
> >>> Do i have to manually download it or what to do.
> >>>
> >>> I would be really very grateful, if I could get help in this. I am
> >>> totally stuck. I have tried lot many ways but couldn't resolve the
> >>> errors.
> >>>
> >>> Thank you Team in anticipation!
> >>>
> >>> Regards,
> >>> Nikhil
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice Build Error

Nikhil Gupta
The output of main/soenv file

The output of epm configure is

The output of dmake configure is

On Sat, Jan 26, 2019 at 12:48 AM Nikhil Gupta <[hidden email]> wrote:
Yes you are right.
But Before start building we have to do the configuration and bootstrapping.As in the mentioned resource:
After I installed epm and Dmake, we have to run the ./bootstrap in main directory. but the file is not present.
and if i directly goes into the Building portion,
I have to run the source<platform-id>, to add environment variables ,how to find my platform id from main/soenv file
Thanks 

On Sat, Jan 26, 2019 at 12:18 AM Marcus <[hidden email]> wrote:
Am 25.01.19 um 19:27 schrieb Nikhil Gupta:
>   Yes,I had already installed unowinreg.dll from the above mentioned source.
> But the problem still remains.
> Are there any log files generated when we build the OpenOffice.
> So that we can check out where the problem occured.

I wonder that you are asking. When you start the build your screen
should be full of it. ;-)

It would be helpful when you can give us this output.

Marcus



> On Fri, Jan 25, 2019 at 11:36 PM Mechtilde <[hidden email]> wrote:
>
>> Hello,
>>
>> did you install
>>
>> cd main
>>
>> wget -O external/unowinreg/unowinreg.dll
>> http://tools.openoffice.org/unowinreg_prebuild/680/unowinreg.dll
>>
>> which is one line
>>
>> Kind regards
>>
>> Am 25.01.19 um 18:54 schrieb Nikhil Gupta:
>>> Hi everyone,
>>> i am Nikhil from India. I am novice to open source as of now but really
>>> interested to learn and contribute for this organization.
>>> I have been trying to set up OpenOffice environment on my Ubuntu(14.04)
>>> system. I am following the steps given on the official site.
>>>
>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
>>>
>>> I have completed all the build requirements that has been stated in this
>>> page:
>>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
>>>
>>> I build and installed dmake and epm by following source.
>>> But when I runs ./bootstrap in main directory it says No such File or
>>> directory
>>>
>>> Do i have to manually download it or what to do.
>>>
>>> I would be really very grateful, if I could get help in this. I am
>>> totally stuck. I have tried lot many ways but couldn't resolve the
>>> errors.
>>>
>>> Thank you Team in anticipation!
>>>
>>> Regards,
>>> Nikhil


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

config.log (34K) Download Attachment
config.log (66K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice Build Error

Peter Kovacs-3
In reply to this post by Nikhil Gupta
You need to do something like:

autoconf

./configure
--with-epm-url=https://sourceforge.net/projects/oooextras.mirror/files/epm-3.7.tar.gz
--with-dmake-url=https://sourceforge.net/projects/oooextras.mirror/files/dmake-4.12.tar.bz2
--with-lang="en-US de fr it pt ja"
--enable-wiki-publisher
--enable-verbose
--without-stlport
--enable-category-b
--enable-opengl
--enable-dbus
--without-junit
--with-package-format="installed archive deb"
--enable-bundled-dictionaries
--with-vendor=ASF buildbot - NOT FOR RELEASE
--with-build-version=%(today)s-Rev.%(got_revision)s

After that has been finished successfull you can bootstrap

On 25.01.19 20:18, Nikhil Gupta wrote:

> Yes you are right.
> But Before start building we have to do the configuration and
> bootstrapping.As in the mentioned resource:
> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
> After I installed epm and Dmake, we have to run the ./bootstrap in main
> directory. but the file is not present.
> and if i directly goes into the Building portion,
> I have to run the source<platform-id>, to add environment variables ,how to
> find my platform id from main/soenv file
> Thanks
>
> On Sat, Jan 26, 2019 at 12:18 AM Marcus <[hidden email]> wrote:
>
>> Am 25.01.19 um 19:27 schrieb Nikhil Gupta:
>>>   Yes,I had already installed unowinreg.dll from the above mentioned
>> source.
>>> But the problem still remains.
>>> Are there any log files generated when we build the OpenOffice.
>>> So that we can check out where the problem occured.
>> I wonder that you are asking. When you start the build your screen
>> should be full of it. ;-)
>>
>> It would be helpful when you can give us this output.
>>
>> Marcus
>>
>>
>>
>>> On Fri, Jan 25, 2019 at 11:36 PM Mechtilde <[hidden email]> wrote:
>>>
>>>> Hello,
>>>>
>>>> did you install
>>>>
>>>> cd main
>>>>
>>>> wget -O external/unowinreg/unowinreg.dll
>>>> http://tools.openoffice.org/unowinreg_prebuild/680/unowinreg.dll
>>>>
>>>> which is one line
>>>>
>>>> Kind regards
>>>>
>>>> Am 25.01.19 um 18:54 schrieb Nikhil Gupta:
>>>>> Hi everyone,
>>>>> i am Nikhil from India. I am novice to open source as of now but really
>>>>> interested to learn and contribute for this organization.
>>>>> I have been trying to set up OpenOffice environment on my Ubuntu(14.04)
>>>>> system. I am following the steps given on the official site.
>>>>>
>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
>>>>> I have completed all the build requirements that has been stated in
>> this
>>>>> page:
>>>>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
>>>>>
>>>>> I build and installed dmake and epm by following source.
>>>>> But when I runs ./bootstrap in main directory it says No such File or
>>>>> directory
>>>>>
>>>>> Do i have to manually download it or what to do.
>>>>>
>>>>> I would be really very grateful, if I could get help in this. I am
>>>>> totally stuck. I have tried lot many ways but couldn't resolve the
>>>>> errors.
>>>>>
>>>>> Thank you Team in anticipation!
>>>>>
>>>>> Regards,
>>>>> Nikhil
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice Build Error

Nikhil Gupta
After completing all the above requirements bootstrap gives the following
output

Script started on Saturday 26 January 2019 04:41:11 AM IST
]0;root@nikhil-VirtualBox: /home/nikhil/help/aoo/main
root@nikhil-VirtualBox:/home/nikhil/help/aoo/main#
exit ./bootstrap
unalias: gunzip not found

Include locations: /etc/perl /usr/local/lib/perl/5.18.2
/usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .

ucpp-1.3.2.tar.gz exists, MD5 checksum is OK
gtest-1.7.0.zip exists, MD5 checksum is OK
mythes-1.2.0.tar.gz exists, MD5 checksum is OK
mdds_0.3.1.tar.bz2 exists, MD5 checksum is OK
libtextcat-2.2.tar.gz exists, MD5 checksum is OK
hsqldb_1_8_0.zip exists, MD5 checksum is OK
Adobe-Core35_AFMs-314.tar.gz exists, MD5 checksum is OK
lucene-2.9.4-src.tar.gz exists, MD5 checksum is OK
ignoring xmlsec1-1.2.14.tar.gz because its prerequisites are not fulfilled
raptor2-2.0.15.tar.gz exists, MD5 checksum is OK
redland-1.0.17.tar.gz exists, MD5 checksum is OK
rasqal-0.9.33.tar.gz exists, MD5 checksum is OK
zlib-1.2.7.tar.bz2 exists, MD5 checksum is OK
ignoring commons-httpclient-3.1-src.tar.gz because its prerequisites are
not fulfilled
ignoring commons-codec-1.9-src.tar.gz because its prerequisites are not
fulfilled
icu4c-4_0_1-src.tgz exists, MD5 checksum is OK
serf-1.2.1.tar.bz2 exists, SHA1 checksum is OK
ignoring commons-logging-1.1.3-src.tar.gz because its prerequisites are not
fulfilled
jpeg-8d.tar.gz exists, MD5 checksum is OK
commons-lang3-3.3-src.tar.gz exists, MD5 checksum is OK
openssl-1.0.2p.tar.gz exists, MD5 checksum is OK
apr-1.5.2.tar.gz exists, MD5 checksum is OK
apr-util-1.5.4.tar.gz exists, MD5 checksum is OK
libxml2-2.9.8.tar.gz exists, MD5 checksum is OK
libxslt-1.1.32.tar.gz exists, MD5 checksum is OK
apache-tomcat-5.5.36-src.tar.gz exists, MD5 checksum is OK
stax-src-1.2.0.zip exists, MD5 checksum is OK
ignoring xsltml_2.1.2.zip because its prerequisites are not fulfilled
Python-2.7.15.tgz exists, MD5 checksum is OK
boost_1_55_0.tar.bz2 exists, MD5 checksum is OK
vigra1.6.0.tar.gz exists, MD5 checksum is OK
expat-2.2.3.tar.bz2 exists, MD5 checksum is OK
curl-7.61.1.tar.gz exists, MD5 checksum is OK
dejavu-fonts-ttf-2.37.tar.bz2 exists, MD5 checksum is OK
croscorefonts-1.31.0.tar.bz2 exists, MD5 checksum is OK
crosextrafonts-20130214.tar.gz exists, MD5 checksum is OK
SampleICC-1.3.2.tar.gz exists, MD5 checksum is OK
ignoring apache-rat-0.10-bin.tar.bz2 because its prerequisites are not
fulfilled
bsh-2.0b6-src.zip exists, MD5 checksum is OK
ignoring CoinMP-1.7.6.tgz because its prerequisites are not fulfilled
ignoring crosextrafonts-carlito-20130920.tar.gz because its prerequisites
are not fulfilled
ignoring GentiumBasic_1102.zip because its prerequisites are not fulfilled
ignoring hyphen-2.7.1.tar.gz because its prerequisites are not fulfilled
ignoring hunspell-1.3.3.tar.gz because its prerequisites are not fulfilled
ignoring rhino1_7R3.zip because its prerequisites are not fulfilled
ignoring nss-3.25-with-nspr-4.12.tar.gz because its prerequisites are not
fulfilled
ignoring LICENSE_source-9.0.0.7-bj.html because its prerequisites are not
fulfilled
ignoring README_source-9.0.0.7-bj.txt because its prerequisites are not
fulfilled
ignoring source-9.0.0.7-bj.zip because its prerequisites are not fulfilled
ignoring README_silgraphite-2.3.1.txt because its prerequisites are not
fulfilled
ignoring silgraphite-2.3.1.tar.gz because its prerequisites are not
fulfilled
ignoring cairo-1.8.0.tar.gz because its prerequisites are not fulfilled
ignoring pixman-0.12.0.tar.gz because its prerequisites are not fulfilled
all external libraries present

dmake is located in search path

bundling of dictionaries is disabled.
]
What is the meaning of dmake is located in search path

Is this an error?


On Sat, Jan 26, 2019 at 3:28 AM Peter Kovacs <[hidden email]> wrote:

> You need to do something like:
>
> autoconf
>
> ./configure
> --with-epm-url=
> https://sourceforge.net/projects/oooextras.mirror/files/epm-3.7.tar.gz
>
> --with-dmake-url=https://sourceforge.net/projects/oooextras.mirror/files/dmake-4.12.tar.bz2
> --with-lang=
> <https://sourceforge.net/projects/oooextras.mirror/files/epm-3.7.tar.gz--with-dmake-url=https://sourceforge.net/projects/oooextras.mirror/files/dmake-4.12.tar.bz2--with-lang=>"en-US
> de fr it pt ja"
> --enable-wiki-publisher
> --enable-verbose
> --without-stlport
> --enable-category-b
> --enable-opengl
> --enable-dbus
> --without-junit
> --with-package-format="installed archive deb"
> --enable-bundled-dictionaries
> --with-vendor=ASF buildbot - NOT FOR RELEASE
> --with-build-version=%(today)s-Rev.%(got_revision)s
>
> After that has been finished successfull you can bootstrap
>
> On 25.01.19 20:18, Nikhil Gupta wrote:
> > Yes you are right.
> > But Before start building we have to do the configuration and
> > bootstrapping.As in the mentioned resource:
> > https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
> > After I installed epm and Dmake, we have to run the ./bootstrap in main
> > directory. but the file is not present.
> > and if i directly goes into the Building portion,
> > I have to run the source<platform-id>, to add environment variables ,how
> to
> > find my platform id from main/soenv file
> > Thanks
> >
> > On Sat, Jan 26, 2019 at 12:18 AM Marcus <[hidden email]> wrote:
> >
> >> Am 25.01.19 um 19:27 schrieb Nikhil Gupta:
> >>>   Yes,I had already installed unowinreg.dll from the above mentioned
> >> source.
> >>> But the problem still remains.
> >>> Are there any log files generated when we build the OpenOffice.
> >>> So that we can check out where the problem occured.
> >> I wonder that you are asking. When you start the build your screen
> >> should be full of it. ;-)
> >>
> >> It would be helpful when you can give us this output.
> >>
> >> Marcus
> >>
> >>
> >>
> >>> On Fri, Jan 25, 2019 at 11:36 PM Mechtilde <[hidden email]> wrote:
> >>>
> >>>> Hello,
> >>>>
> >>>> did you install
> >>>>
> >>>> cd main
> >>>>
> >>>> wget -O external/unowinreg/unowinreg.dll
> >>>> http://tools.openoffice.org/unowinreg_prebuild/680/unowinreg.dll
> >>>>
> >>>> which is one line
> >>>>
> >>>> Kind regards
> >>>>
> >>>> Am 25.01.19 um 18:54 schrieb Nikhil Gupta:
> >>>>> Hi everyone,
> >>>>> i am Nikhil from India. I am novice to open source as of now but
> really
> >>>>> interested to learn and contribute for this organization.
> >>>>> I have been trying to set up OpenOffice environment on my
> Ubuntu(14.04)
> >>>>> system. I am following the steps given on the official site.
> >>>>>
> >>
> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
> >>>>> I have completed all the build requirements that has been stated in
> >> this
> >>>>> page:
> >>>>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
> >>>>>
> >>>>> I build and installed dmake and epm by following source.
> >>>>> But when I runs ./bootstrap in main directory it says No such File or
> >>>>> directory
> >>>>>
> >>>>> Do i have to manually download it or what to do.
> >>>>>
> >>>>> I would be really very grateful, if I could get help in this. I am
> >>>>> totally stuck. I have tried lot many ways but couldn't resolve the
> >>>>> errors.
> >>>>>
> >>>>> Thank you Team in anticipation!
> >>>>>
> >>>>> Regards,
> >>>>> Nikhil
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: [hidden email]
> >> For additional commands, e-mail: [hidden email]
> >>
> >>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice Build Error

Peter Kovacs-3
> dmake is located in search path
means it has found dmake. I would not say it is an error.

> unalias: gunzip not found
this does not sound good. I would install gunzip.


On 26.01.19 00:20, Nikhil Gupta wrote:

> After completing all the above requirements bootstrap gives the following
> output
>
> Script started on Saturday 26 January 2019 04:41:11 AM IST
> ]0;root@nikhil-VirtualBox: /home/nikhil/help/aoo/main
> root@nikhil-VirtualBox:/home/nikhil/help/aoo/main#
> exit ./bootstrap
> unalias: gunzip not found
>
> Include locations: /etc/perl /usr/local/lib/perl/5.18.2
> /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5
> /usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .
>
> ucpp-1.3.2.tar.gz exists, MD5 checksum is OK
> gtest-1.7.0.zip exists, MD5 checksum is OK
> mythes-1.2.0.tar.gz exists, MD5 checksum is OK
> mdds_0.3.1.tar.bz2 exists, MD5 checksum is OK
> libtextcat-2.2.tar.gz exists, MD5 checksum is OK
> hsqldb_1_8_0.zip exists, MD5 checksum is OK
> Adobe-Core35_AFMs-314.tar.gz exists, MD5 checksum is OK
> lucene-2.9.4-src.tar.gz exists, MD5 checksum is OK
> ignoring xmlsec1-1.2.14.tar.gz because its prerequisites are not fulfilled
> raptor2-2.0.15.tar.gz exists, MD5 checksum is OK
> redland-1.0.17.tar.gz exists, MD5 checksum is OK
> rasqal-0.9.33.tar.gz exists, MD5 checksum is OK
> zlib-1.2.7.tar.bz2 exists, MD5 checksum is OK
> ignoring commons-httpclient-3.1-src.tar.gz because its prerequisites are
> not fulfilled
> ignoring commons-codec-1.9-src.tar.gz because its prerequisites are not
> fulfilled
> icu4c-4_0_1-src.tgz exists, MD5 checksum is OK
> serf-1.2.1.tar.bz2 exists, SHA1 checksum is OK
> ignoring commons-logging-1.1.3-src.tar.gz because its prerequisites are not
> fulfilled
> jpeg-8d.tar.gz exists, MD5 checksum is OK
> commons-lang3-3.3-src.tar.gz exists, MD5 checksum is OK
> openssl-1.0.2p.tar.gz exists, MD5 checksum is OK
> apr-1.5.2.tar.gz exists, MD5 checksum is OK
> apr-util-1.5.4.tar.gz exists, MD5 checksum is OK
> libxml2-2.9.8.tar.gz exists, MD5 checksum is OK
> libxslt-1.1.32.tar.gz exists, MD5 checksum is OK
> apache-tomcat-5.5.36-src.tar.gz exists, MD5 checksum is OK
> stax-src-1.2.0.zip exists, MD5 checksum is OK
> ignoring xsltml_2.1.2.zip because its prerequisites are not fulfilled
> Python-2.7.15.tgz exists, MD5 checksum is OK
> boost_1_55_0.tar.bz2 exists, MD5 checksum is OK
> vigra1.6.0.tar.gz exists, MD5 checksum is OK
> expat-2.2.3.tar.bz2 exists, MD5 checksum is OK
> curl-7.61.1.tar.gz exists, MD5 checksum is OK
> dejavu-fonts-ttf-2.37.tar.bz2 exists, MD5 checksum is OK
> croscorefonts-1.31.0.tar.bz2 exists, MD5 checksum is OK
> crosextrafonts-20130214.tar.gz exists, MD5 checksum is OK
> SampleICC-1.3.2.tar.gz exists, MD5 checksum is OK
> ignoring apache-rat-0.10-bin.tar.bz2 because its prerequisites are not
> fulfilled
> bsh-2.0b6-src.zip exists, MD5 checksum is OK
> ignoring CoinMP-1.7.6.tgz because its prerequisites are not fulfilled
> ignoring crosextrafonts-carlito-20130920.tar.gz because its prerequisites
> are not fulfilled
> ignoring GentiumBasic_1102.zip because its prerequisites are not fulfilled
> ignoring hyphen-2.7.1.tar.gz because its prerequisites are not fulfilled
> ignoring hunspell-1.3.3.tar.gz because its prerequisites are not fulfilled
> ignoring rhino1_7R3.zip because its prerequisites are not fulfilled
> ignoring nss-3.25-with-nspr-4.12.tar.gz because its prerequisites are not
> fulfilled
> ignoring LICENSE_source-9.0.0.7-bj.html because its prerequisites are not
> fulfilled
> ignoring README_source-9.0.0.7-bj.txt because its prerequisites are not
> fulfilled
> ignoring source-9.0.0.7-bj.zip because its prerequisites are not fulfilled
> ignoring README_silgraphite-2.3.1.txt because its prerequisites are not
> fulfilled
> ignoring silgraphite-2.3.1.tar.gz because its prerequisites are not
> fulfilled
> ignoring cairo-1.8.0.tar.gz because its prerequisites are not fulfilled
> ignoring pixman-0.12.0.tar.gz because its prerequisites are not fulfilled
> all external libraries present
>
> dmake is located in search path
>
> bundling of dictionaries is disabled.
> ]
> What is the meaning of dmake is located in search path
>
> Is this an error?
>
>
> On Sat, Jan 26, 2019 at 3:28 AM Peter Kovacs <[hidden email]> wrote:
>
>> You need to do something like:
>>
>> autoconf
>>
>> ./configure
>> --with-epm-url=
>> https://sourceforge.net/projects/oooextras.mirror/files/epm-3.7.tar.gz
>>
>> --with-dmake-url=https://sourceforge.net/projects/oooextras.mirror/files/dmake-4.12.tar.bz2
>> --with-lang=
>> <https://sourceforge.net/projects/oooextras.mirror/files/epm-3.7.tar.gz--with-dmake-url=https://sourceforge.net/projects/oooextras.mirror/files/dmake-4.12.tar.bz2--with-lang=>"en-US
>> de fr it pt ja"
>> --enable-wiki-publisher
>> --enable-verbose
>> --without-stlport
>> --enable-category-b
>> --enable-opengl
>> --enable-dbus
>> --without-junit
>> --with-package-format="installed archive deb"
>> --enable-bundled-dictionaries
>> --with-vendor=ASF buildbot - NOT FOR RELEASE
>> --with-build-version=%(today)s-Rev.%(got_revision)s
>>
>> After that has been finished successfull you can bootstrap
>>
>> On 25.01.19 20:18, Nikhil Gupta wrote:
>>> Yes you are right.
>>> But Before start building we have to do the configuration and
>>> bootstrapping.As in the mentioned resource:
>>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
>>> After I installed epm and Dmake, we have to run the ./bootstrap in main
>>> directory. but the file is not present.
>>> and if i directly goes into the Building portion,
>>> I have to run the source<platform-id>, to add environment variables ,how
>> to
>>> find my platform id from main/soenv file
>>> Thanks
>>>
>>> On Sat, Jan 26, 2019 at 12:18 AM Marcus <[hidden email]> wrote:
>>>
>>>> Am 25.01.19 um 19:27 schrieb Nikhil Gupta:
>>>>>   Yes,I had already installed unowinreg.dll from the above mentioned
>>>> source.
>>>>> But the problem still remains.
>>>>> Are there any log files generated when we build the OpenOffice.
>>>>> So that we can check out where the problem occured.
>>>> I wonder that you are asking. When you start the build your screen
>>>> should be full of it. ;-)
>>>>
>>>> It would be helpful when you can give us this output.
>>>>
>>>> Marcus
>>>>
>>>>
>>>>
>>>>> On Fri, Jan 25, 2019 at 11:36 PM Mechtilde <[hidden email]> wrote:
>>>>>
>>>>>> Hello,
>>>>>>
>>>>>> did you install
>>>>>>
>>>>>> cd main
>>>>>>
>>>>>> wget -O external/unowinreg/unowinreg.dll
>>>>>> http://tools.openoffice.org/unowinreg_prebuild/680/unowinreg.dll
>>>>>>
>>>>>> which is one line
>>>>>>
>>>>>> Kind regards
>>>>>>
>>>>>> Am 25.01.19 um 18:54 schrieb Nikhil Gupta:
>>>>>>> Hi everyone,
>>>>>>> i am Nikhil from India. I am novice to open source as of now but
>> really
>>>>>>> interested to learn and contribute for this organization.
>>>>>>> I have been trying to set up OpenOffice environment on my
>> Ubuntu(14.04)
>>>>>>> system. I am following the steps given on the official site.
>>>>>>>
>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
>>>>>>> I have completed all the build requirements that has been stated in
>>>> this
>>>>>>> page:
>>>>>>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
>>>>>>>
>>>>>>> I build and installed dmake and epm by following source.
>>>>>>> But when I runs ./bootstrap in main directory it says No such File or
>>>>>>> directory
>>>>>>>
>>>>>>> Do i have to manually download it or what to do.
>>>>>>>
>>>>>>> I would be really very grateful, if I could get help in this. I am
>>>>>>> totally stuck. I have tried lot many ways but couldn't resolve the
>>>>>>> errors.
>>>>>>>
>>>>>>> Thank you Team in anticipation!
>>>>>>>
>>>>>>> Regards,
>>>>>>> Nikhil
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]