PKCS#11 support on Openoffice

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

PKCS#11 support on Openoffice

Paul Santapau Nebot
Hi,
 I have tested digital signature on Openoffice Writer (GNU/Linux)
and I realized that Oowriter just support using certificates
from Mozilla's store. I'have been searching for some info
about Ooffice2 implementing pkcs#11 capabilities but
I found nothing so I would like to get some questions answered:

Is there an Ooffice2 pkcs#11 support?
In case that no, Is planned to add pkcs#11 support to Ooffice shortly?
Is there any work on progress about that?, any URL?

I'm working on a project where we have implemented a pkcs#11 for
an special kind of software token based on a USB memory stick and
we have it fully-developed it for windows environments and we would like
to have it for GNU/linux too, so we can help working on that.

Thanx.
Greetings.

Paul Santapau Nebot.
[hidden email]
Clauer Team --> www.clauer.uji.es

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: PKCS#11 support on Openoffice

Joachim Lingner - Sun Germany Software Engineer - ham02 - Hamburg
PKCS11 will be supported by means of mozilla. That is, the PKCS11 module
must be added to mozilla.

This may be implemented in OOo2.0.4

--Joachim

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: PKCS#11 support on Openoffice

Malte Timmermann
In reply to this post by Paul Santapau Nebot
Problem within OOo is that OOo currently only supports one security
environment.
As Jochen said, that should change soon.

If you want to see if your implementation will (probably) work with OOo,
you can use some of our test tools:
xmlsecurity/tools/demo => signdemo and verifydemo

There you can choose which security environment to use.

Hope this helps,
Malte.



Joachim Lingner wrote:

> PKCS11 will be supported by means of mozilla. That is, the PKCS11 module
> must be added to mozilla.
>
> This may be implemented in OOo2.0.4
>
> --Joachim
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]