Problems with FTP: change in modes between 3.1 and 3.2

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with FTP: change in modes between 3.1 and 3.2

Fernand Vanrie
Hallo,

as asked by Stephan Berghman is moved this tread to ucb list.

In the past (OO 3.1 and earlier) i could use FTP from within a
FileDialog and using Basic and the API.

Something has changed between versions because it become imposible to
use FTP to have acces to some servers.

Studiing some log files learned us that after pasing the username and
the password UCB uses PASV mode (passif). This is a problem for most
servers who still using  EPSV(Extented passive) This servers are closing
the connection and OO gives a error "Path not Found)

However the situation is complex:
With 3.2 RC1 on a Windows box:
I can NOT  using  the FileDialog
I can NOT using the API to copy a file to Some servers
(filecopy(localfileURL,ftp://user:Password@servername/filename)

With 3.1.1 on a Windows box :
I can use the Filedialog and acces the directories and copy files on them
I can NOT use the API
(filecopy(localfileURL,ftp://user:Password@servername/filename)

Thanks for any hints

Fernand


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems with FTP: change in modes between 3.1 and 3.2

Fernand Vanrie
sorry it has to been

OO us EPSV "Extended passif"

most servers accept only PASV (passif)



Fernand Vanrie wrote:

> Hallo,
>
> as asked by Stephan Berghman is moved this tread to ucb list.
>
> In the past (OO 3.1 and earlier) i could use FTP from within a
> FileDialog and using Basic and the API.
>
> Something has changed between versions because it become imposible to
> use FTP to have acces to some servers.
>
> Studiing some log files learned us that after pasing the username and
> the password UCB uses PASV mode (passif). This is a problem for most
> servers who still using  EPSV(Extented passive) This servers are
> closing the connection and OO gives a error "Path not Found)
>
> However the situation is complex:
> With 3.2 RC1 on a Windows box:
> I can NOT  using  the FileDialog
> I can NOT using the API to copy a file to Some servers
> (filecopy(localfileURL,ftp://user:Password@servername/filename)
>
> With 3.1.1 on a Windows box :
> I can use the Filedialog and acces the directories and copy files on them
> I can NOT use the API
> (filecopy(localfileURL,ftp://user:Password@servername/filename)
>
> Thanks for any hints
>
> Fernand
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems with FTP: change in modes between 3.1 and 3.2

Tobias Krause-2
Hi Fernand,

I checked OOo 3.1.1 and OOo 3.2 RC 1 and both of them use the Extended
Passive Mode. Also, I couldn't find any hints that we support PASV mode
before.

Can you provide additional information about your scenario?

-
Tobias

On 01/14/10 17:12, Fernand Vanrie wrote:

> sorry it has to been
>
> OO us EPSV "Extended passif"
>
> most servers accept only PASV (passif)
>
>
>
> Fernand Vanrie wrote:
>> Hallo,
>>
>> as asked by Stephan Berghman is moved this tread to ucb list.
>>
>> In the past (OO 3.1 and earlier) i could use FTP from within a
>> FileDialog and using Basic and the API.
>>
>> Something has changed between versions because it become imposible to
>> use FTP to have acces to some servers.
>>
>> Studiing some log files learned us that after pasing the username and
>> the password UCB uses PASV mode (passif). This is a problem for most
>> servers who still using  EPSV(Extented passive) This servers are
>> closing the connection and OO gives a error "Path not Found)
>>
>> However the situation is complex:
>> With 3.2 RC1 on a Windows box:
>> I can NOT  using  the FileDialog
>> I can NOT using the API to copy a file to Some servers
>> (filecopy(localfileURL,ftp://user:Password@servername/filename)
>>
>> With 3.1.1 on a Windows box :
>> I can use the Filedialog and acces the directories and copy files on them
>> I can NOT use the API
>> (filecopy(localfileURL,ftp://user:Password@servername/filename)
>>
>> Thanks for any hints
>>
>> Fernand
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]