Re: Does AOO 4.1.8 run under macOS Big Sur?

classic Classic list List threaded Threaded
18 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Jim Jagielski

> On Dec 11, 2020, at 5:27 AM, Bidouille <[hidden email]> wrote:
>
>> Which is why we need to get 4.2.0 out asap :/
>
> Any news?
> TDF blog publish on this bug: https://tinyurl.com/y6zjvp2j
> Bad advice :-(

I love that group. They are like immature kids. Or bitter ex-boy/girl-friends.

What's next? Sticking out their tongues and going "Nyah Nyah Nyah! Apache OpenOffice
are a bunch of poopie-heads!" ? :)
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Peter Kovacs-3

On 11.12.20 12:47, Jim Jagielski wrote:
>> On Dec 11, 2020, at 5:27 AM, Bidouille <[hidden email]> wrote:
>>
>>> Which is why we need to get 4.2.0 out asap :/
>> Any news?
>> TDF blog publish on this bug: https://tinyurl.com/y6zjvp2j
>> Bad advice :-(
> I love that group. They are like immature kids. Or bitter ex-boy/girl-friends.
I told them they should do their own marketing. Just ignore it.
>
> What's next? Sticking out their tongues and going "Nyah Nyah Nyah! Apache OpenOffice
> are a bunch of poopie-heads!" ? :)

Hehe, I do believe some think that way. And that for quite soime time now.

However do you have any Idea by now what goes wrong?
--
This is the Way! http://www.apache.org/theapacheway/index.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Jim Jagielski


> On Dec 11, 2020, at 7:27 AM, Peter Kovacs <[hidden email]> wrote:
>
>
> On 11.12.20 12:47, Jim Jagielski wrote:
>>> On Dec 11, 2020, at 5:27 AM, Bidouille <[hidden email]> wrote:
>>>
>>>> Which is why we need to get 4.2.0 out asap :/
>>> Any news?
>>> TDF blog publish on this bug: https://tinyurl.com/y6zjvp2j
>>> Bad advice :-(
>> I love that group. They are like immature kids. Or bitter ex-boy/girl-friends.
> I told them they should do their own marketing. Just ignore it.
>>
>> What's next? Sticking out their tongues and going "Nyah Nyah Nyah! Apache OpenOffice
>> are a bunch of poopie-heads!" ? :)
>
> Hehe, I do believe some think that way. And that for quite soime time now.
>
> However do you have any Idea by now what goes wrong?

That's what I've been working on w/ the various UNO fixes to macOS. My hope is
to have a test 4.2.0-dev build for someone w/ Big Sur to test on...

Who is running Big Sur?


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Bidouille
> Who is running Big Sur?
We have end users on french forum.
Able (and motivated) to test it soon as possible :)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Jim Jagielski
I'm building a dev version of 4.2.0 w/ lang fr as we speak

> On Dec 11, 2020, at 8:28 AM, Bidouille <[hidden email]> wrote:
>
>> Who is running Big Sur?
> We have end users on french forum.
> Able (and motivated) to test it soon as possible :)
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Jim Jagielski
I have an en-US and fr LANG test builds of AOO 4.2.0 available via:

    http://home.apache.org/~jim/AOO-builds/ <http://home.apache.org/~jim/AOO-builds/>

Also, these include my fork of beanshell (https://github.com/jimjag/beanshell2 <https://github.com/jimjag/beanshell2>)

> On Dec 11, 2020, at 9:08 AM, Jim Jagielski <[hidden email]> wrote:
>
> I'm building a dev version of 4.2.0 w/ lang fr as we speak
>
>> On Dec 11, 2020, at 8:28 AM, Bidouille <[hidden email]> wrote:
>>
>>> Who is running Big Sur?
>> We have end users on french forum.
>> Able (and motivated) to test it soon as possible :)
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Matthias Seidel
In reply to this post by Jim Jagielski
Hi Jim,

Am 11.12.20 um 12:47 schrieb Jim Jagielski:

>> On Dec 11, 2020, at 5:27 AM, Bidouille <[hidden email]> wrote:
>>
>>> Which is why we need to get 4.2.0 out asap :/
>> Any news?
>> TDF blog publish on this bug: https://tinyurl.com/y6zjvp2j
>> Bad advice :-(
> I love that group. They are like immature kids. Or bitter ex-boy/girl-friends.
>
> What's next? Sticking out their tongues and going "Nyah Nyah Nyah! Apache OpenOffice
> are a bunch of poopie-heads!" ? :)
I am sure they already did...

At least that is what I expect from these people! ;-)

Matthias

> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Matthias Seidel
In reply to this post by Jim Jagielski
Hi Jim,

I have been able to open docx with your version (en-US) on Big Sur.
However, I am not sure if this bug ever applied to 4.2.x.

The Extension Manager is still broken. But similar behavior is to be
seen in 4.2.x on Windows, so the UNO problem is not mac specific.

Regards,

   Matthias

Am 11.12.20 um 15:44 schrieb Jim Jagielski:

> I have an en-US and fr LANG test builds of AOO 4.2.0 available via:
>
>     http://home.apache.org/~jim/AOO-builds/ <http://home.apache.org/~jim/AOO-builds/>
>
> Also, these include my fork of beanshell (https://github.com/jimjag/beanshell2 <https://github.com/jimjag/beanshell2>)
>
>> On Dec 11, 2020, at 9:08 AM, Jim Jagielski <[hidden email]> wrote:
>>
>> I'm building a dev version of 4.2.0 w/ lang fr as we speak
>>
>>> On Dec 11, 2020, at 8:28 AM, Bidouille <[hidden email]> wrote:
>>>
>>>> Who is running Big Sur?
>>> We have end users on french forum.
>>> Able (and motivated) to test it soon as possible :)
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Bidouille
> I have been able to open docx with your version (en-US) on Big Sur.
Confirmed, a french user reports no problem too with this 4.2.0-dev.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Matthias Seidel
Hi,

Am 12.12.20 um 14:06 schrieb Bidouille:
>> I have been able to open docx with your version (en-US) on Big Sur.
> Confirmed, a french user reports no problem too with this 4.2.0-dev.

What I recognized with Jim's build:

AOO has no language for spellcheck enabled. I once had this issue on
OS/2 and the cause was that hunspell was missing.

Is hunspell not installed by default on Big Sur and if not, how can I
install it?

(Sorry, I am not a mac user...)

Regards,

   Matthias

>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Jim Jagielski
In reply to this post by Matthias Seidel


> On Dec 12, 2020, at 5:21 AM, Matthias Seidel <[hidden email]> wrote:
>
> Hi Jim,
>
> I have been able to open docx with your version (en-US) on Big Sur.
> However, I am not sure if this bug ever applied to 4.2.x.
>
> The Extension Manager is still broken. But similar behavior is to be
> seen in 4.2.x on Windows, so the UNO problem is not mac specific.
>

Yes... I am also looking into issues w/ 4.2.0-dev and check for updates (main level)


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Rony G. Flatscher (Apache)
On 14.12.2020 13:33, Jim Jagielski wrote:

>> On Dec 12, 2020, at 5:21 AM, Matthias Seidel <[hidden email]> wrote:
>>
>> Hi Jim,
>>
>> I have been able to open docx with your version (en-US) on Big Sur.
>> However, I am not sure if this bug ever applied to 4.2.x.
>>
>> The Extension Manager is still broken. But similar behavior is to be
>> seen in 4.2.x on Windows, so the UNO problem is not mac specific.
>>
> Yes... I am also looking into issues w/ 4.2.0-dev and check for updates (main level)

Ah, o.k. that might explain this. Got a minute so tried to test 4.2 beta w.r.t. issue 127966  [1]
and was not able to get ooRexx functional. When trying to register the oxt package manually with
unopkg, I got this error message:

    wu114216:~ rony$ "/Applications/OpenOffice.app/Contents/program/unopkg" add -f --shared /Library/Frameworks/BSF4ooRexx.framework/Libraries/ScriptProviderForooRexx.oxt
    dyld: Library not loaded: @_______URELIB/libuno_cppu.dylib
      Referenced from: /Applications/OpenOffice.app/Contents/MacOS/uno.bin
      Reason: image not found

---rony

[1] MacOS: Current directory wrongly set to root directory "/" for scripts:
<https://bz.apache.org/ooo/show_bug.cgi?id=127966>


Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Jim Jagielski
Ahh. that's good info. There is something somewhere that still expects that COMID on macOS
is s5abi or, at least, !=gcc3. That gives me some hint to what to look for.

> On Dec 17, 2020, at 11:34 AM, Rony G. Flatscher (Apache) <[hidden email]> wrote:
>
> On 14.12.2020 13:33, Jim Jagielski wrote:
>>> On Dec 12, 2020, at 5:21 AM, Matthias Seidel <[hidden email]> wrote:
>>>
>>> Hi Jim,
>>>
>>> I have been able to open docx with your version (en-US) on Big Sur.
>>> However, I am not sure if this bug ever applied to 4.2.x.
>>>
>>> The Extension Manager is still broken. But similar behavior is to be
>>> seen in 4.2.x on Windows, so the UNO problem is not mac specific.
>>>
>> Yes... I am also looking into issues w/ 4.2.0-dev and check for updates (main level)
>
> Ah, o.k. that might explain this. Got a minute so tried to test 4.2 beta w.r.t. issue 127966  [1]
> and was not able to get ooRexx functional. When trying to register the oxt package manually with
> unopkg, I got this error message:
>
>    wu114216:~ rony$ "/Applications/OpenOffice.app/Contents/program/unopkg" add -f --shared /Library/Frameworks/BSF4ooRexx.framework/Libraries/ScriptProviderForooRexx.oxt
>    dyld: Library not loaded: @_______URELIB/libuno_cppu.dylib
>      Referenced from: /Applications/OpenOffice.app/Contents/MacOS/uno.bin
>      Reason: image not found
>
> ---rony
>
> [1] MacOS: Current directory wrongly set to root directory "/" for scripts:
> <https://bz.apache.org/ooo/show_bug.cgi?id=127966>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Jim Jagielski
Can you try with:

    http://home.apache.org/~jim/AOO-builds/

> On Dec 18, 2020, at 8:45 AM, Jim Jagielski <[hidden email]> wrote:
>
> Ahh. that's good info. There is something somewhere that still expects that COMID on macOS
> is s5abi or, at least, !=gcc3. That gives me some hint to what to look for.
>
>> On Dec 17, 2020, at 11:34 AM, Rony G. Flatscher (Apache) <[hidden email]> wrote:
>>
>> On 14.12.2020 13:33, Jim Jagielski wrote:
>>>> On Dec 12, 2020, at 5:21 AM, Matthias Seidel <[hidden email]> wrote:
>>>>
>>>> Hi Jim,
>>>>
>>>> I have been able to open docx with your version (en-US) on Big Sur.
>>>> However, I am not sure if this bug ever applied to 4.2.x.
>>>>
>>>> The Extension Manager is still broken. But similar behavior is to be
>>>> seen in 4.2.x on Windows, so the UNO problem is not mac specific.
>>>>
>>> Yes... I am also looking into issues w/ 4.2.0-dev and check for updates (main level)
>>
>> Ah, o.k. that might explain this. Got a minute so tried to test 4.2 beta w.r.t. issue 127966  [1]
>> and was not able to get ooRexx functional. When trying to register the oxt package manually with
>> unopkg, I got this error message:
>>
>>   wu114216:~ rony$ "/Applications/OpenOffice.app/Contents/program/unopkg" add -f --shared /Library/Frameworks/BSF4ooRexx.framework/Libraries/ScriptProviderForooRexx.oxt
>>   dyld: Library not loaded: @_______URELIB/libuno_cppu.dylib
>>     Referenced from: /Applications/OpenOffice.app/Contents/MacOS/uno.bin
>>     Reason: image not found
>>
>> ---rony
>>
>> [1] MacOS: Current directory wrongly set to root directory "/" for scripts:
>> <https://bz.apache.org/ooo/show_bug.cgi?id=127966>
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Jim Jagielski
In reply to this post by Matthias Seidel


> On Dec 12, 2020, at 5:21 AM, Matthias Seidel <[hidden email]> wrote:
>
> Hi Jim,
>
> I have been able to open docx with your version (en-US) on Big Sur.
> However, I am not sure if this bug ever applied to 4.2.x.
>
> The Extension Manager is still broken. But similar behavior is to be
> seen in 4.2.x on Windows, so the UNO problem is not mac specific.
>

Can you Help->Check For Updates? I always get a

    Checking for an update failed.

So I'm wondering if the 2 are related?


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Matthias Seidel
Am 18.12.20 um 21:09 schrieb Jim Jagielski:

>
>> On Dec 12, 2020, at 5:21 AM, Matthias Seidel <[hidden email]> wrote:
>>
>> Hi Jim,
>>
>> I have been able to open docx with your version (en-US) on Big Sur.
>> However, I am not sure if this bug ever applied to 4.2.x.
>>
>> The Extension Manager is still broken. But similar behavior is to be
>> seen in 4.2.x on Windows, so the UNO problem is not mac specific.
>>
> Can you Help->Check For Updates? I always get a
>
>     Checking for an update failed.
Yes, update check was broken for me with your latest version.

Haven't checked earlier versions. on mac.

>
> So I'm wondering if the 2 are related?
Maybe, but Extension Manager is also somehow broken on Windows and
update check is working.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Rony G. Flatscher (Apache)
In reply to this post by Jim Jagielski
On 18.12.2020 16:25, Jim Jagielski wrote:
> Can you try with:
>
>     http://home.apache.org/~jim/AOO-builds/

Same error:

    wu114216:~ rony$ "/Applications/OpenOffice.app/Contents/program/unopkg" add -f --shared /Library/Frameworks/BSF4ooRexx.framework/Libraries/ScriptProviderForooRexx.oxt
      dyld: Library not loaded: @_______URELIB/libuno_cppu.dylib
        Referenced from: /Applications/OpenOffice.app/Contents/MacOS/uno.bin
        Reason: image not found

---rony


On Dec 17, 2020, at 11:34 AM, Rony G. Flatscher (Apache) <[hidden email]> wrote:

... cut ...

>>> On 14.12.2020 13:33, Jim Jagielski wrote:
>>>>> On Dec 12, 2020, at 5:21 AM, Matthias Seidel <[hidden email]> wrote:
>>>>>
>>>>> Hi Jim,
>>>>>
>>>>> I have been able to open docx with your version (en-US) on Big Sur.
>>>>> However, I am not sure if this bug ever applied to 4.2.x.
>>>>>
>>>>> The Extension Manager is still broken. But similar behavior is to be
>>>>> seen in 4.2.x on Windows, so the UNO problem is not mac specific.
>>>>>
>>>> Yes... I am also looking into issues w/ 4.2.0-dev and check for updates (main level)
>>> Ah, o.k. that might explain this. Got a minute so tried to test 4.2 beta w.r.t. issue 127966  [1]
>>> and was not able to get ooRexx functional. When trying to register the oxt package manually with
>>> unopkg, I got this error message:
>>>
>>>   wu114216:~ rony$ "/Applications/OpenOffice.app/Contents/program/unopkg" add -f --shared /Library/Frameworks/BSF4ooRexx.framework/Libraries/ScriptProviderForooRexx.oxt
>>>   dyld: Library not loaded: @_______URELIB/libuno_cppu.dylib
>>>     Referenced from: /Applications/OpenOffice.app/Contents/MacOS/uno.bin
>>>     Reason: image not found
>>>
>>> ---rony
>>>
>>> [1] MacOS: Current directory wrongly set to root directory "/" for scripts:
>>> <https://bz.apache.org/ooo/show_bug.cgi?id=127966>
>>>

Reply | Threaded
Open this post in threaded view
|

Re: Does AOO 4.1.8 run under macOS Big Sur?

Jim Jagielski
OK, thx. it seems that the switch from COMID s5abi to gcc3 is a LOT more fragile than it should be.

> On Dec 19, 2020, at 7:59 AM, Rony G. Flatscher (Apache) <[hidden email]> wrote:
>
> On 18.12.2020 16:25, Jim Jagielski wrote:
>> Can you try with:
>>
>>    http://home.apache.org/~jim/AOO-builds/
>
> Same error:
>
>    wu114216:~ rony$ "/Applications/OpenOffice.app/Contents/program/unopkg" add -f --shared /Library/Frameworks/BSF4ooRexx.framework/Libraries/ScriptProviderForooRexx.oxt
>      dyld: Library not loaded: @_______URELIB/libuno_cppu.dylib
>        Referenced from: /Applications/OpenOffice.app/Contents/MacOS/uno.bin
>        Reason: image not found
>
> ---rony
>
>
> On Dec 17, 2020, at 11:34 AM, Rony G. Flatscher (Apache) <[hidden email]> wrote:
>
> ... cut ...
>
>>>> On 14.12.2020 13:33, Jim Jagielski wrote:
>>>>>> On Dec 12, 2020, at 5:21 AM, Matthias Seidel <[hidden email]> wrote:
>>>>>>
>>>>>> Hi Jim,
>>>>>>
>>>>>> I have been able to open docx with your version (en-US) on Big Sur.
>>>>>> However, I am not sure if this bug ever applied to 4.2.x.
>>>>>>
>>>>>> The Extension Manager is still broken. But similar behavior is to be
>>>>>> seen in 4.2.x on Windows, so the UNO problem is not mac specific.
>>>>>>
>>>>> Yes... I am also looking into issues w/ 4.2.0-dev and check for updates (main level)
>>>> Ah, o.k. that might explain this. Got a minute so tried to test 4.2 beta w.r.t. issue 127966  [1]
>>>> and was not able to get ooRexx functional. When trying to register the oxt package manually with
>>>> unopkg, I got this error message:
>>>>
>>>>  wu114216:~ rony$ "/Applications/OpenOffice.app/Contents/program/unopkg" add -f --shared /Library/Frameworks/BSF4ooRexx.framework/Libraries/ScriptProviderForooRexx.oxt
>>>>  dyld: Library not loaded: @_______URELIB/libuno_cppu.dylib
>>>>    Referenced from: /Applications/OpenOffice.app/Contents/MacOS/uno.bin
>>>>    Reason: image not found
>>>>
>>>> ---rony
>>>>
>>>> [1] MacOS: Current directory wrongly set to root directory "/" for scripts:
>>>> <https://bz.apache.org/ooo/show_bug.cgi?id=127966>
>>>>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]