There is a problem with the shared '/usr/bin/soffice' between Libreoffice and OpenOffice.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

There is a problem with the shared '/usr/bin/soffice' between Libreoffice and OpenOffice.

Wroger Wroger
How to fix this?

Possibly uninstall open office - (older version) do the libre office
upgrade and then install the latest Open Office version....

Any ideas?

It won't FIX the shared libraries issue, but it keeps me going.

How to do the fix though?



Synaptic package manager..

Summary of fault.

E:
/var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb:
trying to overwrite '/usr/bin/soffice', which is also in package
openoffice-debian-menus 4.1.3-9783


Synaptic package manager install of Libreoffice updates.


(Reading database ... 672148 files and directories currently installed.)
Preparing to unpack
.../libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb ...
Unpacking libreoffice-common (1:5.1.6~rc2-0ubuntu1~xenial2) ...

dpkg: error processing archive
/var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb
(--unpack):
 trying to overwrite '/usr/bin/soffice', which is also in package
openoffice-debian-menus 4.1.3-9783

rmdir: failed to remove '/var/lib/libreoffice/share/prereg/': No such file
or directory
rmdir: failed to remove '/var/lib/libreoffice/share/': No such file or
directory
rmdir: failed to remove '/var/lib/libreoffice/program/': No such file or
directory
rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for gnome-icon-theme (3.12.0-1ubuntu3) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
dpkg: dependency problems prevent configuration of libreoffice-help-en-us:
 libreoffice-help-en-us depends on libreoffice-l10n-en-us; however:
  Package libreoffice-l10n-en-us is not installed.

dpkg: error processing package libreoffice-help-en-us (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-style-galaxy:
 libreoffice-style-galaxy depends on libreoffice-common (=
1:5.1.6~rc2-0ubuntu1~xenial2); however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-style-galaxy (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-core:
 libreoffice-core depends on libreoffice-common (>> 1:5.1.6~rc2); however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-l10n-en-gb:
 libreoffice-l10n-en-gb depends on libreoffice-common; however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-l10n-en-gb (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of
libreoffice-style-elementary:
 libreoffice-style-elementary depends on libreoffice-style-galaxy; however:
  Package libreoffice-style-galaxy is not configured yet.
 libreoffice-style-elementary depends on libreoffice-common (=
1:5.1.6~rc2-0ubuntu1~xenial2); however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-style-elementary (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3-uno:
 python3-uno depends on libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial2);
however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package python3-uno (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-l10n-en-za:
 libreoffice-l10n-en-za depends on libreoffice-common; however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-l10n-en-za (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-writer:
 libreoffice-writer depends on libreoffice-core (=
1:5.1.6~rc2-0ubuntu1~xenial2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-writer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-math:
 libreoffice-math depends on libreoffice-core (=
1:5.1.6~rc2-0ubuntu1~xenial2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-math (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-help-en-gb:
 libreoffice-help-en-gb depends on libreoffice-l10n-en-gb; however:
  Package libreoffice-l10n-en-gb is not configured yet.
 libreoffice-help-en-gb depends on libreoffice-style-default; however:
  Package libreoffice-style-default is not installed.
  Package libreoffice-style-elementary which provides
libreoffice-style-default is not configured yet.
  Package libreoffice-style-galaxy which provides libreoffice-style-default
is not configured yet.
 libreoffice-help-en-gb depends on libreoffice-writer |
language-support-translations-en; however:
  Package libreoffice-writer is not configured yet.
  Package language-support-translations-en is not installed.

dpkg: error processing package libreoffice-help-en-gb (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-base-core:
 libreoffice-base-core depends on libreoffice-core (=
1:5.1.6~rc2-0ubuntu1~xenial2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-base-core (--configure):
 dependency problems - leaving unconfigured







--

"Oh Benson. Dear Benson. You are so mercifully free of the ravages of
intelligence."
Reply | Threaded
Open this post in threaded view
|

Re: There is a problem with the shared '/usr/bin/soffice' between Libreoffice and OpenOffice.

Johnny Rosenberg
2017-11-19 22:55 GMT+01:00 Wroger Wroger <[hidden email]>:

> How to fix this?
>
> Possibly uninstall open office - (older version) do the libre office
> upgrade and then install the latest Open Office version....
>
> Any ideas?
>

This is probably an Ubuntu question rather than an Apache OpenOffice
question, I guess. I don't have Ubuntu any longer, I switched to Arch Linux
recently, but I would try to uninstall both completely and then, if I
wanted both of them, download the debs from http://www.libreoffice.org/
(”Still” version) and http://www.openoffice.org/ respectively and install
them from a terminal with dpkg.


Kind regards

Johnny Rosenberg



>
> It won't FIX the shared libraries issue, but it keeps me going.
>
> How to do the fix though?
>
>
>
> Synaptic package manager..
>
> Summary of fault.
>
> E:
> /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~
> rc2-0ubuntu1~xenial2_all.deb:
> trying to overwrite '/usr/bin/soffice', which is also in package
> openoffice-debian-menus 4.1.3-9783
>
>
> Synaptic package manager install of Libreoffice updates.
>
>
> (Reading database ... 672148 files and directories currently installed.)
> Preparing to unpack
> .../libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb ...
> Unpacking libreoffice-common (1:5.1.6~rc2-0ubuntu1~xenial2) ...
>
> dpkg: error processing archive
> /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~
> rc2-0ubuntu1~xenial2_all.deb
> (--unpack):
>  trying to overwrite '/usr/bin/soffice', which is also in package
> openoffice-debian-menus 4.1.3-9783
>
> rmdir: failed to remove '/var/lib/libreoffice/share/prereg/': No such file
> or directory
> rmdir: failed to remove '/var/lib/libreoffice/share/': No such file or
> directory
> rmdir: failed to remove '/var/lib/libreoffice/program/': No such file or
> directory
> rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
> rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
> Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
> Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
> Processing triggers for mime-support (3.59ubuntu1) ...
> Processing triggers for gnome-icon-theme (3.12.0-1ubuntu3) ...
> Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
> Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...
> Processing triggers for man-db (2.7.5-1) ...
> Errors were encountered while processing:
>  /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~
> rc2-0ubuntu1~xenial2_all.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> A package failed to install.  Trying to recover:
> dpkg: dependency problems prevent configuration of libreoffice-help-en-us:
>  libreoffice-help-en-us depends on libreoffice-l10n-en-us; however:
>   Package libreoffice-l10n-en-us is not installed.
>
> dpkg: error processing package libreoffice-help-en-us (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of
> libreoffice-style-galaxy:
>  libreoffice-style-galaxy depends on libreoffice-common (=
> 1:5.1.6~rc2-0ubuntu1~xenial2); however:
>   Package libreoffice-common is not installed.
>
> dpkg: error processing package libreoffice-style-galaxy (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-core:
>  libreoffice-core depends on libreoffice-common (>> 1:5.1.6~rc2); however:
>   Package libreoffice-common is not installed.
>
> dpkg: error processing package libreoffice-core (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-l10n-en-gb:
>  libreoffice-l10n-en-gb depends on libreoffice-common; however:
>   Package libreoffice-common is not installed.
>
> dpkg: error processing package libreoffice-l10n-en-gb (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of
> libreoffice-style-elementary:
>  libreoffice-style-elementary depends on libreoffice-style-galaxy; however:
>   Package libreoffice-style-galaxy is not configured yet.
>  libreoffice-style-elementary depends on libreoffice-common (=
> 1:5.1.6~rc2-0ubuntu1~xenial2); however:
>   Package libreoffice-common is not installed.
>
> dpkg: error processing package libreoffice-style-elementary (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of python3-uno:
>  python3-uno depends on libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial2);
> however:
>   Package libreoffice-core is not configured yet.
>
> dpkg: error processing package python3-uno (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-l10n-en-za:
>  libreoffice-l10n-en-za depends on libreoffice-common; however:
>   Package libreoffice-common is not installed.
>
> dpkg: error processing package libreoffice-l10n-en-za (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-writer:
>  libreoffice-writer depends on libreoffice-core (=
> 1:5.1.6~rc2-0ubuntu1~xenial2); however:
>   Package libreoffice-core is not configured yet.
>
> dpkg: error processing package libreoffice-writer (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-math:
>  libreoffice-math depends on libreoffice-core (=
> 1:5.1.6~rc2-0ubuntu1~xenial2); however:
>   Package libreoffice-core is not configured yet.
>
> dpkg: error processing package libreoffice-math (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-help-en-gb:
>  libreoffice-help-en-gb depends on libreoffice-l10n-en-gb; however:
>   Package libreoffice-l10n-en-gb is not configured yet.
>  libreoffice-help-en-gb depends on libreoffice-style-default; however:
>   Package libreoffice-style-default is not installed.
>   Package libreoffice-style-elementary which provides
> libreoffice-style-default is not configured yet.
>   Package libreoffice-style-galaxy which provides libreoffice-style-default
> is not configured yet.
>  libreoffice-help-en-gb depends on libreoffice-writer |
> language-support-translations-en; however:
>   Package libreoffice-writer is not configured yet.
>   Package language-support-translations-en is not installed.
>
> dpkg: error processing package libreoffice-help-en-gb (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-base-core:
>  libreoffice-base-core depends on libreoffice-core (=
> 1:5.1.6~rc2-0ubuntu1~xenial2); however:
>   Package libreoffice-core is not configured yet.
>
> dpkg: error processing package libreoffice-base-core (--configure):
>  dependency problems - leaving unconfigured
>
>
>
>
>
>
>
> --
>
> "Oh Benson. Dear Benson. You are so mercifully free of the ravages of
> intelligence."
>
Reply | Threaded
Open this post in threaded view
|

Re: There is a problem with the shared '/usr/bin/soffice' between Libreoffice and OpenOffice.

Girvin Herr-2
In reply to this post by Wroger Wroger
Greetings,

In my Slackware Linux packages, I have no conflict. There is no soffice
file in my /usr/bin directory. I do have:

/usr/bin/libreoffice5.3

which is a symlink to /opt/libreoffice5.3/program/soffice

and

/usr/bin/openoffice4

Which is a shell script:

#!/bin/sh
/opt/openoffice4/program/soffice

So, as can be seen, the main entry points for these two programs in
/usr/bin are vectors to the separate soffice programs in /opt.

If you make these changes, your conflicts should disappear. I use both
programs, even at the same time, and they work fine without conflicts.
Note that you may need to change your ~/Desktop files to change the
filenames and possibly your desktop icons to change the filenames to the
new names in /usr/bin.

HTH.
Girvin Herr


On 11/19/2017 01:55 PM, Wroger Wroger wrote:

> How to fix this?
>
> Possibly uninstall open office - (older version) do the libre office
> upgrade and then install the latest Open Office version....
>
> Any ideas?
>
> It won't FIX the shared libraries issue, but it keeps me going.
>
> How to do the fix though?
>
>
>
> Synaptic package manager..
>
> Summary of fault.
>
> E:
> /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb:
> trying to overwrite '/usr/bin/soffice', which is also in package
> openoffice-debian-menus 4.1.3-9783
>
>
> Synaptic package manager install of Libreoffice updates.
>
>
> (Reading database ... 672148 files and directories currently installed.)
> Preparing to unpack
> .../libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb ...
> Unpacking libreoffice-common (1:5.1.6~rc2-0ubuntu1~xenial2) ...
>
> dpkg: error processing archive
> /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb
> (--unpack):
>   trying to overwrite '/usr/bin/soffice', which is also in package
> openoffice-debian-menus 4.1.3-9783
>
> rmdir: failed to remove '/var/lib/libreoffice/share/prereg/': No such file
> or directory
> rmdir: failed to remove '/var/lib/libreoffice/share/': No such file or
> directory
> rmdir: failed to remove '/var/lib/libreoffice/program/': No such file or
> directory
> rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
> rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
> Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
> Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
> Processing triggers for mime-support (3.59ubuntu1) ...
> Processing triggers for gnome-icon-theme (3.12.0-1ubuntu3) ...
> Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
> Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...
> Processing triggers for man-db (2.7.5-1) ...
> Errors were encountered while processing:
>   /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> A package failed to install.  Trying to recover:
> dpkg: dependency problems prevent configuration of libreoffice-help-en-us:
>   libreoffice-help-en-us depends on libreoffice-l10n-en-us; however:
>    Package libreoffice-l10n-en-us is not installed.
>
> dpkg: error processing package libreoffice-help-en-us (--configure):
>   dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-style-galaxy:
>   libreoffice-style-galaxy depends on libreoffice-common (=
> 1:5.1.6~rc2-0ubuntu1~xenial2); however:
>    Package libreoffice-common is not installed.
>
> dpkg: error processing package libreoffice-style-galaxy (--configure):
>   dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-core:
>   libreoffice-core depends on libreoffice-common (>> 1:5.1.6~rc2); however:
>    Package libreoffice-common is not installed.
>
> dpkg: error processing package libreoffice-core (--configure):
>   dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-l10n-en-gb:
>   libreoffice-l10n-en-gb depends on libreoffice-common; however:
>    Package libreoffice-common is not installed.
>
> dpkg: error processing package libreoffice-l10n-en-gb (--configure):
>   dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of
> libreoffice-style-elementary:
>   libreoffice-style-elementary depends on libreoffice-style-galaxy; however:
>    Package libreoffice-style-galaxy is not configured yet.
>   libreoffice-style-elementary depends on libreoffice-common (=
> 1:5.1.6~rc2-0ubuntu1~xenial2); however:
>    Package libreoffice-common is not installed.
>
> dpkg: error processing package libreoffice-style-elementary (--configure):
>   dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of python3-uno:
>   python3-uno depends on libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial2);
> however:
>    Package libreoffice-core is not configured yet.
>
> dpkg: error processing package python3-uno (--configure):
>   dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-l10n-en-za:
>   libreoffice-l10n-en-za depends on libreoffice-common; however:
>    Package libreoffice-common is not installed.
>
> dpkg: error processing package libreoffice-l10n-en-za (--configure):
>   dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-writer:
>   libreoffice-writer depends on libreoffice-core (=
> 1:5.1.6~rc2-0ubuntu1~xenial2); however:
>    Package libreoffice-core is not configured yet.
>
> dpkg: error processing package libreoffice-writer (--configure):
>   dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-math:
>   libreoffice-math depends on libreoffice-core (=
> 1:5.1.6~rc2-0ubuntu1~xenial2); however:
>    Package libreoffice-core is not configured yet.
>
> dpkg: error processing package libreoffice-math (--configure):
>   dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-help-en-gb:
>   libreoffice-help-en-gb depends on libreoffice-l10n-en-gb; however:
>    Package libreoffice-l10n-en-gb is not configured yet.
>   libreoffice-help-en-gb depends on libreoffice-style-default; however:
>    Package libreoffice-style-default is not installed.
>    Package libreoffice-style-elementary which provides
> libreoffice-style-default is not configured yet.
>    Package libreoffice-style-galaxy which provides libreoffice-style-default
> is not configured yet.
>   libreoffice-help-en-gb depends on libreoffice-writer |
> language-support-translations-en; however:
>    Package libreoffice-writer is not configured yet.
>    Package language-support-translations-en is not installed.
>
> dpkg: error processing package libreoffice-help-en-gb (--configure):
>   dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libreoffice-base-core:
>   libreoffice-base-core depends on libreoffice-core (=
> 1:5.1.6~rc2-0ubuntu1~xenial2); however:
>    Package libreoffice-core is not configured yet.
>
> dpkg: error processing package libreoffice-base-core (--configure):
>   dependency problems - leaving unconfigured
>
>
>
>
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: There is a problem with the shared '/usr/bin/soffice' between Libreoffice and OpenOffice.

jonathon-3
In reply to this post by Wroger Wroger
On 11/19/2017 09:55 PM, Wroger Wroger wrote:
> /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb:

That tells me that you are using the version from Ubuntu. For at least
the last decade, Ubuntu has added its own plethora of bugs to the
software found in its repositories.

FWIW, Ubuntu is not the only distro that sees adding bugs to the
software it distributes is a virtue to be admired, and replicated as
often as possible.

jonathon


signature.asc (836 bytes) Download Attachment