Unsuccessful test of AOO 4.5 from buildbot output

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

Unsuccessful test of AOO 4.5 from buildbot output

Kay Schenk-2
Hello all --
I just installed the AOO 4.5.0 for Linux-64 from the buildbots
https://ci.apache.org/projects/openoffice/install/linux64/

I'm getting errors (multiple occurrence of each) as follows:

l/ib64/libstdc++.so.6: version `CXXABI_1.3.8' not found
/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found
/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found
/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found

Do these reference new library requirements -- I'm on CentOS7 --or are they
the result of the differences between the buildbot environment and my
machine?

Thanks.

________________________________________
Kay
Reply | Threaded
Open this post in threaded view
|

Re: Unsuccessful test of AOO 4.5 from buildbot output

Carl Marcum


On 2/25/20 6:55 PM, Kay Schenk wrote:

> Hello all --
> I just installed the AOO 4.5.0 for Linux-64 from the buildbots
> https://ci.apache.org/projects/openoffice/install/linux64/
>
> I'm getting errors (multiple occurrence of each) as follows:
>
> l/ib64/libstdc++.so.6: version `CXXABI_1.3.8' not found
> /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found
> /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found
> /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found
>
> Do these reference new library requirements -- I'm on CentOS7 --or are they
> the result of the differences between the buildbot environment and my
> machine?
>
> Thanks.
>
> ________________________________________
> Kay
>
Hi Kay,

I just installed the en-US RPM's from there and got the same result on
my CentOS 7 VM that I rolled back to before installing all the build
dependencies.

Best regards,
Carl

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Unsuccessful test of AOO 4.5 from buildbot output

Drew Jensen
Just download the 4.5 files (no sdk, just the main application w/en_us )
Did a parallel install on Ubuntu 18.04 KDE/Plasma
Install went fine.
Ran a couple of largish writer files into it, did a little light editing -
no problems.
Created a quick small Impress file (no animation) and no problems.
Installed Oracle Report Builder extension - ran a couple of example dbs
with macro controlled report generation - no problems.
Calc; made a quick little spread sheet with a graph, really simple - no
problems.
Then I opened an .xls file I use for testing calculations performance and
ran into a bit of an issue.
Compared to 4.1.6 the file required noticeably more time to load compared
to 4.1.6 (2 sheets, data sheet has 18,048 rows of data)
Forced a recalculation of the full sheet and here version 4.5 was much
worse performance wise over the 4.1.6 version.
4.1.6 takes just a tad but less then 4 minutes to finish and 4.5 took over
6 minutes.

Anyway, hope that feedback helps.

Best wishes,

Drew

On Tue, Feb 25, 2020 at 8:22 PM Carl Marcum <[hidden email]> wrote:

>
>
> On 2/25/20 6:55 PM, Kay Schenk wrote:
> > Hello all --
> > I just installed the AOO 4.5.0 for Linux-64 from the buildbots
> > https://ci.apache.org/projects/openoffice/install/linux64/
> >
> > I'm getting errors (multiple occurrence of each) as follows:
> >
> > l/ib64/libstdc++.so.6: version `CXXABI_1.3.8' not found
> > /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found
> > /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found
> > /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found
> >
> > Do these reference new library requirements -- I'm on CentOS7 --or are
> they
> > the result of the differences between the buildbot environment and my
> > machine?
> >
> > Thanks.
> >
> > ________________________________________
> > Kay
> >
> Hi Kay,
>
> I just installed the en-US RPM's from there and got the same result on
> my CentOS 7 VM that I rolled back to before installing all the build
> dependencies.
>
> Best regards,
> Carl
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Unsuccessful test of AOO 4.5 from buildbot output

Kay Schenk-2
In reply to this post by Carl Marcum
Hi Carl and thanks for the response.

Hmmmm....apparently we need a newer version of gcc  --

https://unix.stackexchange.com/questions/503358/missing-lib64-libstdc-so-6-version-cxxabi-1-3-8-and-cxxabi-1-3-9-on-cento

The buildbot is running on Ubuntu but I don't know what version,and I don't
know what gcc it has.  😕

The actual releases of AOO are built on CentOS systems. Not sure what
version is being used currently, maybe 6.

On Tue, Feb 25, 2020 at 5:22 PM Carl Marcum <[hidden email]> wrote:

>
>
> On 2/25/20 6:55 PM, Kay Schenk wrote:
> > Hello all --
> > I just installed the AOO 4.5.0 for Linux-64 from the buildbots
> > https://ci.apache.org/projects/openoffice/install/linux64/
> >
> > I'm getting errors (multiple occurrence of each) as follows:
> >
> > l/ib64/libstdc++.so.6: version `CXXABI_1.3.8' not found
> > /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found
> > /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found
> > /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found
> >
> > Do these reference new library requirements -- I'm on CentOS7 --or are
> they
> > the result of the differences between the buildbot environment and my
> > machine?
> >
> > Thanks.
> >
> > ________________________________________
> > Kay
> >
> Hi Kay,
>
> I just installed the en-US RPM's from there and got the same result on
> my CentOS 7 VM that I rolled back to before installing all the build
> dependencies.
>
> Best regards,
> Carl
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

--
"And in the end, only kindness matters."
   -- Jewel, "Hands"
________________________________________
MzK
Reply | Threaded
Open this post in threaded view
|

Re: Unsuccessful test of AOO 4.5 from buildbot output

Pedro Lino-3
Hi Kay

Installed the Portuguese and English 4.5.0 x64 build from the buildbot and both worked perfectly under Ubuntu 18.04.4 x64

Where do you see these error messages?

Regards,
Pedro

> On February 26, 2020 9:31 PM Kay Schenk <[hidden email]> wrote:
>
>  
> Hi Carl and thanks for the response.
>
> Hmmmm....apparently we need a newer version of gcc  --
>
> https://unix.stackexchange.com/questions/503358/missing-lib64-libstdc-so-6-version-cxxabi-1-3-8-and-cxxabi-1-3-9-on-cento
>
> The buildbot is running on Ubuntu but I don't know what version,and I don't
> know what gcc it has.  😕
>
> The actual releases of AOO are built on CentOS systems. Not sure what
> version is being used currently, maybe 6.
>
> On Tue, Feb 25, 2020 at 5:22 PM Carl Marcum <[hidden email]> wrote:
>
> >
> >
> > On 2/25/20 6:55 PM, Kay Schenk wrote:
> > > Hello all --
> > > I just installed the AOO 4.5.0 for Linux-64 from the buildbots
> > > https://ci.apache.org/projects/openoffice/install/linux64/
> > >
> > > I'm getting errors (multiple occurrence of each) as follows:
> > >
> > > l/ib64/libstdc++.so.6: version `CXXABI_1.3.8' not found
> > > /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found
> > > /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found
> > > /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found
> > >
> > > Do these reference new library requirements -- I'm on CentOS7 --or are
> > they
> > > the result of the differences between the buildbot environment and my
> > > machine?
> > >
> > > Thanks.
> > >
> > > ________________________________________
> > > Kay
> > >
> > Hi Kay,
> >
> > I just installed the en-US RPM's from there and got the same result on
> > my CentOS 7 VM that I rolled back to before installing all the build
> > dependencies.
> >
> > Best regards,
> > Carl
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>
> --
> "And in the end, only kindness matters."
>    -- Jewel, "Hands"
> ________________________________________
> MzK

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Unsuccessful test of AOO 4.5 from buildbot output

Kay Schenk-2
Hi Pedro --

I see these messages as soon as I start up the new OpenOffice from
command line and it will not continue -- bring up the application.  I
have it installed in a separate directory from my "production" version.
Carl and I are both on CentOS7 with an older gcc it seems and he got
this as well. I remember ahvign this same issue quite some time ago with
the buildbot version. Production versions, because they are built on
older platforms, don't seem to have this issue.

Regards,

Kay

On 2/26/20 2:20 PM, Pedro Lino wrote:

> Hi Kay
>
> Installed the Portuguese and English 4.5.0 x64 build from the buildbot and both worked perfectly under Ubuntu 18.04.4 x64
>
> Where do you see these error messages?
>
> Regards,
> Pedro
>
>> On February 26, 2020 9:31 PM Kay Schenk <[hidden email]> wrote:
>>
>>  
>> Hi Carl and thanks for the response.
>>
>> Hmmmm....apparently we need a newer version of gcc  --
>>
>> https://unix.stackexchange.com/questions/503358/missing-lib64-libstdc-so-6-version-cxxabi-1-3-8-and-cxxabi-1-3-9-on-cento
>>
>> The buildbot is running on Ubuntu but I don't know what version,and I don't
>> know what gcc it has.  😕
>>
>> The actual releases of AOO are built on CentOS systems. Not sure what
>> version is being used currently, maybe 6.
>>
>> On Tue, Feb 25, 2020 at 5:22 PM Carl Marcum <[hidden email]> wrote:
>>
>>>
>>> On 2/25/20 6:55 PM, Kay Schenk wrote:
>>>> Hello all --
>>>> I just installed the AOO 4.5.0 for Linux-64 from the buildbots
>>>> https://ci.apache.org/projects/openoffice/install/linux64/
>>>>
>>>> I'm getting errors (multiple occurrence of each) as follows:
>>>>
>>>> l/ib64/libstdc++.so.6: version `CXXABI_1.3.8' not found
>>>> /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found
>>>> /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found
>>>> /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found
>>>>
>>>> Do these reference new library requirements -- I'm on CentOS7 --or are
>>> they
>>>> the result of the differences between the buildbot environment and my
>>>> machine?
>>>>
>>>> Thanks.
>>>>
>>>> ________________________________________
>>>> Kay
>>>>
>>> Hi Kay,
>>>
>>> I just installed the en-US RPM's from there and got the same result on
>>> my CentOS 7 VM that I rolled back to before installing all the build
>>> dependencies.
>>>
>>> Best regards,
>>> Carl
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>>
>> --
>> "And in the end, only kindness matters."
>>     -- Jewel, "Hands"
>> ________________________________________
>> MzK
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Unsuccessful test of AOO 4.5 from buildbot output

Carl Marcum


On 2/26/20 6:49 PM, Kay Schenk wrote:

> Hi Pedro --
>
> I see these messages as soon as I start up the new OpenOffice from
> command line and it will not continue -- bring up the application.  I
> have it installed in a separate directory from my "production"
> version. Carl and I are both on CentOS7 with an older gcc it seems and
> he got this as well. I remember ahvign this same issue quite some time
> ago with the buildbot version. Production versions, because they are
> built on older platforms, don't seem to have this issue.
>
> Regards,
>
> Kay
>
> On 2/26/20 2:20 PM, Pedro Lino wrote:
>> Hi Kay
>>
>> Installed the Portuguese and English 4.5.0 x64 build from the
>> buildbot and both worked perfectly under Ubuntu 18.04.4 x64
>>
>> Where do you see these error messages?
>>
>> Regards,
>> Pedro
>>
>>> On February 26, 2020 9:31 PM Kay Schenk <[hidden email]> wrote:
>>>
>>>   Hi Carl and thanks for the response.
>>>
>>> Hmmmm....apparently we need a newer version of gcc  --
>>>
>>> https://unix.stackexchange.com/questions/503358/missing-lib64-libstdc-so-6-version-cxxabi-1-3-8-and-cxxabi-1-3-9-on-cento 
>>>
>>>
>>> The buildbot is running on Ubuntu but I don't know what version,and
>>> I don't
>>> know what gcc it has.  😕
>>>
>>> The actual releases of AOO are built on CentOS systems. Not sure what
>>> version is being used currently, maybe 6.
>>>
>>> On Tue, Feb 25, 2020 at 5:22 PM Carl Marcum <[hidden email]> wrote:
>>>
>>>>
>>>> On 2/25/20 6:55 PM, Kay Schenk wrote:
>>>>> Hello all --
>>>>> I just installed the AOO 4.5.0 for Linux-64 from the buildbots
>>>>> https://ci.apache.org/projects/openoffice/install/linux64/
>>>>>
>>>>> I'm getting errors (multiple occurrence of each) as follows:
>>>>>
>>>>> l/ib64/libstdc++.so.6: version `CXXABI_1.3.8' not found
>>>>> /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found
>>>>> /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found
>>>>> /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found
>>>>>
>>>>> Do these reference new library requirements -- I'm on CentOS7 --or
>>>>> are
>>>> they
>>>>> the result of the differences between the buildbot environment and my
>>>>> machine?
>>>>>
>>>>> Thanks.
>>>>>
>>>>> ________________________________________
>>>>> Kay
>>>>>
>>>> Hi Kay,
>>>>
>>>> I just installed the en-US RPM's from there and got the same result on
>>>> my CentOS 7 VM that I rolled back to before installing all the build
>>>> dependencies.
>>>>
>>>> Best regards,
>>>> Carl
>>>>

My CentOS 7 gcc is 4.8.5

The 4.5 I built on the machine ran fine.

I installed the buildbot en-US deb packages on my Ubuntu 18 VM and it runs.
I forgot to note the gcc exact version but it's 7.x

Thanks,
Carl


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Unsuccessful test of AOO 4.5 from buildbot output

Peter Kovacs-4
This is the explanation to the Issue:

https://stackoverflow.com/questions/23494103/version-cxxabi-1-3-8-not-found-required-by#23494975


We do our test builds on Ubuntu, but they are not out of the box
downgrade able to older Linuxes.

You could install a newer Gcc on Centos 7.

Or you could build AOO in the Centos7 machine to get a valid build.


It has nothing to do with our build requirements. Just with the build
setup on the buildbots.


Am 27.02.20 um 01:36 schrieb Carl Marcum:

>
>
> On 2/26/20 6:49 PM, Kay Schenk wrote:
>> Hi Pedro --
>>
>> I see these messages as soon as I start up the new OpenOffice from
>> command line and it will not continue -- bring up the application.  I
>> have it installed in a separate directory from my "production"
>> version. Carl and I are both on CentOS7 with an older gcc it seems
>> and he got this as well. I remember ahvign this same issue quite some
>> time ago with the buildbot version. Production versions, because they
>> are built on older platforms, don't seem to have this issue.
>>
>> Regards,
>>
>> Kay
>>
>> On 2/26/20 2:20 PM, Pedro Lino wrote:
>>> Hi Kay
>>>
>>> Installed the Portuguese and English 4.5.0 x64 build from the
>>> buildbot and both worked perfectly under Ubuntu 18.04.4 x64
>>>
>>> Where do you see these error messages?
>>>
>>> Regards,
>>> Pedro
>>>
>>>> On February 26, 2020 9:31 PM Kay Schenk <[hidden email]> wrote:
>>>>
>>>>   Hi Carl and thanks for the response.
>>>>
>>>> Hmmmm....apparently we need a newer version of gcc  --
>>>>
>>>> https://unix.stackexchange.com/questions/503358/missing-lib64-libstdc-so-6-version-cxxabi-1-3-8-and-cxxabi-1-3-9-on-cento 
>>>>
>>>>
>>>> The buildbot is running on Ubuntu but I don't know what version,and
>>>> I don't
>>>> know what gcc it has.  😕
>>>>
>>>> The actual releases of AOO are built on CentOS systems. Not sure what
>>>> version is being used currently, maybe 6.
>>>>
>>>> On Tue, Feb 25, 2020 at 5:22 PM Carl Marcum <[hidden email]>
>>>> wrote:
>>>>
>>>>>
>>>>> On 2/25/20 6:55 PM, Kay Schenk wrote:
>>>>>> Hello all --
>>>>>> I just installed the AOO 4.5.0 for Linux-64 from the buildbots
>>>>>> https://ci.apache.org/projects/openoffice/install/linux64/
>>>>>>
>>>>>> I'm getting errors (multiple occurrence of each) as follows:
>>>>>>
>>>>>> l/ib64/libstdc++.so.6: version `CXXABI_1.3.8' not found
>>>>>> /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found
>>>>>> /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found
>>>>>> /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found
>>>>>>
>>>>>> Do these reference new library requirements -- I'm on CentOS7
>>>>>> --or are
>>>>> they
>>>>>> the result of the differences between the buildbot environment
>>>>>> and my
>>>>>> machine?
>>>>>>
>>>>>> Thanks.
>>>>>>
>>>>>> ________________________________________
>>>>>> Kay
>>>>>>
>>>>> Hi Kay,
>>>>>
>>>>> I just installed the en-US RPM's from there and got the same
>>>>> result on
>>>>> my CentOS 7 VM that I rolled back to before installing all the build
>>>>> dependencies.
>>>>>
>>>>> Best regards,
>>>>> Carl
>>>>>
>
> My CentOS 7 gcc is 4.8.5
>
> The 4.5 I built on the machine ran fine.
>
> I installed the buildbot en-US deb packages on my Ubuntu 18 VM and it
> runs.
> I forgot to note the gcc exact version but it's 7.x
>
> Thanks,
> Carl
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Unsuccessful test of AOO 4.5 from buildbot output

Pedro Lino-3
In reply to this post by Kay Schenk-2
Hi Kay

> On February 26, 2020 11:49 PM Kay Schenk <[hidden email]> wrote:
>
> I see these messages as soon as I start up the new OpenOffice from
> command line and it will not continue -- bring up the application.  I
> have it installed in a separate directory from my "production" version.
> Carl and I are both on CentOS7 with an older gcc it seems and he got
> this as well. I remember ahvign this same issue quite some time ago with
> the buildbot version. Production versions, because they are built on
> older platforms, don't seem to have this issue.

That is what I figured.
Starting version 4.5 (buildbot) from command I get

Gtk-Message: 09:25:35.089: Failed to load module "canberra-gtk-module"

** (soffice:6631): WARNING **: 09:25:35.096: Unknown type: GailWindow

But this is exactly the same error message that I get if I do the same with version 4.1.7 so it is not a regression...

I have no idea if it is relevant but something is missing.

Regards,
Pedro

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Unsuccessful test of AOO 4.5 from buildbot output

Rory O'Farrell
On Thu, 27 Feb 2020 09:33:40 +0000 (WET)
Pedro Lino <[hidden email]> wrote:

> Hi Kay
>
> > On February 26, 2020 11:49 PM Kay Schenk <[hidden email]> wrote:
> >
> > I see these messages as soon as I start up the new OpenOffice from
> > command line and it will not continue -- bring up the application.  I
> > have it installed in a separate directory from my "production" version.
> > Carl and I are both on CentOS7 with an older gcc it seems and he got
> > this as well. I remember ahvign this same issue quite some time ago with
> > the buildbot version. Production versions, because they are built on
> > older platforms, don't seem to have this issue.
>
> That is what I figured.
> Starting version 4.5 (buildbot) from command I get
>
> Gtk-Message: 09:25:35.089: Failed to load module "canberra-gtk-module"
>
> ** (soffice:6631): WARNING **: 09:25:35.096: Unknown type: GailWindow
>
> But this is exactly the same error message that I get if I do the same with version 4.1.7 so it is not a regression...
>
> I have no idea if it is relevant but something is missing.
>
> Regards,
> Pedro

It is my understanding that the canberra modules are to do with sound; the gailwindow is something to do with GNOME Accessibility Implementation Library; from its name I think it should be graphic related rather than sound related.

I note that on Xubuntu 18.04.X, starting AOO 4.1.6 and 4.1.7 in a terminal I get a gailwindow error, although OO then runs correctly for my purposes (Writer, Impress, very simple Calc).

On Xubuntu 20.04 (updated to daily updates), AOO 4.5.0 did not give gailwindow error when started in a terminal.  The version of AOO 4.5.0 I used was
AOO 450m(Build 990)
Rev 824d147bf9
2020-02-16_04:12:23

--
Rory O'Farrell <[hidden email]>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Unsuccessful test of AOO 4.5 from buildbot output

Pedro Lino-3
Hi Rory

Thank you for the quick answer and details (I just saw a similar issue answered by you on the forum).

I don't use sound on this desktop so it could be missing and I wouldn't notice it :)

As for graphics I don't notice any glitches (on AOO or any other program) so whatever gailwindow is, it is not (apparently) affecting the usability.

Thanks!
Pedro

> On February 27, 2020 11:07 AM Rory O'Farrell <[hidden email]> wrote:
>  
> On Thu, 27 Feb 2020 09:33:40 +0000 (WET)
> Pedro Lino <[hidden email]> wrote:
> >
> > That is what I figured.
> > Starting version 4.5 (buildbot) from command I get
> >
> > Gtk-Message: 09:25:35.089: Failed to load module "canberra-gtk-module"
> >
> > ** (soffice:6631): WARNING **: 09:25:35.096: Unknown type: GailWindow
> >
> > But this is exactly the same error message that I get if I do the same with version 4.1.7 so it is not a regression...
> >
> > I have no idea if it is relevant but something is missing.
>
> It is my understanding that the canberra modules are to do with sound; the gailwindow is something to do with GNOME Accessibility Implementation Library; from its name I think it should be graphic related rather than sound related.
>
> I note that on Xubuntu 18.04.X, starting AOO 4.1.6 and 4.1.7 in a terminal I get a gailwindow error, although OO then runs correctly for my purposes (Writer, Impress, very simple Calc).
>
> On Xubuntu 20.04 (updated to daily updates), AOO 4.5.0 did not give gailwindow error when started in a terminal.  The version of AOO 4.5.0 I used was
> AOO 450m(Build 990)
> Rev 824d147bf9
> 2020-02-16_04:12:23
>
> --
> Rory O'Farrell <[hidden email]>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Unsuccessful test of AOO 4.5 from buildbot output

Rory O'Farrell
On Thu, 27 Feb 2020 12:13:26 +0000 (WET)
Pedro Lino <[hidden email]> wrote:

> Hi Rory
>
> Thank you for the quick answer and details (I just saw a similar issue answered by you on the forum).
>
> I don't use sound on this desktop so it could be missing and I wouldn't notice it :)

I use sound sometimes from VLC media player for testing of a copy video DVD, and sometimes to play a clip from TV (bbc.co.uk) to catch up on a news item; these are handled by Xubuntu.  I don't play media from Impress presentations - waitiong until we get the gstreamer 1.0 properly integrated into Impress - any media (rarely used) in one of my Impress presentations (a video clip) I set up to be handled by the system media player or VLC - clunky, but it works.

The gailwindow problem seems to only concern OpenOffice and to have no obvious effect bad effect.

I have a test machine running Xubuntu 20.04, on which I'll try any test 4.2.0 or 4.5.0

Rory

>
> As for graphics I don't notice any glitches (on AOO or any other program) so whatever gailwindow is, it is not (apparently) affecting the usability.
>
> Thanks!
> Pedro
>
> > On February 27, 2020 11:07 AM Rory O'Farrell <[hidden email]> wrote:
> >  
> > On Thu, 27 Feb 2020 09:33:40 +0000 (WET)
> > Pedro Lino <[hidden email]> wrote:
> > >
> > > That is what I figured.
> > > Starting version 4.5 (buildbot) from command I get
> > >
> > > Gtk-Message: 09:25:35.089: Failed to load module "canberra-gtk-module"
> > >
> > > ** (soffice:6631): WARNING **: 09:25:35.096: Unknown type: GailWindow
> > >
> > > But this is exactly the same error message that I get if I do the same with version 4.1.7 so it is not a regression...
> > >
> > > I have no idea if it is relevant but something is missing.
> >
> > It is my understanding that the canberra modules are to do with sound; the gailwindow is something to do with GNOME Accessibility Implementation Library; from its name I think it should be graphic related rather than sound related.
> >
> > I note that on Xubuntu 18.04.X, starting AOO 4.1.6 and 4.1.7 in a terminal I get a gailwindow error, although OO then runs correctly for my purposes (Writer, Impress, very simple Calc).
> >
> > On Xubuntu 20.04 (updated to daily updates), AOO 4.5.0 did not give gailwindow error when started in a terminal.  The version of AOO 4.5.0 I used was
> > AOO 450m(Build 990)
> > Rev 824d147bf9
> > 2020-02-16_04:12:23
> >
> > --
> > Rory O'Farrell <[hidden email]>
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


--
Rory O'Farrell <[hidden email]>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Unsuccessful test of AOO 4.5 from buildbot output

Kay Schenk-2
In reply to this post by Peter Kovacs-4
Hi Peter--

Thanks for the explanation. My current libstdc++.so.6 only defines up to
CXXABI_1.3.7. It would help if we knew what C++ version is used in the
buildbots. Oddly, I have version 4.8.5 linked to 4.8.2 on my system.

Meanwhile, I will work on doing my own build.

Regards,

Kay

On 2/27/20 12:06 AM, Peter Kovacs wrote:

> This is the explanation to the Issue:
>
> https://stackoverflow.com/questions/23494103/version-cxxabi-1-3-8-not-found-required-by#23494975 
>
>
>
> We do our test builds on Ubuntu, but they are not out of the box
> downgrade able to older Linuxes.
>
> You could install a newer Gcc on Centos 7.
>
> Or you could build AOO in the Centos7 machine to get a valid build.
>
>
> It has nothing to do with our build requirements. Just with the build
> setup on the buildbots.
>
>
> Am 27.02.20 um 01:36 schrieb Carl Marcum:
>>
>>
>> On 2/26/20 6:49 PM, Kay Schenk wrote:
>>> Hi Pedro --
>>>
>>> I see these messages as soon as I start up the new OpenOffice from
>>> command line and it will not continue -- bring up the application. 
>>> I have it installed in a separate directory from my "production"
>>> version. Carl and I are both on CentOS7 with an older gcc it seems
>>> and he got this as well. I remember ahvign this same issue quite
>>> some time ago with the buildbot version. Production versions,
>>> because they are built on older platforms, don't seem to have this
>>> issue.
>>>
>>> Regards,
>>>
>>> Kay
>>>
>>> On 2/26/20 2:20 PM, Pedro Lino wrote:
>>>> Hi Kay
>>>>
>>>> Installed the Portuguese and English 4.5.0 x64 build from the
>>>> buildbot and both worked perfectly under Ubuntu 18.04.4 x64
>>>>
>>>> Where do you see these error messages?
>>>>
>>>> Regards,
>>>> Pedro
>>>>
>>>>> On February 26, 2020 9:31 PM Kay Schenk <[hidden email]> wrote:
>>>>>
>>>>>   Hi Carl and thanks for the response.
>>>>>
>>>>> Hmmmm....apparently we need a newer version of gcc  --
>>>>>
>>>>> https://unix.stackexchange.com/questions/503358/missing-lib64-libstdc-so-6-version-cxxabi-1-3-8-and-cxxabi-1-3-9-on-cento 
>>>>>
>>>>>
>>>>> The buildbot is running on Ubuntu but I don't know what
>>>>> version,and I don't
>>>>> know what gcc it has.  😕
>>>>>
>>>>> The actual releases of AOO are built on CentOS systems. Not sure what
>>>>> version is being used currently, maybe 6.
>>>>>
>>>>> On Tue, Feb 25, 2020 at 5:22 PM Carl Marcum <[hidden email]>
>>>>> wrote:
>>>>>
>>>>>>
>>>>>> On 2/25/20 6:55 PM, Kay Schenk wrote:
>>>>>>> Hello all --
>>>>>>> I just installed the AOO 4.5.0 for Linux-64 from the buildbots
>>>>>>> https://ci.apache.org/projects/openoffice/install/linux64/
>>>>>>>
>>>>>>> I'm getting errors (multiple occurrence of each) as follows:
>>>>>>>
>>>>>>> l/ib64/libstdc++.so.6: version `CXXABI_1.3.8' not found
>>>>>>> /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found
>>>>>>> /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found
>>>>>>> /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found
>>>>>>>
>>>>>>> Do these reference new library requirements -- I'm on CentOS7
>>>>>>> --or are
>>>>>> they
>>>>>>> the result of the differences between the buildbot environment
>>>>>>> and my
>>>>>>> machine?
>>>>>>>
>>>>>>> Thanks.
>>>>>>>
>>>>>>> ________________________________________
>>>>>>> Kay
>>>>>>>
>>>>>> Hi Kay,
>>>>>>
>>>>>> I just installed the en-US RPM's from there and got the same
>>>>>> result on
>>>>>> my CentOS 7 VM that I rolled back to before installing all the build
>>>>>> dependencies.
>>>>>>
>>>>>> Best regards,
>>>>>> Carl
>>>>>>
>>
>> My CentOS 7 gcc is 4.8.5
>>
>> The 4.5 I built on the machine ran fine.
>>
>> I installed the buildbot en-US deb packages on my Ubuntu 18 VM and it
>> runs.
>> I forgot to note the gcc exact version but it's 7.x
>>
>> Thanks,
>> Carl
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
Reply | Threaded
Open this post in threaded view
|

Re: Unsuccessful test of AOO 4.5 from buildbot output

Carl Marcum


On 2/27/20 12:50 PM, Kay Schenk wrote:

> Hi Peter--
>
> Thanks for the explanation. My current libstdc++.so.6 only defines up
> to CXXABI_1.3.7. It would help if we knew what C++ version is used in
> the buildbots. Oddly, I have version 4.8.5 linked to 4.8.2 on my system.
>
> Meanwhile, I will work on doing my own build.
>
> Regards,
>
> Kay
>
> On 2/27/20 12:06 AM, Peter Kovacs wrote:
>> This is the explanation to the Issue:
>>
>> https://stackoverflow.com/questions/23494103/version-cxxabi-1-3-8-not-found-required-by#23494975 
>>
>>
>>
>> We do our test builds on Ubuntu, but they are not out of the box
>> downgrade able to older Linuxes.
>>
>> You could install a newer Gcc on Centos 7.
>>
>> Or you could build AOO in the Centos7 machine to get a valid build.
>>
>>
>> It has nothing to do with our build requirements. Just with the build
>> setup on the buildbots.
>>
>>
>> Am 27.02.20 um 01:36 schrieb Carl Marcum:
>>>
>>>
>>> On 2/26/20 6:49 PM, Kay Schenk wrote:
>>>> Hi Pedro --
>>>>
>>>> I see these messages as soon as I start up the new OpenOffice from
>>>> command line and it will not continue -- bring up the application. 
>>>> I have it installed in a separate directory from my "production"
>>>> version. Carl and I are both on CentOS7 with an older gcc it seems
>>>> and he got this as well. I remember ahvign this same issue quite
>>>> some time ago with the buildbot version. Production versions,
>>>> because they are built on older platforms, don't seem to have this
>>>> issue.
>>>>
>>>> Regards,
>>>>
>>>> Kay
>>>>
>>>> On 2/26/20 2:20 PM, Pedro Lino wrote:
>>>>> Hi Kay
>>>>>
>>>>> Installed the Portuguese and English 4.5.0 x64 build from the
>>>>> buildbot and both worked perfectly under Ubuntu 18.04.4 x64
>>>>>
>>>>> Where do you see these error messages?
>>>>>
>>>>> Regards,
>>>>> Pedro
>>>>>
>>>>>> On February 26, 2020 9:31 PM Kay Schenk <[hidden email]>
>>>>>> wrote:
>>>>>>
>>>>>>   Hi Carl and thanks for the response.
>>>>>>
>>>>>> Hmmmm....apparently we need a newer version of gcc  --
>>>>>>
>>>>>> https://unix.stackexchange.com/questions/503358/missing-lib64-libstdc-so-6-version-cxxabi-1-3-8-and-cxxabi-1-3-9-on-cento 
>>>>>>
>>>>>>
>>>>>> The buildbot is running on Ubuntu but I don't know what
>>>>>> version,and I don't
>>>>>> know what gcc it has.  😕
>>>>>>
>>>>>> The actual releases of AOO are built on CentOS systems. Not sure
>>>>>> what
>>>>>> version is being used currently, maybe 6.
>>>>>>
>>>>>> On Tue, Feb 25, 2020 at 5:22 PM Carl Marcum <[hidden email]>
>>>>>> wrote:
>>>>>>
>>>>>>>
>>>>>>> On 2/25/20 6:55 PM, Kay Schenk wrote:
>>>>>>>> Hello all --
>>>>>>>> I just installed the AOO 4.5.0 for Linux-64 from the buildbots
>>>>>>>> https://ci.apache.org/projects/openoffice/install/linux64/
>>>>>>>>
>>>>>>>> I'm getting errors (multiple occurrence of each) as follows:
>>>>>>>>
>>>>>>>> l/ib64/libstdc++.so.6: version `CXXABI_1.3.8' not found
>>>>>>>> /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found
>>>>>>>> /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found
>>>>>>>> /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found
>>>>>>>>
>>>>>>>> Do these reference new library requirements -- I'm on CentOS7
>>>>>>>> --or are
>>>>>>> they
>>>>>>>> the result of the differences between the buildbot environment
>>>>>>>> and my
>>>>>>>> machine?
>>>>>>>>
>>>>>>>> Thanks.
>>>>>>>>
>>>>>>>> ________________________________________
>>>>>>>> Kay
>>>>>>>>
>>>>>>> Hi Kay,
>>>>>>>
>>>>>>> I just installed the en-US RPM's from there and got the same
>>>>>>> result on
>>>>>>> my CentOS 7 VM that I rolled back to before installing all the
>>>>>>> build
>>>>>>> dependencies.
>>>>>>>
>>>>>>> Best regards,
>>>>>>> Carl
>>>>>>>
>>>
>>> My CentOS 7 gcc is 4.8.5
>>>
>>> The 4.5 I built on the machine ran fine.
>>>
>>> I installed the buildbot en-US deb packages on my Ubuntu 18 VM and
>>> it runs.
>>> I forgot to note the gcc exact version but it's 7.x
>>>
>>> Thanks,
>>> Carl

The 4.5 build from Feb 24 runs fine on my CentOS 8 VM with gcc 8.3.1

Thanks,
Carl


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]