config error on Windows 7

classic Classic list List threaded Threaded
18 messages Options
Reply | Threaded
Open this post in threaded view
|

config error on Windows 7

Clarence GUO
Hi~
When I set up build ENV on Window7, I met a error when configure, what does
it mean?

Can't find MS Visual Studio / VC++ at ./oowintool line 236.
configure: error: oowintool failed to copy CRT

Cannot find VC. But I already saw configure said "checking the Microsoft
C/C++ Compiler... found "

Thanks,
Clarence
Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

John O'Sullivan
Clarence,

The configure script uses flags and env vars to discover the root dir for
the VC install, which is why it's reporting it as found. ./oowintool is
relying on you path being set to pick up cl.exe. You can fix that by
changing your path in Control Panel/System/Environment Variables, or by
running vcvars32.bat from the VC dir tree before you launch the configure
script.

Cheers
John


On Fri, Sep 13, 2013 at 9:48 AM, Clarence GUO <[hidden email]>wrote:

> Hi~
> When I set up build ENV on Window7, I met a error when configure, what does
> it mean?
>
> Can't find MS Visual Studio / VC++ at ./oowintool line 236.
> configure: error: oowintool failed to copy CRT
>
> Cannot find VC. But I already saw configure said "checking the Microsoft
> C/C++ Compiler... found "
>
> Thanks,
> Clarence
>
Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

Clarence GUO
John,
Thanks for your information, I tried these two methods but they both don't
work at my side.
I'll check if there is some environment problem on my machine.

Thanks & BRs
Clarence


2013/9/16 John O'Sullivan <[hidden email]>

> Clarence,
>
> The configure script uses flags and env vars to discover the root dir for
> the VC install, which is why it's reporting it as found. ./oowintool is
> relying on you path being set to pick up cl.exe. You can fix that by
> changing your path in Control Panel/System/Environment Variables, or by
> running vcvars32.bat from the VC dir tree before you launch the configure
> script.
>
> Cheers
> John
>
>
> On Fri, Sep 13, 2013 at 9:48 AM, Clarence GUO <[hidden email]
> >wrote:
>
> > Hi~
> > When I set up build ENV on Window7, I met a error when configure, what
> does
> > it mean?
> >
> > Can't find MS Visual Studio / VC++ at ./oowintool line 236.
> > configure: error: oowintool failed to copy CRT
> >
> > Cannot find VC. But I already saw configure said "checking the Microsoft
> > C/C++ Compiler... found "
> >
> > Thanks,
> > Clarence
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

Oliver-Rainer Wittmann
In reply to this post by Clarence GUO
Hi Clarence,

On 13.09.2013 10:48, Clarence GUO wrote:

> Hi~
> When I set up build ENV on Window7, I met a error when configure, what does
> it mean?
>
> Can't find MS Visual Studio / VC++ at ./oowintool line 236.
> configure: error: oowintool failed to copy CRT
>
> Cannot find VC. But I already saw configure said "checking the Microsoft
> C/C++ Compiler... found "
>

Please, provide your complete 'configure' call.
Then I will be able to help you.

BTW, did you follow the AOO Windows Building guide in our wiki [1] and
[2] to setup your environment?

[1] http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
[2]
http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Building_on_Windows


Best regards, Oliver.

> Thanks,
> Clarence
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

Clarence GUO
Thanks Oliver,
I reference this wiki (
http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step#Windows_7)
for build, seems no much difference with yours.
My configure is

./configure --with-cl-home="/cygdrive/c/Program Files (x86)/Microsoft
Visual Studio 9.0/VC" --with-mspdb-path="/cygdrive/c/Program Files
(x86)/Microsoft Visual Studio 9.0/Common7/IDE"
--with-asm-home="/cygdrive/c/Program Files (x86)/Microsoft Visual Studio
9.0/Bin" --with-csc-path="/cygdrive/c/Program Files (x86)/Microsoft Visual
Studio 9.0/SDK/v3.5" --with-frame-home="/cygdrive/c/Program Files/Microsoft
SDKs/Windows/v6.1" --with-psdk-home="/cygdrive/c/Program Files/Microsoft
SDKs/Windows/v6.1" --with-midl-path="/cygdrive/c/Program Files/Microsoft
SDKs/Windows/v6.1/bin" --with-directx-home="C:/Program Files
(x86)/Microsoft DirectX SDK (June 2010)"
--with-jdk-home="/cygdrive/d/jdk1.7.0_21"
--with-ant-home="/cygdrive/d/apache-ant-1.8.4" --with-dmake-url="
http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2"
--with-epm-url="http://www.msweet.org/files/project2/epm-3.7-source.tar.gz"
--enable-pch --disable-atl --disable-activex --disable-binfilter
--without-junit

Clarence


2013/9/17 Oliver-Rainer Wittmann <[hidden email]>

> Hi Clarence,
>
>
> On 13.09.2013 10:48, Clarence GUO wrote:
>
>> Hi~
>> When I set up build ENV on Window7, I met a error when configure, what
>> does
>> it mean?
>>
>> Can't find MS Visual Studio / VC++ at ./oowintool line 236.
>> configure: error: oowintool failed to copy CRT
>>
>> Cannot find VC. But I already saw configure said "checking the Microsoft
>> C/C++ Compiler... found "
>>
>>
> Please, provide your complete 'configure' call.
> Then I will be able to help you.
>
> BTW, did you follow the AOO Windows Building guide in our wiki [1] and [2]
> to setup your environment?
>
> [1] http://wiki.openoffice.org/**wiki/Documentation/Building_**Guide_AOO<http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO>
> [2] http://wiki.openoffice.org/**wiki/Documentation/Building_**
> Guide_AOO/Building_on_Windows<http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Building_on_Windows>
>
>
> Best regards, Oliver.
>
>  Thanks,
>> Clarence
>>
>>
> ------------------------------**------------------------------**---------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.**apache.org<[hidden email]>
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

Oliver-Rainer Wittmann
Hi,

On 17.09.2013 09:59, Clarence GUO wrote:
> Thanks Oliver,
> I reference this wiki (
> http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step#Windows_7)
> for build, seems no much difference with yours.

This sample step-by-step guide is not mine.
I adapted it according to the updated general and complete requirements
which are referenced on this page.

It looks like that my attempt is not complete as I did not adjusted the
given sample configure call.
The given sample configure call does not match with the changes I have
made to the step-by-step guide

Try the following:
(1) remove the following configure options
--with-cl-home
--with-mspdb-path
--with-asm-home
--with-csc-path

(2) correct the following configure options
--with-frame-home
--with-psdk-home
--with-midl-path
I think you do not have folder "v6.1" in the folder of the Windows SDKs.
I think it must be the folder "v7.0"


Best regards, Oliver.

> My configure is
>
> ./configure --with-cl-home="/cygdrive/c/Program Files (x86)/Microsoft
> Visual Studio 9.0/VC" --with-mspdb-path="/cygdrive/c/Program Files
> (x86)/Microsoft Visual Studio 9.0/Common7/IDE"
> --with-asm-home="/cygdrive/c/Program Files (x86)/Microsoft Visual Studio
> 9.0/Bin" --with-csc-path="/cygdrive/c/Program Files (x86)/Microsoft Visual
> Studio 9.0/SDK/v3.5" --with-frame-home="/cygdrive/c/Program Files/Microsoft
> SDKs/Windows/v6.1" --with-psdk-home="/cygdrive/c/Program Files/Microsoft
> SDKs/Windows/v6.1" --with-midl-path="/cygdrive/c/Program Files/Microsoft
> SDKs/Windows/v6.1/bin" --with-directx-home="C:/Program Files
> (x86)/Microsoft DirectX SDK (June 2010)"
> --with-jdk-home="/cygdrive/d/jdk1.7.0_21"
> --with-ant-home="/cygdrive/d/apache-ant-1.8.4" --with-dmake-url="
> http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2"
> --with-epm-url="http://www.msweet.org/files/project2/epm-3.7-source.tar.gz"
> --enable-pch --disable-atl --disable-activex --disable-binfilter
> --without-junit
>
> Clarence
>
>
> 2013/9/17 Oliver-Rainer Wittmann <[hidden email]>
>
>> Hi Clarence,
>>
>>
>> On 13.09.2013 10:48, Clarence GUO wrote:
>>
>>> Hi~
>>> When I set up build ENV on Window7, I met a error when configure, what
>>> does
>>> it mean?
>>>
>>> Can't find MS Visual Studio / VC++ at ./oowintool line 236.
>>> configure: error: oowintool failed to copy CRT
>>>
>>> Cannot find VC. But I already saw configure said "checking the Microsoft
>>> C/C++ Compiler... found "
>>>
>>>
>> Please, provide your complete 'configure' call.
>> Then I will be able to help you.
>>
>> BTW, did you follow the AOO Windows Building guide in our wiki [1] and [2]
>> to setup your environment?
>>
>> [1] http://wiki.openoffice.org/**wiki/Documentation/Building_**Guide_AOO<http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO>
>> [2] http://wiki.openoffice.org/**wiki/Documentation/Building_**
>> Guide_AOO/Building_on_Windows<http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Building_on_Windows>
>>
>>
>> Best regards, Oliver.
>>
>>   Thanks,
>>> Clarence
>>>
>>>
>> ------------------------------**------------------------------**---------
>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.**apache.org<[hidden email]>
>> For additional commands, e-mail: [hidden email]
>>
>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

Oliver-Rainer Wittmann
Hi,

On 17.09.2013 10:35, Oliver-Rainer Wittmann wrote:

> Hi,
>
> On 17.09.2013 09:59, Clarence GUO wrote:
>> Thanks Oliver,
>> I reference this wiki (
>> http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step#Windows_7)
>>
>> for build, seems no much difference with yours.
>
> This sample step-by-step guide is not mine.
> I adapted it according to the updated general and complete requirements
> which are referenced on this page.
>
> It looks like that my attempt is not complete as I did not adjusted the
> given sample configure call.
> The given sample configure call does not match with the changes I have
> made to the step-by-step guide
>

I have corrected the sample step-by-step guide.

Best regards, Oliver.

> Try the following:
> (1) remove the following configure options
> --with-cl-home
> --with-mspdb-path
> --with-asm-home
> --with-csc-path
>
> (2) correct the following configure options
> --with-frame-home
> --with-psdk-home
> --with-midl-path
> I think you do not have folder "v6.1" in the folder of the Windows SDKs.
> I think it must be the folder "v7.0"
>
>
> Best regards, Oliver.
>
>> My configure is
>>
>> ./configure --with-cl-home="/cygdrive/c/Program Files (x86)/Microsoft
>> Visual Studio 9.0/VC" --with-mspdb-path="/cygdrive/c/Program Files
>> (x86)/Microsoft Visual Studio 9.0/Common7/IDE"
>> --with-asm-home="/cygdrive/c/Program Files (x86)/Microsoft Visual Studio
>> 9.0/Bin" --with-csc-path="/cygdrive/c/Program Files (x86)/Microsoft
>> Visual
>> Studio 9.0/SDK/v3.5" --with-frame-home="/cygdrive/c/Program
>> Files/Microsoft
>> SDKs/Windows/v6.1" --with-psdk-home="/cygdrive/c/Program Files/Microsoft
>> SDKs/Windows/v6.1" --with-midl-path="/cygdrive/c/Program Files/Microsoft
>> SDKs/Windows/v6.1/bin" --with-directx-home="C:/Program Files
>> (x86)/Microsoft DirectX SDK (June 2010)"
>> --with-jdk-home="/cygdrive/d/jdk1.7.0_21"
>> --with-ant-home="/cygdrive/d/apache-ant-1.8.4" --with-dmake-url="
>> http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2"
>> --with-epm-url="http://www.msweet.org/files/project2/epm-3.7-source.tar.gz"
>>
>> --enable-pch --disable-atl --disable-activex --disable-binfilter
>> --without-junit
>>
>> Clarence
>>
>>
>> 2013/9/17 Oliver-Rainer Wittmann <[hidden email]>
>>
>>> Hi Clarence,
>>>
>>>
>>> On 13.09.2013 10:48, Clarence GUO wrote:
>>>
>>>> Hi~
>>>> When I set up build ENV on Window7, I met a error when configure, what
>>>> does
>>>> it mean?
>>>>
>>>> Can't find MS Visual Studio / VC++ at ./oowintool line 236.
>>>> configure: error: oowintool failed to copy CRT
>>>>
>>>> Cannot find VC. But I already saw configure said "checking the
>>>> Microsoft
>>>> C/C++ Compiler... found "
>>>>
>>>>
>>> Please, provide your complete 'configure' call.
>>> Then I will be able to help you.
>>>
>>> BTW, did you follow the AOO Windows Building guide in our wiki [1]
>>> and [2]
>>> to setup your environment?
>>>
>>> [1]
>>> http://wiki.openoffice.org/**wiki/Documentation/Building_**Guide_AOO<http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO>
>>>
>>> [2] http://wiki.openoffice.org/**wiki/Documentation/Building_**
>>> Guide_AOO/Building_on_Windows<http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Building_on_Windows>
>>>
>>>
>>>
>>> Best regards, Oliver.
>>>
>>>   Thanks,
>>>> Clarence
>>>>
>>>>
>>> ------------------------------**------------------------------**---------
>>>
>>> To unsubscribe, e-mail:
>>> dev-unsubscribe@openoffice.**apache.org<[hidden email]>
>>>
>>> For additional commands, e-mail: [hidden email]
>>>
>>>
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

jonasalfredsson@gmail.com
Hi,

I have the same problem with my configure call.

I get error:
Can't find MS Visual Studio / VC++ at ./oowintool line 236.
configure: error: oowintool failed to copy CRT

I tried the solution suggested in earlier posts but no luck.
My configure call looks like this:

SDK_PATH="/cygdrive/c/Program Files/Microsoft SDKs/Windows/v7.0"
./configure \
    --with-frame-home="$SDK_PATH" \
    --with-psdk-home="$SDK_PATH" \
    --with-midl-path="$SDK_PATH/bin" \
    --with-directx-home="C:/Program Files (x86)/Microsoft DirectX SDK (June 2010)" \
   --with-ant-home="/cygdrive/c/apache-ant-1.8.4" \
    --with-dmake-url="http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2" \
    --with-epm-url="http://www.msweet.org/files/project2/epm-3.7-source.tar.gz" \
    --enable-pch \
    --disable-atl \
    --disable-activex \
    --disable-binfilter \
    --without-junit


/Jonas
Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

Oliver-Rainer Wittmann
Hi,

On 11.01.2014 13:41, [hidden email] wrote:

> Hi,
>
> I have the same problem with my configure call.
>
> I get error:
> Can't find MS Visual Studio / VC++ at ./oowintool line 236.
> configure: error: oowintool failed to copy CRT
>
> I tried the solution suggested in earlier posts but no luck.
> My configure call looks like this:
>
> SDK_PATH="/cygdrive/c/Program Files/Microsoft SDKs/Windows/v7.0"

Does this path/directory - C:\Program Files\Microsoft SDKs\Windows\v7.0\
- exist on your system?

Best regards, Oliver.

> ./configure \
>      --with-frame-home="$SDK_PATH" \
>      --with-psdk-home="$SDK_PATH" \
>      --with-midl-path="$SDK_PATH/bin" \
>      --with-directx-home="C:/Program Files (x86)/Microsoft DirectX SDK (June
> 2010)" \
>     --with-ant-home="/cygdrive/c/apache-ant-1.8.4" \
>
> --with-dmake-url="http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2"
> \
>
> --with-epm-url="http://www.msweet.org/files/project2/epm-3.7-source.tar.gz"
> \
>      --enable-pch \
>      --disable-atl \
>      --disable-activex \
>      --disable-binfilter \
>      --without-junit
>
>
> /Jonas
>
>
>
>
> --
> View this message in context: http://openoffice.2283327.n4.nabble.com/config-error-on-Windows-7-tp4652383p4657734.html
> Sent from the Development mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

jonasalfredsson@gmail.com
Hi,

> Does this path/directory - C:\Program Files\Microsoft SDKs\Windows\v7.0\
> - exist on your system?

The path exist, however there was a key missing in the registry.
Installing Visual studio express did not add the key specifying where to find VC. I simply added the key oowintool was looking for on line 236.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\Setup\VC\ProductDir
and gave it the value "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC"

After that the configure and bootstrap steps executed ok, as far as I can see.

/Jonas
Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

Oliver-Rainer Wittmann
Hi,

On 16.01.2014 13:37, [hidden email] wrote:

> Hi,
>
>> Does this path/directory - C:\Program Files\Microsoft SDKs\Windows\v7.0\
>> - exist on your system?
>
> The path exist, however there was a key missing in the registry.
> Installing Visual studio express did not add the key specifying where to
> find VC. I simply added the key oowintool was looking for on line 236.
> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\Setup\VC\ProductDir
> and gave it the value "C:\Program Files (x86)\Microsoft Visual Studio
> 9.0\VC"
>

Hm..
What version of Visual Studio Express did you install?
Version 2008 which contains the compiler which is needed to build AOO is
no longer publicly available.

As far as I remember, if you have give the paths to the compiler as
configure options 'oowintool' should not be called. I need to have a
closer look.


Best regards, Oliver.

> After that the configure and bootstrap steps executed ok, as far as I can
> see.
>
> /Jonas
>
>
>
> --
> View this message in context: http://openoffice.2283327.n4.nabble.com/config-error-on-Windows-7-tp4652383p4657907.html
> Sent from the Development mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

Rob Weir
On Thu, Jan 16, 2014 at 11:14 AM, Oliver-Rainer Wittmann
<[hidden email]> wrote:

> Hi,
>
>
> On 16.01.2014 13:37, [hidden email] wrote:
>>
>> Hi,
>>
>>> Does this path/directory - C:\Program Files\Microsoft SDKs\Windows\v7.0\
>>> - exist on your system?
>>
>>
>> The path exist, however there was a key missing in the registry.
>> Installing Visual studio express did not add the key specifying where to
>> find VC. I simply added the key oowintool was looking for on line 236.
>> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\Setup\VC\ProductDir
>> and gave it the value "C:\Program Files (x86)\Microsoft Visual Studio
>> 9.0\VC"
>>
>
> Hm..
> What version of Visual Studio Express did you install?
> Version 2008 which contains the compiler which is needed to build AOO is no
> longer publicly available.
>

I thought it was available via the Windows SDK for Windows 7:

http://www.microsoft.com/en-us/download/details.aspx?id=3138


> As far as I remember, if you have give the paths to the compiler as
> configure options 'oowintool' should not be called. I need to have a closer
> look.
>
>
> Best regards, Oliver.
>
>
>> After that the configure and bootstrap steps executed ok, as far as I can
>> see.
>>
>> /Jonas
>>
>>
>>
>> --
>> View this message in context:
>> http://openoffice.2283327.n4.nabble.com/config-error-on-Windows-7-tp4652383p4657907.html
>> Sent from the Development mailing list archive at Nabble.com.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

jonasalfredsson@gmail.com
I got hold of a copy of Visual Studio Express 2008. With the configure call above 'oowintool' was called.
The Win SDK did not add the mentioned key to the registry, nor did Visual Studio Express 2008 installer.

/Jonas
Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

Oliver-Rainer Wittmann
In reply to this post by Rob Weir
Hi,

On 16.01.2014 17:32, Rob Weir wrote:

> On Thu, Jan 16, 2014 at 11:14 AM, Oliver-Rainer Wittmann
> <[hidden email]> wrote:
>> Hi,
>>
>>
>> On 16.01.2014 13:37, [hidden email] wrote:
>>>
>>> Hi,
>>>
>>>> Does this path/directory - C:\Program Files\Microsoft SDKs\Windows\v7.0\
>>>> - exist on your system?
>>>
>>>
>>> The path exist, however there was a key missing in the registry.
>>> Installing Visual studio express did not add the key specifying where to
>>> find VC. I simply added the key oowintool was looking for on line 236.
>>> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\Setup\VC\ProductDir
>>> and gave it the value "C:\Program Files (x86)\Microsoft Visual Studio
>>> 9.0\VC"
>>>
>>
>> Hm..
>> What version of Visual Studio Express did you install?
>> Version 2008 which contains the compiler which is needed to build AOO is no
>> longer publicly available.
>>
>
> I thought it was available via the Windows SDK for Windows 7:
>
> http://www.microsoft.com/en-us/download/details.aspx?id=3138
>

The needed compiler comes with the Windows SDK, but not the Visual
Studio Express application.
For building AOO the compiler is needed, Visual Studio is not needed.

Best regards, Oliver.

>
>> As far as I remember, if you have give the paths to the compiler as
>> configure options 'oowintool' should not be called. I need to have a closer
>> look.
>>
>>
>> Best regards, Oliver.
>>
>>
>>> After that the configure and bootstrap steps executed ok, as far as I can
>>> see.
>>>
>>> /Jonas
>>>
>>>
>>>
>>> --
>>> View this message in context:
>>> http://openoffice.2283327.n4.nabble.com/config-error-on-Windows-7-tp4652383p4657907.html
>>> Sent from the Development mailing list archive at Nabble.com.
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

Oliver-Rainer Wittmann
In reply to this post by jonasalfredsson@gmail.com
Hi,

On 16.01.2014 18:28, [hidden email] wrote:
> I got hold of a copy of Visual Studio Express 2008. With the configure call
> above 'oowintool' was called.
> The Win SDK did not add the mentioned key to the registry, nor did Visual
> Studio Express 2008 installer.
>


This wonders me as I have setup a system without any Visual Studio
installed. The compiler comes with the Windows SDK. This system does not
have the memntioned key in the registry and the configure works.

I will have a closer look into the configure.

Best regards, Oliver.

> /Jonas
>
>
>
> --
> View this message in context: http://openoffice.2283327.n4.nabble.com/config-error-on-Windows-7-tp4652383p4657930.html
> Sent from the Development mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

Oliver-Rainer Wittmann
Hi,

On 17.01.2014 07:52, Oliver-Rainer Wittmann wrote:

> Hi,
>
> On 16.01.2014 18:28, [hidden email] wrote:
>> I got hold of a copy of Visual Studio Express 2008. With the configure
>> call
>> above 'oowintool' was called.
>> The Win SDK did not add the mentioned key to the registry, nor did Visual
>> Studio Express 2008 installer.
>>
>
>
> This wonders me as I have setup a system without any Visual Studio
> installed. The compiler comes with the Windows SDK. This system does not
> have the memntioned key in the registry and the configure works.
>
> I will have a closer look into the configure.
>

A closer look to the configure, the oowintool and also my Windows 7
registry reveals the following:
The searched registry key does not exist, but registry key
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\9.0\Setup\VC
exists which is somehow found by the oowintool - see <sub
reg_get_value($)> in oowintool. I observed this situation on three
Windows 7 machine (virtual ones and non-virtual ones) on which I have
setup an AOO build environment.

Did you found the same registry key on your system?
Currently, I do not know what went wrong on your system.

Best regards, Oliver.

> Best regards, Oliver.
>
>> /Jonas
>>
>>
>>
>> --
>> View this message in context:
>> http://openoffice.2283327.n4.nabble.com/config-error-on-Windows-7-tp4652383p4657930.html
>>
>> Sent from the Development mailing list archive at Nabble.com.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

jonasalfredsson@gmail.com
>The searched registry key does not exist, but registry key
>HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\9.0\Setup\VC
>exists which is somehow found by the oowintool - see <sub
>reg_get_value($)> in oowintool. I observed this situation on three
>Windows 7 machine (virtual ones and non-virtual ones) on which I have
>setup an AOO build environment.

>Did you found the same registry key on your system?

I found the key on my system aswell but in my case oowintool does not find it.
Reply | Threaded
Open this post in threaded view
|

Re: config error on Windows 7

Ankit Tekriwal
In reply to this post by Clarence GUO
Clarence GUO <clarence.guo.bj <at> gmail.com> writes:

>
> Hi~
> When I set up build ENV on Window7, I met a error when configure, what
does

> it mean?
>
> Can't find MS Visual Studio / VC++ at ./oowintool line 236.
> configure: error: oowintool failed to copy CRT
>
> Cannot find VC. But I already saw configure said "checking the Microsoft
> C/C++ Compiler... found "
>
> Thanks,
> Clarence
>

Hi,

Did you get any solution for this. I am having the same problem.

Thanks,
Ankit



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]