ctypes and AOO4

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

ctypes and AOO4

LireCouleur
Hello,

I have developed the extension PicoSvoxOOo. This extension enables text
reading with the Pico TTS. Here are the links :

http://lirecouleur.arkaline.fr/2013/11/11/picosvoxooo/ (french only)

http://extensions.openoffice.org/de/node/17608

The extension seems to be ok for Linux (provided that the Pico Svox
package is installed) and Windows. When using Windows and AOO4, the
extension doesn't work.

In order to be more specific about the problem, I joined is a very short
script that may be run as a macro. It produces an error (see the joined
picture) on the "import ctypes" line. This error occurs exclusively with
Apache OpenOffice 4.x on Windows.

I don't understand how to solve this problem. Unfortunately, the Pico
TTS comes as a DLL on Windows and the ctypes module is required in that
case.

Could you help me to make this extension available on Windows and AOO 4.x?

Regards.

Marie


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

ImportCtypes.py (283 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: ctypes and AOO4

Herbert Duerr-3
Bonjour Marie,

On 04.12.2013 19:48, LireCouleur wrote:

> I have developed the extension PicoSvoxOOo. This extension enables text
> reading with the Pico TTS. Here are the links :
>
> http://lirecouleur.arkaline.fr/2013/11/11/picosvoxooo/ (french only)
>
> http://extensions.openoffice.org/de/node/17608
>
> The extension seems to be ok for Linux (provided that the Pico Svox
> package is installed) and Windows. When using Windows and AOO4, the
> extension doesn't work.
>
> In order to be more specific about the problem, I joined is a very short
> script that may be run as a macro. It produces an error (see the joined
> picture) on the "import ctypes" line. This error occurs exclusively with
> Apache OpenOffice 4.x on Windows.

This looks like a known bug that is already fixed on trunk. Kudos to
Hanya for solving that problem! AOO 4.1 will have the fix but for now
you could verify that the fix works by trying a Windows snapshot [2]

[1] https://issues.apache.org/ooo/show_bug.cgi?id=122829
[2] http://ci.apache.org/projects/openoffice/#win

Herbert

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: ctypes and AOO4

LireCouleur
Le 05/12/2013 12:00, Herbert Dürr a écrit :

> Bonjour Marie,
>
> This looks like a known bug that is already fixed on trunk. Kudos to
> Hanya for solving that problem! AOO 4.1 will have the fix but for now
> you could verify that the fix works by trying a Windows snapshot [2]
>
> [1] https://issues.apache.org/ooo/show_bug.cgi?id=122829
> [2] http://ci.apache.org/projects/openoffice/#win
>
> Herbert
>
Hello,

Thak you very much for your answer. You are right. It's the same bug. I
should have looked more carefully at the buglist.
The Windows snapshot you point out solves the problem. The PicoSvoOOo
extension works fine now.

Regards,

Marie

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: ctypes and AOO4

Herbert Duerr-3
On 05.12.2013 21:58, LireCouleur wrote:

> Le 05/12/2013 12:00, Herbert Dürr a écrit :
>> Bonjour Marie,
>>
>> This looks like a known bug that is already fixed on trunk. Kudos to
>> Hanya for solving that problem! AOO 4.1 will have the fix but for now
>> you could verify that the fix works by trying a Windows snapshot [2]
>>
>> [1] https://issues.apache.org/ooo/show_bug.cgi?id=122829
>> [2] http://ci.apache.org/projects/openoffice/#win
>>
>> Herbert
>>
> Hello,
>
> Thak you very much for your answer. You are right. It's the same bug. I
> should have looked more carefully at the buglist.
> The Windows snapshot you point out solves the problem. The PicoSvoOOo
> extension works fine now.

Thank you for checking your PicoSvoOOo extension with our nightly trunk
build. This means that AOO 4.1 will most likely work with it too. It's
too bad that the missing ctypes problem made it into AOO 4.0 and there
is no easy workaround.

Herbert


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]