ext_libraries/apr-util module

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

ext_libraries/apr-util module

Dylan Pham
Hello,

I'm building trunk/450 on macos big sur and got an error below:

Makefile:50: /Users/devops1/aoodev/openoffice/ext_libraries/apr-util/
unxmaccx.pro/misc/build/apr-util-1.6.1/build/rules.mk: No such file or
directory
  make: *** No rule to make target
`/Users/devops1/aoodev/openoffice/ext_libraries/apr-util/
unxmaccx.pro/misc/build/apr-util-1.6.1/build/rules.mk'.  Stop.
  dmake:  Error code 2, while making './
unxmaccx.pro/misc/build/so_built_aprutil'

Questions:
1. the apr module version is 1.6.5, does apr-util version need to match it?
2. I checked the apr module and there is no rules.mk file there and it
built successfully. Not sure why it's required for apr-util, as specified
in the makefile.in as below:

# bring in rules.mk for standard functionality
@INCLUDE_RULES@
@INCLUDE_OUTPUTS@

3. If I need to have a rules.mk what do I need to do? Is there a template?

Thank you,
Dylan
Reply | Threaded
Open this post in threaded view
|

Re: ext_libraries/apr-util module

Dylan Pham
I found apr_rules.mk and apr_rules.mk.in so I'll use these as templates to
build apr_util and see how it goes. If I'm heading in wrong direction
please feel free to let me know, thanks.


Dylan

On Wed, Jan 27, 2021 at 2:48 PM Dylan Pham <[hidden email]> wrote:

> Hello,
>
> I'm building trunk/450 on macos big sur and got an error below:
>
> Makefile:50: /Users/devops1/aoodev/openoffice/ext_libraries/apr-util/
> unxmaccx.pro/misc/build/apr-util-1.6.1/build/rules.mk: No such file or
> directory
>   make: *** No rule to make target
> `/Users/devops1/aoodev/openoffice/ext_libraries/apr-util/
> unxmaccx.pro/misc/build/apr-util-1.6.1/build/rules.mk'.  Stop.
>   dmake:  Error code 2, while making './
> unxmaccx.pro/misc/build/so_built_aprutil'
>
> Questions:
> 1. the apr module version is 1.6.5, does apr-util version need to match it?
> 2. I checked the apr module and there is no rules.mk file there and it
> built successfully. Not sure why it's required for apr-util, as specified
> in the makefile.in as below:
>
> # bring in rules.mk for standard functionality
> @INCLUDE_RULES@
> @INCLUDE_OUTPUTS@
>
> 3. If I need to have a rules.mk what do I need to do? Is there a template?
>
> Thank you,
> Dylan
>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: ext_libraries/apr-util module

Jim Jagielski
In reply to this post by Dylan Pham
Which version of Xcode?

> On Jan 27, 2021, at 5:48 PM, Dylan Pham <[hidden email]> wrote:
>
> Hello,
>
> I'm building trunk/450 on macos big sur and got an error below:
>
> Makefile:50: /Users/devops1/aoodev/openoffice/ext_libraries/apr-util/
> unxmaccx.pro/misc/build/apr-util-1.6.1/build/rules.mk: No such file or
> directory
>  make: *** No rule to make target
> `/Users/devops1/aoodev/openoffice/ext_libraries/apr-util/
> unxmaccx.pro/misc/build/apr-util-1.6.1/build/rules.mk'.  Stop.
>  dmake:  Error code 2, while making './
> unxmaccx.pro/misc/build/so_built_aprutil'
>
> Questions:
> 1. the apr module version is 1.6.5, does apr-util version need to match it?
> 2. I checked the apr module and there is no rules.mk file there and it
> built successfully. Not sure why it's required for apr-util, as specified
> in the makefile.in as below:
>
> # bring in rules.mk for standard functionality
> @INCLUDE_RULES@
> @INCLUDE_OUTPUTS@
>
> 3. If I need to have a rules.mk what do I need to do? Is there a template?
>
> Thank you,
> Dylan


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: ext_libraries/apr-util module

Dylan Pham
I'm using Xcode 12.3

On Thu, Jan 28, 2021 at 4:24 AM Jim Jagielski <[hidden email]> wrote:

> Which version of Xcode?
>
> > On Jan 27, 2021, at 5:48 PM, Dylan Pham <[hidden email]> wrote:
> >
> > Hello,
> >
> > I'm building trunk/450 on macos big sur and got an error below:
> >
> > Makefile:50: /Users/devops1/aoodev/openoffice/ext_libraries/apr-util/
> > unxmaccx.pro/misc/build/apr-util-1.6.1/build/rules.mk: No such file or
> > directory
> >  make: *** No rule to make target
> > `/Users/devops1/aoodev/openoffice/ext_libraries/apr-util/
> > unxmaccx.pro/misc/build/apr-util-1.6.1/build/rules.mk'.  Stop.
> >  dmake:  Error code 2, while making './
> > unxmaccx.pro/misc/build/so_built_aprutil'
> >
> > Questions:
> > 1. the apr module version is 1.6.5, does apr-util version need to match
> it?
> > 2. I checked the apr module and there is no rules.mk file there and it
> > built successfully. Not sure why it's required for apr-util, as specified
> > in the makefile.in as below:
> >
> > # bring in rules.mk for standard functionality
> > @INCLUDE_RULES@
> > @INCLUDE_OUTPUTS@
> >
> > 3. If I need to have a rules.mk what do I need to do? Is there a
> template?
> >
> > Thank you,
> > Dylan
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: ext_libraries/apr-util module

Jim Jagielski
There are issues w/ older versions of APR and newer versions of Xcode (well,
really, clang) where during the ./configure process, some ignored errors in
previous versions of clang are now fatal, causing the configure scripts to
fail.

> On Jan 28, 2021, at 12:44 PM, Dylan Pham <[hidden email]> wrote:
>
> I'm using Xcode 12.3
>
> On Thu, Jan 28, 2021 at 4:24 AM Jim Jagielski <[hidden email]> wrote:
>
>> Which version of Xcode?
>>
>>> On Jan 27, 2021, at 5:48 PM, Dylan Pham <[hidden email]> wrote:
>>>
>>> Hello,
>>>
>>> I'm building trunk/450 on macos big sur and got an error below:
>>>
>>> Makefile:50: /Users/devops1/aoodev/openoffice/ext_libraries/apr-util/
>>> unxmaccx.pro/misc/build/apr-util-1.6.1/build/rules.mk: No such file or
>>> directory
>>> make: *** No rule to make target
>>> `/Users/devops1/aoodev/openoffice/ext_libraries/apr-util/
>>> unxmaccx.pro/misc/build/apr-util-1.6.1/build/rules.mk'.  Stop.
>>> dmake:  Error code 2, while making './
>>> unxmaccx.pro/misc/build/so_built_aprutil'
>>>
>>> Questions:
>>> 1. the apr module version is 1.6.5, does apr-util version need to match
>> it?
>>> 2. I checked the apr module and there is no rules.mk file there and it
>>> built successfully. Not sure why it's required for apr-util, as specified
>>> in the makefile.in as below:
>>>
>>> # bring in rules.mk for standard functionality
>>> @INCLUDE_RULES@
>>> @INCLUDE_OUTPUTS@
>>>
>>> 3. If I need to have a rules.mk what do I need to do? Is there a
>> template?
>>>
>>> Thank you,
>>> Dylan
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]