extensions description xml doesn't exist

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

extensions description xml doesn't exist

John D'Orazio
Today I was rebuilding an extension I had written 4 years ago, and I just
happened to look at the "Retriever Output" window in Netbeans, and I found
this error:

23-feb-2019 19.14.23 : Retrieving Location:
http://openoffice.org/extensions/description/2006
Error: File not found in the specified address :
http://www.openoffice.org/extensions/description/2006


If I try to navigate to http://openoffice.org/extensions/description/2006 I
get a "page not found".

In the wiki the only reference is to this page:
https://wiki.openoffice.org/wiki/Documentation/DevGuide/Extensions/Description_of_XML_Elements

Should this xml descriptor still exist in this location?

John R. D'Orazio
Reply | Threaded
Open this post in threaded view
|

Re: extensions description xml doesn't exist

Pedro Lino-3
All extensions are now at https://extensions.openoffice.org/
If your extension is hosted at the new address maybe it needs a little URL editing
Hope this helps...


>     On February 24, 2019 at 1:07 PM John D'Orazio < [hidden email] mailto:[hidden email] > wrote:
>
>
>     Today I was rebuilding an extension I had written 4 years ago, and I just
>     happened to look at the "Retriever Output" window in Netbeans, and I found
>     this error:
>
>     23-feb-2019 19.14.23 : Retrieving Location:
>     http://openoffice.org/extensions/description/2006
>     Error: File not found in the specified address :
>     http://www.openoffice.org/extensions/description/2006
>
>
>     If I try to navigate to http://openoffice.org/extensions/description/2006 I
>     get a "page not found".
>
>     In the wiki the only reference is to this page:
>     https://wiki.openoffice.org/wiki/Documentation/DevGuide/Extensions/Description_of_XML_Elements
>
>     Should this xml descriptor still exist in this location?
>
>     John R. D'Orazio
>
Reply | Threaded
Open this post in threaded view
|

Re: extensions description xml doesn't exist

John D'Orazio
I don't see an XML descriptor at extensions.openoffice.org ? Should it be
at a URL such as https://extensions.openoffice.org/description/2006 ?

On Sun, Feb 24, 2019 at 5:53 PM Pedro Lino <[hidden email]> wrote:

> All extensions are now at https://extensions.openoffice.org/
> If your extension is hosted at the new address maybe it needs a little URL
> editing
> Hope this helps...
>
>
> >     On February 24, 2019 at 1:07 PM John D'Orazio <
> [hidden email] mailto:
> [hidden email] > wrote:
> >
> >
> >     Today I was rebuilding an extension I had written 4 years ago, and I
> just
> >     happened to look at the "Retriever Output" window in Netbeans, and I
> found
> >     this error:
> >
> >     23-feb-2019 19.14.23 : Retrieving Location:
> >     http://openoffice.org/extensions/description/2006
> >     Error: File not found in the specified address :
> >     http://www.openoffice.org/extensions/description/2006
> >
> >
> >     If I try to navigate to
> http://openoffice.org/extensions/description/2006 I
> >     get a "page not found".
> >
> >     In the wiki the only reference is to this page:
> >
> https://wiki.openoffice.org/wiki/Documentation/DevGuide/Extensions/Description_of_XML_Elements
> >
> >     Should this xml descriptor still exist in this location?
> >
> >     John R. D'Orazio
> >
>


--
John R. D'Orazio
Reply | Threaded
Open this post in threaded view
|

Re: extensions description xml doesn't exist

Pedro Lino-3

>     On February 25, 2019 at 8:38 PM John D'Orazio < [hidden email] mailto:[hidden email] > wrote:
>
>
>     I don't see an XML descriptor at extensions.openoffice.org ? Should it be
>     at a URL such as https://extensions.openoffice.org/description/2006 ?
>

Actually that part seems to be ignored.
The description.xml in all the extensions I use start with

<?xml version="1.0" encoding="UTF-8"?>
<description xmlns="http://openoffice.org/extensions/description/2006"
xmlns:d="http://openoffice.org/extensions/description/2006"
xmlns:xlink="http://www.w3.org/1999/xlink">

But that address is a 404...

Does anyone know what is the point of including this outdated header?
Should it be fixed/updated or simply removed?


>     On Sun, Feb 24, 2019 at 5:53 PM Pedro Lino < [hidden email] mailto:[hidden email] > wrote:
>
>
>         > >         All extensions are now at https://extensions.openoffice.org/
> >         If your extension is hosted at the new address maybe it needs a little URL
> >         editing
> >         Hope this helps...
> >
> >     >     >
>
>         > >
> >             > > >             On February 24, 2019 at 1:07 PM John D'Orazio <
> > >
> > >         > >         [hidden email] mailto:[hidden email] mailto:
> >         [hidden email] mailto:[hidden email] > wrote:
> >         >
> >         >
> >
> >             > > >             Today I was rebuilding an extension I had written 4 years ago, and I
> > >
> > >         > >         just
> >
> >             > > >             happened to look at the "Retriever Output" window in Netbeans, and I
> > >
> > >         > >         found
> >
> >             > > >             this error:
> > >
> > >         > >
> >             > > >             23-feb-2019 19.14.23 : Retrieving Location:
> > >             http://openoffice.org/extensions/description/2006
> > >             Error: File not found in the specified address :
> > >             http://www.openoffice.org/extensions/description/2006
> > >
> > >         > >         >
> >
> >             > > >             If I try to navigate to
> > >
> > >         > >         http://openoffice.org/extensions/description/2006 I
> >
> >             > > >             get a "page not found".
> > >
> > >         > >
> >             > > >             In the wiki the only reference is to this page:
> > >
> > >         > >         https://wiki.openoffice.org/wiki/Documentation/DevGuide/Extensions/Description_of_XML_Elements
> >         >
> >
> >             > > >             Should this xml descriptor still exist in this location?
> > >
> > >         > >
> >             > > >             John R. D'Orazio
> > >
> > >         > >
> >     >
>
>     --
>     John R. D'Orazio
>
Reply | Threaded
Open this post in threaded view
|

Re: extensions description xml doesn't exist

John D'Orazio
Not being an expert in xml structures, it does seem to me however that the
url isn't really to be considered an actual url, I guess it's just a string
(called a URI ) to identify the elements in this xml tree as belonging to
this family of elements.
https://stackoverflow.com/a/11602530
So in that case it's really indifferent if the "URL" resolves or not, so I
guess I can safely ignore the warning message in Netbeans (and I'm not sure
why netbeans even tries to resolve that as a url?)

On Mon, Feb 25, 2019 at 11:17 PM Pedro Lino <[hidden email]> wrote:

>
> >     On February 25, 2019 at 8:38 PM John D'Orazio <
> [hidden email] mailto:
> [hidden email] > wrote:
> >
> >
> >     I don't see an XML descriptor at extensions.openoffice.org ? Should
> it be
> >     at a URL such as https://extensions.openoffice.org/description/2006
> ?
> >
>
> Actually that part seems to be ignored.
> The description.xml in all the extensions I use start with
>
> <?xml version="1.0" encoding="UTF-8"?>
> <description xmlns="http://openoffice.org/extensions/description/2006"
> xmlns:d="http://openoffice.org/extensions/description/2006"
> xmlns:xlink="http://www.w3.org/1999/xlink">
>
> But that address is a 404...
>
> Does anyone know what is the point of including this outdated header?
> Should it be fixed/updated or simply removed?
>
>
> >     On Sun, Feb 24, 2019 at 5:53 PM Pedro Lino < [hidden email]
> mailto:[hidden email] > wrote:
> >
> >
> >         > >         All extensions are now at
> https://extensions.openoffice.org/
> > >         If your extension is hosted at the new address maybe it needs
> a little URL
> > >         editing
> > >         Hope this helps...
> > >
> > >     >     >
> >
> >         > >
> > >             > > >             On February 24, 2019 at 1:07 PM John
> D'Orazio <
> > > >
> > > >         > >         [hidden email] mailto:
> [hidden email] mailto:
> > >         [hidden email] mailto:
> [hidden email] > wrote:
> > >         >
> > >         >
> > >
> > >             > > >             Today I was rebuilding an extension I
> had written 4 years ago, and I
> > > >
> > > >         > >         just
> > >
> > >             > > >             happened to look at the "Retriever
> Output" window in Netbeans, and I
> > > >
> > > >         > >         found
> > >
> > >             > > >             this error:
> > > >
> > > >         > >
> > >             > > >             23-feb-2019 19.14.23 : Retrieving
> Location:
> > > >             http://openoffice.org/extensions/description/2006
> > > >             Error: File not found in the specified address :
> > > >             http://www.openoffice.org/extensions/description/2006
> > > >
> > > >         > >         >
> > >
> > >             > > >             If I try to navigate to
> > > >
> > > >         > >
> http://openoffice.org/extensions/description/2006 I
> > >
> > >             > > >             get a "page not found".
> > > >
> > > >         > >
> > >             > > >             In the wiki the only reference is to
> this page:
> > > >
> > > >         > >
> https://wiki.openoffice.org/wiki/Documentation/DevGuide/Extensions/Description_of_XML_Elements
> > >         >
> > >
> > >             > > >             Should this xml descriptor still exist
> in this location?
> > > >
> > > >         > >
> > >             > > >             John R. D'Orazio
> > > >
> > > >         > >
> > >     >
> >
> >     --
> >     John R. D'Orazio
> >
>


--
don John R. D'Orazio
Reply | Threaded
Open this post in threaded view
|

Re: extensions description xml doesn't exist

Dave Fisher
(1) I am pretty sure that URL has been 404 for about 7 years.

(2) You can always ask the Netbeans developers at [hidden email] <mailto:[hidden email]>

Regards,
Dave

> On Feb 25, 2019, at 3:12 PM, John D'Orazio <[hidden email]> wrote:
>
> Not being an expert in xml structures, it does seem to me however that the
> url isn't really to be considered an actual url, I guess it's just a string
> (called a URI ) to identify the elements in this xml tree as belonging to
> this family of elements.
> https://stackoverflow.com/a/11602530
> So in that case it's really indifferent if the "URL" resolves or not, so I
> guess I can safely ignore the warning message in Netbeans (and I'm not sure
> why netbeans even tries to resolve that as a url?)
>
> On Mon, Feb 25, 2019 at 11:17 PM Pedro Lino <[hidden email]> wrote:
>
>>
>>>    On February 25, 2019 at 8:38 PM John D'Orazio <
>> [hidden email] mailto:
>> [hidden email] > wrote:
>>>
>>>
>>>    I don't see an XML descriptor at extensions.openoffice.org ? Should
>> it be
>>>    at a URL such as https://extensions.openoffice.org/description/2006
>> ?
>>>
>>
>> Actually that part seems to be ignored.
>> The description.xml in all the extensions I use start with
>>
>> <?xml version="1.0" encoding="UTF-8"?>
>> <description xmlns="http://openoffice.org/extensions/description/2006"
>> xmlns:d="http://openoffice.org/extensions/description/2006"
>> xmlns:xlink="http://www.w3.org/1999/xlink">
>>
>> But that address is a 404...
>>
>> Does anyone know what is the point of including this outdated header?
>> Should it be fixed/updated or simply removed?
>>
>>
>>>    On Sun, Feb 24, 2019 at 5:53 PM Pedro Lino < [hidden email]
>> mailto:[hidden email] > wrote:
>>>
>>>
>>>>>        All extensions are now at
>> https://extensions.openoffice.org/
>>>>        If your extension is hosted at the new address maybe it needs
>> a little URL
>>>>        editing
>>>>        Hope this helps...
>>>>
>>>>>>
>>>
>>>>>
>>>>>>>            On February 24, 2019 at 1:07 PM John
>> D'Orazio <
>>>>>
>>>>>>>        [hidden email] mailto:
>> [hidden email] mailto:
>>>>        [hidden email] mailto:
>> [hidden email] > wrote:
>>>>>
>>>>>
>>>>
>>>>>>>            Today I was rebuilding an extension I
>> had written 4 years ago, and I
>>>>>
>>>>>>>        just
>>>>
>>>>>>>            happened to look at the "Retriever
>> Output" window in Netbeans, and I
>>>>>
>>>>>>>        found
>>>>
>>>>>>>            this error:
>>>>>
>>>>>>>
>>>>>>>            23-feb-2019 19.14.23 : Retrieving
>> Location:
>>>>>            http://openoffice.org/extensions/description/2006
>>>>>            Error: File not found in the specified address :
>>>>>            http://www.openoffice.org/extensions/description/2006
>>>>>
>>>>>>>>
>>>>
>>>>>>>            If I try to navigate to
>>>>>
>>>>>>>
>> http://openoffice.org/extensions/description/2006 I
>>>>
>>>>>>>            get a "page not found".
>>>>>
>>>>>>>
>>>>>>>            In the wiki the only reference is to
>> this page:
>>>>>
>>>>>>>
>> https://wiki.openoffice.org/wiki/Documentation/DevGuide/Extensions/Description_of_XML_Elements
>>>>>
>>>>
>>>>>>>            Should this xml descriptor still exist
>> in this location?
>>>>>
>>>>>>>
>>>>>>>            John R. D'Orazio
>>>>>
>>>>>>>
>>>>>
>>>
>>>    --
>>>    John R. D'Orazio
>>>
>>
>
>
> --
> don John R. D'Orazio

Reply | Threaded
Open this post in threaded view
|

Re: extensions description xml doesn't exist

Matthias Seidel
In reply to this post by John D'Orazio
Hi John,

Am 26.02.19 um 00:12 schrieb John D'Orazio:
> Not being an expert in xml structures, it does seem to me however that the
> url isn't really to be considered an actual url, I guess it's just a string
> (called a URI ) to identify the elements in this xml tree as belonging to
> this family of elements.
> https://stackoverflow.com/a/11602530

That's exactly the way I understand it.

Because of the confusion created by such an URI we created a special
page for our update feed:
http://www.openoffice.org/installation/description/

Maybe this is something to do for other "unresolved" URIs?

Regards,

   Matthias

> So in that case it's really indifferent if the "URL" resolves or not, so I
> guess I can safely ignore the warning message in Netbeans (and I'm not sure
> why netbeans even tries to resolve that as a url?)
>
> On Mon, Feb 25, 2019 at 11:17 PM Pedro Lino <[hidden email]> wrote:
>
>>>     On February 25, 2019 at 8:38 PM John D'Orazio <
>> [hidden email] mailto:
>> [hidden email] > wrote:
>>>
>>>     I don't see an XML descriptor at extensions.openoffice.org ? Should
>> it be
>>>     at a URL such as https://extensions.openoffice.org/description/2006
>> ?
>> Actually that part seems to be ignored.
>> The description.xml in all the extensions I use start with
>>
>> <?xml version="1.0" encoding="UTF-8"?>
>> <description xmlns="http://openoffice.org/extensions/description/2006"
>> xmlns:d="http://openoffice.org/extensions/description/2006"
>> xmlns:xlink="http://www.w3.org/1999/xlink">
>>
>> But that address is a 404...
>>
>> Does anyone know what is the point of including this outdated header?
>> Should it be fixed/updated or simply removed?
>>
>>
>>>     On Sun, Feb 24, 2019 at 5:53 PM Pedro Lino < [hidden email]
>> mailto:[hidden email] > wrote:
>>>
>>>         > >         All extensions are now at
>> https://extensions.openoffice.org/
>>>>         If your extension is hosted at the new address maybe it needs
>> a little URL
>>>>         editing
>>>>         Hope this helps...
>>>>
>>>>     >     >
>>>         > >
>>>>             > > >             On February 24, 2019 at 1:07 PM John
>> D'Orazio <
>>>>>         > >         [hidden email] mailto:
>> [hidden email] mailto:
>>>>         [hidden email] mailto:
>> [hidden email] > wrote:
>>>>         >
>>>>         >
>>>>
>>>>             > > >             Today I was rebuilding an extension I
>> had written 4 years ago, and I
>>>>>         > >         just
>>>>             > > >             happened to look at the "Retriever
>> Output" window in Netbeans, and I
>>>>>         > >         found
>>>>             > > >             this error:
>>>>>         > >
>>>>             > > >             23-feb-2019 19.14.23 : Retrieving
>> Location:
>>>>>             http://openoffice.org/extensions/description/2006
>>>>>             Error: File not found in the specified address :
>>>>>             http://www.openoffice.org/extensions/description/2006
>>>>>
>>>>>         > >         >
>>>>             > > >             If I try to navigate to
>>>>>         > >
>> http://openoffice.org/extensions/description/2006 I
>>>>             > > >             get a "page not found".
>>>>>         > >
>>>>             > > >             In the wiki the only reference is to
>> this page:
>>>>>         > >
>> https://wiki.openoffice.org/wiki/Documentation/DevGuide/Extensions/Description_of_XML_Elements
>>>>         >
>>>>
>>>>             > > >             Should this xml descriptor still exist
>> in this location?
>>>>>         > >
>>>>             > > >             John R. D'Orazio
>>>>>         > >
>>>>     >
>>>     --
>>>     John R. D'Orazio
>>>
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: extensions description xml doesn't exist

Matthias Seidel
Hi all,

For the moment I have created a landing page for this URI:
http://openoffice.org/extensions/description/2006

This should also "fix" the warnings in Netbeans.

Regards,

   Matthias

Am 26.02.19 um 11:16 schrieb Matthias Seidel:

> Hi John,
>
> Am 26.02.19 um 00:12 schrieb John D'Orazio:
>> Not being an expert in xml structures, it does seem to me however that the
>> url isn't really to be considered an actual url, I guess it's just a string
>> (called a URI ) to identify the elements in this xml tree as belonging to
>> this family of elements.
>> https://stackoverflow.com/a/11602530
> That's exactly the way I understand it.
>
> Because of the confusion created by such an URI we created a special
> page for our update feed:
> http://www.openoffice.org/installation/description/
>
> Maybe this is something to do for other "unresolved" URIs?
>
> Regards,
>
>    Matthias
>
>> So in that case it's really indifferent if the "URL" resolves or not, so I
>> guess I can safely ignore the warning message in Netbeans (and I'm not sure
>> why netbeans even tries to resolve that as a url?)
>>
>> On Mon, Feb 25, 2019 at 11:17 PM Pedro Lino <[hidden email]> wrote:
>>
>>>>     On February 25, 2019 at 8:38 PM John D'Orazio <
>>> [hidden email] mailto:
>>> [hidden email] > wrote:
>>>>     I don't see an XML descriptor at extensions.openoffice.org ? Should
>>> it be
>>>>     at a URL such as https://extensions.openoffice.org/description/2006
>>> ?
>>> Actually that part seems to be ignored.
>>> The description.xml in all the extensions I use start with
>>>
>>> <?xml version="1.0" encoding="UTF-8"?>
>>> <description xmlns="http://openoffice.org/extensions/description/2006"
>>> xmlns:d="http://openoffice.org/extensions/description/2006"
>>> xmlns:xlink="http://www.w3.org/1999/xlink">
>>>
>>> But that address is a 404...
>>>
>>> Does anyone know what is the point of including this outdated header?
>>> Should it be fixed/updated or simply removed?
>>>
>>>
>>>>     On Sun, Feb 24, 2019 at 5:53 PM Pedro Lino < [hidden email]
>>> mailto:[hidden email] > wrote:
>>>>         > >         All extensions are now at
>>> https://extensions.openoffice.org/
>>>>>         If your extension is hosted at the new address maybe it needs
>>> a little URL
>>>>>         editing
>>>>>         Hope this helps...
>>>>>
>>>>>     >     >
>>>>         > >
>>>>>             > > >             On February 24, 2019 at 1:07 PM John
>>> D'Orazio <
>>>>>>         > >         [hidden email] mailto:
>>> [hidden email] mailto:
>>>>>         [hidden email] mailto:
>>> [hidden email] > wrote:
>>>>>         >
>>>>>         >
>>>>>
>>>>>             > > >             Today I was rebuilding an extension I
>>> had written 4 years ago, and I
>>>>>>         > >         just
>>>>>             > > >             happened to look at the "Retriever
>>> Output" window in Netbeans, and I
>>>>>>         > >         found
>>>>>             > > >             this error:
>>>>>>         > >
>>>>>             > > >             23-feb-2019 19.14.23 : Retrieving
>>> Location:
>>>>>>             http://openoffice.org/extensions/description/2006
>>>>>>             Error: File not found in the specified address :
>>>>>>             http://www.openoffice.org/extensions/description/2006
>>>>>>
>>>>>>         > >         >
>>>>>             > > >             If I try to navigate to
>>>>>>         > >
>>> http://openoffice.org/extensions/description/2006 I
>>>>>             > > >             get a "page not found".
>>>>>>         > >
>>>>>             > > >             In the wiki the only reference is to
>>> this page:
>>>>>>         > >
>>> https://wiki.openoffice.org/wiki/Documentation/DevGuide/Extensions/Description_of_XML_Elements
>>>>>         >
>>>>>
>>>>>             > > >             Should this xml descriptor still exist
>>> in this location?
>>>>>>         > >
>>>>>             > > >             John R. D'Orazio
>>>>>>         > >
>>>>>     >
>>>>     --
>>>>     John R. D'Orazio
>>>>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

RE: extensions description xml doesn't exist

Jörg Schmidt-2
> From: Matthias Seidel [mailto:[hidden email]]
> Sent: Tuesday, February 26, 2019 11:45 AM
> To: [hidden email]
> Subject: Re: extensions description xml doesn't exist
>
> Hi all,
>
> For the moment I have created a landing page for this URI:
> http://openoffice.org/extensions/description/2006
>
> This should also "fix" the warnings in Netbeans.

+1, well done


greetings,
Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extensions description xml doesn't exist

Andrea Pescetti-2
In reply to this post by Matthias Seidel
On 26/02/2019 Matthias Seidel wrote:
> For the moment I have created a landing page for this URI:
> http://openoffice.org/extensions/description/2006

This will work, but I confirm what you and others had guesses: this is
not required to be an URI where some resources will be found. It is just
for the sake of namespacing, and it is fine if one doesn't get anything
there (but it doesn't harm if one sees the page you've put there either,
so it's fine to keep it!).

Regards,
   Andrea.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extensions description xml doesn't exist

Pedro Lino-3

> On February 26, 2019 at 6:25 PM Andrea Pescetti <[hidden email]> wrote:
>
> On 26/02/2019 Matthias Seidel wrote:
> > For the moment I have created a landing page for this URI:
> > http://openoffice.org/extensions/description/2006
>
> This will work, but I confirm what you and others had guesses: this is
> not required to be an URI where some resources will be found. It is just
> for the sake of namespacing, and it is fine if one doesn't get anything
> there (but it doesn't harm if one sees the page you've put there either,
> so it's fine to keep it!).

+1
Well done Matthias!

Any progress on the Check for Updates issue?

Regards,
Pedro

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]