format changes mysteriously.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

format changes mysteriously.

Felmon Davis

greets!

using AO 4.1.5; for some reason when I type a something on a new line
and end it with ':' that is, with the colon, the format of the line
changes from my default to 'Heading 3'.

I note if after the change to 'Heading 3' if I do an 'undo' (via
'ctrl+z') it changes the format to 'text-body'.

I have tried deleting 'default.ott', I have replaced it with a version
from an older set-up I used to use (sitting in backup).

in 'organizer' 'default' says it is 'linked with' 'none'.

quite annoying. suggestions?

(I'm on Debian.)

f.

--
Felmon Davis

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: format changes mysteriously.

Brian Barker
At 00:51 01/03/2018 -0500, Felmon Davis wrote:
>using AO 4.1.5; for some reason when I type a something on a new
>line and end it with ':' that is, with the colon, the format of the
>line changes from my default to 'Heading 3'.

That's supposed to happen - but when you type Ctrl+3, not Shift+: . A
few thoughts:

o Go to Tools | Customise... | Keyboard.
o Under Category, open the Styles entry and select Paragraph.
o Under Function, select "Heading 3".
o What does it say under Keys? It should be Ctrl+3; is it something else?

o Go to Tools | Customise... | Keyboard.
o Under Category, select Format.
o Under Function, select Apply.
o What does it say under Keys? It should be nothing; is it something else?

o If Shift+: is being interpreted as Ctrl+3, is there something
seriously wrong with your keyboard driver? Or keyboard? What happens
if you type Shift+: in another application?

But I'm guessing ...

I trust this helps.

Brian Barker


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: format changes mysteriously.

Felmon Davis
In reply to this post by Felmon Davis
On Thu, 1 Mar 2018, Brian Barker wrote:

> At 00:51 01/03/2018 -0500, Felmon Davis wrote:
>> using AO 4.1.5; for some reason when I type a something on a new line and
>> end it with ':' that is, with the colon, the format of the line changes
>> from my default to 'Heading 3'.
>
> That's supposed to happen - but when you type Ctrl+3, not Shift+: . A few
> thoughts:
>
> o Go to Tools | Customise... | Keyboard.
> o Under Category, open the Styles entry and select Paragraph.
> o Under Function, select "Heading 3".
> o What does it say under Keys? It should be Ctrl+3; is it something else?
>
> o Go to Tools | Customise... | Keyboard.
> o Under Category, select Format.
> o Under Function, select Apply.
> o What does it say under Keys? It should be nothing; is it something else?
>
> o If Shift+: is being interpreted as Ctrl+3, is there something seriously
> wrong with your keyboard driver? Or keyboard? What happens if you type
> Shift+: in another application?
>
> But I'm guessing ...
>
> I trust this helps.

I had, I recall, rooted around in those settings but it was good to
have another look. all these settings look 'kosher'.

the problem has cleared up though. here is my hypothesis but I don't
know if it makes sense: perhaps my default.ott was
misconfigured/corrupt (I make adjustments relatively often) and it
'caught something'.

I don't know why I didn't immediately see a change when I replaced it
with an older copy, I don't know when it gets loaded. I usually do not
restart AO but maybe I had. loaded a document that gave me the problem
and there's no problem now.

I much appreciate the good advice!

"there's always something."

f.

--
Felmon Davis

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: format changes mysteriously.

Felmon Davis
In reply to this post by Felmon Davis


On Thu, 1 Mar 2018, Brian Barker wrote:

> At 00:51 01/03/2018 -0500, Felmon Davis wrote:
>> using AO 4.1.5; for some reason when I type a something on a new line and
>> end it with ':' that is, with the colon, the format of the line changes
>> from my default to 'Heading 3'.
>
> That's supposed to happen - but when you type Ctrl+3, not Shift+: . A few
> thoughts:
>
> o Go to Tools | Customise... | Keyboard.
> o Under Category, open the Styles entry and select Paragraph.
> o Under Function, select "Heading 3".
> o What does it say under Keys? It should be Ctrl+3; is it something else?
>
> o Go to Tools | Customise... | Keyboard.
> o Under Category, select Format.
> o Under Function, select Apply.
> o What does it say under Keys? It should be nothing; is it something else?
>
> o If Shift+: is being interpreted as Ctrl+3, is there something seriously
> wrong with your keyboard driver? Or keyboard? What happens if you type
> Shift+: in another application?
>
> But I'm guessing ...
>
> I trust this helps.
>

seems I spoke (wrote) too soon. the problem is not extinct.

I have to make some more observations. I am beginning to see a
pattern. more later.

f.

--
Felmon Davis

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: format changes mysteriously.

Felmon Davis
In reply to this post by Felmon Davis
On Thu, 1 Mar 2018, Brian Barker wrote:

> At 00:51 01/03/2018 -0500, Felmon Davis wrote:
>> using AO 4.1.5; for some reason when I type a something on a new line and
>> end it with ':' that is, with the colon, the format of the line changes
>> from my default to 'Heading 3'.
>
> That's supposed to happen - but when you type Ctrl+3, not Shift+: . A few
> thoughts:
>
> o Go to Tools | Customise... | Keyboard.
> o Under Category, open the Styles entry and select Paragraph.
> o Under Function, select "Heading 3".
> o What does it say under Keys? It should be Ctrl+3; is it something else?
>
> o Go to Tools | Customise... | Keyboard.
> o Under Category, select Format.
> o Under Function, select Apply.
> o What does it say under Keys? It should be nothing; is it something else?
>
> o If Shift+: is being interpreted as Ctrl+3, is there something seriously
> wrong with your keyboard driver? Or keyboard? What happens if you type
> Shift+: in another application?
>
> But I'm guessing ...
>
> I trust this helps.

so I had a hypothesis which didn't pan out: thought it might correlate
with copying and pasting from the browser or from other people's
documents (I get several docs from people I have to comment on).
however, I clearly get the effect on opening a new document.

so it passed all your tests. I don't have many other apps to try but
nothing like this occurs in Kate or in Kword (hmm..., interesting,
never looked at this before!) or even in Calc from the AO suite.

I forgot to play with this on my office computer but I think not it
doesn't happen there. I forgot to fetch that default.ott and try it
here; will fetch it next time I'm at that machine. (also Linux,
Debian; I believe same version of AO.)

will keep scratching.

f.

--
Felmon Davis

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]