[framework-issues] [Issue 49426] repeated focus grabbing on start and document load

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[framework-issues] [Issue 49426] repeated focus grabbing on start and document load

habig
To comment on the following update, log in, then open the issue:
http://www.openoffice.org/issues/show_bug.cgi?id=49426





------- Additional comments from [hidden email] Tue Nov  8 07:53:17 -0800 2005 -------
The problem is more fundamental than simply not supporting _NET_WM_USER_TIME
properly.  oo is _ignoring_ the "kludgy" window manager global focus
preferences, at least in my case (WindowMaker WindowMaker-0.92.0-3.fc4, linux
FC4).  Since I have the window manager trying to open oo in a different virtual
desktop to dodge its slow startup, the fact that it insists on grabbing the
focus means that my whole desktop gets yanked out from under me so I can watch
oo open up, plus whatever I was happily typing in my intended window goes
streaming instead right into the freshly opened document where it doesn't belong.

This was not a problem in oo v1.x, but is a defect new to v2.x.  Applications
should never make a decision about such things as focus, that's the window
manager's job.

PS - if this issue is indeed a dupe, what's the master issue?


---------------------------------------------------------------------
Please do not reply to this automatically generated notification from
Issue Tracker. Please log onto the website and enter your comments.
http://qa.openoffice.org/issue_handling/project_issues.html#notification

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]