help needed building AOO for the first time

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

help needed building AOO for the first time

Shachar Arieli
Hi,

I am trying to build AOO on windows 10 for the first time.
I installed all the prerequisites as far as i understood.
When i attempt to create the build i get an error " configure: error:
cannot run /bin/sh ./config.sub "
See the output of the console below:

shach@DESKTOP-1FFQPA8 /cygdrive/c/aoo/openoffice/main
$ ./configure --build=BUILD
checking whether configure is up-to-date... yes
********************************************************************
*                                                                  *
*   Apache OpenOffice build configuration.                         *
*                                                                  *
*   The configure process checks your platform to see whether      *
*   you can build Apache OpenOffice on it.                         *
*   This process checks all pre-requisites and generates a file    *
*   containing the necessary environment variables.                *
*   Source this file after configure has ended successfully.       *
*                                                                  *
*   Warnings that are generated during the configure process       *
*   must be taken into account since it can be a reason for        *
*   an unsuccessful build of Apache OpenOffice.                    *
*                                                                  *
********************************************************************

********************************************************************
*                                                                  *
*   Checking the platform pre-requisites.                          *
*                                                                  *
********************************************************************

checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for gawk... gawk
checking for gawk... /usr/bin/gawk
checking for sed... /usr/bin/sed
checking for solenv environment... default
checking for custom pack.lst... no
configure: error: cannot run /bin/sh ./config.sub


Thanks
Reply | Threaded
Open this post in threaded view
|

Re: help needed building AOO for the first time

Matthias Seidel
Hi,

You're welcome!

Am 26.09.20 um 17:17 schrieb Shachar Arieli:
> Hi,
>
> I am trying to build AOO on windows 10 for the first time.
> I installed all the prerequisites as far as i understood.

I think we need more details...

What prerequisites have you installed?
Which branch of AOO do you want to build?
Which version if Cygwin do you use (type "uname -a" in cygwin)?

> When i attempt to create the build i get an error " configure: error:
> cannot run /bin/sh ./config.sub "
> See the output of the console below:
You sure did "autoconf" before that?
>
> shach@DESKTOP-1FFQPA8 /cygdrive/c/aoo/openoffice/main
> $ ./configure --build=BUILD

I don't even know what --build=BUILD should do, is this your complete
./configure?
If yes, you will get a lot more errors later...

But let's begin with the basic questions above, then we can surely find
a way...

Regards,

   Matthias

> checking whether configure is up-to-date... yes
> ********************************************************************
> *                                                                  *
> *   Apache OpenOffice build configuration.                         *
> *                                                                  *
> *   The configure process checks your platform to see whether      *
> *   you can build Apache OpenOffice on it.                         *
> *   This process checks all pre-requisites and generates a file    *
> *   containing the necessary environment variables.                *
> *   Source this file after configure has ended successfully.       *
> *                                                                  *
> *   Warnings that are generated during the configure process       *
> *   must be taken into account since it can be a reason for        *
> *   an unsuccessful build of Apache OpenOffice.                    *
> *                                                                  *
> ********************************************************************
>
> ********************************************************************
> *                                                                  *
> *   Checking the platform pre-requisites.                          *
> *                                                                  *
> ********************************************************************
>
> checking for grep that handles long lines and -e... /usr/bin/grep
> checking for egrep... /usr/bin/grep -E
> checking for gawk... gawk
> checking for gawk... /usr/bin/gawk
> checking for sed... /usr/bin/sed
> checking for solenv environment... default
> checking for custom pack.lst... no
> configure: error: cannot run /bin/sh ./config.sub
>
>
> Thanks
>


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: help needed building AOO for the first time

John D'Orazio
In reply to this post by Shachar Arieli
Are you following one of these guides :

https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step#Windows_7.2C_Windows_8.1.2C_Windows_10

https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO

https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Building_on_Windows

I confess I haven't done a build for a year or two now, but when I did a
successful build I contributed to the page in the first link to document
the process, and others have contributed in the meantime to make it
possible to build with 64bit cygwin.
Now that Windows 10 has WSL2 it might be interesting to try a build that
way instead of using cygwin, but for a first successful build I would
suggest following the above guides step by step.

On Sat, Sep 26, 2020, 17:18 Shachar Arieli <[hidden email]> wrote:

> Hi,
>
> I am trying to build AOO on windows 10 for the first time.
> I installed all the prerequisites as far as i understood.
> When i attempt to create the build i get an error " configure: error:
> cannot run /bin/sh ./config.sub "
> See the output of the console below:
>
> shach@DESKTOP-1FFQPA8 /cygdrive/c/aoo/openoffice/main
> $ ./configure --build=BUILD
> checking whether configure is up-to-date... yes
> ********************************************************************
> *                                                                  *
> *   Apache OpenOffice build configuration.                         *
> *                                                                  *
> *   The configure process checks your platform to see whether      *
> *   you can build Apache OpenOffice on it.                         *
> *   This process checks all pre-requisites and generates a file    *
> *   containing the necessary environment variables.                *
> *   Source this file after configure has ended successfully.       *
> *                                                                  *
> *   Warnings that are generated during the configure process       *
> *   must be taken into account since it can be a reason for        *
> *   an unsuccessful build of Apache OpenOffice.                    *
> *                                                                  *
> ********************************************************************
>
> ********************************************************************
> *                                                                  *
> *   Checking the platform pre-requisites.                          *
> *                                                                  *
> ********************************************************************
>
> checking for grep that handles long lines and -e... /usr/bin/grep
> checking for egrep... /usr/bin/grep -E
> checking for gawk... gawk
> checking for gawk... /usr/bin/gawk
> checking for sed... /usr/bin/sed
> checking for solenv environment... default
> checking for custom pack.lst... no
> configure: error: cannot run /bin/sh ./config.sub
>
>
> Thanks
>