how to debug problem with openoffice webdav?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

how to debug problem with openoffice webdav?

Joakim Verona
I'm coding a webdav storage using Apache Slide.

The implementation works ok with MS Office, but Ooo dies.
I'm having trouble figuring out how to debug the problem.

Heres one try I made:

 strace /usr/lib/openoffice.org2.0/program/swriter.bin \
 http://kurono:8080/slide/files/0/dav0/33/x.doc

near the end of the strace I get:

write(30, "OPTIONS /slide/files/0/dav0/5170"..., 153) = 153
select(31, [30], NULL, NULL, {120, 0}*** buffer overflow detected ***:
strace terminated
======= Backtrace: =========
/lib/libc.so.6(__chk_fail+0x41)[0x58cc45]
/lib/libc.so.6(__vsprintf_chk+0x0)[0x58c510]
/lib/libc.so.6(_IO_default_xsputn+0x97)[0x50f858]
/lib/libc.so.6(_IO_vfprintf+0xd92)[0x4ea894]
/lib/libc.so.6(__vsprintf_chk+0xa1)[0x58c5b1]
/lib/libc.so.6(__sprintf_chk+0x30)[0x58c504]
strace[0x804f497]
strace[0x804c879]
strace[0x804ba80]
/lib/libc.so.6(__libc_start_main+0xdf)[0x4c3d5f]
strace[0x80495d1]

which doesnt say much.

Some hints how to debug this with gdb would be nice, but all hints
apreciated.

Regards,
--
Joakim Verona





---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: how to debug problem with openoffice webdav?

CPHennessy
On Wed December 14 2005 10:23, Joakim Verona wrote:
> I'm coding a webdav storage using Apache Slide.
>
> The implementation works ok with MS Office, but Ooo dies.
> I'm having trouble figuring out how to debug the problem.
>
> Heres one try I made:
>
>  strace /usr/lib/openoffice.org2.0/program/swriter.bin \
>  http://kurono:8080/slide/files/0/dav0/33/x.doc

Is this an OpenOffice.org from http://openoffice.org ?
Have you tried one of the release candidates for 2.0.1 ?
Also have you tested with OOo 1.1.x ?

I use 1.1.3  ( .4 and .5 ) for webdav with no problems).


--
CPH : openoffice.org contributor

Maybe your question has been answered already?
                                http://user-faq.openoffice.org/#FAQ

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: how to debug problem with openoffice webdav?

Joakim Verona
CPHennessy <[hidden email]> writes:

> Is this an OpenOffice.org from http://openoffice.org ?

Its the ooo 2.0 that comes with Fedora Core 4.

> Have you tried one of the release candidates for 2.0.1 ?
> Also have you tested with OOo 1.1.x ?
>
> I use 1.1.3  ( .4 and .5 ) for webdav with no problems).

I dont have the 1.1 series about anymore, but I seem to recall that I
didnt have this issue with those. I will try with 2.01 as well.

I've found one problem, at least. My webdav implementation didn't
answer PROPGET properly for "resourcetype". Fixing this allows me to
open the document at least. Saving still doesnt work in ooo, but it
does work with MS Office.



>
> --
> CPH : openoffice.org contributor
>
> Maybe your question has been answered already?
> http://user-faq.openoffice.org/#FAQ

--
Joakim Verona
www.verona.se

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: how to debug problem with openoffice webdav?

Kai Sommerfeld
In reply to this post by Joakim Verona
Hi,

  have you tried tcpdump to catch the HTTP traffic between OOo and your
app? Seems that your reply from "OPTIONS /slide/files/0/dav0/5170" is
confusing OOo.

- Kai.

Joakim Verona wrote:

> I'm coding a webdav storage using Apache Slide.
>
> The implementation works ok with MS Office, but Ooo dies.
> I'm having trouble figuring out how to debug the problem.
>
> Heres one try I made:
>
>  strace /usr/lib/openoffice.org2.0/program/swriter.bin \
>  http://kurono:8080/slide/files/0/dav0/33/x.doc
>
> near the end of the strace I get:
>
> write(30, "OPTIONS /slide/files/0/dav0/5170"..., 153) = 153
> select(31, [30], NULL, NULL, {120, 0}*** buffer overflow detected ***:
> strace terminated
> ======= Backtrace: =========
> /lib/libc.so.6(__chk_fail+0x41)[0x58cc45]
> /lib/libc.so.6(__vsprintf_chk+0x0)[0x58c510]
> /lib/libc.so.6(_IO_default_xsputn+0x97)[0x50f858]
> /lib/libc.so.6(_IO_vfprintf+0xd92)[0x4ea894]
> /lib/libc.so.6(__vsprintf_chk+0xa1)[0x58c5b1]
> /lib/libc.so.6(__sprintf_chk+0x30)[0x58c504]
> strace[0x804f497]
> strace[0x804c879]
> strace[0x804ba80]
> /lib/libc.so.6(__libc_start_main+0xdf)[0x4c3d5f]
> strace[0x80495d1]
>
> which doesnt say much.
>
> Some hints how to debug this with gdb would be nice, but all hints
> apreciated.
>
> Regards,


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]