main/store exported symbol issues

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

main/store exported symbol issues

Jim Jagielski
It looks like I'm having some weird build issues with
this module due to exported symbols not working out
(on macOS... haven't tried Linux yet). Any ideas??

The error is:

[ build CHK ] loaded modules: store
[ build PKG ] store_xml
mkdir -p /Users/jim/src/asf/AOO420/main/solver/420/unxmaccx.pro/workdir/Package/ && touch /Users/jim/src/asf/AOO420/main/solver/420/unxmaccx.pro/workdir/Package/store_xml
Undefined symbols for architecture x86_64:
  "UDK_3_0_0 {", referenced from:
     -exported_symbol[s_list] command line option
  "global:", referenced from:
     -exported_symbol[s_list] command line option
  "local:", referenced from:
     -exported_symbol[s_list] command line option
  "store_acquireHandle;", referenced from:
     -exported_symbol[s_list] command line option
  "store_attrib;", referenced from:
     -exported_symbol[s_list] command line option
  "store_closeDirectory;", referenced from:
     -exported_symbol[s_list] command line option
  "store_closeFile;", referenced from:
     -exported_symbol[s_list] command line option
  "store_closeStream;", referenced from:
     -exported_symbol[s_list] command line option
  "store_createMemoryFile;", referenced from:
     -exported_symbol[s_list] command line option
  "store_findFirst;", referenced from:
     -exported_symbol[s_list] command line option
  "store_findNext;", referenced from:
     -exported_symbol[s_list] command line option
  "store_flushFile;", referenced from:
     -exported_symbol[s_list] command line option
  "store_flushStream;", referenced from:
     -exported_symbol[s_list] command line option
  "store_getFileRefererCount;", referenced from:
     -exported_symbol[s_list] command line option
  "store_getFileSize;", referenced from:
     -exported_symbol[s_list] command line option
  "store_getStreamSize;", referenced from:
     -exported_symbol[s_list] command line option
  "store_link;", referenced from:
     -exported_symbol[s_list] command line option
  "store_openDirectory;", referenced from:
     -exported_symbol[s_list] command line option
  "store_openFile;", referenced from:
     -exported_symbol[s_list] command line option
  "store_openStream;", referenced from:
     -exported_symbol[s_list] command line option
  "store_readStream;", referenced from:
     -exported_symbol[s_list] command line option
  "store_rebuildFile;", referenced from:
     -exported_symbol[s_list] command line option
  "store_releaseHandle;", referenced from:
     -exported_symbol[s_list] command line option
  "store_remove;", referenced from:
     -exported_symbol[s_list] command line option
  "store_rename;", referenced from:
     -exported_symbol[s_list] command line option
  "store_setStreamSize;", referenced from:
     -exported_symbol[s_list] command line option
  "store_symlink;", referenced from:
     -exported_symbol[s_list] command line option
  "store_writeStream;", referenced from:
     -exported_symbol[s_list] command line option
  "};", referenced from:
     -exported_symbol[s_list] command line option
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [/Users/jim/src/asf/AOO420/main/solenv/gbuild/LinkTarget.mk:251: /Users/jim/src/asf/AOO420/main/solver/420/unxmaccx.pro/workdir/LinkTarget/Library/libstore.dylib] Error 1
dmake:  Error code 2, while making 'all'

1 module(s):
        store
need(s) to be rebuilt


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

main/store exported symbol issues

Matthias Seidel

Hi Jim,

"Undefined symbols for architecture x86_64:"

This might have something to do with Damjans changes for a Windows 64-bit build.

The buildbots for Windows and Linux are doing fine, so it seems to be macOS only.

Regards,

   Matthias


Am 03.07.2018 um 13:26 schrieb Jim Jagielski:
It looks like I'm having some weird build issues with
this module due to exported symbols not working out
(on macOS... haven't tried Linux yet). Any ideas??

The error is:

[ build CHK ] loaded modules: store
[ build PKG ] store_xml
mkdir -p /Users/jim/src/asf/AOO420/main/solver/420/unxmaccx.pro/workdir/Package/ && touch /Users/jim/src/asf/AOO420/main/solver/420/unxmaccx.pro/workdir/Package/store_xml
Undefined symbols for architecture x86_64:
  "UDK_3_0_0 {", referenced from:
     -exported_symbol[s_list] command line option
  "global:", referenced from:
     -exported_symbol[s_list] command line option
  "local:", referenced from:
     -exported_symbol[s_list] command line option
  "store_acquireHandle;", referenced from:
     -exported_symbol[s_list] command line option
  "store_attrib;", referenced from:
     -exported_symbol[s_list] command line option
  "store_closeDirectory;", referenced from:
     -exported_symbol[s_list] command line option
  "store_closeFile;", referenced from:
     -exported_symbol[s_list] command line option
  "store_closeStream;", referenced from:
     -exported_symbol[s_list] command line option
  "store_createMemoryFile;", referenced from:
     -exported_symbol[s_list] command line option
  "store_findFirst;", referenced from:
     -exported_symbol[s_list] command line option
  "store_findNext;", referenced from:
     -exported_symbol[s_list] command line option
  "store_flushFile;", referenced from:
     -exported_symbol[s_list] command line option
  "store_flushStream;", referenced from:
     -exported_symbol[s_list] command line option
  "store_getFileRefererCount;", referenced from:
     -exported_symbol[s_list] command line option
  "store_getFileSize;", referenced from:
     -exported_symbol[s_list] command line option
  "store_getStreamSize;", referenced from:
     -exported_symbol[s_list] command line option
  "store_link;", referenced from:
     -exported_symbol[s_list] command line option
  "store_openDirectory;", referenced from:
     -exported_symbol[s_list] command line option
  "store_openFile;", referenced from:
     -exported_symbol[s_list] command line option
  "store_openStream;", referenced from:
     -exported_symbol[s_list] command line option
  "store_readStream;", referenced from:
     -exported_symbol[s_list] command line option
  "store_rebuildFile;", referenced from:
     -exported_symbol[s_list] command line option
  "store_releaseHandle;", referenced from:
     -exported_symbol[s_list] command line option
  "store_remove;", referenced from:
     -exported_symbol[s_list] command line option
  "store_rename;", referenced from:
     -exported_symbol[s_list] command line option
  "store_setStreamSize;", referenced from:
     -exported_symbol[s_list] command line option
  "store_symlink;", referenced from:
     -exported_symbol[s_list] command line option
  "store_writeStream;", referenced from:
     -exported_symbol[s_list] command line option
  "};", referenced from:
     -exported_symbol[s_list] command line option
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [/Users/jim/src/asf/AOO420/main/solenv/gbuild/LinkTarget.mk:251: /Users/jim/src/asf/AOO420/main/solver/420/unxmaccx.pro/workdir/LinkTarget/Library/libstore.dylib] Error 1
dmake:  Error code 2, while making 'all'

1 module(s): 
	store
need(s) to be rebuilt


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]



smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: main/store exported symbol issues

Jim Jagielski


> On Jul 3, 2018, at 7:47 AM, Matthias Seidel <[hidden email]> wrote:
>
> Hi Jim,
>
> "Undefined symbols for architecture x86_64:"
>
> This might have something to do with Damjans changes for a Windows 64-bit build.
>
> The buildbots for Windows and Linux are doing fine, so it seems to be macOS only.
>
> Regards,
>
>    Matthias
>

Thanks... anyone recall offhand what those changes were, svn rev #s, etc...?

Reply | Threaded
Open this post in threaded view
|

Re: main/store exported symbol issues

Matthias Seidel
Am 03.07.2018 um 13:59 schrieb Jim Jagielski:

>
>> On Jul 3, 2018, at 7:47 AM, Matthias Seidel <[hidden email]> wrote:
>>
>> Hi Jim,
>>
>> "Undefined symbols for architecture x86_64:"
>>
>> This might have something to do with Damjans changes for a Windows 64-bit build.
>>
>> The buildbots for Windows and Linux are doing fine, so it seems to be macOS only.
>>
>> Regards,
>>
>>    Matthias
>>
> Thanks... anyone recall offhand what those changes were, svn rev #s, etc...?
Of course Damjan knows best! ;-)

But this might fit:
https://svn.apache.org/viewvc?view=revision&revision=1827620

Regards,
   Matthias

>
>



smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: main/store exported symbol issues

Jim Jagielski
Looking over it again, it looks like the build is trying to do something wonky
with the store.map file...

> On Jul 3, 2018, at 8:28 AM, Matthias Seidel <[hidden email]> wrote:
>
> Am 03.07.2018 um 13:59 schrieb Jim Jagielski:
>>
>>> On Jul 3, 2018, at 7:47 AM, Matthias Seidel <[hidden email]> wrote:
>>>
>>> Hi Jim,
>>>
>>> "Undefined symbols for architecture x86_64:"
>>>
>>> This might have something to do with Damjans changes for a Windows 64-bit build.
>>>
>>> The buildbots for Windows and Linux are doing fine, so it seems to be macOS only.
>>>
>>> Regards,
>>>
>>>   Matthias
>>>
>> Thanks... anyone recall offhand what those changes were, svn rev #s, etc...?
>
> Of course Damjan knows best! ;-)
>
> But this might fit:
> https://svn.apache.org/viewvc?view=revision&revision=1827620
>
> Regards,
>    Matthias
>
>>
>>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: main/store exported symbol issues

Jim Jagielski
In reply to this post by Matthias Seidel
I think this may have to do w/ the 'Implement the ability to build "UDK versioned" libraries in gbuild'
stuff from

     http://svn.apache.org/viewvc?view=revision&revision=1827456

This is breaking macOS horribly!

> On Jul 3, 2018, at 8:28 AM, Matthias Seidel <[hidden email]> wrote:
>
> Am 03.07.2018 um 13:59 schrieb Jim Jagielski:
>>
>>> On Jul 3, 2018, at 7:47 AM, Matthias Seidel <[hidden email]> wrote:
>>>
>>> Hi Jim,
>>>
>>> "Undefined symbols for architecture x86_64:"
>>>
>>> This might have something to do with Damjans changes for a Windows 64-bit build.
>>>
>>> The buildbots for Windows and Linux are doing fine, so it seems to be macOS only.
>>>
>>> Regards,
>>>
>>>   Matthias
>>>
>> Thanks... anyone recall offhand what those changes were, svn rev #s, etc...?
>
> Of course Damjan knows best! ;-)
>
> But this might fit:
> https://svn.apache.org/viewvc?view=revision&revision=1827620
>
> Regards,
>    Matthias
>
>>
>>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]