sdk configuration on macos

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

sdk configuration on macos

Hyeon Lee-2

 
 
  Hi, I'm building the office on macos 10.15. 
  I found out that the configure only supports until sdk version 10.11 in the code:
  https://github.com/apache/openoffice/blob/trunk/main/configure.ac#L3946
  Is this behavior intended, or is it just an old code? Is there any problem if I change the required sdk version?
 
  Thanks for your reply in advance.
 
  Regards, 
  Hyeon
 
Reply | Threaded
Open this post in threaded view
|

Re: sdk configuration on macos

Matthias Seidel
Hi Hyeon,

Thank you for your contribution to our translation and my Pull Request!

Am 16.07.20 um 16:15 schrieb Hyeon Lee:
>  
>  
>   Hi, I'm building the office on macos 10.15. 
>   I found out that the configure only supports until sdk version 10.11 in the code:
>   https://github.com/apache/openoffice/blob/trunk/main/configure.ac#L3946
>   Is this behavior intended, or is it just an old code? Is there any problem if I change the required sdk version?

Unfortunately no mac user seems to be around, but I would suspect that
it is because of compatibility with older systems.

If you are interested in the build script (for 4.1.7), see:

http://svn.apache.org/repos/asf/openoffice/devtools/build-scripts/4.1.7/unxmacos/

Regards,

   Matthias

>  
>   Thanks for your reply in advance.
>  
>   Regards, 
>   Hyeon
>  


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: sdk configuration on macos

Peter Kovacs-3
Hello Hyeon,


I am not sure. I think we moved up to 10.11 because it still supports
the target 10.07 and is still supported by current Code.

We tend to support rather a huge range of history, this decision is
contrary to usual Production line.

We currently still target:

Windows XP (4.1.7 seems to work on Windows 2000, we had feedback on
users about this. ;) )

CentOS 7

MacOSx Lion 10.07


You can still move up the SDKs if you like. I wanted to try that too,
after we have fixed the issues that block 4.2.0 from the release.


All the Best

Peter


Am 17.07.20 um 18:44 schrieb Matthias Seidel:

> Hi Hyeon,
>
> Thank you for your contribution to our translation and my Pull Request!
>
> Am 16.07.20 um 16:15 schrieb Hyeon Lee:
>>  
>>  
>>    Hi, I'm building the office on macos 10.15.
>>    I found out that the configure only supports until sdk version 10.11 in the code:
>>    https://github.com/apache/openoffice/blob/trunk/main/configure.ac#L3946
>>    Is this behavior intended, or is it just an old code? Is there any problem if I change the required sdk version?
> Unfortunately no mac user seems to be around, but I would suspect that
> it is because of compatibility with older systems.
>
> If you are interested in the build script (for 4.1.7), see:
>
> http://svn.apache.org/repos/asf/openoffice/devtools/build-scripts/4.1.7/unxmacos/
>
> Regards,
>
>     Matthias
>
>>    
>>    Thanks for your reply in advance.
>>    
>>    Regards,
>>    Hyeon
>>  

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: sdk configuration on macos

Hyeon Lee-2
In reply to this post by Hyeon Lee-2
Thanks for the replies!
I tried with higher version sdks for the configuration, and it seems that there are no serious problems to finish it.

I was just wondering if there are some old sdks dependencies that does not support the latest OS that i didn’t notice.

But I will test my codes on 10.11 before committing, so please don't be concerned about that point:)

Regards,
Hyeon

> On Jul 18, 2020, at 4:55 PM, Peter Kovacs <[hidden email]> wrote:
>
> Hello Hyeon,
>
>
> I am not sure. I think we moved up to 10.11 because it still supports the target 10.07 and is still supported by current Code.
>
> We tend to support rather a huge range of history, this decision is contrary to usual Production line.
>
> We currently still target:
>
> Windows XP (4.1.7 seems to work on Windows 2000, we had feedback on users about this. ;) )
>
> CentOS 7
>
> MacOSx Lion 10.07
>
>
> You can still move up the SDKs if you like. I wanted to try that too, after we have fixed the issues that block 4.2.0 from the release.
>
>
> All the Best
>
> Peter
>
>
>>> Am 17.07.20 um 18:44 schrieb Matthias Seidel:
>> Hi Hyeon,
>> Thank you for your contribution to our translation and my Pull Request!
>>> Am 16.07.20 um 16:15 schrieb Hyeon Lee:
>>>      Hi, I'm building the office on macos 10.15.
>>>  I found out that the configure only supports until sdk version 10.11 in the code:
>>>  https://github.com/apache/openoffice/blob/trunk/main/configure.ac#L3946
>>>  Is this behavior intended, or is it just an old code? Is there any problem if I change the required sdk version?
>> Unfortunately no mac user seems to be around, but I would suspect that
>> it is because of compatibility with older systems.
>> If you are interested in the build script (for 4.1.7), see:
>> http://svn.apache.org/repos/asf/openoffice/devtools/build-scripts/4.1.7/unxmacos/
>> Regards,
>>   Matthias
>>>     Thanks for your reply in advance.
>>>     Regards,
>>>  Hyeon
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]





---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: sdk configuration on macos

Peter Kovacs-3
I think in the end it needs to run on a mac OSx Lion, because we claim
it will.

So if recent targets build a Version that installs and works with MacOSx
Lion, we could simplify our build setup for Macs.



All the Best

Peter

Am 18.07.20 um 10:34 schrieb Hyeon Lee:

> Thanks for the replies!
> I tried with higher version sdks for the configuration, and it seems that there are no serious problems to finish it.
>
> I was just wondering if there are some old sdks dependencies that does not support the latest OS that i didn’t notice.
>
> But I will test my codes on 10.11 before committing, so please don't be concerned about that point:)
>
> Regards,
> Hyeon
>
>> On Jul 18, 2020, at 4:55 PM, Peter Kovacs <[hidden email]> wrote:
>>
>> Hello Hyeon,
>>
>>
>> I am not sure. I think we moved up to 10.11 because it still supports the target 10.07 and is still supported by current Code.
>>
>> We tend to support rather a huge range of history, this decision is contrary to usual Production line.
>>
>> We currently still target:
>>
>> Windows XP (4.1.7 seems to work on Windows 2000, we had feedback on users about this. ;) )
>>
>> CentOS 7
>>
>> MacOSx Lion 10.07
>>
>>
>> You can still move up the SDKs if you like. I wanted to try that too, after we have fixed the issues that block 4.2.0 from the release.
>>
>>
>> All the Best
>>
>> Peter
>>
>>
>>>> Am 17.07.20 um 18:44 schrieb Matthias Seidel:
>>> Hi Hyeon,
>>> Thank you for your contribution to our translation and my Pull Request!
>>>> Am 16.07.20 um 16:15 schrieb Hyeon Lee:
>>>>       Hi, I'm building the office on macos 10.15.
>>>>   I found out that the configure only supports until sdk version 10.11 in the code:
>>>>   https://github.com/apache/openoffice/blob/trunk/main/configure.ac#L3946
>>>>   Is this behavior intended, or is it just an old code? Is there any problem if I change the required sdk version?
>>> Unfortunately no mac user seems to be around, but I would suspect that
>>> it is because of compatibility with older systems.
>>> If you are interested in the build script (for 4.1.7), see:
>>> http://svn.apache.org/repos/asf/openoffice/devtools/build-scripts/4.1.7/unxmacos/
>>> Regards,
>>>    Matthias
>>>>      Thanks for your reply in advance.
>>>>      Regards,
>>>>   Hyeon
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: sdk configuration on macos

Jim Jagielski
In reply to this post by Hyeon Lee-2
The behavior is intended for ASF community builds. You are certainly able to adjust the scripts to allow for a more personalized build

> On Jul 16, 2020, at 10:15 AM, Hyeon Lee <[hidden email]> wrote:
>
>
>
>
>  Hi, I'm building the office on macos 10.15.
>  I found out that the configure only supports until sdk version 10.11 in the code:
>  https://github.com/apache/openoffice/blob/trunk/main/configure.ac#L3946
>  Is this behavior intended, or is it just an old code? Is there any problem if I change the required sdk version?
>
>  Thanks for your reply in advance.
>
>  Regards,
>  Hyeon
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]