setBlog not implemented for preparedStatement in HSQLdb SDBC driver

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

setBlog not implemented for preparedStatement in HSQLdb SDBC driver

Drew Jensen
That is the error I get with the follow lines:

  if CurrentControl.ServiceName =
"stardiv.one.form.component.ImageControl" then
       prepStatement.setBlob( fldcnt, CurrentControl.BoundField.getBlob )
else
       prepStatement.setString( fldcnt,
CurrentControl.BoundField.getString )
end if

This ie with 3.2 RC5 and an embedded db, XP.

The exact error is

Type: com.sun.star.sdbc.SQLException
The driver does not support the functionality for
'XParameters::setBlob'. It is not implemented.


This is correct?

Thanks

Drew


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

SetBlob.... ( was Re: setBlog not implemented for preparedStatement in HSQLdb SDBC driver)

Drew Jensen
and as a BTW

  if CurrentControl.ServiceName =
"stardiv.one.form.component.ImageControl" then
      dim oStream as object
     oStream = CurrentControl.BoundField.getBinaryStream
     prepStatement.setBinaryStream( fldcnt, oStream, oStream.Length )
else
      prepStatement.setString( fldcnt,
CurrentControl.BoundField.getString )
end if

Does work, quite well.

Drew


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: SetBlob.... ( was Re: setBlog not implemented for preparedStatement in HSQLdb SDBC driver)

Ocke Janssen
Hi Drew,

I thought that I fixed that one in a DEV320 but that doesn't seem to be.
So please submit an issue for it. Thanks.

Best regards,

Ocke

Drew Jensen wrote:

> and as a BTW
>
>  if CurrentControl.ServiceName =
> "stardiv.one.form.component.ImageControl" then
>      dim oStream as object
>     oStream = CurrentControl.BoundField.getBinaryStream
>     prepStatement.setBinaryStream( fldcnt, oStream, oStream.Length )
> else
>      prepStatement.setString( fldcnt,
> CurrentControl.BoundField.getString )
> end if
>
> Does work, quite well.
>
> Drew
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


--
Ocke Janssen                      Tel: +49 40 23646 661, x66661
Dipl. Inf(FH)                     Fax: +49 40 23646 550
Sun Microsystems Inc.
Nagelsweg 55                      mailto:[hidden email]
D-20097 Hamburg                   http://www.sun.com/staroffice

Sitz der Gesellschaft:
Sun Microsystems GmbH, Sonnenallee 1, D-85551 Kirchheim-Heimstetten
Amtsgericht Muenchen: HRB 161028
Geschaeftsfuehrer: Thomas Schroeder, Wolfgang Engels
Vorsitzender des Aufsichtsrates: Martin Haering


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: SetBlob.... ( was Re: setBlog not implemented for preparedStatement in HSQLdb SDBC driver)

frank.schoenheit
Hi Ocke,

> I thought that I fixed that one in a DEV320 but that doesn't seem to be.
> So please submit an issue for it. Thanks.

Wasn't that in one of the dba33? CWS', i.e. for 3.3 only?

Ciao
Frank

--
- Frank Schönheit, Software Engineer         [hidden email] -
- Sun Microsystems                      http://www.sun.com/staroffice -
- OpenOffice.org Base                       http://dba.openoffice.org -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: SetBlob.... ( was Re: setBlog not implemented for preparedStatement in HSQLdb SDBC driver)

DrewJensen-2
On 2/9/2010 11:53 AM, Frank Schoenheit, Sun Microsystems Germany wrote:
> Hi Ocke,
>
>> I thought that I fixed that one in a DEV320 but that doesn't seem to be.
>> So please submit an issue for it. Thanks.
>
> Wasn't that in one of the dba33? CWS', i.e. for 3.3 only?
>

If so it hasn't integrated yet - tried with dev300_m70 same error.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: SetBlob.... ( was Re: setBlog not implemented for preparedStatement in HSQLdb SDBC driver)

Reizinger Zoltán
Hi all,

Ezzel a dátummal: Tuesday 09 February 2010 19.00.32 Drew Jensen ezt írta:

> On 2/9/2010 11:53 AM, Frank Schoenheit, Sun Microsystems Germany wrote:
> > Hi Ocke,
> >
> >> I thought that I fixed that one in a DEV320 but that doesn't seem to be.
> >> So please submit an issue for it. Thanks.
> >
> > Wasn't that in one of the dba33? CWS', i.e. for 3.3 only?
>
> If so it hasn't integrated yet - tried with dev300_m70 same error.
>
I think the issue according to issue tracker and eis  is fixed in cws dba33b
and integrated into m70:
 http://qa.openoffice.org/issues/show_bug.cgi?id=105086 

Then it is a not fully solved issue.  

Zoltan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: SetBlob.... ( was Re: setBlog not implemented for preparedStatement in HSQLdb SDBC driver)

Ocke Janssen
Hi all,

Reizinger Zoltán wrote:

> Hi all,
>
> Ezzel a dátummal: Tuesday 09 February 2010 19.00.32 Drew Jensen ezt írta:
>  
>> On 2/9/2010 11:53 AM, Frank Schoenheit, Sun Microsystems Germany wrote:
>>    
>>> Hi Ocke,
>>>
>>>      
>>>> I thought that I fixed that one in a DEV320 but that doesn't seem to be.
>>>> So please submit an issue for it. Thanks.
>>>>        
>>> Wasn't that in one of the dba33? CWS', i.e. for 3.3 only?
>>>      
>> If so it hasn't integrated yet - tried with dev300_m70 same error.
>>
>>    
> I think the issue according to issue tracker and eis  is fixed in cws dba33b
> and integrated into m70:
>  http://qa.openoffice.org/issues/show_bug.cgi?id=105086 
>
> Then it is a not fully solved issue.  
>  
That's the part which I don't understand. I have to check the history of
some files later on. Hopefully I simply forget it and it isn't no merge
problem.

- oj
> Zoltan
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>  


--
Ocke Janssen                      Tel: +49 40 23646 661, x66661
Dipl. Inf(FH)                     Fax: +49 40 23646 550
Sun Microsystems Inc.
Nagelsweg 55                      mailto:[hidden email]
D-20097 Hamburg                   http://www.sun.com/staroffice

Sitz der Gesellschaft:
Sun Microsystems GmbH, Sonnenallee 1, D-85551 Kirchheim-Heimstetten
Amtsgericht Muenchen: HRB 161028
Geschaeftsfuehrer: Thomas Schroeder, Wolfgang Engels
Vorsitzender des Aufsichtsrates: Martin Haering


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: SetBlob.... ( was Re: setBlog not implemented for preparedStatement in HSQLdb SDBC driver)

DrewJensen-2
On 2/10/2010 1:38 AM, Ocke Janssen wrote:

> Hi all,
>
> Reizinger Zoltán wrote:
>> Hi all,
>>
>> Ezzel a dátummal: Tuesday 09 February 2010 19.00.32 Drew Jensen ezt írta:
>>> On 2/9/2010 11:53 AM, Frank Schoenheit, Sun Microsystems Germany wrote:
>>>> Hi Ocke,
>>>>
>>>>> I thought that I fixed that one in a DEV320 but that doesn't seem
>>>>> to be.
>>>>> So please submit an issue for it. Thanks.
>>>> Wasn't that in one of the dba33? CWS', i.e. for 3.3 only?
>>> If so it hasn't integrated yet - tried with dev300_m70 same error.
>>>
>> I think the issue according to issue tracker and eis is fixed in cws
>> dba33b and integrated into m70:
>> http://qa.openoffice.org/issues/show_bug.cgi?id=105086
>> Then it is a not fully solved issue.
> That's the part which I don't understand. I have to check the history of
> some files later on. Hopefully I simply forget it and it isn't no merge
> problem.
>
> - oj
>> Zoltan
>>


Well gets more fun.

HSQLdb setBlob gives a not implemented message, but setBinaryStream works.

MySQL native connector 1.0 & 1.0.1Alpha, setBlob is implemented and
runs, just doesn't push data into the table - and - setBinarStream gives
error "not implemented".



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]